OpenCore Sammelthread (Hilfe und Diskussion)

  • Soviel ich weiß. kann man die Trim Funktion bei NVMe ohnehin nicht abstellen.


    Die "Wartezeit" scheint aber durchaus unterschiedlich zu sein. Auszug Boot-Screen:


    spaceman_trim_free-blocks:3326 scan took 15.964022 s, trim took 10.101359 s

    Davor und danach läuft alles prima.


    Gesamtzeit von Picker zum Login 35-38sec


    Edit:

    Ich habe 2 NVMe im System.

    Grüße, MacDream

  • Nein, Trim ist nicht automatisch aktiviert.

    Hallo DSM2 , habe mal das so ausprobiert wie beschrieben, dennoch wird im Terminal mit dem Befehl

    nvram -xp kein Eintrag Trim... angezeigt. Allerdings in den Sysinfos über meinen... wird Trim bestätigt. für beide NVME und SSD

  • Ruhig auch mal die Nachfolgenden Posts dazu lesen.

    Keine Unterstützung per PN...

    Eure Fragen gehören ins Forum, nicht in mein Postfach!

  • Hallo zusammen, mal ne Anfängerfrage:


    Weiß jemand, wie ich OC dazu bringe, dass kein OS automatisch gestartet wird, sondern auf eine Tastaturauswahl gewartet wird?


    Ich habe in den Dokumentationen hierzu nichts gefunden, da gibt es nur einen Timeout, der in Sekunden angegeben wird.


    Danke und Grüße


    Thomas

    Gigabyte Z390M Gaming - Intel i9-9900k - Sapphire Radeon RX580 Nitro- Apple AirPort Extreme - 16GB RAM - 512GB m.2 PCIe SSD - MacOS Catalina

  • Das Timeout auf 0 stellen.

  • da gibt es nur einen Timeout, der in Sekunden angegeben wird

    Und wenn Du den auf "0" stellst, passiert .... nichts. OC wartet auf Deinen Tastaturbefehl. ;)

    Gruß

    LOM


  • ... so einfach kann die Welt sein ;-)


    Danke :-)

    Gigabyte Z390M Gaming - Intel i9-9900k - Sapphire Radeon RX580 Nitro- Apple AirPort Extreme - 16GB RAM - 512GB m.2 PCIe SSD - MacOS Catalina

  • Ich habe in den Dokumentationen hierzu nichts gefunden, da gibt es nur einen Timeout, der in Sekunden angegeben wird.

    Also, ich finde, dass das in der OpenCore-Dokumentation schon ziemlich deutlich drin steht ;-)

    Der Rest wird dann durch die Beschreibung von "ShowPicker" klar.


    Habe natürlich gesehen, dass LuckyOldMan es schon beantwortet hat, aber ich wollte trotzdem für die Allgemeinheit nochmal drauf hinweisen, dass man sehr sehr häufig einfach nur den jeweiligen Eintrag, um den es geht, als Suchbegriff ins Suchfeld in der Configuration.pdf einzugeben braucht, und man hat die Antwort binnen Sekunden. :-)

    HACKINTOSH für Musik- und Videoproduktion

    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: OpenCore-EFI-Ordner und Anleitung

    Gigabyte Z390 DESIGNARE: fertiger Clover-EFI-Ordner zum Download

  • Könnte mir bitte Jemand helfen bei meinem 2. Hacki mit MSI H110M Eco Board - Intel i5-6600 mit Intel HD Graphic 530.

    Der Hacki lief bisher sehr gut auch mit 4K am Samsung UHD Monitor mit Clover und diesem Kernel to Patch Eintrag:


    <key>KextsToPatch</key>

    <array>

    <dict>

    <key>Comment</key>

    <string>Framebuffer for 4K display</string>

    <key>Find</key>

    <data>

    AwAiDQADAwMAAAACAAAwAQAAAAAAAABgmRQ=

    </data>

    <key>Name</key>

    <string>AppleIntelFramebufferAzul</string>

    <key>Replace</key>

    <data>

    AwAiDQADAwMAAAAEAAAgAgAAAAAAAACAmRQ=

    </data>

    </dict>

    </array>

    </dict>


    Nun habe ich versucht die Big Sur Beta3 dort zu betreiben, bootet auch, aber eben nur mit 1080P und 60 Hz, sollte aber

    mit UHD und 30 Hz laufen wie mit Clover 5107.


    Mein Frage ist was Open Core 0.6 betrifft; Wie bekomme ich diesen Patch aus Kernel to Patch in Clover ein ?


    Ich habe bei Open Core nachgelesen, komme da aber nicht ganz klar, wie man dort unter der Rupbrik "Patch" die Daten

    aus Clover dort einträgt mit dem Tool ProperTree, mit den ich bis jetzt alles schon gemacht habe.

    Bei meinem 1. Hacki brauchte ich keine Kernel to Patch Einträge in Open Core 0.6.


    Würde mich über Hilfe dazu sehr freuen. Danke.

  • Öffne doch mal deine Clover config.plist mit PlistEdit Pro und gleichzeitig deine OC config.plist, auch mit PlistEdit Pro. Dann such nach dem Patch in der Clover config und ziehe ihn per Drag&Drop in die OC config nach Kernel->Patch

    Gruß, karacho


    Bitte keine Supportanfragen via PN. Eure fragen gehören ins Forum!

    Ich hab noch drei Patronen, eine für dich und zwei für mich...

  • Danke Freund karacho.. werde ich nachher mal testen.


    Update: Ich habe das gemacht und des sieht so aus:

    Ich meine gelesen zu haben bei Open Core Desktop-Guide das bei "Identifier" was rein muss oder ?

    und auch andere Strings sind leer bei"Base","Mask" "MinKernel" und "MaxKernel". Und es geht immer noch kein 4K nur 10980 P an HDMI.

    Vielleicht wirkt daher der Patch nicht auf die Grafik ?

    Wenn ich mit Clover in Catalina 10.15.6 boote funktioniert alles, Sound ok und 4K Grafik mit 30 Hz ok.

    Muss dann wohl was an Open Core sein.


  • und wer sagt, wenn ein Patch unter Catalina funktioniert, sollte auch unter BS funktionieren...code ändern sich dann wie ist es bei so großen Änderungen von BS :think:

  • ich hatte vergessen zu erwähnen, das alles was ich bisher zu dem Hack 2 geschrieben habe, sich ausschliesslich auf macOS Catalina 10.15.6 bezieht.


    Ich möchte ja erst mal diesen Hacki fit für Open Core 0.6 mit Catalina mache,


    Big Sur läuft zwar auch mit den selben Problemen, die werden aber später geklärt,

    wenn erst mal Catalina ordentlich mit Open Core 0.6, genauso perfekt wie zur Zeit mit Clover 5107 läuft

  • Ja aber wie mein Vorredner schon sagte: "Du solltest eventuell mal suchen ob es einen Fix für die spezifische Version des Betriebssystems gibt", ich erinnere dabei nur an die leidigen USB-Portlimit-Patches von welchen es in fast jeder neuen Version einen neuen gab.


    Die Daten welche für die Grafik da eingegeben werden, sollten sich ja nicht ändern aber eventuell bezieht sich der Fix auf eine andere "Kext".

    Mit freundlichen Grüßen! Jens!


    Ich hab zwar keine Lösung, doch ich bewundere dein Problem!


    Hardware:

  • manfredm1970 Lade doch bitte einmal beide config.plist hoch, die von Clover wo alles funktioniert, und deine aktuelle OpenCore config.plist

    Gruß, karacho


    Bitte keine Supportanfragen via PN. Eure fragen gehören ins Forum!

    Ich hab noch drei Patronen, eine für dich und zwei für mich...

  • karacho danke schon mal im Voraus das du dir die Mühe machst dir das mal anzusehen.


    Ein Problem ist schon unter Open Core 0.6 gelöst und es ist, das jetzt der Sound mit der ALC887 unter Catalina 10.15.6 läuft, nur eben unter Big Sur noch nicht.


    Ok anbei die beiden config.plist aus Clover 5103 und Open Core 0.6 wie immer persönliche Daten wie z.B. Seriennummern und MLB+ROM ge(x)t.


    Noch mal die relevanten Daten vom Hacki 2: Läuft als iMac 17,1

    Motherboard MSI M110 Eco, CPU: Intel i5-6600, Grafik: Interne Intel HFD Graphic 530, Sound: Realtek ALC 887.

    WLAN TP Link WDN4800 (muss ich selber noch in Big Sur zum laufen bringen - ist aber Nebensache)


    Nachtrag-Update: in Big Sur geht auch sound mit ALC 887, habe die neuesten Lilu und WEG benutzt.


    Bezieht sich jetzt auf Big Sur:

    Merkwürdig ist noch das ständige erscheinen der Aufforderung mich mit der Apple-ID anzumelden, ein kleines Bild was auf Klicks garnicht reagiert.

    Und es wird immer WLAN versucht zu starten, obwohl ich es garnicht eingerichtet habe und des demzufolge in Netzwerkeinstellungen nicht existiert.

    Gelöst nach nvram-reset alles ok.

  • Beim Start von Big Sur haut es im Verbose-Modus in reichlicher Fülle verteilt die Meldung raus: "disk11S5S1 is not readable", teilweise in Blöcken zu 20, 30 Stück.

    Ein Check via Terminal ergibt: disk 11 ist mein OC-Stick, aber da gibt es kein S5S1.

    Was passiert da? Geister-Partitionen?

    Gruß

    LOM


  • Das ist das Unsealed-Volume (Snapshot), welches zu diesem Zeitpunkt nicht lesbar ist, wenn ich das richtig verstanden habe.

    An der Stelle, wo du während der Installation ca 10 Minuten warten musst, wird es erstellt.

    MfG, docplag



  • welches zu diesem Zeitpunkt nicht lesbar ist

    Also ignorieren?

    Gruß

    LOM


  • Ja, bleibt dir ja nichts anderes übrig. Oder...du löscht im Recovery en Snapshot, aber das ist eine etwas längere Geschichte.:)

    MfG, docplag