OpenCore Sammelthread (Hilfe und Diskussion)

  • Herky85 Wenn DRM (inkl. TV-App) unter Catalina nicht richtig funktioniert, liegt es wahrscheinlich an dem von dir verwendeten SMBIOS. Vereinfacht gesagt ist es wohl so, dass SMBIOS-Typen, die mit iGPU arbeiten, DRM auf dem Hackintosh unter Catalina nicht können. Daher gilt es, dem System quasi in diesem Punkt (nicht das ganze System betreffend) vorzugaukeln, es hätte es mit einem SMBIOS zu tun, das DRM komplett unterstützt (z.B. iMacPro1,1). Mit dem Bootargument shikigva=80 (dieses benötigt allerdings zwingend WhateverGreen!) sollte das dann eigentlich funktionieren – ohne dass du dein SMBIOS ändern musst.

    HACKINTOSH für Musik- und Videoproduktion

    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: OpenCore-EFI-Ordner und Anleitung

  • @JimSalabim


    ....die mit iGPU arbeiten, DRM auf dem Hackintosh unter Catalina nicht können......


    Da muss ich dir wieder sprechen , das mit dem SMBIOS wird richtig sein .

    Ich stell mal eine Behauptung auf das liegt mehr an der Plattform-ID die man auswählen tut.


    An mein Hackbook Skylake i5 6200U getestet , mein SMBIOS=MacBookPro13,1


    Hier mit getestet



    Hackbook HP Notebook - 15-ac135ng (ENERGY STAR)


    MacBookPro13,2 , CPU i5-6200U , 12GB RAM , Intel Grafik HD520 , OpenCore 0.7.0

  • OSX-Einsteiger Interessant, danke für die Info!

    HACKINTOSH für Musik- und Videoproduktion

    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: OpenCore-EFI-Ordner und Anleitung

  • Welches Ergebnis hatte Dein Test?

    Grüße

    Arkturus

  • JimSalabim  OSX-Einsteiger Danke für die Informationen, es funktioniert nun bei mir mit iMacPro1,1 und shikigva=80, obwohl iMac15,1 näher an meinem System ist.



    System: Gigabyte GA-H97-HD3, OpenCore 0.7.6

    Intel Core I5-4690 3,83GHz 16Gb DDR3 Ram, RX 580 OC 8Gb Ram, SSD SanDisk 480Gb (Windows 11),SSD SanDisk 480Gb (macOS Monterey). Toshiba USB Festplatte 640Gb, SATA Festplatte 250Gb

    Thinkpad X220 mit Windows 11

    Laptop: MSi MS-1632, GeForce Go 6100, 1,5 GB Ram Mobile AMD Sempron 3200+ 1,6 GHz mit Windows 8.1
    Laptop: 800Mhz, 512Mb Ram und Windows98
    Trekstor Surftab Wintron 10.1 (Windows10)
    Power Mac G4 733MHz, 640Mb Ram
    MacBook 2,1 mit Yosemite :gibtsnicht:

    Edited 2 times, last by Herky85 ().

  • in dem fall willst du aber deine dGPU verwenden , daher ist das imacpro SMbios eher für dich gedacht , da hab Mojave Catalina viel am DRM zeug rumgedreh worden ist:) aber gut wenn es läuft !


    KEIN SUPPORT PER PN!

    julian2_pic.png

  • Herky85 Wenn du iMacPro1,1 verwendest, kannst du shikigva=80 weglassen.

    HACKINTOSH für Musik- und Videoproduktion

    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: OpenCore-EFI-Ordner und Anleitung

  • Hab auch den Wechsel von iMac15,1 auf iMacPro1,1 gewagt. Zuerst Rechner aus der Cloud abgemeldet. SN und Board-ID neu generiert, UUID übernommen. Soweit scheint alles zu laufen. iTV, Facetime, iMessage läuft, Video-Prog alles grün.


    GA-Z97X-Gaming 7 | i7-4790K | Aorus RX580 | Monterey | OC
    GA-B250N-Phoenix WiFi | i7-7700 | Nvidia GTX730 | Big Sur | OC
  • nach der Anleitung von khoronakernel funktioniert jetzt der iMacPro1,1 (Hasswell) selbst mit funktionierendem NVRAM und PrimeVideo im Safari in HD.

    Grüße

    Arkturus

  • nach der Anleitung von khoronakernel funktioniert jetzt der iMacPro1,1 (Hasswell) selbst mit funktionierendem NVRAM und PrimeVideo im Safari in HD. offline

    Hättest nur einen Wert verändern müssen :D Und zwar WriteFlash = YES

    Liebe Grüße, alex


     Mac mini Late 2020 – M1 – 16GB RAM – 256GB SSD

     MacBook Pro 15” Late 2015 – i7 4980HQ – 16GB RAM – 256GB SSD

     MacBook Pro 13” Late 2014 – i5 4278U – 8GB RAM – 120GB SSD

    iPhone 13 – iPhone 8 Plus – iPad Pro 12,9" – AirPods 1. Gen – AirPods Pro – Apple Watch S5 44mm




  • Hättest nur einen Wert verändern müssen :D Und zwar WriteFlash = YES

    steht das jetzt für FileVault oder den NVRAM?

    Grüße

    Arkturus

  • Das ist für den NVRAM, damit die Fehlermeldung verschwindet.

    Liebe Grüße, alex


     Mac mini Late 2020 – M1 – 16GB RAM – 256GB SSD

     MacBook Pro 15” Late 2015 – i7 4980HQ – 16GB RAM – 256GB SSD

     MacBook Pro 13” Late 2014 – i5 4278U – 8GB RAM – 120GB SSD

    iPhone 13 – iPhone 8 Plus – iPad Pro 12,9" – AirPods 1. Gen – AirPods Pro – Apple Watch S5 44mm




  • Ich find's echt geil, dass man jetzt ab 0.5.8 den ApfsDriverLoader.efi nicht mehr braucht. Das zeigt, dass OC noch lange nicht ausgereizt ist. Super Job Download-Fritz & Developer.

    Gruß, karacho


    Bitte keine Supportanfragen via PN. Eure fragen gehören ins Forum!

    Ich hab noch drei Patronen, eine für dich und zwei für mich...

  • Hab auch auf 0.5.8 upgedatet und es läuft super ohne ApfsDriverLoader. :-)

    HACKINTOSH für Musik- und Videoproduktion

    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: OpenCore-EFI-Ordner und Anleitung

  • werd erst im release drauf wechseln , dauert ja nicht so lange normal :)


    KEIN SUPPORT PER PN!

    julian2_pic.png

  • @karacho @JimSalabim Sry das ich noch mal fragen muss, aber mir fehlt mit 0.5.8 im Bootpicker meine zweite NVMe mit Mojave. Gibts da noch eine Feineinstellung? Ansonsten hätte ich alle Möglichkeiten durch. Gruß


    GA-Z97X-Gaming 7 | i7-4790K | Aorus RX580 | Monterey | OC
    GA-B250N-Phoenix WiFi | i7-7700 | Nvidia GTX730 | Big Sur | OC
  • JimSalabim wollte mal fragen wie du herausbekommen hast, wie deine Boot-EFI Partition heisst? Das klappt bei mir nicht richtig :-(

    „Die Definition von Wahnsinn ist, immer wieder das Gleiche zu tun und andere Ergebnisse zu erwarten.“ - Albert Einstein

  • bumbuy Ist die auch APFS-formatiert? Oder HFS+? Falls zweiteres, hast du HFS in deinem ScanPolicy-Wert (Misc->Security) mit eingeschlossen? Wenn sie mit ScanPolicy auf 0 auch nicht erscheint, liegt es daran aber nicht. Ansonsten kannst du mal den Wert 6913 (kein Device Lock, alle unterstützten Filesystems außer ESP) probieren. Wenn das alles nicht hilft, könntest du mal noch probieren, nen Custom-Entry (Misc->Entries) zu erstellen. Etwa so wie ich hier für Windows, nur dass du halt dafür den PciRoot-Pfad für das Preboot-Volume deiner Mojave-NVMe brauchst. Ich denke aber nicht, dass das notwendig ist.


    StevePeter Ich kann dir nicht ganz folgen: Was meinst du damit, wie die EFI-Partition heißt? Und welche EFI-Partition meinst du – Windows oder macOS? Oder suchst du nach dem PciRoot-Pfad? Falls ja: Ich hab mir mal alle Schritte dafür als gut verständliche Anleitung zusammengeschrieben, die würde ich nochmal kurz aktualisieren und hochladen, falls gewünscht.

    HACKINTOSH für Musik- und Videoproduktion

    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: OpenCore-EFI-Ordner und Anleitung

  • @JimSalabim Alle Platten sind APSF-Formatiert. Mit dem Wert 6913 taucht die fehlende Mojave-NVMe wieder auf, Standardwert 983299 zeigt sie jetzt auch. :) Einzig eine kleine externe NVMe über Adapter mit eSATA angeschlossen zeigt sich noch nicht. Aber toll das die internen wieder alle da sind. Besten Dank!


    GA-Z97X-Gaming 7 | i7-4790K | Aorus RX580 | Monterey | OC
    GA-B250N-Phoenix WiFi | i7-7700 | Nvidia GTX730 | Big Sur | OC

    Edited once, last by bumbuy: Ergänzung ().

  • Oder suchst du nach dem PciRoot-Pfad? Falls ja: Ich hab mir mal alle Schritte dafür als gut verständliche Anleitung zusammengeschrieben,

    Guckst du dort -> PCIROOT Pfade für Custom Entries für OpenCore heraus finden.

    Gruß, karacho


    Bitte keine Supportanfragen via PN. Eure fragen gehören ins Forum!

    Ich hab noch drei Patronen, eine für dich und zwei für mich...