OpenCore Sammelthread (Hilfe und Diskussion)

  • Bezüglich I2C Trackpad:


    Gerade auf olarila.com drüber gestolpert


    Quote

    I2C trackpad is now working simply by moving VoodooGPIO and VoodooI2CServices above in config.plist so they load firstly, then add VoodooI2C and lastly VoodooI2CHID.

  • Hallo Si Vis Pacem ,

    das mit der Reihenfolge ist bekannt. Das Problem ist eine Kernelpanik beim Herunterfahren.

    Ich habe das mal hier gepostet und eine erste Antwort gibt es auch schon, auch wenn dazu noch die Lösung fehlt.


    Link

    Grüße und Good Hack Michael


    :hackintosh:

    Edited once, last by anonymous writer ().

  • Welches SMBIOS nutzt du?


    Ich nutze ein "iMac Pro 1.1". Da in OpenCore erst wenige SMBIOS-Daten hinterlegt sind, reicht es beispielsweise beim "iMac Pro 1.1" nicht aus, in der "Platform Info" die "Automatic" auf "YES" zu stellen und die paar Werte in "Generic" auszufüllen. Denn dann werden die restlichen Werte (des gewählten SMBIOS die ebenfalls vorhanden sein müssen) eben automatisch aufgefüllt. Diese passen aber nicht zum SMBIOS "iMac Pro 1.1", da hierzu (noch) keine Informationen vorliegen. Somit ist das ganze zwar lauffähig, aber größtenteils falsch konfiguriert – entsprechend läuft es nicht korrekt mit der Grafikkarte. Hatte dasselbe Problem auch.


    Stattdessen stelle "Automatic" auf "NO" und fülle "Data Hub", "Platform NVRAM" und "SMBIOS" gewissenhaft aus, schon funktioniert das auch mit der Grafikkarte!


    Beispiel:



    ROM, Seriennummern und UUIDs sind noch nachzutragen. Findest du in deinem Clover-Configurator.

    Viel Erfolg!

    ASUS PRIME X299-DELUXE i9-9940X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64 • BMD Intensity Pro 4K

    ASUS WS X299 SAGE/10G i9-10980XE • DDR4 64GB • SSD 970 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon VII • BMD DeckLink 4K Extreme 12G


    Ordnung ist die primitivste Form von Chaos. (Hans-Jürgen Quadbeck-Seeger)

  • Ich habe irgendwie den falschen Ansatz gehabt. Ich habe ein fertig mit Clover eingerichtetes macOS genommen und das mit dem OC gebootet da lief nichts mit Videoproc, aber mit OC und einem frisch installierten System läuft es mittlerweile Problemlos.

    Mit freundlichen Grüßen! Jens!


    Ich hab zwar keine Lösung, doch ich bewundere dein Problem!


    Hardware:

  • Ich habe ein fertig mit Clover eingerichtetes macOS genommen und das mit dem OC gebootet da lief nichts mit Videoproc

    Habe ich genau so. Und es macht nichts. Warum auch, ob OC oder Clover, das System bleibt Vanilla. Ich konnte somit dem Problem auf den Grund gehen. Und es lag letztendlich am SMBIOS, bzw. fehlenden Einträgen dazu.

    ASUS PRIME X299-DELUXE i9-9940X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64 • BMD Intensity Pro 4K

    ASUS WS X299 SAGE/10G i9-10980XE • DDR4 64GB • SSD 970 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon VII • BMD DeckLink 4K Extreme 12G


    Ordnung ist die primitivste Form von Chaos. (Hans-Jürgen Quadbeck-Seeger)

  • Hat jemand eine Ahnung was die SSDT-EC-USBX.aml bewirkt, außer dass ich ein O.E.M. bekomme? :)


    Gruß derHackfan

  • Sorgt dafür, dass AppleBusPowerController lädt, welcher unter anderem den verfügbaren USB Port Strom managed. USBX ist dabei ein applespezifisches device bestimmter iMacs, je nach Wahl des SMBios müssen unterschiedliche SSDTs verwendet werden, siehe hier unter 3.: 2.07 USB Port Lösungen

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • So, ich habe es nun auch mal in Angriff genommen OC zu testen, nachdem ich die kleineren Probleme mit den z97 Boards( Bios auf UEFI) &

    config.plist bearbeiten gelöst habe, bootet meine "AlteDame" zügig durch.


    Leider habe ich noch eine Fehlermeldung beim booten, die ich nicht in den Griff bekomme.


    Vielleicht hat ja einer von euch eine Idee...

    Images

    Files

    • OC.zip

      (1.49 MB, downloaded 79 times, last: )


    MacPro:7.1 Gigabyte B550 AORUS PRO CPU: Ryzen 7 3700X Memory: 32GB Corsair Vengeance LPX DDR4-3200 CL16 D GPU: Sapphire Radeon RX 5500 XT 8GB HDD: 1xM2 1TB

    Bootloader: OpenCoreVersion.svg

    MacBook Pro 8.3 (orignal):  CPU: 2,4 GHz Intel Core i7 Quad-Core 8GB 1600 DDR3 1xSSD 256GB 1xHDD 2TB Wifi/Bluetooth 802.11n/4.0 macOS 10.13.6


  • Roy Jones

    – VBoxHfs.efi und HFSPlus.efi, du solltest dich für einen entscheiden

    – die Reihenfolge der Kexte ist entscheidend! Erst Lilu.kext, dann deren aufbauende Plugs wie AppleALC etc. Erst VirtualSMC.kext, dann dessen …

    ASUS PRIME X299-DELUXE i9-9940X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64 • BMD Intensity Pro 4K

    ASUS WS X299 SAGE/10G i9-10980XE • DDR4 64GB • SSD 970 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon VII • BMD DeckLink 4K Extreme 12G


    Ordnung ist die primitivste Form von Chaos. (Hans-Jürgen Quadbeck-Seeger)

  • apfelnico : Ich danke dir für deine schnelle Hilfe, jetzt klappt es :)


    MacPro:7.1 Gigabyte B550 AORUS PRO CPU: Ryzen 7 3700X Memory: 32GB Corsair Vengeance LPX DDR4-3200 CL16 D GPU: Sapphire Radeon RX 5500 XT 8GB HDD: 1xM2 1TB

    Bootloader: OpenCoreVersion.svg

    MacBook Pro 8.3 (orignal):  CPU: 2,4 GHz Intel Core i7 Quad-Core 8GB 1600 DDR3 1xSSD 256GB 1xHDD 2TB Wifi/Bluetooth 802.11n/4.0 macOS 10.13.6


  • Habe mir durch die viele Fummelei mit den verschiedenen Tools in der config.plist zwischen OpenCore.efi und Boot Picker zwei Meldungen eingefangen,


    CS: No schema for ExposeBootPath at 3 index!

    OC: Missing GOP on console - Unsupported


    jemand eine Idee?

  • Solche Fehler sind auch häufig Werte zwischen falsch gesetzten string , data usw.

    In deinem ersten Fall gibt es den Eintrag und der verwendeten Version nicht mehr.


    Replaced `ExposeBootPath` with `ExposeSensitiveData`


    im Zweiten Fall könnte es einer Deiner 4 Lieblingshacken sein


    iMac17,1 GA-Z170N WiFi F22f |i5-6600 HD530 |RX 560 |16GB |250GB SSD |macOS 11.2 .1| *
    iMac20,1 NVISEN Y-MU01 |i7-10510U |16GB |256GB SSD |macOS 11.2.1 & 11.3 b1 | *
    MacBookPro14,1 XiaoMi-Pro-15,6" |i5-8250U UHD620 |8GB |250 & 250GB SSD |macOS 10.15.7 (19H524) | *
    MacBookPro16,1 RedMi 14" |i7-10510U | 8GB | 512GB SSD |macOS 11.2.1 & 11.3 b1 | *
    MacMini8,1 HYSTOU P05B |I7-8550U UHD620|16GB |500GB SSD |macOS 10.15.7 (19H524) & 11.2.1 | *
    MacMini8,1HYSTOU S210H |I9-9880H UHD630|32GB |250GB SSD |macOS 11.2.1 & 11.3 b6| *

    | * BootLoader OpenCore REL-069-2021-04-10

  • ExposeBootPath löschen und der andere wert kommt hierhin:


    <key>Security</key>
    <dict>
    <key>ExposeSensitiveData</key>
    <integer>2</integer>
  • Wo das gerade schon Thema ist... am besten als Wert ne "3". Steht zwar nicht in der Doku geht aber trotzdem. Damit wird neben booter-path auch die opencore-version parallel mitgeliefert. Ist z.b. wichtig für den Kext Updater.

    Airportkompatible Karte trotz BIOS Whitelist? >> Klick <<

  • Ihr bezieht euch jetzt aber auf Open Core v.0.0.2, weil ich auf einem extra USB Stick den OC EFI Maker teste und da in der v.0.0.1, da trifft diese Änderung nämlich nicht zu.

  • Gerade deshalb sage ich ja, lest immer die aktualisierten Docs mit. Und aus diesem Grunde halte ich (derzeit) nichts von "OC EFI Maker". Alles steckt noch in den Kinderschuhen, es ändert sich permanent. Wen es interessiert, der sollte eben bei der Quelle nachschauen. https://github.com/acidanthera/OpenCorePkg

    Hier nur Zip downloaden und "macbuild.tool" (Terminal) aufrufen. Ist doch kein Ding. Dann Docs lesen und eigene plist gewissenhaft mit der sample vergleichen.

    ASUS PRIME X299-DELUXE i9-9940X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64 • BMD Intensity Pro 4K

    ASUS WS X299 SAGE/10G i9-10980XE • DDR4 64GB • SSD 970 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon VII • BMD DeckLink 4K Extreme 12G


    Ordnung ist die primitivste Form von Chaos. (Hans-Jürgen Quadbeck-Seeger)

  • derHackfan komisch das Du da den Fehler der anderen Version bekommst, ist aber am Ende auch egal ich halte es da mehr wie es apfelnico schreibt. Und da funktioniert es auch meist.


    iMac17,1 GA-Z170N WiFi F22f |i5-6600 HD530 |RX 560 |16GB |250GB SSD |macOS 11.2 .1| *
    iMac20,1 NVISEN Y-MU01 |i7-10510U |16GB |256GB SSD |macOS 11.2.1 & 11.3 b1 | *
    MacBookPro14,1 XiaoMi-Pro-15,6" |i5-8250U UHD620 |8GB |250 & 250GB SSD |macOS 10.15.7 (19H524) | *
    MacBookPro16,1 RedMi 14" |i7-10510U | 8GB | 512GB SSD |macOS 11.2.1 & 11.3 b1 | *
    MacMini8,1 HYSTOU P05B |I7-8550U UHD620|16GB |500GB SSD |macOS 10.15.7 (19H524) & 11.2.1 | *
    MacMini8,1HYSTOU S210H |I9-9880H UHD630|32GB |250GB SSD |macOS 11.2.1 & 11.3 b6| *

    | * BootLoader OpenCore REL-069-2021-04-10