OpenCore Sammelthread (Hilfe und Diskussion)

  • Kennst du den neuen OC-Editor? siehe Anhang

    vielen lieben Dank :)

    Damit gehts auch.


    jetzt nur noch es hinbekommen mit USB Zeug mit Hackintool und dann fertig.

  • Du wirst sehen, das ist die einfachste Aufgabe....

    Hackintool starten....

    mit dem Besen erstmal alles clearen

    der Kreis mit Pfeilen, dient zum Aktualisieren ...

    jetzt mit einem Reinen USB2-Stick alle Ports nach und nach besetzen, damit wird der Eintrag grün.

    Das gleiche mit einem USB3-Stick/Device.....

    alles was nicht grün ist , mit dem - Zeichen löschen.

    dann rechts auf exportieren klicken, und die generierte USBPorts.kext , in dein EFI einpflegen....

    jetzt noch den XhciPortLimit deaktivieren.... neu booten... ferdisch

    Gigabyte Z390 Aorus Master
    i9-9900KF-WA-Kü
    16GB DDR4
    SSD-NVMe-Samsung EVO970 500GB
    ATI Sapphire Nitro RX 580 4GB
    OSX HighSierra/Mojave/BigSur
    Boot: OpenCore

  • Klingt ja wirklich einfach.

    Muss dann auch noch in der Config irgendwas geändert werden?
    Oder einfach erzeugte Kext in den Kext Ordner und XhciPortLimit deaktivieren ?

  • Hab ich doch oben schon geschrieben.....liest du das nicht?


    +++++

    und die generierte USBPorts.kext , in dein EFI einpflegen....

    jetzt noch den XhciPortLimit deaktivieren.... neu booten... ferdisch

    ++++++

    Gigabyte Z390 Aorus Master
    i9-9900KF-WA-Kü
    16GB DDR4
    SSD-NVMe-Samsung EVO970 500GB
    ATI Sapphire Nitro RX 580 4GB
    OSX HighSierra/Mojave/BigSur
    Boot: OpenCore

  • Muss dann auch noch in der Config irgendwas geändert werden?

    ...die USBPorts.kext muss in die config.plist unter dem Menüpunkt Kernel eingetragen werden und die Datei selbst in den Kext-Ordner hineinpacken...


    hackintosh-forum.de/attachment/164943/

    ...er, sie und es haben eingeschalteT, ausgeschalteT, umgeschalteT

    ...er, sie und es können einschalteN, ausschalteN, umschalteN

    Edited 2 times, last by maschinenwart ().

  • maschinenwart

    Genau so habe ich es gemacht. Wenn die USBPorts Kext aber unter Kernel eintrage. Kommt beim Booten der Fehler das er die USB Ports unter Contents/MacOS vermisst.
    Ohne eintragen, also nur mit USBPorts Kext im Ordner bootet er durch.


    Siehe Bild. Wenn es so ist, kommt der Fehler.

  • Wenn du deinen USBPorts.kext nicht einbindest wird Sie auch nicht geladen.

    Also muss Sie eingebunden werden.

    Wenn du aber deinen USBPorts.kext mit der rechten Maus taste anklickst und den

    Paket Inhalt anzeigen wählst, dort bissl durchguckst wirst du bemerken das es im Contents Ordner keinen MacOS Ordner vorhanden ist.

    Also musst du unter ExecutablePath "Contents/MacOS/" auch weglöschen, danach ist das Fehler weg.


    Gruss Coban

     MSI-B150M Mortar | Intel® Core™ i7-6700 Skylake | 64GB DDR4 RAM | Intel® HD Graphics 530 | Samsung NVMe 960 EVO / 1x2 TB HDD | BCM943602BAED DW1830 | OpenCore aktuell / macOS Catalina 10.15 / Windows 10 Pro / Ubuntu 20.04 LTS

     Lenovo S340-15IIL | Intel® Core™ i7-1065G7 IceLake | 12GB DDR4 RAM | Intel® Iris Plus Graphics G7 | Nvme Intel SSDPEKNW512G8L/SSD Samsung 256GB | BCM94360NG | OpenCore aktuell / macOS Catalina 10.15 / BigSur 11.0 / Win 10 Pro / Ubuntu 20.04 LTS


    " Chasch nöd s Föifi und s Weggli ha."

  • Vielen lieben Dank :) Es hat geklappt.

  • Ich möchte hier mal die Frage stellen, ob der QtOpenCoreConfig-Mac einen Plist Editor vollwertig erstetzt? Werde ich damit in der Lage sein, bei einem Update die config.plist mit der Sample.plist abzugleichen und Neuerungen in die config.plist zu übernehmen? bananaskin

    Grüße

    Arkturus


    iMacPro1,1 Asus Prime B250M Plus, Intel QuadCore i5 7500 Kaby Lake 3,41 Ghz, PowerColor RX580 8192 MB VRAM, Realtek ALC888B (ID 1 (2)), Fenvi T919 , 16GB Ballistic Sport DDR4 2400, Mojave 10.14.6 ((18G3020) Clover r5119, BS 11.1 (20C5048k) OC 0.6.2

  • Ich hoffe doch denn plötzlich ging bei mir der ProperTree leider nicht mehr. Plötzlich Meldung : Python wurde beendet, danach kriege ich es nicht mehr geöffnet.

  • das hat mit meiner Frage aber nicht zu tun. Die stellt darauf ab, ob man sich als Anfänger und OC Einsteiger in ein Tool einarbeitet, was einen am Ende des Tages in die Sackgasse führt. Ohne die Antwort abzuwarten nehme ich an es kommt ein klares Nein. Dann wäre mein dringender Rat, nehme einen PlistEditor Deiner Wahl und arbeite damit. Einmal die Struktur der config.plist verstanden, wird es ein Kinderspiel ein Udate durchzuführen. Dabei müssen zwischen zwei Dateien unterschiedlicher Struktur Daten migriert werden, wobei oft die Struktur zu ergänzen oder ändern ist. Neue funktionen kommen hinzu, alte fallen weg oder es wird innerhalb der Struktur verschoben und die Datenformate ändern sich. Das macht sich am einfachsten per Drag and Drop im PlistEditor.

    Grüße

    Arkturus


    iMacPro1,1 Asus Prime B250M Plus, Intel QuadCore i5 7500 Kaby Lake 3,41 Ghz, PowerColor RX580 8192 MB VRAM, Realtek ALC888B (ID 1 (2)), Fenvi T919 , 16GB Ballistic Sport DDR4 2400, Mojave 10.14.6 ((18G3020) Clover r5119, BS 11.1 (20C5048k) OC 0.6.2

  • Beim Anschluss des zweiten Monitor an HDMI flackert der Hauptmonitor andauernd, dieser ist an einem miniDP angeschlossen.

    Im abgesicherten Modus sieht alles wie gewohnt und bleibt alles ruhig, nach Start im "normalen" Modus gehts wieder von vorne los.



    Grafikkarte RX5500XT



    Under Windows läuft alles wie gehabt.

    Edited 5 times, last by schmalen: Zusatz in einem anderen POST ().

  • Weiß jemand was man tun kann bezüglich Dualboot?

    Wenn ich im OC Menü Windows auswähle, endet dies im Bluescreen.

    Laut dem Dortania Guide soll SyncRuntimePermissions und ProtectUefiServices aktiviert sein.

    Beides ist bei mir der Fall.


    Weiß jemand eine Lösung?

  • Läßt sich Windows noch direkt aus dem BIOS starten (ohne OC dazwischen)?

  • Ja ich kann den Windows Bootmanager ohne Probleme ausführen.

  • Hast du ein SSDT-XOSI.aml im Einsatz?

    Wenn ja kannst du mal den zuverfügung stellen?.


    Gruss Coban


    Edit:

    Hab grad in einem EFI von dir (älterer Beitrag) gesehen das du ein SSDT-PLUG-DRTNIA.aml einsetzt.

    Den solltest du mit SSDT-PLUG.aml vom OpenCore Package ersetzen.

    Du hast ein CoffeeLake System, also sollte die SSDT-PNLF.aml auch die SSDT-PNLFCFL.aml vom OpenCore Package sein.

     MSI-B150M Mortar | Intel® Core™ i7-6700 Skylake | 64GB DDR4 RAM | Intel® HD Graphics 530 | Samsung NVMe 960 EVO / 1x2 TB HDD | BCM943602BAED DW1830 | OpenCore aktuell / macOS Catalina 10.15 / Windows 10 Pro / Ubuntu 20.04 LTS

     Lenovo S340-15IIL | Intel® Core™ i7-1065G7 IceLake | 12GB DDR4 RAM | Intel® Iris Plus Graphics G7 | Nvme Intel SSDPEKNW512G8L/SSD Samsung 256GB | BCM94360NG | OpenCore aktuell / macOS Catalina 10.15 / BigSur 11.0 / Win 10 Pro / Ubuntu 20.04 LTS


    " Chasch nöd s Föifi und s Weggli ha."

    Edited once, last by cobanramo ().

  • Published benutzt du für dein Dual Boot Setup 2 Festplatten oder befinden sich Windows und MacOS zusammen auf einem Datenträger?

    Ich möchte hier mal die Frage stellen, ob der QtOpenCoreConfig-Mac einen Plist Editor vollwertig erstetzt? Werde ich damit in der Lage sein, bei einem Update die config.plist mit der Sample.plist abzugleichen und Neuerungen in die config.plist zu übernehmen? bananaskin

    QtOpenCoreConfig ist vom Konzept her das gleiche wie OpenCore Cofigurator. Also ein GUI-basiertes Tool, um Parameter für OpenCore Configs zu bearbeiten, das dementsprechend nur die Felder/Parameter anzeigt, die es kennt. Das heißt, die müssen halt jedes mal, wenn ein neues Feature zu OpenCore dazu kommt, aktualisiert werden.


    Wenn Du einen echten freeware plist Editor haben willst, dann nimm doch einfach PlistEDPlus vom selben Entwickler: https://github.com/ic005k/PlistEDPlus

  • ich bin nicht sicher, ob ein OC oder Big Sur Beta Problem. Nach dem letzten Update meines macBookPro13,1 (T460) auf Big Sur 11,2 Beta 2 bleibt die Möhre nach dem Umschalten auf die iGPU hängen, Verbose bringt da keine Meldungen mehr. Derzeit nutze ich der OC 0.6.6 nigthly, habe aber keine EFI dazu auf nem Stick. Auch frühere Versionen funktionierender EFI's von OC, einschl. Clover 5125 bringen kein anderes Ergebnis.


    Kann jemand mal in der EFI schauen, ob hier ggf. andere Einträöge in Device Propertie für die HD520 erforderlich sind? Bei Dortania sieht das nähmlich anders aus für Skylake.



    Sind ext. Bootargumente erforderlich?

    Files

    Grüße

    Arkturus


    iMacPro1,1 Asus Prime B250M Plus, Intel QuadCore i5 7500 Kaby Lake 3,41 Ghz, PowerColor RX580 8192 MB VRAM, Realtek ALC888B (ID 1 (2)), Fenvi T919 , 16GB Ballistic Sport DDR4 2400, Mojave 10.14.6 ((18G3020) Clover r5119, BS 11.1 (20C5048k) OC 0.6.2

  • cobanramo


    also ich habe nun die SSDT- Plug.aml, die SSDT-PNLF.aml und die SSDT-PNLFCFL.aml im Einsatz.

    Wenn ich ohne die PNLFCFL Boote, kommt er bis Reperatur wird vorbereitet.

    Wenn ich mit PNLFCFL Boote springt er sofort zum Bluescreen.


    5T33Z0 MacOS und Windows liegen auf 2 verschiedenen Datenträgern.

  • Arkturus Du hast 9 veraltete kexte in deiner EFI, darunter Whatevergreen, Lilu und VirtualSMC. Mach erstmal ein Update deiner Extensions und teste dann nochmal.


    Published Wozu brauchst du die SSDT-PNLF.aml? Handelt es sich hier um einen Laptop?

    Gruß, karacho


    Bitte keine Supportanfragen via PN. Eure fragen gehören ins Forum!

    Ich hab noch drei Patronen, eine für dich und zwei für mich...