OpenCore Sammelthread (Hilfe und Diskussion)

  • Doctor Plagiat ja habe diverse Aptio's getestet, ---- ohne erfolg.


    Hinweis Download-Fritz im Post. #31. --> Bitte nicht den verwenden... AptioMemoryFix + CPU PM MSR + InvalidFlexRatio Quirks sollten's tun

  • schmalen  Doctor Plagiat Keine Ahnung warum das bei euch nicht funktioniert.
    Ich nutzte OC auf einem USB Stick und kann den an jeden Rechner im Haus einstecken und komme mindestens in das Auswahlmenu und darüber hinaus, von daher bin ich gerade ein wenig hilflos und oder ratlos, ich würde ja gerne helfen aber mir fällt leider nichts sinnvolles ein.

  • derHackfan Trotzdem DANKE!


    Ich habe OC auch auf einen USB-Stick gepackt, komme auch in 's Auswahlmenü, nur macOS ist nicht da.

    Aber ist ja nun wirklich kein Beinbruch, solange man einen funktionierenden Clover-Bootloader hat.

    Kommt Zeit kommt Rat.

    MfG, docplag



  • Den LPC umzubenennen hat zum einen nix mit Grafik zu tun, zum anderen ist es auch nicht wirklich nötig. Und heißt dieses Device bei dir wirklich LPC, oder LPC0?

    ASUS PRIME X299-DELUXE i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

    ASUS WS X299 SAGE/10G i9-10980XE • DDR4 64GB • SSD 970 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon VII • DeckLink 4K Extreme 12G


    Ordnung ist die primitivste Form von Chaos. (Hans-Jürgen Quadbeck-Seeger)

  • Läuft mit meinem X299. Finetuning muss noch. Superschnell und reduziert aufs Wesentliche. Hut ab Download-Fritz


    ASUS PRIME X299-DELUXE i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

    ASUS WS X299 SAGE/10G i9-10980XE • DDR4 64GB • SSD 970 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon VII • DeckLink 4K Extreme 12G


    Ordnung ist die primitivste Form von Chaos. (Hans-Jürgen Quadbeck-Seeger)

  • OC nimmt alle Patches an nur nicht den LPC to LPCB ,sobald ich den auf Yes setze startet der Rechner nichtmehr.

    Klappt bei mir bestens.



    "TableSignature" habe ich bei mir nicht gesetzt, in Verbindung mit "All" (true) wird die komplette ACPI durchsucht, nicht nur die erste oder spezifizierte Table (in diesem Falle egal, ist nur in der DSDT enthalten, es gibt aber auch Fälle von Renames, die sollten auch in weiteren internen SSDTs ausgeführt werden). Wichtig ist jedoch "Count". Ist dieser auf "0" gesetzt, werden ALLE gefundenen entsprechenden Zeichenketten ersetzt, ist zum Beispiel hier eine "1" festgelegt, wird nur der erste gefundene Eintrag ersetzt. Im Falle von "LPC0" funktioniert das dann natürlich nicht, denn dieser taucht mehrfach auf. Wird nun nur EIN Eintrag davon umbenannt, ist Chaos in der DSDT "vorprogrammiert". Es hilft ungemein, die sehr gute Dokumentation "Configuration.pdf" zu lesen …

    ASUS PRIME X299-DELUXE i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

    ASUS WS X299 SAGE/10G i9-10980XE • DDR4 64GB • SSD 970 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon VII • DeckLink 4K Extreme 12G


    Ordnung ist die primitivste Form von Chaos. (Hans-Jürgen Quadbeck-Seeger)

  • Alles was mit OpenCore zu tun hat hier OpenCore Sammelthread (Hilfe und Diskussion) rein und nicht immer neu Themen auf machen.


    Finde ich auch und darum ist nun alles wieder vereint.


    iMac17,1 GA-Z170N WiFi F22f |i5-6600 HD530 |RX 560 |16GB |250GB SSD |macOS 11.2 .1| *
    iMac20,1 NVISEN Y-MU01 |i7-10510U |16GB |256GB SSD |macOS 11.2.1 & 11.3 b1 | *
    MacBookPro14,1 XiaoMi-Pro-15,6" |i5-8250U UHD620 |8GB |250 & 250GB SSD |macOS 10.15.7 (19H524) | *
    MacBookPro16,1 RedMi 14" |i7-10510U | 8GB | 512GB SSD |macOS 11.2.1 & 11.3 b1 | *
    MacMini8,1 HYSTOU P05B |I7-8550U UHD620|16GB |500GB SSD |macOS 10.15.7 (19H524) & 11.2.1 | *
    MacMini8,1HYSTOU S210H |I9-9880H UHD630|32GB |250GB SSD |macOS 11.2.1 & 11.3 b1| *

    | * BootLoader OpenCore REL-067-2021-02-20

  • Irgendwie stehe ich gerade auf dem Schlauch. Nach der ganzen Zeit mit dem doch eher zur Faulheit verführenden CloverConfigurator habe ich den Faden nochnicht gefunden, obwohl OC ja doch eher einer konsequenten Weiterentwicklung

    von Ozmosis gleicht und ich zu den Zeiten ROMs gebastelt hatte mit welchen alles funktionierte.


    Nur hänge ich gerade am "simpelsten" der GPU-Geschichte fest...


    Mit freundlichen Grüßen! Jens!


    Ich hab zwar keine Lösung, doch ich bewundere dein Problem!


    Hardware:

  • Seit Gestern hat sich die Konfig sehr veraendert. Bereits funktioniert:

    - console output (mit dem Apfel oder Verbose)... bei mir 2560x1440

    - die boot Platte ist gespeichert (neuer AptioFix)


    es fehlt nur der generic Boot aber das kommt bald...

  • Also ich bin gerade am überlegen ob ich einen neuen HACKINTOSH bauen soll und war begeistert wie gut osmosis funktionierte. So wie ich verstanden habe ist das jetzt der heimliche Nachfolger.. aber patcht man hier auch das bios oder ist das vorgehen eher wie bei clover(über die Efi partition)?

  • 1. Ist es kein heimlicher Nachfolger da er schon seit ein paar Jahren im Gespräch war.

    2. Macht das selbe wie Clover auch er, wird aus der EFI geladen.


    Nur ist er auf das minimalste reduziert und das ist auch gut so, keinen sinnlosen schnick schnack.

  • Danke für die antwort,

    Was ich an osmosis so mochte das das bios eingespielt wurde und die hardware einfach funktionierte.

    Noch sehe ich bzw. Verstehe ich die Vorteile nicht die OC bringt ausser das es schneller (ist es?) ist und weniger "bloat" beinhaltet (okay das ist schon was :D)

  • Technologisch schon anders, allein wie Kexte eingebunden werden. Die sehr durchschaubare config.plist ist ein Hit.

    ASUS PRIME X299-DELUXE i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

    ASUS WS X299 SAGE/10G i9-10980XE • DDR4 64GB • SSD 970 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon VII • DeckLink 4K Extreme 12G


    Ordnung ist die primitivste Form von Chaos. (Hans-Jürgen Quadbeck-Seeger)

  • apfelnico : Kannst du mir bitte nochmal einen Stubser geben in Richtung Grafikkarte ??

    Mit freundlichen Grüßen! Jens!


    Ich hab zwar keine Lösung, doch ich bewundere dein Problem!


    Hardware:

  • es mangelt derzeit an Anleitung und oder Unterstützung wann welcher Eintrag in der config angepasst werden muss.

    Ich zitiere mich mal selber, vielleicht kann man so den einen oder anderen OC Anwender zur Mitarbeit bewegen.

    Resolution, wenn das mal so einfach wäre, seine Auflösung eintragen und dann sollte es gehen.



    Leider nein, es bedarf zwei Einträge in der config.plist dafür...


    Edit: EFI vom Freitag, 3. Mai 2019

    • add Platforminfo
    • add UEFI
  • Ich würde mich ja zur Mitarbeit bewegen lassen, wenn ich doch in der Bootauwahl ein macOS zur Auswahl hätte. Leider auf dem ASRock Z390 nicht, nit dem selben Stick auf dem Dell-Laptop dagegen macOS + Recovery.

    Muss wohl am ASRock-Board liegen.

    MfG, docplag



  • Resolution, wenn das mal so einfach wäre, seine Auflösung eintragen und dann sollte es gehen.


    Schau bei meinem angehefteten nach, so funktioniert das. In beiden darüber „Text“ festlegen. Bin nur mobil unterwegs, deshalb nicht mehr...

    ASUS PRIME X299-DELUXE i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

    ASUS WS X299 SAGE/10G i9-10980XE • DDR4 64GB • SSD 970 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon VII • DeckLink 4K Extreme 12G


    Ordnung ist die primitivste Form von Chaos. (Hans-Jürgen Quadbeck-Seeger)

  • apfelnico Ich danke für deine Mitarbeit.

    Deinen EFI Ordner hatte ich mir auch schon angesehen und so funktioniert es bei mir leider nicht.
    Einzig wenn ich GOP auf Yes stelle klappt es mit der richtigen Auflösung, damit kann ich auch leben, es gibt also zwei Wege und das gilt es doch mal für die Community festzuhalten.


    Edit: OpenCore v.0.2 eingesetzt und läuft...

    Edited 2 times, last by derHackfan: Edit eingefügt. ().

  • Mein Problem "keine macOS im Bootmenü" hat jetzt NoirOSX gelöst.

    Ein recht herzliches :danke2: dafür.

    Mit seiner EFI konnte ich in 's System booten. Das ist erstmal ne Grundlage, auch wenn es beim Shutdown ne KP gibt. Warum meine EFI nicht ging und seine funktionierte, habe ich aber noch nicht heraugefunden.


    Für Andere die OC auch mal ausprobieren wollen und ebenfalls Probleme haben, können die EFI von NoirOSX testen. Die config.plist muss dann aber noch an 's eigene System angepasst werden. Die im Anhang ist für das ASRock Z390 Phantom ITX.


    OC-EFI(vonNoirOSX).zip

    MfG, docplag