OpenCore Sammelthread (Hilfe und Diskussion)

  • Ja, dass ist das Problem, dass Thema ist extrem anspruchsvoll mit vielen Fachbegriffen, wenn man also die Fremdprache nicht auf Muttersprachlerniveau beherrscht, kann man da schon Probleme bekommen.



    Leider ist die Guide nicht auf Portugisisch, sodass sich wohl Niemand die Mühe macht, sie ins Deutsche zu übersetzen, da in den Deutschen Schulen massenweise die amerikanische Sprache gelernt wird.


    Mit den Google Übersetzer, kann man es mit ausreichender Motivation vielleicht doch schaffen.

  • Wie aktiviere ich die Openshell.efi in OC? Ist die nicht standardmäßig vorhanden? Die Leertaste läßt sie nicht erscheinen.

    Gruß

    LOM



  • Die OpenShell.efi muss im Ordner Tools liegen und in der config.plist (Misc/Tools) aktiviert sein.....und ja, sie sollte standardmäßig vorhanden und aktiviert sein.

  • Nur kurz angemerkt, Computer Englisch und Schulenglisch sollte man nicht gleich setzen . WYSIWYG

  • badbrain

    Mein Fehler - ich hatte bereits händisch die O...S....efi in Driver statt in Tools eingefügt und einen Eintrag in Misc/...gemacht. Das funzte nur eingeschränkt - beim Start kamen diverse gelbe Textzeilen noch vor dem Picker.


    So - jetzt passt auch das. :)

    Gruß

    LOM



    Edited once, last by LuckyOldMan ().

  • Nach neu Install von Catalina, starte ich den App Store und diese wird unerwartet beendet.

    Installiert wurde es nach dem Guide von Dortania.

    Keine Anmeldung mit der Apple ID, wurde übersprungen, bei der Neu Install von MacOS.

    ID wurde auch mit GenSMBIOS erstellt.

    EFI Hochgeladen.

    Files

    • EFI.zip

      (2.59 MB, downloaded 10 times, last: )

    AMD R7 2700X | GIGABYTE AORUS X570 Master | 16 GB GSkill Trident Z DDR4-3600 CL18 | MSI GTX 1080 ti Gaming | Auzentech X-Fi HT HD | WD SN750 500GB | Corsair RM750i | Win 10 Pro

    AMD FX 8350 | Asus Crosshair V Formula Z | 16 GB GSkill Ripjaws X DDR3-2400 CL11 |MSI RX 480 Gaming X | 120GB + 250 GB SSD | Enermax Platimax D.F 500 | MAC OS X 11 | Open Core

  • Mit gensmbios das smbios neu generiert, und nach dem überspringen der Einrichtung nach dem installieren von BS versucht neu anzumelden, mit deiner Apple ID? War das ein Clean install oder drüber gebügelt? Beim drüber bügeln sollte man nicht das smbios wechseln. Bei einem Clean install isses egal. Dann sollte man jedoch seinen Rechner zuvor bei allen Apple Diensten abmelden oder besser noch, den Rechner mit dem alten smbios aus dem Account werfen. OK, das erklärt aber immer noch nicht, wieso der AppStore abkackt.


    Edit: Sehe gerade dass du Catalina neu installiert hast. Ändert aber nix an meiner Aussage zu den Apple-Diensten.

    Gruß, karacho


    Bitte keine Supportanfragen via PN. Eure fragen gehören ins Forum!

    Ich hab noch drei Patronen, eine für dich und zwei für mich...

  • Ja Habe das Catalina Neu Installier, also Format SSD, eu erstellt und dann Frisch neu aufgesetzt.

    Sogar mit 2 verschiedene USB-Sticks.

    1. Stick mit BDU erstellt und OC ersetzt.

    2. Stick Erstellt nach Anleitung von Dortania.


    Beides gleicher Fehler, Appstore startet kurz, dann Force Close mit Meldung App Store wurde unerwartet beendet.

    Bin ratlos.

    AMD R7 2700X | GIGABYTE AORUS X570 Master | 16 GB GSkill Trident Z DDR4-3600 CL18 | MSI GTX 1080 ti Gaming | Auzentech X-Fi HT HD | WD SN750 500GB | Corsair RM750i | Win 10 Pro

    AMD FX 8350 | Asus Crosshair V Formula Z | 16 GB GSkill Ripjaws X DDR3-2400 CL11 |MSI RX 480 Gaming X | 120GB + 250 GB SSD | Enermax Platimax D.F 500 | MAC OS X 11 | Open Core

  • Hattest du zuvor auch Catalina drauf? Wenn ja, warum hast du denn dann dein smbios gewechselt?


    Edit: Das erklärt aber immer noch nicht, wieso der AppStore sich verabschiedet. Auch mit einem anderen smbios dürfte der nicht abstürzen.

    Gruß, karacho


    Bitte keine Supportanfragen via PN. Eure fragen gehören ins Forum!

    Ich hab noch drei Patronen, eine für dich und zwei für mich...

  • Ja, hatte es mal nach dieser Anleitung installiert:

    HowTo: Ryzentosh


    Jetzt versuche ich noch Oracle VM VirtualBox, mit Virtual Win 10 zu erstellen.

    So das ich es nach der Anleitung noch mal installieren kann.

    Denn TransMac ist nicht gerade günstig.


    Ich hatte auf OC 0.6.3 und hab Probleme der iCloud, mit dieser Meldung:
    Diese Apple id ist gültig. Allerdings handelt es dabei sich um keinen iCloud Account.
    Da habe ich dann ein neues SMBios, ohne Erfolg. Meldung bleibt.


    Dann ist meine SSD Kaputt gegangen und ich habe es jetzt auf eine Neue SSD installiert und jetzt habe ich das Problem mit dem App-Store.

    AMD R7 2700X | GIGABYTE AORUS X570 Master | 16 GB GSkill Trident Z DDR4-3600 CL18 | MSI GTX 1080 ti Gaming | Auzentech X-Fi HT HD | WD SN750 500GB | Corsair RM750i | Win 10 Pro

    AMD FX 8350 | Asus Crosshair V Formula Z | 16 GB GSkill Ripjaws X DDR3-2400 CL11 |MSI RX 480 Gaming X | 120GB + 250 GB SSD | Enermax Platimax D.F 500 | MAC OS X 11 | Open Core

  • Der Fehler liegt wohl im neu installiertem System. Evtl ist bei der Installation was falsch gelaufen, sonst würde der AppStore nicht abstürzen.


    Den Umweg über Oracle virtual Box kannst Du dir sparen. Wenn macOS läuft und nur der AppStore zickig ist, kannst du das ganze unter macOS leichter erstellen, ohne virtual Box. Lade dir hier im Forum im Downloadbereich AnyMacOs runter, und lade damit den Catalina Installer neu runter.

    Gruß, karacho


    Bitte keine Supportanfragen via PN. Eure fragen gehören ins Forum!

    Ich hab noch drei Patronen, eine für dich und zwei für mich...

  • OOH, das habe ich warscheinlich falsch geschrieben.

    Ich habe 2 PCs (Win10), mit den erstelle und editiere ich alles.

    2. PC ist das Testobjekt, MacOS.


    Ich habe vor, Oracle VM VirtualBox, mit Virtual Win 10 zu erstellen, so das ich bei TransMac die 14 Tage Testzeitraum, immer wieder verlängern kann. :)


    Dann will ich es nach dieser Anleitung HowTo: Ryzentosh erneut installieren.

    AMD R7 2700X | GIGABYTE AORUS X570 Master | 16 GB GSkill Trident Z DDR4-3600 CL18 | MSI GTX 1080 ti Gaming | Auzentech X-Fi HT HD | WD SN750 500GB | Corsair RM750i | Win 10 Pro

    AMD FX 8350 | Asus Crosshair V Formula Z | 16 GB GSkill Ripjaws X DDR3-2400 CL11 |MSI RX 480 Gaming X | 120GB + 250 GB SSD | Enermax Platimax D.F 500 | MAC OS X 11 | Open Core

  • Nachdem ja inzwischen bei mir Windows & macOS mit OC gestartet werden, versuche ich gerade, nach dieser Methode ( https://kextcache.com/opencore-dualboot-guide/ ) auch das früher unter Clover vorhandene Ubuntu in OC einzubinden und breche mir bald die Gräten auf der Suche nach dem richtigen Eintrag der Ubuntu-Platte bzw. deren Bootloader grub.., den ich in der config.plist unter misc->entries einfügen muss.


    Damit ich das überhaupt als komplettes Bild auf dem Monitor bekomme, habe ich außer Cata/Moj & Ubuntu alle weiteren Platten abgekoppelt.



    Ich habe mich mit FS0 bis FS12 plus dir durchgehangelt, wurde aber nicht fündig.


    Es muss doch einen einfacheren Weg geben, das hinzubekommen. :rolleyes:

    Gruß

    LOM



  • Alles was du finden musst ist das efi mit der unterverzeichnis bspl. Ubuntu :)


    Es geht auch einfacher, guck dir mal den OC Configurator an, unter entries kannst du dort sogar anwählen zu dem efi datei.


    gruss coban

     MSI-B150M Mortar | Intel® Core™ i7-6700 Skylake | 64GB DDR4 RAM | Intel® HD Graphics 530 | Samsung NVMe 960 EVO / 1x2 TB HDD | BCM943602BAED DW1830 | OpenCore aktuell / macOS Catalina 10.15 / Windows 10 Pro / Ubuntu 20.04 LTS

     Lenovo S340-15IIL | Intel® Core™ i7-1065G7 IceLake | 12GB DDR4 RAM | Intel® Iris Plus Graphics G7 | Nvme Intel SSDPEKNW512G8L/SSD Samsung 256GB | BCM94360NG | OpenCore aktuell / macOS Catalina 10.15 / BigSur 11.0 / Win 10 Pro / Ubuntu 20.04 LTS


    " Chasch nöd s Föifi und s Weggli ha."

  • Alles was du finden musst ist das efi mit der unterverzeichnis bspl. Ubuntu

    So habe ich den Artikel auch verstanden.

    Hier ist die Linux-Platte (plus eine HFS+-Partition):


     

    Es fehlt eine EFI. Deshalb finde ich vermutlich nach obiger Methode nichts - auch nicht über die Entries-Auswahl im OCC.


    Unter Clover sah das für Ubuntu Zusätzliche so aus:



    Mehr war nicht erforderlich. Wäre ja zu schön gewesen, das in OC einfach nur anzuhängen. Leider, leider ... ;)

    Gruß

    LOM



  • "Es ist nicht aller Tage ...

    ... Ubuntu kommt wieder - keine Frage!" ;)




    guck dir mal den OC Configurator an

    Ich nutze den OCC trotz aller Unkenrufe schon ja schon etwas länger, wobei immer nach dem Abspeichern per Editor gegengeprüft wird. Aber mit Deinem Hinweis hast Du mich dazu gebracht, in Kombination mit dem OCC das zu versuchen, was ich eben angesprochen hatte .


    Ich nahm den kompletten, für Clover erstellten Ubuntu-Ordner und packte ihn in den EFI-Ordner von OC. Dann via config.plist den OCC geöffnet, zu Misc->Entries gehangelt, via Browse eine Verknüpfung zur grubx64.efi hergestellt und der Pfad stand ohne kryptische Schreibarbeit in der richtigen Zeile. :)



    Dann noch den Namen für den OC-Picker angepasst (grubx64 klingt jetzt nicht so dolle) und fertig.

    Nun linuxt es auch wieder. ;)

    Gruß

    LOM



  • So MacOS nach dieser Anleitung HowTo: Ryzentosh erneut installiert und gleicher Fehler. ( Meldung: App Store wurde unerwartet beendet)


    Laut Fehlerbericht:

    Crashed Thread: 40 com.apple.audio.IOThread.client

    Exception Type: EXC_BAD_Instruction (SIGILL)

    Exception Notes: EXC_CORPSE_NOTIFY


    Termination Signal: Illegal instruction: 4

    Termination Reason: Namespace SIGNAL, Code 0x4

    Termination Process: exc Handler (513)


    Fehler gefunden. Der Fehler ist, es muss das richtige Sound Ausgabegerät ausgewählt werden, sonst Crasht der App Store. WTF

    AMD R7 2700X | GIGABYTE AORUS X570 Master | 16 GB GSkill Trident Z DDR4-3600 CL18 | MSI GTX 1080 ti Gaming | Auzentech X-Fi HT HD | WD SN750 500GB | Corsair RM750i | Win 10 Pro

    AMD FX 8350 | Asus Crosshair V Formula Z | 16 GB GSkill Ripjaws X DDR3-2400 CL11 |MSI RX 480 Gaming X | 120GB + 250 GB SSD | Enermax Platimax D.F 500 | MAC OS X 11 | Open Core

    Edited once, last by Gordon-1979: Fehler Gefunden. ().

  • Hallo,


    beschäftige mich gerade intensiv mit der Dortonia Guide,

    habe auch schon Erfolge gezielt und hab es bis zum Bootscreen geschafft, mit einem bekannten Fehler:


    OCB: Start Image failed =Aborted


    Jetzt versuche ich noch mehr zu lesen, da der Guide ja alles sein soll, was man braucht.

    Bin mir aber gerade nicht sicher, weil ein Link im Guide defekt ist:


    Defekt: https://github.com/dortania/Ge…es/compiled/SSDT-UNC0.aml


    Ist SSDT-UNCO dass Gleiche was ich hier finde, nur vielleicht ein ältere Bezeichung, also ist UNCO jetzt nur noch UNC


    Kann ich also dass problemlos nehmen?


    https://github.com/dortania/Ge…les/compiled/SSDT-UNC.aml



    Einmal steht, dass nur diese speziellen benötigt werden:

    https://dortania.github.io/Get…html#amd-bulldozer-jaguar


    SSDTs required:

    SSDT-EC-USBX-DESKTOP.aml

    SSDT-PLUG-DRTNIA.aml

    SSDT-RTC0-RANGE-HEDT.aml

    SSDT-UNCO.aml


    Zuvor gibt es aber noch eine Allgemeinere Seite, wo steht, dass nur diese benötigt werden.


    SSDT-EC-USBX.dsl

    SSDT-PLUG.dsl

    SSDT-RTC0-RANGE.dsl

    SSDT-UNC.dsl


    Soll ich also beide Seiten kombinieren, Getting Started und die Erweiterte Seite, ich verstehe nur nicht, warum auf der Erweiterten Seite, dann plötzlich die SSDT von Getting Started nichtmehr sind.


    Update:

    Komme nicht weiter, die Guide funktioniert wohl nicht sowie vorgesehen, weiß jemand was dass für ne Software ist, wo er dass aml in dsl umwandelt und bearbeitet.


    https://dortania.github.io/Get…#edits-to-the-sample-ssdt


    Ich habe mit SSDTTime ein DSDT.aml erzeugt, dieses muss ich nun in dsl umändern, bearbeiten, danach wieder als aml ins EFI einbauen.

    Edited 2 times, last by Mijami ().

  • Die Dateien mit der Endung dsl sind reine Texdateien, die mit MacIASL bearbeitet werden. Diese werden danach mit MacIASL in das maschinenlesbare Formal mal kompiliert. Um Dateien im Format aml zu dekompiliern, empfehle ich dir IASL im Terminal zu verwenden. Es gibt im Netz eine sehr gute Anleitung dafür.


    MacIASL soll beim Dekompilieren nicht sauber arbeiten? Kann das jemand bestätigen?


    https://hackintoshpro.com/patch-dsdt-hackintosh/

  • Gibt es eigentlich noch funktionierende Seriennummer??

    Ich habe gerade 30 Seriennummern von CloverConfigurator/SMBiOS und Gensmbios durchgetestet und immer die gleich Meldung:

    Das ist keine gültige Seriennummer. Prüfe deine Angaben.........

    https://checkcoverage.apple.com/de/de/


    Dabei habe ich: iMac Pro 1,1 , Mac Pro 7,1 , Mac Pro 19,1 , Mac Pro 17,1

    Ohne Erfolg.

    AMD R7 2700X | GIGABYTE AORUS X570 Master | 16 GB GSkill Trident Z DDR4-3600 CL18 | MSI GTX 1080 ti Gaming | Auzentech X-Fi HT HD | WD SN750 500GB | Corsair RM750i | Win 10 Pro

    AMD FX 8350 | Asus Crosshair V Formula Z | 16 GB GSkill Ripjaws X DDR3-2400 CL11 |MSI RX 480 Gaming X | 120GB + 250 GB SSD | Enermax Platimax D.F 500 | MAC OS X 11 | Open Core