Mojave auf Asus N56VZ

  • Wie gesagt, da steht nichts.


    In macOS kann ich EFI mounten. Es ist Fat32 und dort ist der EFI Ordner vom USB Stick drin. Aber das BIOS findet nur "Mac OS X" und nicht mit UEFI, außer ich stecke den USB Stick ein.


    Habe mit dem Clover Installer auch ausprobiert UEFI rauszunehmen und mit legacy bios versehen. Keine Änderung. Im BIOS steht weiterhin nur MAC OS X, wovon er nicht bootet.


    Die Clover Legacy lässt sich auch nicht vom Stick booten. Bios meldet nur: select proper boot device...


    Habe auch folgendes erfolglos versucht:

    • Install for UEFI booting only
    • Installiere Clover in der ESP
    • Bootloader / Kein Update für MBR und PBR
    • Drivers64UEFI / EmuVariableUefi-64
    • Drivers64UEFI / OsxAptioFixDrv-64
    • Drivers64UEFI / PartitionDxe-64


    Und zusätzlich bekomme ich das WLAN nicht zum Laufen. Im Installer funktionierte es ja noch.


    Auch geht kein Clover Update. Versuche ich vom Stick mit nem geupdateten Clover und geupdateten kexten (durch Kext Updater) zu starten, bootet er nicht. In Clover gibt es dann keinen Eintrag für mac OS, also keine Startoption 😕



    Geschafft! Das BIOS hat selbstständig nichts gefunden. Ich konnte aber eine zusätzliche Bootoption angeben und auf EFI\EFI\BOOT\BOOTX64.EFI verweisen. Jetzt bootet er von der EFI-Partition!


    Jetzt läuft auch WLAN. Ich habe alle kexte, analog zu Rehabman in L/E/ gepackt.


    Als nächstes steht an die ganzen Sachen auf den aktuellen Stand zu kriegen. Meine bisherigen Versuche haben zu einem nicht bootendem System geführt.


    Vielen Dank für eure intensive Unterstützung und euer tolles Forum!

    8 Mal editiert, zuletzt von TAWL ()

  • TAWL

    Hat den Titel des Themas von „Clover startet nicht“ zu „Mojave auf Asus N56VZ“ geändert.
  • So alles ist up-to-date, Sound läuft auch. Touchpad ist so lala. Manchmal springt er einfach in den Fullscreen Modus.


    Was mich aber gerade mehr stört: Intel Power Gadget sagt, dass die CPU Clockspeed gleichbleibend auf 3 Ghz ist. Hat das was mit fehlerhaften Einstellungen im ACPI zu tun?

  • CPUFriend ( und eventuell zusätzlich eine SSDT.aml erzeugt mit ssdtPRGen.sh kann da eventuell helfen. )


    https://github.com/acidanthera…ob/master/Instructions.md

    Grüße und Good Hack Michael


    :hackintosh:

  • Danke! Habe es in der Zwischenzeit mit Rehabmans Anleitung für eine angepasste SSDT geschafft.


    Im Akku-Modus läuft er nicht ganz so rund. Bei Cinebench droppt er alle 2sek. auf 1,2 Ghz und springt dann wieder für 2sek. auf 3 Ghz Turbo.


    Lässt sich das Trackpad auf nem Hacki irgendwie einstellen (genutzte Gesten, Scrollgeschwindigkeit)? Die Apple Einstellungen verändern ja nichts.

    Bin mir aber auch nicht sicher, ob ich nicht zuviele kexte für das Touchpad drauf habe: ApplePS2Controller, ApplePS2ElanTouchpad, ApplePS2SmartTouchPad und VoodooPS2Controller.

    Habe auch noch irgendwoher einen VoodooI2C-v2 runtergeladen, aber nicht eingefügt...


    Möchte auch nochmal auf folgendes zurück kommen:

    Veraltet heißt, dass sie nicht mehr gebraucht werden? Oder in einer neuen Version?


    Für die letzten drei kexte... finde da auch nicht so wirklich was für. EAPDFix könnte was mit dem Audiojack zu tun haben. Wenn ich irgendwann mal ein TM-Backup habe, werde ich mal versuchen die drei unbekannten Kexte zu löschen.

    Einmal editiert, zuletzt von TAWL ()

  • Daher war der Vorschlag auch CPUFriend und die SSDT.aml nur als Variante. Unter Mojave funktioniert eine SSDT.aml nur noch bedingt oder gar nicht.


    Besser ist wenn man nur einen Kext für Touchpad verwendet. Beim Booten mit Clover kannst durch drücken der Leertaste über dem Booteintrag Kexte blockieren und so mal Testen welchen wirklich benötigst.


    I2C geht nur bei neueren Laptops mit entsprechendem I2C Controller.


    TAWL ,

    ganz ausführlich haben wir das mal hier gemacht. Ist sicher die beste Methode, aber etwas knifflig.


    SMBIOS iMac17,1 / Skylake i76700K und Powermanagement - wie funktioniert es richtig?

    Grüße und Good Hack Michael


    :hackintosh:

    Einmal editiert, zuletzt von anonymous writer ()

  • Auch wenn die Zeit gerade mehr als knapp ist, mal eine kurze Zwischenmeldung:


    Neue WLAN-Karte ist angekommen. War durch den EFI-Ordner plug 'n play.


    Die Kiste läuft richtig gut. Bevor ich hier aber den fertigen EFI-Ordner final hochlade muss ich erst noch die ToDo-Liste abarbeiten.


    ToDo:

    - Powermanagement verbessern

    - Trackpad verbessern

    - Kamera zum laufen kriegen (Status-LED geht zwar an, aber zeigt kein Bild, z.B. in FaceTime)

    - Beim Cloverstart das macOS mit Mojave-Bild versehen

    - Mal testen, ob der SD-Karten-Slot funktioniert

    - Entsperren mit Apple Watch zum laufen kriegen (Airdrop und Continuity läuft)

    - Ruhezustand (er geht gar nicht in den Sleep, er wacht vorher schon wieder auf)

    2 Mal editiert, zuletzt von TAWL ()