Mojave auf i5-750 und Asus P7P55D?

  • Hallo Forum,


    ich habe ein MacBook Early 2011 15", welches kein Update auf Mojave bekommen hat. Ich spiele schon länger mit dem Gedanke einen Hackintosh zu erstellen. Bevor ich mir allerdings Hardware kaufe, wollte ich probieren, ob das auch mit meiner noch vorhandenen Hardware funktioniert.


    CPU: i5-750

    MB: Asus P7P55D

    GPU: Sapphire R9 380 Nitro 4GB


    Ich habe gestern (bzw. heute nacht) schon einige Stunden probiert, allerdings bin ich immer gescheitert.


    Meine bisherigen Schritte:

    1. Mojave herunterladen

    2. Bootstick erstellen

    3. Clover installieren


    Bei Punkt 3 komme ich leider schon an meine Grenzen. Die Installation ansich ist klar, aber ich weiß nicht welche Punkte ich anwählen soll.

    Diese Punkte hab ich ausgewählt:


    Die Installation wird abgeschlossen, allerdings habe ich danach kein EFI Ordner/Partition, welche ich mounten kann.


    Ist es überhaupt sinnvoll, Mojave (oder generell macOS) mit diesem alten Mainboard zu installieren?

  • Hallo,

    hast du Mojave jetzt installiert bekommen? Ist mir nicht ganz klar.


    Welche EFI Partition kannst du nicht mounten - die vom Stick oder der Festplatte? Bei korrekter Formatierung der Festplatte und/oder USB-Stick wird automatisch eine unsichtbare EFI-Partition angelegt.


    Auf deinem Bild musst du eigentlich nur noch das 2. Feld von oben "installiere Clover in der ESP anhaken", dann passt das schon!

    • Lenovo Thinkpad X220 i5-2540M HD3000 8GB Dualboot mit Sierra 10.12 und Mojave 10.14.3 Clover 4700
    • Lenovo Thinkpad X230 i5-3320M HD4000 8GB Dualboot mit Sierra 10.12 und Mojave 10.14.3 Clover 4670
    • Lenovo ThinkCentre m93P Tiny i5-4570T HD4600 12GB Win10 + Mojave 10.14.3 auf einer Platte Clover 4741
    • Lenovo ThinkCentre m58 Core2Duo E85400 6GB NVIDIA GT730 2GB (Asus) WindowsXP + High Sierra Clover 4861
  • Danke schon mal für die Antwort.

    Ist es eigentlich nötig den Stick jedes mal neu zu machen, wenn ich Clover mit anderen Einstellungen schon mal installiert habe oder kann man einfach die Clover Installation erneut ausführen mit anderen instellungen?


    Ich kann die EFI Partition vom Stick nicht mounten.

    Ich habe Clover mit "installiere Clover in der ESP" angehakt und auf dem Stick installiert. Wenn ich den dann an meinen PC stecke und davon boote kommt zwar das Clover Bootmenü, aber es wird mir das Symbol angezeigt, wenn ich die Installation starte.

  • Hi,


    ich vermute, dass der Stick nicht korrekt formatiert ist! Das solltest du wählen!: macOS extended (jourmald) und Guid Partitionstabelle


    Zu deine Frage: Der Stick, wenn das passende macOS für deine Hardware drauf ist, musst du den nicht neu machen, aber Clover schon, wenn du wie oben den Haken vergessen hast! Muss zum BIOS passen!

    Treiber und Einstellungen kann man ja auch noch über den Clover Configurator nachinstallieren oder entfernen und verändern.
    Kexte gehen auch, die wollen dann aber die EFI-Partition haben.


    Deine CPU geht übrigens nur bis High Sierra. SMBIOS iMAC11,1 (bis 11,3 müssten eigentlich alle gehen)

    (Man kann Mojave mit diversen patches da bestimmt irgendwie drauf-bringen, aber das würde ich für den Anfang mal lassen)


    Hast du dir schon Gedanken über die BIOS Einstellungen gemacht?


    Ich nutze übrigens immer einen USB-Stick 2.0, da die 3.0er immer mal wieder nicht wollen und so ein Stoppschild dann kommt. Das kommt natürlich auch, wenn das macOS für deine Hardware ungeeignet ist.

    • Lenovo Thinkpad X220 i5-2540M HD3000 8GB Dualboot mit Sierra 10.12 und Mojave 10.14.3 Clover 4700
    • Lenovo Thinkpad X230 i5-3320M HD4000 8GB Dualboot mit Sierra 10.12 und Mojave 10.14.3 Clover 4670
    • Lenovo ThinkCentre m93P Tiny i5-4570T HD4600 12GB Win10 + Mojave 10.14.3 auf einer Platte Clover 4741
    • Lenovo ThinkCentre m58 Core2Duo E85400 6GB NVIDIA GT730 2GB (Asus) WindowsXP + High Sierra Clover 4861
  • Ich habe den Stick komplett neugemacht mit High Sierra. Damit konnte ich High Sierra installieren.

    Jetzt das nächste Problem: Bei der Ersteinrichtung komme ich nicht weiter, da ich (verschiedene) Grafikfehler habe.

    Mein Monitor (Full HD) ist über HDMI angeschlossen, falls das wichtig ist.


  • Whatevergreen und Lilu kexte hast du im Other Ordner?


    Im Clover Configurator bei Graphics mal nichts eintragen!

    • Lenovo Thinkpad X220 i5-2540M HD3000 8GB Dualboot mit Sierra 10.12 und Mojave 10.14.3 Clover 4700
    • Lenovo Thinkpad X230 i5-3320M HD4000 8GB Dualboot mit Sierra 10.12 und Mojave 10.14.3 Clover 4670
    • Lenovo ThinkCentre m93P Tiny i5-4570T HD4600 12GB Win10 + Mojave 10.14.3 auf einer Platte Clover 4741
    • Lenovo ThinkCentre m58 Core2Duo E85400 6GB NVIDIA GT730 2GB (Asus) WindowsXP + High Sierra Clover 4861
  • Whatevergreen, Lilu und FakeSMC habe ich im Other Ordner.


    Bei Graphics ist nichts eingetragen und als SMBIOS habe ich iMac11,1.


    Hast du noch andere Ideen?

  • Lade doch mal bitte deine genutzt EFI hier als Zip hoch. Vielleicht passt in der Config.plist oder der EFI was nicht so ganz.


    Gruß Mocca55

    iMac9,1|Intel Pentium E5400 @ 2.50Ghz|GeForce GT530 1GB|3GB DDR2|OSX 10.11.6 El Capitan auf 500GB WD Green |Clover
    iMac14,1|Intel Xeon W3550 @ 3.07Ghz|nVidia Quadro FX1800 768MB|4GB DDR3|OSX 10.13.6 High Sierra auf 240GB SSD |Clover
    iMac14,2
    |Intel Core i7-2600k @ 3.40Ghz|
    MSI R9 270X 2GB|2x 4GB Samsung DDR3|OSX 10.13.6 Sierra + 10.14. Mojave auf 120GB Thoshiba A100 SSD|Win7 64bit auf SSD Samsung Evo 850|Clover
    MacBookPro6,1|i3 330M @ 2.13 Ghz|ATI Radeon HD 5650|2x 2GB RAM DDR3|10.13.6 High Sierra|250GB SanDisk SSD|Cloverr

    ———>Kein Support über Privatnachrichten<———

  • EFI ist im Anhang

    Dateien

    • EFI.zip

      (2,18 MB, 9 Mal heruntergeladen, zuletzt: )
  • Hi,


    hau mal usbinjectall.kext noch mit in den Other Ordner.


    In der Config.plist unter ACPI mal fogendes eintragen:

    Rename PEG0 to GFX1- find: 50454730 replace:47465831

    und den noch:

    Rename GFX0 to GFX2 - find: 47465830 replace: 47465832


    Dann noch unter Graphics: FBName Lagotto - (this framebuffer is native for Tonga, r9 380/r9 285 cards)


    Kann das hier auf Arbeit leider nicht vorbereiten.


    Mocca55 kann ja auch noch mal drüber schauen!

    • Lenovo Thinkpad X220 i5-2540M HD3000 8GB Dualboot mit Sierra 10.12 und Mojave 10.14.3 Clover 4700
    • Lenovo Thinkpad X230 i5-3320M HD4000 8GB Dualboot mit Sierra 10.12 und Mojave 10.14.3 Clover 4670
    • Lenovo ThinkCentre m93P Tiny i5-4570T HD4600 12GB Win10 + Mojave 10.14.3 auf einer Platte Clover 4741
    • Lenovo ThinkCentre m58 Core2Duo E85400 6GB NVIDIA GT730 2GB (Asus) WindowsXP + High Sierra Clover 4861
  • USBInjectAll.kext habe ich hinzugefügt.

    Die Werte in ACPI habe ich auch eingetragen. Der Wert 47465830 stand schon bei Rename GFX0 to IGPU. Diese Zeile habe ich gelöscht, da ich nicht weiß, ob der Haken bei Disabled den Wert ignoriert.

    Unter Graphics habe ich Lagotto eingestellt.


    Die Grafikfehler treten allerdings immer noch auf


    Im Anhang ist das überarbeitete EFI.

    Dateien

    • EFI.zip

      (2,2 MB, 7 Mal heruntergeladen, zuletzt: )
  • Versuchs mal mit der config.plist!


    Im BIOS kannst du mal das einstellen PEG (wenn es das bei dir so gibt):

  • Mit der config.plist immer noch das Problem.

    Und ich kann sowas nicht in meinem BIOS einstellen. Mein BIOS ist auch schon das aktuellste, das es für das Board gibt.


    Manchmal sieht der Fehler auch so aus wie auf dem Bild. Der Mauszeiger reagiert zwar, aber ich kann in der Liste nicht scrollen oder den Balken ziehen.

  • Und kannst du nicht mit der Tastatur navigieren?


    Hier die nächste config:

    Dateien

    • config.plist

      (26,38 kB, 4 Mal heruntergeladen, zuletzt: )
    • Lenovo Thinkpad X220 i5-2540M HD3000 8GB Dualboot mit Sierra 10.12 und Mojave 10.14.3 Clover 4700
    • Lenovo Thinkpad X230 i5-3320M HD4000 8GB Dualboot mit Sierra 10.12 und Mojave 10.14.3 Clover 4670
    • Lenovo ThinkCentre m93P Tiny i5-4570T HD4600 12GB Win10 + Mojave 10.14.3 auf einer Platte Clover 4741
    • Lenovo ThinkCentre m58 Core2Duo E85400 6GB NVIDIA GT730 2GB (Asus) WindowsXP + High Sierra Clover 4861
  • Auch mit dieser Config der Grafikfehler.


    Wenn ich beliebige Tasten drücke, wird nur der Bildschirm kurz hell. Siehe Anhang. Ich hab 3 Tasten gedrückt, deswegen wird es 3 mal hell.


  • Was ist denn das für eine Tastatur USB?

    • Lenovo Thinkpad X220 i5-2540M HD3000 8GB Dualboot mit Sierra 10.12 und Mojave 10.14.3 Clover 4700
    • Lenovo Thinkpad X230 i5-3320M HD4000 8GB Dualboot mit Sierra 10.12 und Mojave 10.14.3 Clover 4670
    • Lenovo ThinkCentre m93P Tiny i5-4570T HD4600 12GB Win10 + Mojave 10.14.3 auf einer Platte Clover 4741
    • Lenovo ThinkCentre m58 Core2Duo E85400 6GB NVIDIA GT730 2GB (Asus) WindowsXP + High Sierra Clover 4861
  • Ja, USB.

    Cherry eVolution Stream XT: https://geizhals.de/cherry-evo…85-23100de-2-a395537.html


    Aber wie in dem Video zu sehen verschwindet auch manchmal die Liste und dann erscheint wieder das Apple Logo mit Ladebalken, aber danach passiert nichts mehr.


    Da das nur ein Test sein soll, ist es nicht so schlimm, wenn das mit meiner Hardware nicht funktioniert. Hatte mir sowieso schon überlegt neue Hardware zu kaufen.

  • Du ,ich hab ein älteres System als du. Es sollte gehen, nur die Grafik ist irgendwie problematisch. Tastaturprobleme hatte ich jetzt aber auch noch nicht :) Ich würde aber an deiner Stelle noch nicht aufgeben!


    Um das Setup abzuschließen, könntest du nämlich die Festplatte an den Mac hängen und es da fertig machen.


    Okay , schmeiß mal diesen Ordner noch in deinen Cloverordner


    Musst du natürlich entpacken!

    Dateien

    • Lenovo Thinkpad X220 i5-2540M HD3000 8GB Dualboot mit Sierra 10.12 und Mojave 10.14.3 Clover 4700
    • Lenovo Thinkpad X230 i5-3320M HD4000 8GB Dualboot mit Sierra 10.12 und Mojave 10.14.3 Clover 4670
    • Lenovo ThinkCentre m93P Tiny i5-4570T HD4600 12GB Win10 + Mojave 10.14.3 auf einer Platte Clover 4741
    • Lenovo ThinkCentre m58 Core2Duo E85400 6GB NVIDIA GT730 2GB (Asus) WindowsXP + High Sierra Clover 4861
  • Zum Thema Grafik sollte das nicht mit Whatevergreen.kext und Lilu.kext laufen. Ohne irgendwelche Einstellungen in Bezug auf Grafik in der Config.plist.


    Wurde das schon getestet?


    Gruß Mocca55

    iMac9,1|Intel Pentium E5400 @ 2.50Ghz|GeForce GT530 1GB|3GB DDR2|OSX 10.11.6 El Capitan auf 500GB WD Green |Clover
    iMac14,1|Intel Xeon W3550 @ 3.07Ghz|nVidia Quadro FX1800 768MB|4GB DDR3|OSX 10.13.6 High Sierra auf 240GB SSD |Clover
    iMac14,2
    |Intel Core i7-2600k @ 3.40Ghz|
    MSI R9 270X 2GB|2x 4GB Samsung DDR3|OSX 10.13.6 Sierra + 10.14. Mojave auf 120GB Thoshiba A100 SSD|Win7 64bit auf SSD Samsung Evo 850|Clover
    MacBookPro6,1|i3 330M @ 2.13 Ghz|ATI Radeon HD 5650|2x 2GB RAM DDR3|10.13.6 High Sierra|250GB SanDisk SSD|Cloverr

    ———>Kein Support über Privatnachrichten<———

  • Ja, siehe Post 6

    • Lenovo Thinkpad X220 i5-2540M HD3000 8GB Dualboot mit Sierra 10.12 und Mojave 10.14.3 Clover 4700
    • Lenovo Thinkpad X230 i5-3320M HD4000 8GB Dualboot mit Sierra 10.12 und Mojave 10.14.3 Clover 4670
    • Lenovo ThinkCentre m93P Tiny i5-4570T HD4600 12GB Win10 + Mojave 10.14.3 auf einer Platte Clover 4741
    • Lenovo ThinkCentre m58 Core2Duo E85400 6GB NVIDIA GT730 2GB (Asus) WindowsXP + High Sierra Clover 4861