Macbook startet nicht mehr nach Multibeast USB 3rd party

  • Guten Tag zusammen 😊

    Bin neu hier in eurem Forum und freue mich schon auf die eine oder andere neue Bekanntschaft. Kenne mich auch nicht recht gut mit der ganzen Geschichte aus also vergebt mir bitte mein Laienhaftes Halbwissen 😅


    So, bastel wastel wieder am Start...

    Hab grad n kleines Problem besser gesagt seit gestern... hab mir jetzt eine USB 3.0 Express Card bestellt, leider habe ich keine passende direkt für mein MacBook gefunden und deshalb eine bestellt wo andere Käufer in den Kommentaren geschrieben haben bei Ihnen würde es mit bisschen Arbeit im MacBook einwandfrei laufen.


    So, gestern kam die Karte. Vor lauter Freude gleich losgelegt und paar Tutorial im netz angeschaut.


    Dafür müsste ich im Terminal eingeben:


    csrutil disable


    Damit werden die Sicherheitsfunktionen des macs ausgeschaltet damit der Treiber installiert werden kann. (Laut Internet so nötig)


    Anschließend mit Multibeast im Legacy Mode den 3rd USB ausgewählt und installiert, hat soweit funktioniert, nun solle ich dass gerät Neustarten damit der Treiber funktioniert und anschließend im Terminal wieder mit csrutil enable die Sicherheit aktivieren.


    Tja, nach dem Neustart ist er nicht mehr gebootet.... er bringt pieps Töne die laut der Apple Seite darauf hinweisen dass dr RAM nicht funktioniert....


    Komischer weise komme ich aber noch ins Boot Menü und kann aber Windows starten dass ich mit Bootcamp installiert hatte.


    Auch der Rückbau auf die alten RAM Riegel hatte kein Erfolg... mit dem festplattendiensprogramm habe ich bereits eine Reparatur durchführen lassen, Os wurde neu aufgespielt jedoch beides ohne Erfolg 😓


    In den abgesicherten Modus habe ich mit viel Glück hin und wieder und nach langer Wartezeit Zugriff...


    Es währe prima wenn der Karen wieder läuft, mit USB 3.0....


    Ich habe mir eben von eurer Seite Kext Utility geladen um im abgesicherten Modus laufen lassen, jetzt kommt direkt nach dem einschalten ein stop Zeichen anstelle des Apfels.... im verbose Modus zeigt es mir folgendes an. (Siehe bitte Bild)


    Habt ihr irgendwelche tips für mich?


    Mein nächster Schritt währ gewesen dass ich den .kext des USB Treibers im abgesicherten wieder runter hau, aber ich hätt echt gern das der Port läuft... bin mir sicher dass ich riesigen Mist gebaut hab und eh schon dementsprechend drauf also schimpft bitte nicht all zu sehr mit mir 😅


    Vielen Dank für eure Hilfe und brauchbare Kommentare! Schönen Tag!

    • Prozessor: AMD Ryzen 7 1800X 8x 3.6Ghz So.AM4 WOF
    • Mainboard: Asus TUF X470-Plus Gaming AMD X470 DDR4 ATX Retail
    • Speicher: 16GB (2x 8192MB) G.Skill RipJaws DDR4-3200 DIMM
    • Grafikkarte: 2GB KFA2 GeForce GT 1030
    • SSD:Crucial 500GB MX500
    • HDD: Seagate BarraCuda 1000GB
    • Betriebssystem: Windows 10 Pro x64
  • Moin und :welcome3: ,


    Fürs Erste bitte in den Single-User-Modus starten - Beim Erklingen des Einschalttons CMD-S drücken.


    Dann das Dateisystem mit Schreibzugriff mounten.


    Code
    1. mount -uw /


    Danach den PrelinkedKernel löschen und KernelCache erneuern:


    Code
    1. rm /System/Library/PrelinkedKernels/prelinkedkernel
    2. touch /System/Library/Extentions/
    3. kextcache -u /
    4. reboot



    Falls das nicht ausreicht, wieder in den SingleUserMode s.o. den Kext löschen und dann wie oben Cache neu erstellen.


    Falls du nicht in den SingleUserMode kommst mit CMD-R in den RecoveryModus booten und dort im Terminal die Befehle angepasst ausführen:


    Code
    1. rm /Volumes/xyz/System/Library/PrelinkedKernels/prelinkedkernel
    2. touch /Volumes/xyz/System/Library/Extentions/
    3. kextcache -u /Volumes/xyz
    4. reboot


    xyz ist der Name deiner macOS-Partition.


    Edit:


    kextcache -u natürlich.

  • Moin Moin willkommen.. .


    " Anschließend mit Multibeast im Legacy Mode den 3rd USB ausgewählt und installiert..."



    schau mal hier .... -->>>>


    Nutzung von Unibeast, Multibeast und/oder Distros



    lg gerox


    -->> Gruss Gemuese Rambo

  • Vielen Dank für s willkommen heißen und die wahnsinnig schnelle Antwort 😊🎉


    Mit CMD+S komme ich leider nur wieder zum Stop Zeichen...


    Probier jetzt gerade deine zweite Variante über s Terminal aus 👍


    Vielen Dank schonmal 👍


    P.s. Ganz doofe Frage... für dieses xyz, wo finde ich jetzt wie meine OS Partition heißt... 😅

    • Prozessor: AMD Ryzen 7 1800X 8x 3.6Ghz So.AM4 WOF
    • Mainboard: Asus TUF X470-Plus Gaming AMD X470 DDR4 ATX Retail
    • Speicher: 16GB (2x 8192MB) G.Skill RipJaws DDR4-3200 DIMM
    • Grafikkarte: 2GB KFA2 GeForce GT 1030
    • SSD:Crucial 500GB MX500
    • HDD: Seagate BarraCuda 1000GB
    • Betriebssystem: Windows 10 Pro x64
  • So, diese sachen werden mir dann alle aufgezeigt. ICC weiß jetzt ehrlich gesagt trotzdem nicht genau wie ich den beschrieben Pfad schreiben muss... hab sämtliche Variationen probiert aber irgendwie geht es nicht....


    Bin für eure Hilfe sehr dankbar! Wenn ich mit meiner rumspielendes gegen die Regeln verstoßen habe möchte ich mich als erstes dafür entschuldigen, ich weis Unwissenheit schützt vor Strafe nicht aber es tut mir echt leid... bin froh wenn mein Baby wieder läuft und des Multikäse wieder weg ist...


    Anbei noch Bilder was er grad macht...

  • Einfach im Terminal


    Code
    1. ls /Volumes/

    eingeben.


    Sollte Macintosh HD oder ähnlich sein, insofern du es nicht umbenannt hast. Im Falle von Macintosh HD also:


    /Volumes/Macintosh HD/


    Im Terminal kannst du AutoComplete verwenden. Einfach die ersten paar Buchstaben eintippen und auf die TAB-Taste drücken.


    Edit:

    Gerade deine Screenshots angesehen. Ist Macintosh HD.


    Code
    1. rm /Volumes/Macintosh\ HD/System/Library/PrelinkedKernels/prelinkedkernel
    2. touch /Volumes/Macintosh\ HD/System/Library/Extentions/
    3. kextcache -u /Volumes/Macintosh\ HD
    4. reboot

    Einfach rm /V eingeben und TAB drücken, dann Mac und TAB drücken und Sys und TAB drücken und so weiter.


    Edit:


    Natürlich kextcache -u.

  • Nope denn der Plattenname ist in 2 Worte geteilt deswegen der backslash \ nach Macintosh.


    Und die Cache bzw prelinkedkernel zu erneuern macht erst Sinn wenn der störende Kext gelöscht wurde .


    Liste die Verzeichnisse und schau ob du ihn findest :


    ls -la /Volumes/Macintosh\ HD/System/Library/Extensions/


    bzw


    ls -la /Volumes/Macintosh\ HD/Library/Extensions/


    wenn gefunden :


    rm -rf /Volumes/Macintosh\ HD/System/Library/Extensions/Falscher.kext


    danach prelinkedkernel erneuern und rebooten

  • eVillain, ich denke ich konnte die 2 Übeltäter finden und hab sie auf dem Bild markiert. Diese muss ich jetzt mit deiner Anleitung entfernen oder nur einen oder sogar mehr? Vielen Dank.

    Images

    • Prozessor: AMD Ryzen 7 1800X 8x 3.6Ghz So.AM4 WOF
    • Mainboard: Asus TUF X470-Plus Gaming AMD X470 DDR4 ATX Retail
    • Speicher: 16GB (2x 8192MB) G.Skill RipJaws DDR4-3200 DIMM
    • Grafikkarte: 2GB KFA2 GeForce GT 1030
    • SSD:Crucial 500GB MX500
    • HDD: Seagate BarraCuda 1000GB
    • Betriebssystem: Windows 10 Pro x64
  • Wenn Original MBP dann auf jeden Fall beide:


    rm -rf /Volumes/Macintosh\ HD/Library/Extensions/FakeSMC.kext



    Wenn Hacki dann den hier:


    rm -rf /Volumes/Macintosh\ HD/Library/Extensions/GenericUSBXHCI.kext


    danach


    touch /Volumes/Macintosh\ HD/Library/Extensions/


    kextcache -u


    reboot

  • eVillian super, des hat funktioniert, Mac ist wieder hochgefahren 🎉 ich wollte ihn Neustarten um das kexrupdate noch zu machen dann ging er sich während dem runterfahren auf....


    Hab es wieder ins Terminal geschafft und wollte es dann machen, jedoch funktioniert es nicht.... was hab ich wieder falsch gemacht 😔😢

    Images

    • Prozessor: AMD Ryzen 7 1800X 8x 3.6Ghz So.AM4 WOF
    • Mainboard: Asus TUF X470-Plus Gaming AMD X470 DDR4 ATX Retail
    • Speicher: 16GB (2x 8192MB) G.Skill RipJaws DDR4-3200 DIMM
    • Grafikkarte: 2GB KFA2 GeForce GT 1030
    • SSD:Crucial 500GB MX500
    • HDD: Seagate BarraCuda 1000GB
    • Betriebssystem: Windows 10 Pro x64
  • hab ich nicht gesagt daß du das machen sollst ...


    kextupdate ist kein macOS command wie du selber schon gesehen hast .


    kextcache -u eingeben


    machen lassen

    neustarten und fertig im besten Falle

  • Sorry, ja dass habe ich vorhin eingegeben, es machte mir jedoch den Anschein als ob es nicht funktioniert hätte...

    Images

    • Prozessor: AMD Ryzen 7 1800X 8x 3.6Ghz So.AM4 WOF
    • Mainboard: Asus TUF X470-Plus Gaming AMD X470 DDR4 ATX Retail
    • Speicher: 16GB (2x 8192MB) G.Skill RipJaws DDR4-3200 DIMM
    • Grafikkarte: 2GB KFA2 GeForce GT 1030
    • SSD:Crucial 500GB MX500
    • HDD: Seagate BarraCuda 1000GB
    • Betriebssystem: Windows 10 Pro x64
  • Gemacht, bringt mich dann hier hin.

    Images

    • Prozessor: AMD Ryzen 7 1800X 8x 3.6Ghz So.AM4 WOF
    • Mainboard: Asus TUF X470-Plus Gaming AMD X470 DDR4 ATX Retail
    • Speicher: 16GB (2x 8192MB) G.Skill RipJaws DDR4-3200 DIMM
    • Grafikkarte: 2GB KFA2 GeForce GT 1030
    • SSD:Crucial 500GB MX500
    • HDD: Seagate BarraCuda 1000GB
    • Betriebssystem: Windows 10 Pro x64
  • zum Donner ;)


    sudo kextcache -prelinkedkernel


    wenn dat wieder nicht geht


    boote normal und lass ihn rödeln er sollte dir beim boot einen cache rebuild fahren und danach finger davon .

  • Ging wieder nicht.... ich lasse ihn jetzt Booten und hab Finger weg 😅 Danke dir schonmal vielmals für deine/eure Hilfe! Ihr seit klasse!

    • Prozessor: AMD Ryzen 7 1800X 8x 3.6Ghz So.AM4 WOF
    • Mainboard: Asus TUF X470-Plus Gaming AMD X470 DDR4 ATX Retail
    • Speicher: 16GB (2x 8192MB) G.Skill RipJaws DDR4-3200 DIMM
    • Grafikkarte: 2GB KFA2 GeForce GT 1030
    • SSD:Crucial 500GB MX500
    • HDD: Seagate BarraCuda 1000GB
    • Betriebssystem: Windows 10 Pro x64
  • ja weil ich doof den Pfad nicht mit angegeben habe ...läuft die Möhre jetzt ?


    korrekt wäre gewesen


    kextcache -u /Volumes/Macintosh\ HD/System/Library/PrelinkedKernels/prelinkedkernel


    Was du jetzt aber nicht mehr ausführen musst wenn er gebootet hat .

  • touch /S/L/E und kextcache -u generiert einen neuen prelinkedkernel.