Lenovo X1 Carbon 3the Gen. i7-5600U - 2the Baustelle

  • griven heute ist der zweite Versuch zu einem X1 carbon mit der Post eingetroffen. Abweichend zum ersten habe ich nun eine (deutsche) Tastatur mit Hintergrundbeleuchtung. Dieses Setup ist recht selten zu finden.


    Installation verlief mit Fake-ID unspektakulär. Umstellung auf iGPU ohne Fake-ID war erstmal enttäuschend. KP ohne Ende. Erst nachdem ich auf der M2. SATA eine EFI angelegt und Clover in ESP, nicht aber für UEFI-Motherboard installiert habe, kann ich ohne Fake-ID booten. Derzeit läuft das ergänzende Update zu 10.14.3 in der Hoffnung, das danach noch alle funktioniert.


    Was noch nicht funktioniert:

    - Touchpad ruckelt, nicht brauchbar

    - Trackpad geht gar nicht (voodootreiber tauschen wird helfen)

    - Displayhelligkeit mittels F5 (-) und F6 (+) geht nicht.


    Was kann ich zur Displayhelligkeit noch tun?


    Die originale DSDT habe ich mit Clover + F4 geladen.



    EDIT: Sehe gerade, beim zweiten Reboot zu dem ergänzendem Update wieder KP. Ich werde das mit Fake-ID ausführen müssen. - Ja jetzt läuft es durch - Beeten -

    Hat nix genützt - ohne Fake ID wieder KP

    --
    Grüße


    Christian


    "Ein Hackintosh ist wie ein Garten, es gibt immer etwas zu tun."


    3the_Baustelle: ThinkPad T430 i5 6300U 8Gb RAM iGPU HD520 WIFI: DW 1560??, Clover 4871


    iMac 18,2 Asus Prime B250M Plus, Intel QuadCore i5 7500 Kaby Lake 3,41 Ghz, PowerColor RX580 8192 MB NVRAM, Realtek ALC888B (ID 2), TP-LINK Archer T9E AC1900 PCIe, 16GB Ballistic Sport DDR4 2400, Mojave 10.14.3 Clover r4844

    MacBookPro 9,2 Lenovo Thinkpad T430, Intel Core i5 3320M 2,6GHz, Intel HD4000 1366x768 DE, 8GB RAM, Mojave 10.14.3, Clover r4844

    iMac 14,2 Asus P8H67 M Pro, Intel Core i5 2400, VTX3D Radeon HD 7850 2GB X-Edition, iGPU HD2000, Realtek ALC892 (ID 31), 8 GB RAM, Mojave 10.14.3, BootLoader Clover r4844

    Einmal editiert, zuletzt von chmeseb ()

  • chmeseb

    Hat das Label von Erledigt auf In Arbeit geändert
  • chmeseb

    Hat den Titel des Themas von „Lenovo X1 Carbon 3the Gen. i7-5600 - kein Hacki geworden“ zu „Lenovo X1 Carbon 3the Gen. i7-5600U - 2the Baustelle“ geändert.
  • Die Broadwell ist echt was nervig ^^

    Lade mal Deinen aktuellen EFI Ordner hoch ich denke hier muss man noch ein wenig am Framebuffer arbeiten aber das bekommen wir in den Griff (Stichwort ist Framebuffer Stolen Memory)...

    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, macOS Mojave 10.14
    System 2 (MacBook Pro 10.2): ThinkPad T430, i5-3360M @ 2.8 GHz, 8GB DDR3, IntelHD 4000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Dual Boot MacOS Mojave 10.14, Windows10 Pro 64Bit

    griven.png

  • geht heute Nachmittag an die Arbeit ;)


    griven zunächst positiv die iGPU funktioniert. Ich habe nochmals die EFI clean eingerichtet und die config.plist.postinstall aus der Anleitung von Tony genommen. Ohne zu wissen weshalb funzt die iGPU jetzt.


    was nicht funktioniert ist die Batterieanzeige. Das Akku wird im Systembericht auch nicht erkannt. Wenn ich vom Stick mit der alten EFI Boote schon. Unterschied ist eigentlich nur die config plist in der ich aber keine unterschiede erkenne. Die EFI von Stick bootet aber nur mit Fake-ID.


    Weiterhin wären noch die Funktionstasten schön für die Displayhelligkeit. Ich erinnert mich dass Laut/Leise auf dem vorigen X1 als auch am T430 ohne Fn funktionieren. Hier muss ich für laut leise Fn bemühen.


    Zu guter letzt funktionieren im Clover die Funktionstasten Fn + F4 und Fn + F11 nicht. Die Original *.aml sind deshalb aus er alten EFI von gestern.



    - Akkuanzeige

    - Helligkeitsteuerung

    - Clover Fn +


    - Beim schreiben merke ich gerade das Komma und Semikolon nicht funktionieren. Die Taste scheint tot. Bisher noch nicht aufgefallen. muss ich im Auge behalten.


    EDIT: Funktionstasten war eine Bioseinstellung. Die ACPI Original *aml sind jetzt neu geladen.


    EDIT: Ich kann jetzt alle EFI Varianten ohne Fake-ID booten. In keiner funktioniert die Akkuanzeige. Habe ich andere BatteryManager probiert.


    Aber egal, das ThinkPad muss zurück, die Komma/Semikolon-Taste ist tot.


    Im Hinblick auf das Sleep before Login würde ich aber gerne noch abklären, ob es dafür eine Workarround gibt. Sonst würde ich kein Drittes X1 Carbon ordern. Jedenfalls kein 3the Gen.


    Hast Du da einen Lösungsansatz?

    Dateien

    • CLOVER.zip

      (8,01 MB, 1 Mal heruntergeladen, zuletzt: )

    --
    Grüße


    Christian


    "Ein Hackintosh ist wie ein Garten, es gibt immer etwas zu tun."


    3the_Baustelle: ThinkPad T430 i5 6300U 8Gb RAM iGPU HD520 WIFI: DW 1560??, Clover 4871


    iMac 18,2 Asus Prime B250M Plus, Intel QuadCore i5 7500 Kaby Lake 3,41 Ghz, PowerColor RX580 8192 MB NVRAM, Realtek ALC888B (ID 2), TP-LINK Archer T9E AC1900 PCIe, 16GB Ballistic Sport DDR4 2400, Mojave 10.14.3 Clover r4844

    MacBookPro 9,2 Lenovo Thinkpad T430, Intel Core i5 3320M 2,6GHz, Intel HD4000 1366x768 DE, 8GB RAM, Mojave 10.14.3, Clover r4844

    iMac 14,2 Asus P8H67 M Pro, Intel Core i5 2400, VTX3D Radeon HD 7850 2GB X-Edition, iGPU HD2000, Realtek ALC892 (ID 31), 8 GB RAM, Mojave 10.14.3, BootLoader Clover r4844

    4 Mal editiert, zuletzt von chmeseb ()

  • Das Sleep before Login Problem sollte es eigentlich gar nicht geben denn das ist nichts weiter als ein Anzeichen dafür das der Framebuffer nicht korrekt initialisiert wird (ob das nun an einem Fehlerhaften GOP liegt oder an macOS mag ich nicht beurteilen). Versuch mal im Bios, sofern möglich, den CSM Mode zu aktivieren oder falls er aktiviert ist zu deaktivieren beides kann helfen. Was die Akku Anzeige angeht braucht es einen DSDT Patch aber es macht wenig bis keinen Sinn da jetzt Zeit rein zu investieren wenn Du das Gerät am langen Ende vielleicht doch nicht behalten möchtest oder Dich für etwas komplett anderes entscheidest.


    Wegen der Grafik kannst Du auch mal diesen Ansatz probieren: config.plist

    Dann aber mit dieser Kextsammlung: Other.zip

    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, macOS Mojave 10.14
    System 2 (MacBook Pro 10.2): ThinkPad T430, i5-3360M @ 2.8 GHz, 8GB DDR3, IntelHD 4000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Dual Boot MacOS Mojave 10.14, Windows10 Pro 64Bit

    griven.png

  • griven Ich konnte CSM im Bios aktivieren. Das hatte ich noch nicht gemacht weil mein T430 dann nicht mehr bootet. Dem X1 ist das wohl egal. Aber weder CSM noch die configt.plist + other haben etwas verändert.

    Übrigens habe ich alle EFI + config.plist durchgetestet. Es gab keine KP mehr.


    Ich werde jetzt als nächstes mit Verkäufer über die defekt Komma+Semikolon Taste verhandeln. Wenn er da keine Lösung hat wird das Projekt begraben. Wenn Ja melde ich mich vorher nochmal.


    Schönes Wochenende bis dahin und Dank für Deine Geduld.

    --
    Grüße


    Christian


    "Ein Hackintosh ist wie ein Garten, es gibt immer etwas zu tun."


    3the_Baustelle: ThinkPad T430 i5 6300U 8Gb RAM iGPU HD520 WIFI: DW 1560??, Clover 4871


    iMac 18,2 Asus Prime B250M Plus, Intel QuadCore i5 7500 Kaby Lake 3,41 Ghz, PowerColor RX580 8192 MB NVRAM, Realtek ALC888B (ID 2), TP-LINK Archer T9E AC1900 PCIe, 16GB Ballistic Sport DDR4 2400, Mojave 10.14.3 Clover r4844

    MacBookPro 9,2 Lenovo Thinkpad T430, Intel Core i5 3320M 2,6GHz, Intel HD4000 1366x768 DE, 8GB RAM, Mojave 10.14.3, Clover r4844

    iMac 14,2 Asus P8H67 M Pro, Intel Core i5 2400, VTX3D Radeon HD 7850 2GB X-Edition, iGPU HD2000, Realtek ALC892 (ID 31), 8 GB RAM, Mojave 10.14.3, BootLoader Clover r4844

  • Dann machen wir diesen Thread mal zu. Die nächste Baustelle wird ein T430 i5 6300u.

    --
    Grüße


    Christian


    "Ein Hackintosh ist wie ein Garten, es gibt immer etwas zu tun."


    3the_Baustelle: ThinkPad T430 i5 6300U 8Gb RAM iGPU HD520 WIFI: DW 1560??, Clover 4871


    iMac 18,2 Asus Prime B250M Plus, Intel QuadCore i5 7500 Kaby Lake 3,41 Ghz, PowerColor RX580 8192 MB NVRAM, Realtek ALC888B (ID 2), TP-LINK Archer T9E AC1900 PCIe, 16GB Ballistic Sport DDR4 2400, Mojave 10.14.3 Clover r4844

    MacBookPro 9,2 Lenovo Thinkpad T430, Intel Core i5 3320M 2,6GHz, Intel HD4000 1366x768 DE, 8GB RAM, Mojave 10.14.3, Clover r4844

    iMac 14,2 Asus P8H67 M Pro, Intel Core i5 2400, VTX3D Radeon HD 7850 2GB X-Edition, iGPU HD2000, Realtek ALC892 (ID 31), 8 GB RAM, Mojave 10.14.3, BootLoader Clover r4844

  • chmeseb

    Hat das Label von In Arbeit auf Erledigt geändert