Clover Update "nicht mehr" direkt möglich.

  • Hallo,

    seit neustem kann ich Clover nicht mehr über die PKG oder das Clover Utility updaten, da meine EFI Partition "anscheinend" (also gehe ich mal davon aus) für Clover nicht gefunden wird.


    Statt mir - wie bereits bekannt - "Upgrade" anzuzeigen wird hier nur Überspringen oder Installieren als Möglichkeit gegeben. Es ist entweder so als würde meine EFI Partition ODER

    die dortige Clover Installation nicht gefunden werden.


    Unter High Sierra war das kein Problem, da konnte ich ganz normal über die PKG updaten.


    (1) Vielleicht interessant als Symptom: Wenn ich eine ganz normale Installation durchführe wird auf der Macintosh SSD in der Hauptfolder (müsste glaube ich "/" sein) ein Order mit EFI-Backup und EFI angelegt.


    Ich hatte mal folgende Idee:


    - Die alte Clover Installation löschen und die aktuelle einfach frisch installieren. Das allerdings geht nicht, denn dann habe ich das Symptom wie in (1) beschrieben.

    - Frage: Irgendeine Idee wie ich das fixen kann?


    LG

    Bilder

    Mit (un)freundlichen Grüßen,
    Murashi


    iMac15,1: MSI B85M-E45 - Intel Core i5 3,2GHz - 16GB DDR3 - RX460 4GB - 275GB Crucial M300 - 240GB Kingston A400
     MacBookPro9,2:
    HP EliteBook 8470p - Intel Core I5 3,2GHz - 8GB DDR3 - Intel HD400 - 120GB Sandisk SSD-Plus

     MacBook7,1: Apple MacBook - Intel Core 2 Duo 2,4 - 9GB DDR3 - nVidia GeForce 320M - 120GB Sandisk SSD-Plus


    uV2SMdZ.png

  • Du hast wohl in der Zwischenzeit neu installiert, dabei die Platte komplett formatiert und deinen EFI-Ordner manuell auf die EFI-Partition kopiert.

    Dabei gehen natürlich die vorherigen Einstellungen unter /Library/Preferences/com.projectosx.clover.installer.plist verloren.

    Somit weiss das neue PKG nicht, was du vorher eingerichtet hattest.

    Wenn du nun neu installieren musst, um die genannte plist wieder zu generieren, empfiehlt es sich, dort die richtigen Einstellungen durchzuführen und vorsichtshalber die ursprüngliche config.plist zu sichern.

    Gruß
    Al6042


    Asus Prime Z390-A 0805 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.3 | Clover 4871

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14.3 | Clover 4871

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.3


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!


    al6042.png

  • EFI Backups habe ich auch, sind auch recht nützlich. Immerhin sammeln sich dort neben den älteren Clover-Versionen auch ältere Kexte, Konfigurationen etc. Zum stöbern nicht schlecht.

    ASUS PRIME X299-DELUXE • i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

  • al6042


    Eher kein Backup an sich. Meine EFI Partition wird - sofern ich die Macintosh SSD formatiere - gar nicht gelöscht. Die bleibt so zu sagen immer vorhanden. Dachte das ist nicht schlimm, wusste gar nicht das eine Plist von Clover angelegt wird.


    Aber ansonsten trifft es genau das was du geschrieben hast.


    Wie kann ich den mit dem Formatieren aus dem Festplattendienstprogramm heraus die EFI Partition löschen?


    apfelnico


    Backup immer meine EFI Folder, zum einen weil ich dann alles habe und zum anderen weil die Konfiguration soweit endlich perfekt ist. Da brauche ich am Ende nur umkopieren. ^^
    Hab auch ältere Versionen ^^

    Mit (un)freundlichen Grüßen,
    Murashi


    iMac15,1: MSI B85M-E45 - Intel Core i5 3,2GHz - 16GB DDR3 - RX460 4GB - 275GB Crucial M300 - 240GB Kingston A400
     MacBookPro9,2:
    HP EliteBook 8470p - Intel Core I5 3,2GHz - 8GB DDR3 - Intel HD400 - 120GB Sandisk SSD-Plus

     MacBook7,1: Apple MacBook - Intel Core 2 Duo 2,4 - 9GB DDR3 - nVidia GeForce 320M - 120GB Sandisk SSD-Plus


    uV2SMdZ.png

  • Ich meinte den automatisch erzeugten EFI-Backup Folder. Ist ganz praktisch.


    Wenn du eine Festplatte mit dem FDP neu initialisierst, wird eine neue unsichtbare EFI-Partition angelegt (HFS+, APFS).

    ASUS PRIME X299-DELUXE • i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

  • Früher hatte ich immer mit RHEL gebootet und über den dortigen Festplattenmanager den APFS Container gelöscht.

    Mit (un)freundlichen Grüßen,
    Murashi


    iMac15,1: MSI B85M-E45 - Intel Core i5 3,2GHz - 16GB DDR3 - RX460 4GB - 275GB Crucial M300 - 240GB Kingston A400
     MacBookPro9,2:
    HP EliteBook 8470p - Intel Core I5 3,2GHz - 8GB DDR3 - Intel HD400 - 120GB Sandisk SSD-Plus

     MacBook7,1: Apple MacBook - Intel Core 2 Duo 2,4 - 9GB DDR3 - nVidia GeForce 320M - 120GB Sandisk SSD-Plus


    uV2SMdZ.png

  • Ja und? Deine Frage war doch, wie geht das mit dem Festplattendienstprogramm. Die EFI-Partition gehört in diesen Fällen dazu und wird automatisch angelegt. Entfernt sollte dienlichst werden, maximal geleert und neu bestückt.

    ASUS PRIME X299-DELUXE • i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

  • > Wenn du eine Festplatte mit dem FDP neu initialisierst, wird eine neue unsichtbare EFI-Partition angelegt (HFS+, APFS).

    Kann ich jetzt nicht bestätigen, wenn ich denn AFPS Container mittels der Freien Deutschen Partei (FDP ^^) neu initialisiere, dann ist dennoch immer noch der alte EFI Inhalt vorhanden.

    Mit (un)freundlichen Grüßen,
    Murashi


    iMac15,1: MSI B85M-E45 - Intel Core i5 3,2GHz - 16GB DDR3 - RX460 4GB - 275GB Crucial M300 - 240GB Kingston A400
     MacBookPro9,2:
    HP EliteBook 8470p - Intel Core I5 3,2GHz - 8GB DDR3 - Intel HD400 - 120GB Sandisk SSD-Plus

     MacBook7,1: Apple MacBook - Intel Core 2 Duo 2,4 - 9GB DDR3 - nVidia GeForce 320M - 120GB Sandisk SSD-Plus


    uV2SMdZ.png

  • eine _Partition_ zu ändern ist etwas anderes als eine _Platte_ zu „initialisieren“ (Apple-Sprech). Bei letzterem wird die Platte selbst komplett platt gemacht, sämtliche vorhandenen Strukturen sind weg und es wird neu angelegt was man eingestellt hat.

    ASUS PRIME X299-DELUXE • i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

  • Muss ich also dann praktisch den Blau markierten Teil "löschen" - also die Platte direkt. Nicht nur die Partition.


    Gut ich lerne gerne dazu :)

    Bilder

    Mit (un)freundlichen Grüßen,
    Murashi


    iMac15,1: MSI B85M-E45 - Intel Core i5 3,2GHz - 16GB DDR3 - RX460 4GB - 275GB Crucial M300 - 240GB Kingston A400
     MacBookPro9,2:
    HP EliteBook 8470p - Intel Core I5 3,2GHz - 8GB DDR3 - Intel HD400 - 120GB Sandisk SSD-Plus

     MacBook7,1: Apple MacBook - Intel Core 2 Duo 2,4 - 9GB DDR3 - nVidia GeForce 320M - 120GB Sandisk SSD-Plus


    uV2SMdZ.png

  • Ja genau. Wobei, soll wirklich DIESE Platte weg? Dort liegt dein macOS.

    ASUS PRIME X299-DELUXE • i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

  • Wenn ich den (Hack)Mac neu aufsetzen dann wird die Platte gelöscht. Wollte gerade nur sicher gehen das ich verstanden habe, was du meinst ^^

    Mit (un)freundlichen Grüßen,
    Murashi


    iMac15,1: MSI B85M-E45 - Intel Core i5 3,2GHz - 16GB DDR3 - RX460 4GB - 275GB Crucial M300 - 240GB Kingston A400
     MacBookPro9,2:
    HP EliteBook 8470p - Intel Core I5 3,2GHz - 8GB DDR3 - Intel HD400 - 120GB Sandisk SSD-Plus

     MacBook7,1: Apple MacBook - Intel Core 2 Duo 2,4 - 9GB DDR3 - nVidia GeForce 320M - 120GB Sandisk SSD-Plus


    uV2SMdZ.png

  • Community Bot

    Hat das Label von In Arbeit auf Erledigt geändert
  • Ich nehme an damit ist der Thread erledigt und ich spendiere ihm mal den passenden Haken ;)

    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, macOS Mojave 10.14
    System 2 (MacBook Pro 10.2): ThinkPad T430, i5-3360M @ 2.8 GHz, 8GB DDR3, IntelHD 4000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Dual Boot MacOS Mojave 10.14, Windows10 Pro 64Bit

    griven.png

  • Entschuldige griven ich vergaß :(


    Danke dir :)

    Mit (un)freundlichen Grüßen,
    Murashi


    iMac15,1: MSI B85M-E45 - Intel Core i5 3,2GHz - 16GB DDR3 - RX460 4GB - 275GB Crucial M300 - 240GB Kingston A400
     MacBookPro9,2:
    HP EliteBook 8470p - Intel Core I5 3,2GHz - 8GB DDR3 - Intel HD400 - 120GB Sandisk SSD-Plus

     MacBook7,1: Apple MacBook - Intel Core 2 Duo 2,4 - 9GB DDR3 - nVidia GeForce 320M - 120GB Sandisk SSD-Plus


    uV2SMdZ.png