Atheros 9240 funktioniert auf T430 nach Kextupdates nicht

  • Nach dem letzten Kextupdate des AirPortBrcmFixup.kext von 1.1.6 auf 1.1.9 kann auf meinem T430 die von  Sascha_77 gebrandete Atheros 9240 nicht mehr geladen werden. Fehler: Es ist keine Wlanhardware installiert. Auch den AirPortAtheros40.text und KextCash reparieren nütze nix.

    Downgrade auf 1.1.6 hat das Prtoblem zunächst gelöst.


    Update: Diese Erfolgsmeldung war etwas voreilig. Weder

    Sorry, hier muss noch ein anderes Problem dahinter stecken.


    Ich hatte als die Atheros 9240 ausgefallen war, den AirPortAtheros40.kext repariert, dann Downgrade des letzen Cloverupdate gemacht. Wlan geht wieder. Hab edann die Kexte verglichen und eine neue Version des AirPortBrcmFixup.kext gefunden und diesen (zu Unrecht) verdächtigt. Jedoch hat nur ein Downgrade des AirPortBrcmFixup.kext allein keine Erfolg gebracht.


    Auch der AtherosWiFiInjector.kext ist unschuldig.


    Auch das Update 10.14.3 spielt keine Rolle, das Problem war vorher vorhanden.


    Zeitlich kriege ich das jetzt nicht hin, jegliche Kexte einzeln zu prüfen.


    Deshalb hier die Frage, an welche Schrauben noch gestellt werden müsste?

    --
    Grüße


    Christian


    "Ein Hackintosh ist wie ein Garten, es gibt immer etwas zu tun."


    iMac 18,2 Asus Prime B250M Plus, Intel QuadCore i5 7500 Kaby Lake 3,41 Ghz, PowerColor RX580 8192 MB NVRAM, Realtek ALC888B (ID 2), TP-LINK Archer T9E AC1900 PCIe, 16GB Ballistic Sport DDR4 2400, Mojave 10.14.3 Clover r4910

    MacBookPro 13,1 Lenovo ThinkPad T460 i5 6300U 8Gb RAM iGPU HD520 WIFI: IPS 1920x1080, WIFI DW 1560, Mojave 10.14.3, Clover r4910

    MacBookPro 9,2 Lenovo Thinkpad T430, Intel Core i5 3320M 2,6GHz, Intel HD4000 1366x768 DE, 8GB RAM, Mojave 10.14.3, Clover r4910

    iMac 14,2 Asus P8H67 M Pro, Intel Core i5 2400, VTX3D Radeon HD 7850 2GB X-Edition, iGPU HD2000, Realtek ALC892 (ID 31), 8 GB RAM, Mojave 10.14.3, BootLoader Clover r4910

    Edited once, last by chmeseb ().

  • chmeseb

    Added the Label Umsetzung prüfen
  • chmeseb

    Changed the title of the thread from “AirportBrcmFixup.xext V. 1.1.9 funktionoiert auf einem T430 nicht mit gebrandeter Atheros 9240” to “Atheros 9240 funktioniert auf T430 nach Kextupdates nicht”.
  • Nicht am AirPortBrcmFixup.kext. Der ist für Broadcom Wi-Fi cards.

    Grüße und Good Hack Michael


    :hackintosh:

  • ok, die Kexte hatte ich aus einer EFI für das T430 von Sascha_77 so übernommen und immer aktualisiert.


    Ich teste mal alles durch, vielleicht finde ich nach dem Prinzip von Versuch und Irrtum den Übeltäter.

    --
    Grüße


    Christian


    "Ein Hackintosh ist wie ein Garten, es gibt immer etwas zu tun."


    iMac 18,2 Asus Prime B250M Plus, Intel QuadCore i5 7500 Kaby Lake 3,41 Ghz, PowerColor RX580 8192 MB NVRAM, Realtek ALC888B (ID 2), TP-LINK Archer T9E AC1900 PCIe, 16GB Ballistic Sport DDR4 2400, Mojave 10.14.3 Clover r4910

    MacBookPro 13,1 Lenovo ThinkPad T460 i5 6300U 8Gb RAM iGPU HD520 WIFI: IPS 1920x1080, WIFI DW 1560, Mojave 10.14.3, Clover r4910

    MacBookPro 9,2 Lenovo Thinkpad T430, Intel Core i5 3320M 2,6GHz, Intel HD4000 1366x768 DE, 8GB RAM, Mojave 10.14.3, Clover r4910

    iMac 14,2 Asus P8H67 M Pro, Intel Core i5 2400, VTX3D Radeon HD 7850 2GB X-Edition, iGPU HD2000, Realtek ALC892 (ID 31), 8 GB RAM, Mojave 10.14.3, BootLoader Clover r4910

  • Sascha hat dir 3 kexte geschickt:

    FakePCIID_AR9280_as_Custom.kext

    FakePCIID.kext

    AtherosWiFiInjector.kext

    Die gehören in den Other/Kext Ordner

    AirPortAtheros40.kext kannst du in den L/E legen. dann KextCache erneuern. So funktioniert das bei mir! (Update Mojave die 3. probiere ich heute abend aber erst)

    • Lenovo Thinkpad X220 i5-2540M HD3000 8GB Dualboot mit Sierra 10.12 und Mojave 10.14.3 Clover 4700
    • Lenovo Thinkpad X230 i5-3320M HD4000 8GB Dualboot mit Sierra 10.12 und Mojave 10.14.4 Clover 4920
    • Lenovo ThinkCentre m93P Tiny i5-4570T HD4600 12GB Win10 + Mojave 10.14.4 auf einer Platte Clover 4741
    • Lenovo ThinkCentre m58 Core2Duo E85400 6GB NVIDIA GT730 2GB (Asus) WindowsXP + High Sierra Clover 4861
  • Die Kexte habe ich da drin und sie funktionieren, aber ...


    KextUpdater hat zur Aktualisierung der FakePCIID.kext neben dem FakePCIID_AR9280_as_Custom.kext auch noch andere, u.a. den FakePCIID_AR9280_as_AR946x.kext angeboten. Den habe ich ungesehen in Other kopiert.


    Letzteren darf aber nicht in Other. Der unterbindet die Funktion der Atheros 9240.


    Somit ist das Problem gelöst.

    --
    Grüße


    Christian


    "Ein Hackintosh ist wie ein Garten, es gibt immer etwas zu tun."


    iMac 18,2 Asus Prime B250M Plus, Intel QuadCore i5 7500 Kaby Lake 3,41 Ghz, PowerColor RX580 8192 MB NVRAM, Realtek ALC888B (ID 2), TP-LINK Archer T9E AC1900 PCIe, 16GB Ballistic Sport DDR4 2400, Mojave 10.14.3 Clover r4910

    MacBookPro 13,1 Lenovo ThinkPad T460 i5 6300U 8Gb RAM iGPU HD520 WIFI: IPS 1920x1080, WIFI DW 1560, Mojave 10.14.3, Clover r4910

    MacBookPro 9,2 Lenovo Thinkpad T430, Intel Core i5 3320M 2,6GHz, Intel HD4000 1366x768 DE, 8GB RAM, Mojave 10.14.3, Clover r4910

    iMac 14,2 Asus P8H67 M Pro, Intel Core i5 2400, VTX3D Radeon HD 7850 2GB X-Edition, iGPU HD2000, Realtek ALC892 (ID 31), 8 GB RAM, Mojave 10.14.3, BootLoader Clover r4910

  • chmeseb

    Set the Label from Umsetzung prüfen to Erledigt
  • Community Bot

    Set the Label from Erledigt to In Arbeit
  • Ja der FakePCIID_AR9280_as_AR946x.kext gehört da nicht rein.


    Wirf einfach alles bis auf meine 3 Kexte aus der EFI raus was mit WLAn zu tun hat. Dann läufts. Gerade mein T530 auf 10.14.3 aktualisiert und die AR9280 tuts nach wie vor.

    Airportkompatible Karte trotz BIOS Whitelist? >> Klick <<

    -------------------------------------------------------------------------------------
    Habe mir gestern beim Harken den Haken in die Hacken gehauen

    -------------------------------------------------------------------------------------
    Bitte keine Supportanfragen auf meiner Pinnwand bzw. per PM. Dafür ist das Forum da!

    Edited once, last by Sascha_77 ().

  • Community Bot

    Set the Label from In Arbeit to Erledigt