Update von Sierra (10.12.3) auf Mojave oder High Sierra

  • Hallo zusammen,


    nach einiger Weile wollte ich mich nun an ein größeres Update wagen und meinen Hackintosh von Sierra zu Mojave oder High Sierra bringen.

    Ich habe mich bereits durch ein paar Themen (z.B. UPDATE MOJAVE) gelesen, möchte jedoch gerne auf Nummer Sicher gehen.

    Systemkomponenten: ASUS Z170 Deluxe, Intel i7 6700K, ASUS GeForce STRIX GTX 980 - Clover 4844, iMac 17,1


    Welche Installation würdet ihr momentan empfehlen, da ja anscheinend noch keine Treiber für Nvidia verfügbar sind?


    1. Benötige ich einen Installationsstick oder kann ich einfach per AppStore updaten - sollte ich vorher noch alle anderen Updates installieren (inklusive High Sierra)?
    2. BIOS Update: Ja oder Nein?
    3. Wird meine Festplatte automatisch auf APFS umgestellt? Und sollte ich die anderen während der Installation lieber abklemmen?
    4. Ich habe ein komplettes Backup der SSD auf einer HDD, EFI liegt auch als Backup vor. Kann ich einfach auf die bestehende SSD installieren?
    5. Aktuelle Kexts (Update mit KextUpdater gemacht, einige doppelt, besser in SLE oder EFI?):
      1. SLE AppleALC, AppleGraphicsControl, Brcm, Lilu
      2. EFI AppleALC, FakeSMC, IntelMausiEthernet, Lilu, Shiki, USBInjectAll
    6. Welche Kexts sind überflüssig und welche benötige ich neu (z.B: FakeSMC vs VirtualSMC, Whatevergreen, BRCMWLFIXUP, AIRPORTBRCMFIXUP)? Wann sollte ich die neuen installieren (vor oder nach dem Update)?
    7. Welche neuen Clover-Einträge benötige ich und welche kann ich löschen (Graphics (0x19120000), KextsToPatch, Rt Variables, SMBIOS)? Beispiel Neue Clover "KextsToPatch"-Einträge für Mojave, INSTALL-STICK FÜR DIVERSE SYSTEM-VARIANTEN (HIGH SIERRA 10.13.6 UND MOJAVE 10.14)
      Insbesondere unterscheiden sich Acpi, Boot und KextsToPatch doch deutlich von meiner aktuell laufenden Config.


    8. Vor der dem Update bei Boot auf Verbose (-v) stellen und nv_disable=1? Muss ich dann auch bei System Parameters den Haken bei NvidiaWeb entfernen?
    9. Das Update auf den neuen Nvidia-Treiber mache ich erst im Anschluss an die Installation mittels NVIDIA® WebDriver Updater oder Webdriver All Versions?
      Oder kann ich mittels letzteren Programms einfach vor der Installation den passenden Treiber für Mojave installieren?


    Entschuldigt die vielen Fragen und hoffentlich könnt ihr mir weiterhelfen.

  • Im Grundsatz gehen Updates bei gut laufenden Rechnern eigentlich recht problemlos, besonders, wo Du von Allem ein Backup zu haben scheinst. Mojave wird mit deiner Grafik allerdings nicht wirklich laufen, die Nvidia-Techniker sind zur Zeit wohl mit dem Erstellen der neuen Windows-Sync-Treiber voll ausgelastet..

    Du solltest allerdings alle Hackintosh-Kexte aus den eigentlichen (Mac-)System-Ordnern in die Clover-EFI verschieben. Da findest Du sie leichter und kannst sie auch besser auf aktuellem Stand halten. BTW.: bitte die Hackintosh-Kexte UND Clover unbedingt vor dem System-Update auf den neusten Stand bringen. Wir hätten da auch ein passendes Tool..


    :hackintosh:

  • Ich habe ein ähnliches System (siehe Profil) und Mojave läuft wunderbar. Allerdings nutze ich ausschließlich die interne GraKa HD530.

    Ich brauche nur ein Mindestmaß an Kexten, bei "Kext-to-Patch" habe ich keine Eintragungen. Dein Problem wird die NVIDIA werden, vermute ich.

  • Für Mojave gibt es noch keine Webdriver, die GTX 980 wird sich deshalb nicht nutzen lassen unter Mojave (bzw. nur als Standard-Grafik mit 5 MB VRAM laufen). Ich bin deshalb auch erstmal nur auf High Sierra gegangen. Eine RX 580 ist bei mir aber schon unterwegs.

  • Vielen Dank für die schnellen Rückmeldungen.

    Den Kext Updater habe ich bereits installiert und hier alles auf die neuste Version gebracht.

    Nun habe ich ein Update auf High Sierra machen wollen und die Installation lief auch wunderbar durch - allerdings war nach dem Neustart die Partition nicht mehr da und nun weiß ich nicht wirklich weiter... :(

  • Was heißt "nicht mehr da"? Wird macOS in Clover nicht mehr angezeigt?

  • Im Festplattendienstprogramm wird mir die Partition als unpartitioniert angezeigt.

    Kann nur noch über mein Backup (Sierra) starten.

  • Ich kann Dir nicht sagen, was da passiert ist. Ich tendiere grundsätzlich zu einer "cleanen" Installation, also kein Update, sondern High Sierra (oder was immer es werden soll) komplett neu zu installieren. Wenn Du ein Backup hast, sollte das einen Versuch wert sein.

  • Von welchem Festplattendienstprogramm wird denn hier gesprochen?

    Das von Sierra oder das von High Sierra, bzw. Mojave?


    Während der Installation von HS oder MJ wird die macOS-Platte zu APFS konvertiert und ist somit für ältere macOS-Versionen wahrscheinlich nicht sichtbar.

    Damit Clover diese Partition lesen kann, gibt es einen weiteren EFI-Treiber namens ApfsDriverLoader-64.efi, der in den Ordner /EFI/CLOVER/driver64UEFI kopiert werden muss.


    Welche Clover Version liegt denn bei phramenma vor?

    Ist es die aktuellste 4844, dann kann die beiliegende Datei benutzt werden.

    Wird eine frühere Version von Clover eingesetzt, macht es Sinn diese zu aktualisieren und dabei direkt den Treiber in der Auswahl hinzuzufügen.

    Files

    Gruß
    Al6042


    Asus Prime Z390-A 1005 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.5 | Clover 4934

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.14.5 | Clover 4934

    NUC7i5BNK 0076 | i5 7260U | 16GB | HD640 | NVMe 500 GB | macOS 10.14.5 | OC 0.3

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.5


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Vielen Dank! al6042

    Es lag wohl an dem fehlenden EFI-Treiber.

    Clover liegt in aktueller Version vor.

    Nun weiß ich aber leider nicht wo ich weiterzumachen habe...

    Denn wenn ich die Installations-Partition nehme bekomme ich folgenden Fehler:



    Zur Auswahl habe ich noch:

    Boot FileVault Prebooter from Preboot

    Boot macOS Install Prebooter from Preboot (siehe Fehler oben)

    Boot macOS from Macintosh HD

  • Nun,

    das liegt zum einen wahrscheinlich an deinen aktuellen BIOS Settings.

    Hast du die interne Grafik darin aktiviert?

    Wenn ja, wie ist die genaue Einstellung?

    Hier mal ein Screenshot meines H170N-Wifi:


    Ansonsten wäre spannend zu wissen, wie dein EFI-Ordner zusammengestellt ist, ohne dabei nur mit Screenshots zu arbeiten.

    Packe den Ordner doch bitte mal als ZIP-Datei in deiner nächsten Antwort dazu.

    Gruß
    Al6042


    Asus Prime Z390-A 1005 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.5 | Clover 4934

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.14.5 | Clover 4934

    NUC7i5BNK 0076 | i5 7260U | 16GB | HD640 | NVMe 500 GB | macOS 10.14.5 | OC 0.3

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.5


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • BIOS-Einstellungen:

    Load Optimized Defaults

    Advanced/System Agent/Graphics Configuration/Primary Display: PEG (optional Auto oder IGFX anwählbar)

    Advanced/USB Configuration/Legacy USB Support: Disabled

    Advanced/USB Configuration/XHCI Hand-Off: Enabled

    Boot/CSM/Launch CSM: Disabled

    Boot/Secure Boot/OS Type: Other O

    vt-D : Disabled

    SATA auf AHCI eingestellt


    Diese Punkte kann ich bei mir nicht finden:

    HPET ggf. auf 64Bit einstellen

    XHCI-Mode : Auto

    EHCI-Hand Off : Enabled

    Powermanagement ggf. auf S3 only stellen

    Jedes ggf. vorgenommene Overclocking ausschalten

    CPU EIST : Disable


    Wenn du die integrierte GPU verwenden willst, kannst du die nächsten 2 Schritte überspringen.

    Internal Graphics : OFF

    Init Display First auf den PCIe Slot ändern in dem eure Grafikkarte steckt.

    Wenn du die integrierte Grafik verwenden willst:

    Intel Processor Graphics : Enabled

    Intel Prozessor Graphics Memory: 64M <- Wichtig! Mehr führen bei manchen zu Problemen. Im Zweifelsfall austesten mit 32/96M

    DVMT Total Memory Size : MAX

    Edited 2 times, last by phramenma ().

  • Der Link funktioniert nicht.

    Bitte lade die ZIP-Datei als Dateianhang im Thread direkt hoch.

    Gruß
    Al6042


    Asus Prime Z390-A 1005 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.5 | Clover 4934

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.14.5 | Clover 4934

    NUC7i5BNK 0076 | i5 7260U | 16GB | HD640 | NVMe 500 GB | macOS 10.14.5 | OC 0.3

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.5


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Die ist leider zu groß - daher hatte ich sie hochgeladen. :/


    Edit: Jetzt sollte es klappen.

  • Dann entferne die darin befindlichen Ordner /EFI/APPLE und /EFI/CLOVER/themes

    Gruß
    Al6042


    Asus Prime Z390-A 1005 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.5 | Clover 4934

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.14.5 | Clover 4934

    NUC7i5BNK 0076 | i5 7260U | 16GB | HD640 | NVMe 500 GB | macOS 10.14.5 | OC 0.3

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.5


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Ist oben hier geändert. :)

    EFI.zip

  • Es geht grundsätzlich darum dass die Dateien eines Threads nicht auf x-beliebigen Filehostern liegen und somit im Laufe der Zeit aus den Threads verschwinden.

    Deswegen auch meine Bitte, die Datei im Thread zu platzieren.

    Gruß
    Al6042


    Asus Prime Z390-A 1005 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.5 | Clover 4934

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.14.5 | Clover 4934

    NUC7i5BNK 0076 | i5 7260U | 16GB | HD640 | NVMe 500 GB | macOS 10.14.5 | OC 0.3

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.5


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Entschuldige bitte, ich habe es im Post über Dir nachgetragen - und ja, die Anmerkung macht natürlich Sinn.


    Unter Boot Options habe ich gerade festgestellt, dass dort folgende Reihenfolge eingestellt ist (alle von der SSD auf der Mac und Win installiert sind):

    1. Clover start bootmgfw.efi at EFI
    2. UEFI OS
    3. Windows Boot Manager

    Ist das so korrekt?

  • Kann ich dir nicht so genau sagen, da ich kein Dualboot-System nutze, das beide Betriebssysteme auf der gleichen Platte hat.

    Dafür habe ich aber mal deine EFI überarbeitet.

    Da waren noch alte Ordner aus frühen Clover-Installationen integriert.

    Zusätzlich waren die SMBIOS-Daten deines iMac17,1 noch von 2015... in der Zwischenzeit hat Apple hierfür Firmware-Updates verteilt, die dein Gerät auf den Stand September 2018 gehoben und somit auch Mojave-Ready gemacht hätte.


    Zudem habe ich ein paar Kexte und auch KextsToPatch-Einträge ausgetauscht, bzw. entfernt.


    Bitte teste mal die beiliegende EFI... benenne vorher aber deinen aktuellen Ordner auf der EFI-Partition zu "EFI-alt" um, damit wir dessen Inhalt nicht verlieren.

    Files

    • EFI.zip

      (6.71 MB, downloaded 16 times, last: )

    Gruß
    Al6042


    Asus Prime Z390-A 1005 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.5 | Clover 4934

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.14.5 | Clover 4934

    NUC7i5BNK 0076 | i5 7260U | 16GB | HD640 | NVMe 500 GB | macOS 10.14.5 | OC 0.3

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.5


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Wow, vielen Dank für Deine Hilfe. :S

    Ja, Mojave war eigentlich mein Plan - aber da Nvidia hier noch nicht so weit ist, wollte ich erst einmal langsam auf High Sierra und zu gegebener Zeit dann auf Mojave.


    Ich teste und melde mich zurück.