High Sierra Installation auf XMG A705 ( Clevo N170SD )

  • Hi Zusammen !

    Hab mir überlegt per DualBoot auf mein Geschäftsnotebook Mac OS (High Sierra) zu knallen.

    es handelt sich um dieses Notebook :

    https://www.notebookcheck.net/…book-Review.139678.0.html


    Processor
    Intel Core i7-4720HQ (Intel Core i7)

    Graphics adapter
    NVIDIA GeForce GTX 960M - 2048 MB, Core: 1097 MHz, Memory: 2500 MHz, GDDR5, ForceWare 345.05 (9.18.13.4505), Optimus

    Memory
    8192 MB DDR3-1600, dual-channel, two memory banks (both filled)

    Mainboard

    Intel HM87 (Lynx Point)



    Edit 2 :


    Hab mich nun nochmal ein wenig dran gesetzt ..


    mit NVIDIA wird wohl nicht laufen , mir aber eher mal schnuppe die INTEL HD läuft per inject intel sauber.

    Ton Läuft.

    Tastatur läuft. ( allerdings erkennt er sie falsch - er sieht ALT als CMD an .. und die "rechtsklick" taste neben ALT GR als ALT GR an ...)


    Wo ich nun noch hilfe benötigen würde wäre bei :


    Trackpad

    Grafikprobleme bei Chrome Nutzung ( sobald ich im chrome bin und dort die maus bewege hab ich immer wieder blackscreens , warum auch immer bild weg bild da .. geht die ganze zeit so .. vermute er will per optimus die Geforce ansprechen ( hab eigentlich im Clover nv-Diasble1 laufen) .. vllt hat da jemand noch einen Rat.


    an Kext sind installiert : Lilu Whatevergreen FakeSMC VoodooHDA VoodooPS2Controller und ACPIBateryManager...


    Clover file kann ich anhängen wenn gewünscht ..


    SMBios ist von einem Macbookpro 11,2


    Grafikkarte ist nun die interne HD 4600

    Hackintosh System : Intel i5 3570 - MSI H61M-P20 -AMD HD5570 - 16 GB DDR 3 1600 - High Sierra - Clover Bootloader

    Hackbook Work : XMG A705 3AF - Intel i7 4720HQ - Geforce GTX960M + HD4600 ( GTX Deaktiviert in MacOS ) - 16 GB Ram - Clover Booatloader

    4 Mal editiert, zuletzt von julian91 () aus folgendem Grund: Änderung

  • Trackpad

    Grafikprobleme bei Chrome Nutzung


    vermute er will per optimus die Geforce anspreche

    Welches Trackpad ist verbaut, es gibt ja noch mehrere Kext die man ausprobieren kann?

    Wie ist es mit Safari und FireFox oder WhatEver?

    Optimus wird unter macOS gar nicht unterstützt, also wird da auch nichts angesprochen.

    iMac16,2 (Late 2015): GA Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.11.6 - Ozmosis + Clover r4509
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.13.3 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.3 - Ozmosis + Clover r4359


    Metzger für angewandte Mettologie

  • Welches Trackpad ist verbaut, es gibt ja noch mehrere Kext die man ausprobieren kann?

    Muss ich Prüfen , darüber infos zu bekommen ist gar nicht so einfach ... evlt boot ich windows einmal um nachzuschauen



    Wie ist es mit Safari und FireFox oder WhatEver


    Safari läuft einwandfrei. Firefox noch nicht getestet.

    Hab mitlerweile auch die FAkePCI kext für die HD Grafikkarte auf dem Clover unter Other,

    brachte aber leider keine Besserung :(

    Hackintosh System : Intel i5 3570 - MSI H61M-P20 -AMD HD5570 - 16 GB DDR 3 1600 - High Sierra - Clover Bootloader

    Hackbook Work : XMG A705 3AF - Intel i7 4720HQ - Geforce GTX960M + HD4600 ( GTX Deaktiviert in MacOS ) - 16 GB Ram - Clover Booatloader

  • Die Intel HD 4600 braucht kein FakePCIID.kext sondern einen Inject Intel und eine IG Platform ID, alternativ vielleicht Lilu.kext plus WhateverGreen.kext im Ordner Other. :)

    iMac16,2 (Late 2015): GA Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.11.6 - Ozmosis + Clover r4509
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.13.3 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.3 - Ozmosis + Clover r4359


    Metzger für angewandte Mettologie

  • hast du grade zufällig die IG Plattform ID für mich ?

    hatte im netz eine gefunden , aber die wollte wohl nicht laufen :(

    derzeit ist die 0a26006 drin ...


    lilu und whatever ist ja vorhanden schon:-)

    Hackintosh System : Intel i5 3570 - MSI H61M-P20 -AMD HD5570 - 16 GB DDR 3 1600 - High Sierra - Clover Bootloader

    Hackbook Work : XMG A705 3AF - Intel i7 4720HQ - Geforce GTX960M + HD4600 ( GTX Deaktiviert in MacOS ) - 16 GB Ram - Clover Booatloader

  • Versuch mal folgende:


    MacBook Pro 11,2 -> Klick


    0x04060000

    0x04120004

    0x04160000


    Oder mit dem Clover Configurator aus dem Download Center oder mit dem Cloud Clover Editor -> Klick

    iMac16,2 (Late 2015): GA Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.11.6 - Ozmosis + Clover r4509
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.13.3 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.3 - Ozmosis + Clover r4359


    Metzger für angewandte Mettologie

  • 0x04060000

    Geil danke ! der wars ! , nun spinnt kein google mehr rum :-)


    Nun hab ich nur noch das Trackpad und was ich noch entdeckt habe das die standy / ruhezustand noch so will .. er ist mir ausversehen rein in ruhezustand und nicht mehr aufgewacht ... und die Bildschirmhelligkeit lässt sich leider auch nicht ändern ... hab ich alles jetzt erst entdeckt , gestern wars ein wenig spät :D


    und dann noch das Problem das er nicht Sauber die Tastatur erkennt :/

    Hackintosh System : Intel i5 3570 - MSI H61M-P20 -AMD HD5570 - 16 GB DDR 3 1600 - High Sierra - Clover Bootloader

    Hackbook Work : XMG A705 3AF - Intel i7 4720HQ - Geforce GTX960M + HD4600 ( GTX Deaktiviert in MacOS ) - 16 GB Ram - Clover Booatloader

  • und die Bildschirmhelligkeit lässt sich leider auch nicht ändern

    Hast du es mal mit Add PNLF Device unter dem Reiter ACPI in der config.plist versucht?

    iMac16,2 (Late 2015): GA Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.11.6 - Ozmosis + Clover r4509
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.13.3 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.3 - Ozmosis + Clover r4359


    Metzger für angewandte Mettologie

  • Add PNLF Device


    habe nur addpnlf_100000000 unter ACPI und darunter gab es keine besserung ...








    New Edit :


    So hab nun nach einigem rumprobieren einiges zum laufen bekommen:

    NVME Boot (SSD SATA hat den EFI und bootet die NVMe SSD) : Problem hier ist Bios kann nicht von NVMe Booten.

    Tastatur und Touchpad laufen nun sauber.

    Sound ist nun lauter ( hab die VoodooHDA bearbeitet und damit alles lauter bekommen)

    Grafik läuft sauber.


    Was mir fehlt ist nun Bildschirmhelligkeit / Sleep mode / Hibernate.

    Wenn mir dafür noch jemand Hilfe geben könnte gerne ! Weil da verzweifle ich grade ein wenig :(

    Hackintosh System : Intel i5 3570 - MSI H61M-P20 -AMD HD5570 - 16 GB DDR 3 1600 - High Sierra - Clover Bootloader

    Hackbook Work : XMG A705 3AF - Intel i7 4720HQ - Geforce GTX960M + HD4600 ( GTX Deaktiviert in MacOS ) - 16 GB Ram - Clover Booatloader

    5 Mal editiert, zuletzt von julian91 ()

  • Auf meinem Hackbook Toshiba Qosmio mit SMBIOS MacBookPro10,1 liegt die Helligkeitssteuerung unter FN + Rollen und FN + Pause, musst du mal schauen welche Tasten bei dir belegt sind. :)

    iMac16,2 (Late 2015): GA Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.11.6 - Ozmosis + Clover r4509
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.13.3 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.3 - Ozmosis + Clover r4359


    Metzger für angewandte Mettologie

  • Ich hab hier vorbeschrieftete Tasten von XMG.. Lautstärke tasten funktionieren per FN. Helligkeit nicht leider :/ Genauso wie auch zb Trackpad sperren Funktioniert oder Tastaturbeleuchtung ein und aus.

    Hackintosh System : Intel i5 3570 - MSI H61M-P20 -AMD HD5570 - 16 GB DDR 3 1600 - High Sierra - Clover Bootloader

    Hackbook Work : XMG A705 3AF - Intel i7 4720HQ - Geforce GTX960M + HD4600 ( GTX Deaktiviert in MacOS ) - 16 GB Ram - Clover Booatloader

  • Meine Tasten sind von Toshiba auch vorgegeben, aber ein Mac OS X oder macOS interessiert sich nun mal nicht für die Belegung auf einem quasi Windows Notebook, darum meinte ich musst du mal schauen.... :)

    iMac16,2 (Late 2015): GA Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.11.6 - Ozmosis + Clover r4509
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.13.3 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.3 - Ozmosis + Clover r4359


    Metzger für angewandte Mettologie

  • hmm ok , was mich aber wundert das er definitiv nicht auf voller helligkeit arbeitet.

    kann ich das beim boot festlegen das die helligkeit höher ist ?

    das würde mir schon mal erst mal helfen ..

    Hackintosh System : Intel i5 3570 - MSI H61M-P20 -AMD HD5570 - 16 GB DDR 3 1600 - High Sierra - Clover Bootloader

    Hackbook Work : XMG A705 3AF - Intel i7 4720HQ - Geforce GTX960M + HD4600 ( GTX Deaktiviert in MacOS ) - 16 GB Ram - Clover Booatloader

  • Das PNLF Device ist für die Helligkeit, das kann man entweder über eine DSDT oder eine SSDT (Stichwort Hot Patch) oder eben über den Clover Fix unter ACPI machen und in der Regel sollte das dann schon auch funktionieren.

    iMac16,2 (Late 2015): GA Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.11.6 - Ozmosis + Clover r4509
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.13.3 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.3 - Ozmosis + Clover r4359


    Metzger für angewandte Mettologie

  • Werd ich mir mal anschauen ...

    ist aber erst mal zweitrangig.

    da die kiste im Büro an 2 Monitoren hängen soll ( lieber 3 wenn es möglich ist VGA auch zu nutzen) hab ich jetzt das Problem das nur am DP poart per Adapter HDMI Funktioniert. der HDMI Ausgang am Notebook selber lässt sich nicht nutzen.

    kann es sein das der HDMI zur Geforce gehört und somit nicht nutzbar ist ? das wäre schade ...

    Hackintosh System : Intel i5 3570 - MSI H61M-P20 -AMD HD5570 - 16 GB DDR 3 1600 - High Sierra - Clover Bootloader

    Hackbook Work : XMG A705 3AF - Intel i7 4720HQ - Geforce GTX960M + HD4600 ( GTX Deaktiviert in MacOS ) - 16 GB Ram - Clover Booatloader

  • Und was war jetzt die Lösung um alle drei Monitore in Betrieb zu nehmen, hier wäre eine Rückmeldung doch sehr interessant für die Community?

    iMac16,2 (Late 2015): GA Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.11.6 - Ozmosis + Clover r4509
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.13.3 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.3 - Ozmosis + Clover r4359


    Metzger für angewandte Mettologie

  • Lösung ist noch nicht final wie ich heute morgen feststellen dürfte.

    Könnte aber auch am Notebook selber liegen...

    Ein Monitor hängt per DP und einer Per HDMI Dran. Durch eine Plattform ID Änderung bekam ich dann auch den HDMI Port zum laufen (Screenshot für Plattform folgt)

    Allerdings hatte ich heute morgen das NB eingeschaltet er zeigte mir Clover nur auf den TFTs an und den boot nicht auf dem Notebook ( was gestern aber beim Neustart ging) und ist dann kurze zeit Später einfach neugestartet nach dem Boot wenn er die Grafik Einheit lädt vermutlich( er bootet wie immer Dreiviertel , wird kurz schwarz , logo kommt wieder und er bootet fertig).

    In der Ganzen zeit war aber das Interne Display Schwarz, musste beide Monitore Abstecken und dann nochmal starten und konnte dann als der boot durch war am internen display erst die Displays wieder anstecken .. find ich ein wenig doof die Lösung aber naja vllt hat dafür ja noch jemand die endlösung :D


    Dann bleiben nur noch offen : Helligkeit - Standby - Ruhezustand offen. Rest läuft ja einwandfrei:)