DELL Latitude E7240 - das vielleicht bessere Low Budget MacBookAir6,2 ?


  • Quelle: Dell


    Hallo Community,


    in diesem Thread geht es um das DELL Latitude E7240 - das vielleicht bessere Low Budget MacBookAir6,2 - und ist ein Gemeinschaftsprojekt von Dentai   umax1980 und derHackfan


    was ist drin

    • Intel Core i5 4300u
    • Intel HD 4400
    • Intel Wireless und Bluetooth

    was geht

    • Batterie (Anzeige)
    • Bluetooth
    • Display (Helligkeit)
    • HDMI
    • Kamera
    • mDP
    • SD Card Reader
    • Sleep
    • Sound
    • USB 2.0
    • USB 3.0

    was nicht geht

    • Intel Wireless 7260 (muss getauscht werden)
    • Dentai Atheros AR9485
    • derHackfan Atheros AR9285
    • Umax1980

    was kostet der Spaß

    • 114,90€ bis 164,90€ (inklusive Versand)

    wie das Upgrade machen




    -> Clover Dell Latitude Theme im Anhang <-


    - in Arbeit -


    Gruß derHackfan

    Files

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.5 - OpenCore-v0.0.2
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

    Edited 11 times, last by Dentai: Update eingefügt ().

  • - Platzhalter -

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.5 - OpenCore-v0.0.2
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

  • - Platzhalter -

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.5 - OpenCore-v0.0.2
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

  • derHackfan

    Added the Label In Arbeit
  • Hat sich mittlerweile etwas bei den Card Readern getan. Oder ist das noch eine der älteren Generationen, die weniger Zickig bzw. anders angebunden waren?


    Bei meinem 7270 mag der noch nicht.

    iMac 13,2
    i5 3750K :: Gigabyte GA-Z77-DS3H Rev. 1.0 :: PowerColor RedDevil RX480 8 GB :: 32 GB Ram DDR 3 :: SanDisk 240 GB :: macOS 10.12.6 Sierra @ Clover r4392 :: Samsung 750 EVO 250 GB :: Windows 10 Pro
    MacBook Pro 13,1 - Latitude E7270 :: 12,5" FullHD IPS Touch Display
    i5-6300U :: Intel HD520 :: 8 GB RAM :: DW1560 :: macOS 10.13.4 @ Clover r4411 - Not Working :: Brightness before Sleep :: Cardreader
    MacBook Pro 8,1 - Lenovo G500
    i3-3110M :: Intel HD4000 :: 8 GB RAM :: Atheros AR5B195 :: Crucial M4 128 GB :: macOS 10.13.4 @ Clover r4411 - Not Working :: Cardreader

    MacBook Pro 8,1
    - 13" Anfang 2011

    MacBook Air 7,2 - 13" Anfang 2015


  • Nabend,


    das ist eine Nette alternative zu einem Thinkpad :) Danke für die Infos!


    Grüße,

    alex

    Mit freundlichen Grüßen,

    alex


    unx.png


    CustoMac [iMac19,1] - macOS 10.14.5 (18F132)
    Mainboard: Asus Prime B360M-A | BIOS: 2401
    Prozessor: i5 8600 - 3,1 GHz
    Grafikkarte: MSI Radeon RX 580 Armor 8GB OC
    RAM: 16GB G.Skill Aegis DDR4-3000Mhz
    WiFi + BT: BCM943602CS
    Bootloader: Clover Nightly
                                         Real Mac
    MacBook Pro 15" Late 2015 | macOS 10.14.4
    MacBook Pro 13" Late 2014 | macOS 10.14.4
    MacBook Pro 13" Late 2011 | macOS 10.12.6

    iDevice - iOS 12.3

    iPhone 8+ | iPad Pro 11" 2.Gen
  • burzlbaum verbaut ist ein Broadcom 5880 und der funktioniert ab dem Power Button.


    Un!x Danke für die Rückmeldung.

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.5 - OpenCore-v0.0.2
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

    Edited 2 times, last by derHackfan: @User ergänzt ().

  • Mittlerweile habe ich auch angefangen mein E7240 zu bearbeiten. Aktuell hänge ich bei dem Problem, dass meine nachträglich verbaute Atheros AR9485 mittlerweile irgendwie läuft aber leider nicht richtig.


    Aktuell sitze ich auf macOS 10.13.6 und habe mit folgender Anleitung die Wifi Funktion zum laufen gebracht


    https://osxlatitude.com/forums…485ar9565-wireless-cards/


    Leider kommt es zu folgenden Problemen

    1: Bluetooth findet keine Geräte und man wird nicht gefunden

    2: Der Wlan Durchsatz ist mit max 670kb doch etwas gering.


    Leider habe ich aktuell noch keine Infos bezüglich dieser Probleme bei der Karte gefunden. Was mir allerdings auffällt, ist das Signal von -113dBm was ja Quasi schein tot ist.

  • Hat das E7240 eigentlich kein eigenes WLAN-Modul so wie das E6X30?

    BT läuft auf dem E6330 mit dem Dell verbauten BT top und in Kombi mit der BCM943224HMS gibt es auch keinerlei Probleme im WLAN.

    Grüße und Good Hack Michael


    :hackintosh:

  • Display (Helligkeit)

    Grundsätzlich ist die Funktion vorhanden, nur leider mit der falschen Tastaturbelegung, anstatt über Fn + rauf/runter muss man Fn + Insert/F3 drücken, der anonymous writer hat sich aber angeboten hier zu helfen. :thumbup:

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.5 - OpenCore-v0.0.2
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

  • Ich nutze den 7240 schon eine Zeit... Bin soweit auch zufrieden :)

    Zum Thema Tastenbelegung der Helligkeit hatte ich hier schon mal ein Thema. Problem wurde gelöst und die Helligkeit lies sich über FN Pfeil oben/unten ändern.

    Helligkeit mit FN Tasten möglich?


    Was bei mir noch geht ist die Kamera. Das steht obenr unter -Was geht- nicht.


    Ich hatte es nun schon ein paar mal das der Akku im Standby komplett leer wurde bis er im Standby komplett aus gegangen ist.

    Danach lies sich er sich nicht mehr booten und musste neu aufgesetzt werden.

    Und die Akkulaufzeit könnte etwas besser sein. Unter Windoof hielt er länger durch ^^

    ASRock B85m ITX - i3 4330 - HD4600 - 8GB Ram - SSD - 10.14 - Clover non UEFI
    Dell E6540 - i5 4310M - HD 4600 - 16GB Ram - BCM4352 - SSD - 10.13 - Clover UEFI
    Dell E7440/7240 - i5 4200U - HD 4400 - 8GB Ram - BCM4352 - SSD - 10.14 - Clover UEFI
    Intel Nuc BOXD54250WYKH2 - i5-4250U - HD5000 - 8GB Ram - BCM4352 - SSD OSX - Lüfterlos - 10.14 - Clover UEFI

    Edited once, last by Peter_Pan ().

  • und die Helligkeit lies sich über FN Pfeil oben/unten ändern.

    Über die DSDT aus dem Anhang? Genau die bewirkt bei mir nüscht und gar nichts, vielleicht magst du das ganze mal ein wenig erläutern?

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.5 - OpenCore-v0.0.2
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

  • Ich kann da nicht wirklich viel zu sagen.

    Das müsste die DSDT gewesen sein Helligkeit mit FN Tasten möglich?

    Den EFI Ordner hatte ich damals aus dem Netz am Anfang der Einrichtung und anonymous writer hatte mir die DSDT zusätzlich gepatcht.

    Falls es im Post oben unter gegangen ist. Meine Kamera funktioniert auch.


    Soll ich vielleicht mal meinen ganzen EFI Ordner hochladen?

    ASRock B85m ITX - i3 4330 - HD4600 - 8GB Ram - SSD - 10.14 - Clover non UEFI
    Dell E6540 - i5 4310M - HD 4600 - 16GB Ram - BCM4352 - SSD - 10.13 - Clover UEFI
    Dell E7440/7240 - i5 4200U - HD 4400 - 8GB Ram - BCM4352 - SSD - 10.14 - Clover UEFI
    Intel Nuc BOXD54250WYKH2 - i5-4250U - HD5000 - 8GB Ram - BCM4352 - SSD OSX - Lüfterlos - 10.14 - Clover UEFI

  • Soll ich vielleicht mal meinen ganzen EFI Ordner hochladen?

    Wenn du der Meinung bist dass der EFI Ordner besser ist als die Spende von dem unbekannten Holländer dann kannst du das gerne machen, ich behaupte mal da stimmt fast alles und die Helligkeitssteuerung ist eher ein Flüchtigkeitsfehler. :)

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.5 - OpenCore-v0.0.2
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

  • Der Meinung das der EFI Ordner den ich benutze besser ist bin ich sicherlich nicht.X/ Dafür habe ich dann doch zu wenig Ahnung.

    Ist nur ein Angebot da ich dir nicht sagen kann was genau bei mir anders ist :) Kann ihn dir auch per PN schicken

    ASRock B85m ITX - i3 4330 - HD4600 - 8GB Ram - SSD - 10.14 - Clover non UEFI
    Dell E6540 - i5 4310M - HD 4600 - 16GB Ram - BCM4352 - SSD - 10.13 - Clover UEFI
    Dell E7440/7240 - i5 4200U - HD 4400 - 8GB Ram - BCM4352 - SSD - 10.14 - Clover UEFI
    Intel Nuc BOXD54250WYKH2 - i5-4250U - HD5000 - 8GB Ram - BCM4352 - SSD OSX - Lüfterlos - 10.14 - Clover UEFI

  • Ach was immer her damit, im Grunde ist es so dass ich völlig überrascht wurde mit diesem Weihnachtsgeschenk von einem unbekannten Spender, jedes Murmeltier hätte dafür Geld genommen und insofern freue ich mich um so mehr über dieses Community Sharing.

    Werf den Schuh mal ins Getriebe... :thumbup:

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.5 - OpenCore-v0.0.2
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

  • :P Hier ist der EFI Ordner

    Files

    • EFI.zip

      (5.06 MB, downloaded 35 times, last: )

    ASRock B85m ITX - i3 4330 - HD4600 - 8GB Ram - SSD - 10.14 - Clover non UEFI
    Dell E6540 - i5 4310M - HD 4600 - 16GB Ram - BCM4352 - SSD - 10.13 - Clover UEFI
    Dell E7440/7240 - i5 4200U - HD 4400 - 8GB Ram - BCM4352 - SSD - 10.14 - Clover UEFI
    Intel Nuc BOXD54250WYKH2 - i5-4250U - HD5000 - 8GB Ram - BCM4352 - SSD OSX - Lüfterlos - 10.14 - Clover UEFI

  • Vielen Dank, du bekommst auf jeden Fall eine Rückmeldung! :)

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.5 - OpenCore-v0.0.2
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

  • Hallo derHackfan

    ich kenne denn EFI vom Holländer nicht, aber mein E6330 und dieser Laptop sind in vielen sehr ähnlich. Vor allem was die DSDT angeht.

    Kann dir berichten das auch bei meinem E6330 alles läuft wie auf einem echten Mac ohne irgendeine Einschränkung inklusive den FN-Tasten.

    Somit ist der auch ein Anwärter auf den Titel "DAS VIELLEICHT BESSERE LOW BUDGET MacBookPro10,1" :)


    Jedenfalls enthält die DSDT.aml aus Post #16 genau die gleichen Patches für die FN-Tasten wie mein E6330. :thumbup:



    Grüße und Good Hack Michael


    :hackintosh:

  • der Akku im Standby komplett leer wurde bis er im Standby komplett aus gegangen ist.

    Danach lies sich er sich nicht mehr booten und musste neu aufgesetzt werden.

    Hatte das auch mal bei einem Hackbook. Aber statt neuaufsetzen hat es auch gereicht mit meinem „rescue Stick“ (installationsstick mit Clover) clover zu starten und dann einmal damit ins System zu booten. Danach ging das Clover auf der ssd auch wieder... fand ich seltsam aber wie ich das gerade lese passiert das wohl öfter bei kompletter Entladung im Standby

    iMac 13,2
    i5 3750K :: Gigabyte GA-Z77-DS3H Rev. 1.0 :: PowerColor RedDevil RX480 8 GB :: 32 GB Ram DDR 3 :: SanDisk 240 GB :: macOS 10.12.6 Sierra @ Clover r4392 :: Samsung 750 EVO 250 GB :: Windows 10 Pro
    MacBook Pro 13,1 - Latitude E7270 :: 12,5" FullHD IPS Touch Display
    i5-6300U :: Intel HD520 :: 8 GB RAM :: DW1560 :: macOS 10.13.4 @ Clover r4411 - Not Working :: Brightness before Sleep :: Cardreader
    MacBook Pro 8,1 - Lenovo G500
    i3-3110M :: Intel HD4000 :: 8 GB RAM :: Atheros AR5B195 :: Crucial M4 128 GB :: macOS 10.13.4 @ Clover r4411 - Not Working :: Cardreader

    MacBook Pro 8,1
    - 13" Anfang 2011

    MacBook Air 7,2 - 13" Anfang 2015


  • Jedenfalls enthält die DSDT.aml aus Post #16 genau die gleichen Patches für die FN-Tasten wie mein E6330. :thumbup:

    Seite nicht gefunden. :(

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.5 - OpenCore-v0.0.2
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie