Nvidia GTX 980M auf Lenovo Hackbook - Nvidia Treiber

  • Hallo Forum - ich wollte mal fragen, ob das überhaupt geht:

    Kann man auf einem Hackbook 13.1 mit Nvidiakarte einen Treiber installieren? Mein Leonovo-Hackbook konnte HS installieren. Aber der Bildschirm flackert. Da braucht es doch einen Treiber oder eine alternative Lösung. Wisst ihr da Bescheid? Danke für kurzen Tipp.

    Projekte
    -------------------------------------------------------

    MacBookPro 13,1, High Sierra: in Bearbeitung...Lenovo IdeaPad Y900-17ISK - 17.3" (Model 80Q1) | CPU: Intel Core i7 (6th Gen) 6820HK / 2.7 GHz, 1 processor - 4 cores - 8 threads, Skylake | Graphics Processor: NVIDIA GeForce GTX 980M - 8 GB | CONNECTIONS: 3 x USB 3.0, USB-C, USB 2.0, HDMI, DisplayPort | Motherboard: Lenovo Ares |

  • Hallo biobios,


    der offentsichtlichste Weg ist wohl der Nvidia Webdriver, hast du den schon versucht?

    Rechenknecht: i5-3570k # GA-z77n-wifi # GTX960 4GB # 8GB # Broadcom BCM94322 Wlan # Sierra 10.12.6 # Clover4586
    Lenovo X230: i5-3220 # HD4000 # 8GB # Sierra 10.12.6 #Foktech AC Wlanstick# Clover4586
    Videoknecht: i5-4690 # GA-z97n-wifi # Gigabyte R280X# 16GB # Atheros 9285 Combo # Sierra 10.13.6 #Clover4586

  • bioBios kannst du bitte mal im BIOS schauen ob es da Einträge bezüglich Nvidia Optimus und oder eine Auswahl bei der bevorzugten Grafiklösung (priorität) gibt?

    iMac16,2 (Late 2015): GA Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.11.6 - Ozmosis + Clover r4509
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.13.3 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.3 - Ozmosis + Clover r4359


    Metzger für angewandte Mettologie

  • bioBios Bei einigen Lenovo Notebooks lässt sich im BIOS wählen ob Optimus auf enabled/disabled steht und ob man die Intel Grafik oder die Nvidia Grafik verwenden möchte, daher kann es gut sein dass andere Hersteller (z.B. Dell) das BIOS auch so großzügig gestaltet haben.

    Man kann natürlich blind drauf los installieren aber ein Blick ins BIOS im Vorfeld könnte schon hilfreich sein.

    iMac16,2 (Late 2015): GA Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.11.6 - Ozmosis + Clover r4509
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.13.3 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.3 - Ozmosis + Clover r4359


    Metzger für angewandte Mettologie

  • Nvidia-Treiber habe ich schon installiert - nichts mit dem clover configurator vorher gemacht. Einfach Treiber installiert und Neustart. Leider blieb dann das System beim Boot hängen. Durch nv_disable=1 (glaube ich wenigstens...) im clover konnte ich wieder starten und Treiber deinstallieren.


    Frage: muss ich im Clover Configurator vorher etwas ändern?

    Bios: Man kann nicht viel ändern. Hier sind die Bilder vom Setup.

    Projekte
    -------------------------------------------------------

    MacBookPro 13,1, High Sierra: in Bearbeitung...Lenovo IdeaPad Y900-17ISK - 17.3" (Model 80Q1) | CPU: Intel Core i7 (6th Gen) 6820HK / 2.7 GHz, 1 processor - 4 cores - 8 threads, Skylake | Graphics Processor: NVIDIA GeForce GTX 980M - 8 GB | CONNECTIONS: 3 x USB 3.0, USB-C, USB 2.0, HDMI, DisplayPort | Motherboard: Lenovo Ares |

  • Welcher Status herrscht denn?

    Wenn du im Clover Auswahl Menü bist und unter Optionen/Graphics guckst, welche Grafik gibt den Ton an bzw. welche Grafik steht zur Verfügung, Intel oder Nvidia oder kannst du beide sehen?

    Daraus lassen sich Rückschlüsse bezüglich Optimus ziehen und gezielter vorgehen. :)

    iMac16,2 (Late 2015): GA Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.11.6 - Ozmosis + Clover r4509
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.13.3 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.3 - Ozmosis + Clover r4359


    Metzger für angewandte Mettologie

  • ... danke. Ich poste mal den Screen.

    Bilder

    Projekte
    -------------------------------------------------------

    MacBookPro 13,1, High Sierra: in Bearbeitung...Lenovo IdeaPad Y900-17ISK - 17.3" (Model 80Q1) | CPU: Intel Core i7 (6th Gen) 6820HK / 2.7 GHz, 1 processor - 4 cores - 8 threads, Skylake | Graphics Processor: NVIDIA GeForce GTX 980M - 8 GB | CONNECTIONS: 3 x USB 3.0, USB-C, USB 2.0, HDMI, DisplayPort | Motherboard: Lenovo Ares |

  • Nach dem Screenshot und meinen Erfahrungen sage ich mal die Nvidia Optimums Funktion ist im BIOS (auch wenn da keine Einstellung ist im BIOS) auf disabled gesetzt, ansonsten wäre die Intel im Screenshot zu sehen.

    Mann könnte jetzt in Linux oder Windows das überprüfen... :)

    iMac16,2 (Late 2015): GA Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.11.6 - Ozmosis + Clover r4509
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.13.3 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.3 - Ozmosis + Clover r4359


    Metzger für angewandte Mettologie

  • ... ist das jetzt ein gutes Zeichen? Ich habe einen Live-Linux-USB-Stick. Was müsste ich unter Linux-Ubuntu tun?

    Habe das mit Ubuntu rausgefiltert (Anhang). Hilft das?

    Bilder

    Projekte
    -------------------------------------------------------

    MacBookPro 13,1, High Sierra: in Bearbeitung...Lenovo IdeaPad Y900-17ISK - 17.3" (Model 80Q1) | CPU: Intel Core i7 (6th Gen) 6820HK / 2.7 GHz, 1 processor - 4 cores - 8 threads, Skylake | Graphics Processor: NVIDIA GeForce GTX 980M - 8 GB | CONNECTIONS: 3 x USB 3.0, USB-C, USB 2.0, HDMI, DisplayPort | Motherboard: Lenovo Ares |

    Einmal editiert, zuletzt von bioBios ()

  • bioBios Nein, versuch mal hwinfo --short im Terminal.

    iMac16,2 (Late 2015): GA Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.11.6 - Ozmosis + Clover r4509
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.13.3 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.3 - Ozmosis + Clover r4359


    Metzger für angewandte Mettologie

  • Ist in dem Laptop denn nun ein "Xeon E3 1220 der 5. Generation" oder wie in deinem Profil zu sehen die 6820HK verbaut?

    Kabylake Laptop: Dell Vostro 5370, i5-8250U, UHD 620
    Dell T20: Intel Xeon E3-1225 v3, MSI GeForce GT 710 2GD3H LP

  • ... hwinfo habe ich leider nicht. Wenn ich's versuche zu laden kommt Meldung "unable to locate package hwinfo".

    Ich habe noch folgende Infos über das System (Anhang)

    Dateien

    • USB.txt

      (551 Byte, 4 Mal heruntergeladen, zuletzt: )
    • codec10_dump.txt

      (3,75 kB, 5 Mal heruntergeladen, zuletzt: )
    • PCI.txt

      (2,86 kB, 14 Mal heruntergeladen, zuletzt: )
    • codec00_dump.txt

      (11,21 kB, 4 Mal heruntergeladen, zuletzt: )

    Projekte
    -------------------------------------------------------

    MacBookPro 13,1, High Sierra: in Bearbeitung...Lenovo IdeaPad Y900-17ISK - 17.3" (Model 80Q1) | CPU: Intel Core i7 (6th Gen) 6820HK / 2.7 GHz, 1 processor - 4 cores - 8 threads, Skylake | Graphics Processor: NVIDIA GeForce GTX 980M - 8 GB | CONNECTIONS: 3 x USB 3.0, USB-C, USB 2.0, HDMI, DisplayPort | Motherboard: Lenovo Ares |

  • bioBios Lass uns das Pferd mal anders aufziehen. :)

    Bei meinem Hackbook mit Nvidia Optimus Verbund schaut es wie auf dem Screenshot aus,




    es stehen beide Grafiklösungen zur Verfügung und Clover ist so schlau und erkennt das auch, das heißt im BIOS ist der Nvda_Optm. Verbund auf enabled gesetzt (ich habe dazu aber keine Optionen im BIOS).
    In deinem Fall ist es so dass die Intel HD Grafik gar nicht zur Verfügung steht und demnach der Nvda_Optm. Verbund auf disabled gesetzt ist (du hast dazu auch keine Optionen im Bios).


    Meiner Meinung nach kann es dann nur über die Nvidia GTX 980m (Maxwell Chip) und dem Nvidia WebDriver und dem passenden SMBIOS und oder zusätzlichen Kexten auf dem Desktop zu einer QE/Hardwarebeschleunigung kommen.


    Es liegt an dir das ganze mit viel Geduld und Ausdauer herauszufinden. :)

    iMac16,2 (Late 2015): GA Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.11.6 - Ozmosis + Clover r4509
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.13.3 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.3 - Ozmosis + Clover r4359


    Metzger für angewandte Mettologie

  • ... hm. d.h. konkret. Ich versuche mal MacBook 13,2 / 13,3 / 12,xy /usw. Keine Änderung bei Kext-Files. Und wenn's nicht geht, dann mit anderen Kext-Files versuchen. Welche? Sind die OsxAptioFixDrv-64.efi usw. unsere Kandidaten?


    oder könnte ev. diese Lösung mit dem "Cuda" Treiber etwas bringen.

    Projekte
    -------------------------------------------------------

    MacBookPro 13,1, High Sierra: in Bearbeitung...Lenovo IdeaPad Y900-17ISK - 17.3" (Model 80Q1) | CPU: Intel Core i7 (6th Gen) 6820HK / 2.7 GHz, 1 processor - 4 cores - 8 threads, Skylake | Graphics Processor: NVIDIA GeForce GTX 980M - 8 GB | CONNECTIONS: 3 x USB 3.0, USB-C, USB 2.0, HDMI, DisplayPort | Motherboard: Lenovo Ares |

  • ... also mit CUDA ist wohl nix. Geht nicht. SMBIOS auf 13,1 gestellt. Hat jemand eine Idee?

    Projekte
    -------------------------------------------------------

    MacBookPro 13,1, High Sierra: in Bearbeitung...Lenovo IdeaPad Y900-17ISK - 17.3" (Model 80Q1) | CPU: Intel Core i7 (6th Gen) 6820HK / 2.7 GHz, 1 processor - 4 cores - 8 threads, Skylake | Graphics Processor: NVIDIA GeForce GTX 980M - 8 GB | CONNECTIONS: 3 x USB 3.0, USB-C, USB 2.0, HDMI, DisplayPort | Motherboard: Lenovo Ares |

  • Versuch es mal mit einem iMac13,2 oder 14,2 SMBIOS und berichte bitte. :)

    iMac16,2 (Late 2015): GA Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.11.6 - Ozmosis + Clover r4509
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.13.3 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.3 - Ozmosis + Clover r4359


    Metzger für angewandte Mettologie

  • Danke vielmals- hier meine Ergebnisse:

    1. 13,2 - 13,3 und 14,2 starten ohne Nvidia-Treiber (deaktiviert)
    2. Kein vollständiger Boot. Mit aktiviertem Nvidia-Treiber sind folgende Fehlermeldungen beim Boot aufgetaucht (Anhang)
    3. habe noch mein EFI.zip mitgeliefert

    Bilder

    Dateien

    • EFI.zip

      (23,48 MB, 6 Mal heruntergeladen, zuletzt: )

    Projekte
    -------------------------------------------------------

    MacBookPro 13,1, High Sierra: in Bearbeitung...Lenovo IdeaPad Y900-17ISK - 17.3" (Model 80Q1) | CPU: Intel Core i7 (6th Gen) 6820HK / 2.7 GHz, 1 processor - 4 cores - 8 threads, Skylake | Graphics Processor: NVIDIA GeForce GTX 980M - 8 GB | CONNECTIONS: 3 x USB 3.0, USB-C, USB 2.0, HDMI, DisplayPort | Motherboard: Lenovo Ares |

  • Dann scheint das SMBIOS zu passen und vielleicht hilft hier jetzt das WhateverGreen.kext und oder noch weitere SMBIOS Versionen, da wüsste ich jetzt nur noch iMac 17,1 oder so, kann aber auch sein dass es dennoch nicht geht bei deinem Notebook.

    Versuch macht klug... :)

    iMac16,2 (Late 2015): GA Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.11.6 - Ozmosis + Clover r4509
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.13.3 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.3 - Ozmosis + Clover r4359


    Metzger für angewandte Mettologie