ThinkPad x121e, wie ans Laufen bekommen?

  • Hallo miteinander! Momentan versuche ich mein x121e (i3-2367M, Intel HD3000, 6GB 1333er Speicher und SSD) mit Sierra bzw. High Sierra auszustatten, was sich (für mich) allerdings deutlich schwieriger gestaltet als gedacht.


    Ich schaffe es nicht mal zum Installationsbildschirm (meist fliege ich wegen unsupported CPU/ unsupported PCH raus, den durchgestrichenen Kreis durfte ich auch schon einige Male begutachten, ebenso ACPI Errors, die durchfüttern und dann den Kreis erzeugen), daher würde ich mich über Hilfe sehr freuen.


    Die DSDT habe ich per Clover (F4) gesichert, wobei mein Latein da auch schon zu Ende ist. Mir ist nicht mal klar, ob die Config.plist passt. Hier sind ja einige Experten unterwegs (nochmal vor allem herzlichen Dank grt , ohne Dich würde heute wohl nicht mal das T430 laufen). Vielleicht könnt ihr mir ja unter die Arme greifen, das EFI, mit dem ich aktuell herumspiele, hänge ich an.


    Was mir gerade noch einfaellt: Aktuell ist Clover im Legacy Modus auf dem Stick installiert (allerdings in der ESP), da ich im Internet gelesen habe, dass ein UEFI Boot mit dem Book wohl nicht möglich ist, probiert hab ichs aber auch damit schon (klappte nicht). Grüße und Danke im Voraus!

    Dateien

    • EFI.zip

      (2,19 MB, 8 Mal heruntergeladen, zuletzt: )

    MacBookPro9,2: ThinkPad T430 (i5 @ 2,6GHz, HD4000, 4GB RAM, 128GB SSD)


    MacPro5,1: i7-920, ASUS RIIE, 12GB RAM, HD7750 2GB, 120GB SSD &1 TB HDD


    - - -: ThinkPad x121e (i3 @ 1,4GHz, HD3000, 6GB 1066MHz RAM, 500GB SSD)

    Einmal editiert, zuletzt von siegertyp () aus folgendem Grund: Gerätebeschreibung ausgeführt

  • noch mal nachgehakt.. das ist die version mit dem i3-2357M oder i3-2367M und der intelHD3000?

    was sagt das bios zu uefi? gibts da wie beim T430 die einstellung UEFI only ... first und so, oder fehlen die?

    eigentlich sollte das kleine ding ja ein schwestermodell des X220 sein, nur noch kleiner.

    heute wird nix mehr, nachher ist stammtisch. aber ich guck mir das mal an. sollte ja eigentlich nicht grossartig anders, als das X220 zum laufen zu kriegen sein.

    versuch mal für den anfang ganz abgespeckt zu starten. fakesmc sensoren raus, nur die nackte fakesmc selbst, einen voodoops2.kext, intelmausiethernet.kext (oder den intelE1000e) und damit die cpu nicht rumbockt noch eine nullcpupowermanagement.kext mit dazu.

    ich häng mal eine config.plist mit dran. deine war nicht sooo hübsch, fand ich.

    wenn du so in den installer und vielleicht ja sogar durch die installation kommst, wird noch nicht viel funktionieren - sound batterie etc, aber das kommt dann mit der dsdt.

    Dateien

    thinkpad T440s: i5-4210U, intelHD4400, 8gbRam, 10.14/clover

    thinkpad W520: i7-2720qm, nVidiaQuadro1000m/intelHD3000, 16gbRam, 10.11.6/clover
    thinkpad X220: i5-2520m, intelHD3000, 16gbRam, 10.12.6/clover
    temporär: T520: i5-2520m, HD3000, 6gb, systemvorkoster


    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD
    nächster Termin: voraussichtlich MITTWOCH der 19.12.2018, 19.00 Uhr

  • Hey grt, toll, dass du vorbei schaust! Erstmal zu den offenen Fragen (ergänze ich oben gleich auch noch): Beim Prozessor handelt es sich um den i3-2367M und korrekt, die Grafikkarte ist die (iGPU) HD3000 und im BIOS kann ich zwischen "Both", "UEFI only" und "Legacy only" wählen, bei gewähltem "Both" dazu noch Legacy oder UEFI first (momentan Both eingestellt, mit dem UEFI Clover liess ich UEFI only stehen).


    Die angehaengte config.plist in Kombination mit aufgeräumten Kexten (dafür mit NullCPUPowerManagement und IntelMausiEthernet) laeuft zügig in ACPI Errors, die dann wieder für den durchgestrichen Kreis (auf grafisch fehlerhaftem Log) sorgen. Letzte lesbare Zeile:

    "ACPI Error: Method parse/execution failed [\PNOT] (Node ffffff8031c87c00), AE_NOT_FOUND (20160930/psparse-632)"


    Euch in jedem Fall viel Spass beim Stammtisch, finde ich wirklich klasse!

    MacBookPro9,2: ThinkPad T430 (i5 @ 2,6GHz, HD4000, 4GB RAM, 128GB SSD)


    MacPro5,1: i7-920, ASUS RIIE, 12GB RAM, HD7750 2GB, 120GB SSD &1 TB HDD


    - - -: ThinkPad x121e (i3 @ 1,4GHz, HD3000, 6GB 1066MHz RAM, 500GB SSD)

  • da könnte der kontakt zum stick verlorengegangen sein... usb3 oder 2 stick und anschluss? nimm mal einen usb2. und setz in der config.plist mal den haken bei drop all oemssdt oder so ähnlich. kannst du auch beim boot in den options -> acpi -> drop tables machen.

    und uefi kann der kleine also. dann stell mal auf uefi only oder both und dabei dann uefi first, und installier den clover auch als uefi auf den stick.

    ich strick dir dann die tage eine dsdt.

    thinkpad T440s: i5-4210U, intelHD4400, 8gbRam, 10.14/clover

    thinkpad W520: i7-2720qm, nVidiaQuadro1000m/intelHD3000, 16gbRam, 10.11.6/clover
    thinkpad X220: i5-2520m, intelHD3000, 16gbRam, 10.12.6/clover
    temporär: T520: i5-2520m, HD3000, 6gb, systemvorkoster


    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD
    nächster Termin: voraussichtlich MITTWOCH der 19.12.2018, 19.00 Uhr

  • Den Lösungsansatz mit UEFI Clover in der ESP und UEFI only habe ich gerade getestet, ging aber leider nicht. Die oem ACPI Tabes zu droppen probiere ich gleich mal.

    MacBookPro9,2: ThinkPad T430 (i5 @ 2,6GHz, HD4000, 4GB RAM, 128GB SSD)


    MacPro5,1: i7-920, ASUS RIIE, 12GB RAM, HD7750 2GB, 120GB SSD &1 TB HDD


    - - -: ThinkPad x121e (i3 @ 1,4GHz, HD3000, 6GB 1066MHz RAM, 500GB SSD)

  • und uefi first? damit hatte der X220 keine probleme.

    thinkpad T440s: i5-4210U, intelHD4400, 8gbRam, 10.14/clover

    thinkpad W520: i7-2720qm, nVidiaQuadro1000m/intelHD3000, 16gbRam, 10.11.6/clover
    thinkpad X220: i5-2520m, intelHD3000, 16gbRam, 10.12.6/clover
    temporär: T520: i5-2520m, HD3000, 6gb, systemvorkoster


    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD
    nächster Termin: voraussichtlich MITTWOCH der 19.12.2018, 19.00 Uhr

  • Meinte, dass es in exakt dem gleichen Fehler endete, ebenso mit gestoppten OEM tables. Hm, speilt leider keine Rolle, ob UEFI only oder UEFI first, das Ergebnis ist das gleiche.


    Zum Stick noch: Ist ein USB2 Stick, der, wenn mich nicht alles täuscht, auch am USB2 Port hängt.

    MacBookPro9,2: ThinkPad T430 (i5 @ 2,6GHz, HD4000, 4GB RAM, 128GB SSD)


    MacPro5,1: i7-920, ASUS RIIE, 12GB RAM, HD7750 2GB, 120GB SSD &1 TB HDD


    - - -: ThinkPad x121e (i3 @ 1,4GHz, HD3000, 6GB 1066MHz RAM, 500GB SSD)

  • ok. evtl. brauchts eine fakeid für den prozzi.

    und wenn der dringend legacy will, dann lass ihm den erstmal.

    wie siehts mit den bioseinstellungen aus? kannst dich an denen vom T430 orientieren.

    thinkpad T440s: i5-4210U, intelHD4400, 8gbRam, 10.14/clover

    thinkpad W520: i7-2720qm, nVidiaQuadro1000m/intelHD3000, 16gbRam, 10.11.6/clover
    thinkpad X220: i5-2520m, intelHD3000, 16gbRam, 10.12.6/clover
    temporär: T520: i5-2520m, HD3000, 6gb, systemvorkoster


    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD
    nächster Termin: voraussichtlich MITTWOCH der 19.12.2018, 19.00 Uhr

  • Ob er tatsächlich nur Legacy mag, weiss ich nicht mal, hab das nur irgendwo aufgegriffen. Kann ich eine Fake ID in die config.plist setzen, oder benötige ich dafür zusätzlich etwas?


    Die BIOS Einstellungen sollten sonst auch passen. Die WLAN Karte habe ich abgeschaltet, ebenso WWAN, sonst ist alles aktiviert. VT-d ist abgeschaltet (ebenso die andere Virtualisierungstechnik, Namen vergessen). Memory Protection (oder so ähnlich) ist aktiviert. Die Bootreihenfolge passt auch, wobei ich meist über das Bootmenue manuell wähle. Die SSD laeuft auch im AHCI Modus, sonst fällt mir nichts ein, was beachtet werden muesste.

    MacBookPro9,2: ThinkPad T430 (i5 @ 2,6GHz, HD4000, 4GB RAM, 128GB SSD)


    MacPro5,1: i7-920, ASUS RIIE, 12GB RAM, HD7750 2GB, 120GB SSD &1 TB HDD


    - - -: ThinkPad x121e (i3 @ 1,4GHz, HD3000, 6GB 1066MHz RAM, 500GB SSD)

  • vtd darf sein, der tut nicht weh, der rest ist ok.

    config ein wenig modifiziert - mit sandybridge fakecpuid hängt dran.

    Dateien

    thinkpad T440s: i5-4210U, intelHD4400, 8gbRam, 10.14/clover

    thinkpad W520: i7-2720qm, nVidiaQuadro1000m/intelHD3000, 16gbRam, 10.11.6/clover
    thinkpad X220: i5-2520m, intelHD3000, 16gbRam, 10.12.6/clover
    temporär: T520: i5-2520m, HD3000, 6gb, systemvorkoster


    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD
    nächster Termin: voraussichtlich MITTWOCH der 19.12.2018, 19.00 Uhr

  • Verdammt, bist du schnell! die neue config.plist habe ich probiert, aber das endet in einer Kernel Panic. Ein Bild davon habe ich angehängt.

    Bilder

    MacBookPro9,2: ThinkPad T430 (i5 @ 2,6GHz, HD4000, 4GB RAM, 128GB SSD)


    MacPro5,1: i7-920, ASUS RIIE, 12GB RAM, HD7750 2GB, 120GB SSD &1 TB HDD


    - - -: ThinkPad x121e (i3 @ 1,4GHz, HD3000, 6GB 1066MHz RAM, 500GB SSD)

  • mistmistmist... da gab es eine massnahme, mit der man diese elend langen texte so kürzen kann, dass der eigentliche panikgrund erkennbar wird. hab ich aber gerade nicht auf dem schirm.

    du installierst highsierra? hättest du noch einen sierrainstaller da? kannst du den mal mit der efi starten wenn ja?

    thinkpad T440s: i5-4210U, intelHD4400, 8gbRam, 10.14/clover

    thinkpad W520: i7-2720qm, nVidiaQuadro1000m/intelHD3000, 16gbRam, 10.11.6/clover
    thinkpad X220: i5-2520m, intelHD3000, 16gbRam, 10.12.6/clover
    temporär: T520: i5-2520m, HD3000, 6gb, systemvorkoster


    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD
    nächster Termin: voraussichtlich MITTWOCH der 19.12.2018, 19.00 Uhr

  • Ja, momentan probiere ich es mit HighSierra. Habe zwar keinen fertigen Stick (ausser HighSierra) hier, aber die Installer von Sierra und Mojave hier "liegen". Dann erstelle ich mal einen Installationsstick mit Sierra und melde mich mit dem Resultat zurück, dauert leider lange mit USB2.

    MacBookPro9,2: ThinkPad T430 (i5 @ 2,6GHz, HD4000, 4GB RAM, 128GB SSD)


    MacPro5,1: i7-920, ASUS RIIE, 12GB RAM, HD7750 2GB, 120GB SSD &1 TB HDD


    - - -: ThinkPad x121e (i3 @ 1,4GHz, HD3000, 6GB 1066MHz RAM, 500GB SSD)

  • ok. ich guck vom stammtisch aus mal rein.

    thinkpad T440s: i5-4210U, intelHD4400, 8gbRam, 10.14/clover

    thinkpad W520: i7-2720qm, nVidiaQuadro1000m/intelHD3000, 16gbRam, 10.11.6/clover
    thinkpad X220: i5-2520m, intelHD3000, 16gbRam, 10.12.6/clover
    temporär: T520: i5-2520m, HD3000, 6gb, systemvorkoster


    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD
    nächster Termin: voraussichtlich MITTWOCH der 19.12.2018, 19.00 Uhr

  • So, durch den Installer bin ich leider nicht gekommen, steigt wieder recht früh aus. Die letzten zwei Zeilen lauten:

    Waiting for remote debugger connection.

    kdp_poll: no debugger device


    Davor wird die Uptime aufgeführt, ebenso zum Beispiel: "System model name: MacBookPro8,1".


    Im Abschnitt davor wird das Synaptics Touchpad initialisiert(?). Wenn ich wieder am Rechner bin, kann ich ein Bild davon hochladen, hier klappt das leider nicht vom Handy...

    MacBookPro9,2: ThinkPad T430 (i5 @ 2,6GHz, HD4000, 4GB RAM, 128GB SSD)


    MacPro5,1: i7-920, ASUS RIIE, 12GB RAM, HD7750 2GB, 120GB SSD &1 TB HDD


    - - -: ThinkPad x121e (i3 @ 1,4GHz, HD3000, 6GB 1066MHz RAM, 500GB SSD)

  • uptime ist kernelpanik. hättest du ein bildchen davon bitte?

    thinkpad T440s: i5-4210U, intelHD4400, 8gbRam, 10.14/clover

    thinkpad W520: i7-2720qm, nVidiaQuadro1000m/intelHD3000, 16gbRam, 10.11.6/clover
    thinkpad X220: i5-2520m, intelHD3000, 16gbRam, 10.12.6/clover
    temporär: T520: i5-2520m, HD3000, 6gb, systemvorkoster


    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD
    nächster Termin: voraussichtlich MITTWOCH der 19.12.2018, 19.00 Uhr

  • Ein Bild des Screens hänge ich an, hab leider keine Ahnung, wodurch die Panik ausgelöst wurde.

  • ich bin noch nicht am rechner - guck doch mal in die config > kernelpatches oder so. da wo die ganzen Haken mit cpupowermanagement und so sind. da ist ein Haken "Kernelapic" oder so. mach weg, wenn gesetzt, oder setz ihn, wenn er nicht da ist.

    thinkpad T440s: i5-4210U, intelHD4400, 8gbRam, 10.14/clover

    thinkpad W520: i7-2720qm, nVidiaQuadro1000m/intelHD3000, 16gbRam, 10.11.6/clover
    thinkpad X220: i5-2520m, intelHD3000, 16gbRam, 10.12.6/clover
    temporär: T520: i5-2520m, HD3000, 6gb, systemvorkoster


    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD
    nächster Termin: voraussichtlich MITTWOCH der 19.12.2018, 19.00 Uhr

  • Gesagt, getan. Hier das Ergebnis:

  • hmmm... vielleicht tut es eine dsdt...

    und teste mal ältere cloverversionen aus. welche hast du jetzt am start?

    thinkpad T440s: i5-4210U, intelHD4400, 8gbRam, 10.14/clover

    thinkpad W520: i7-2720qm, nVidiaQuadro1000m/intelHD3000, 16gbRam, 10.11.6/clover
    thinkpad X220: i5-2520m, intelHD3000, 16gbRam, 10.12.6/clover
    temporär: T520: i5-2520m, HD3000, 6gb, systemvorkoster


    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD
    nächster Termin: voraussichtlich MITTWOCH der 19.12.2018, 19.00 Uhr