Intel 7,8,9 Chipsatz - Sleep geht nicht (inklusive Lösung)

  • Heyho liebes Forum,

    ich bin jetzt mit meinem Hackintosh seit geraumer Zeit auf Mojave unterwegs und eigentlich läuft das ganze ziehmlich Gut.Er booted sauber durch und dank NoVPAJpeg.kext funktioniert auch die Vorschau wie sie soll.
    Probleme gibts allerdings noch beim Ruhezustand, denn der Rechner reißt sich immer wieder automatisch selbst aus dem Sleep.


    Code
    1. log show --style syslog | fgrep "Wake reason"
    2. 2018-10-14 15:19:37.518856+0200 localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: GLAN EHC2
    3. 2018-10-14 15:19:37.518858+0200 localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: GLAN EHC2

    Lese ich also richtig das es am Ethernet liegt? Wie fixe ich das?

    Zum anderen hatte ich darüber gelesen das man mit dem FB-Patcher wunderbar seine USB-Belegung durchchecken kann um im Nachgang einen Kext dafür auszuwerfen. Allerdings zeigt das Ding bei mir nix an. (USBinjectAll lag in der EFI).


                      


    LG


    PS: Eine aktuelle EFI liegt bei.


    Tut mir leid das sollte eigentlich unter Desktops ...

    Files

    • EFI.zip

      (18.19 MB, downloaded 102 times, last: )

    iHackPro 1.1: Ryzen 5 3600 / Gigabyte A520M H / 16 GB DDR4 / MSI RX 580 ARMOR / 2x BX500 240 GB / 2x Seagate 1TB HDD / 10.15 Catalina / Windows 10


    MacBook Pro 8,1 : Intel Core i7 2620M / 16 GB Ram / 256 GB SSD / TB HDD / 10.13 High Sierra


    GamingPC: Ryzen 7 5800X / Gigabyte x570 Aorus Elite / 32 GB DDR4 / AMD Radeon 6900XT / Scandisk Ultra II 960 GB / Kingston Predator SSD 240GB / Windows 10


    HuaweiMatebook 14: Ryzen 5 4600H / 16 GB DDR4 / 512 GB SSD / Windows 10

    Edited once, last by MiChaRiot ().

  • @Sleep

    Wie sehen denn deine Einstellungen in: Systemsteuerung -> Energie sparen aus?

    Ist dort "Ruhezustand bei Netzwerkzugriff beenden" aktiviert?


    @FBPatcher

    Ich glaube für den FBPatcher muss auch noch der PortLimitPatch aktiv sein, kann mich aber auch irren.

    Aber probieren geht über studieren :D

    Zum Verkauf geplant -> Board: GA-Z97X-UD5H-BK / CPU: i7-4790K / Grafikkarte: R280X / RAM: 16GB DDR3
    CNC Maschine (Apple Power Mac G5): Board: GA-Z77N-WiFi / CPU: i5-3570K / R280X / RAM: 16GB DDR3


    Rechtschreibung, Grammatik, Satzzeichen, Textformatierung und manchmal auch ein Komma führen zu einer besseren Verständlichkeit ;) :D

  • Hast du eine PCIe Airport Karte mit Bluetooth verbaut? Hatte bis Montag das selbe „Problem“.


    Und der FBPatcher funktioniert mit Serie 6 Chipsätzen nur eingeschränkt.

  • MiChaRiot

    Nachdem die Kiste bereits läuft, muss der Thread sogar zu "Post-install allgemein"... ;)

    Gruß
    Al6042

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • al6042 Danke fürs verschieben!

    Neozee Japp das habe ich! Hast du eine Lösung ?

    @CrazyCreator "Ruhezustand bei Netzwerkzugriff" hatte ich bereits deaktiviert


    iHackPro 1.1: Ryzen 5 3600 / Gigabyte A520M H / 16 GB DDR4 / MSI RX 580 ARMOR / 2x BX500 240 GB / 2x Seagate 1TB HDD / 10.15 Catalina / Windows 10


    MacBook Pro 8,1 : Intel Core i7 2620M / 16 GB Ram / 256 GB SSD / TB HDD / 10.13 High Sierra


    GamingPC: Ryzen 7 5800X / Gigabyte x570 Aorus Elite / 32 GB DDR4 / AMD Radeon 6900XT / Scandisk Ultra II 960 GB / Kingston Predator SSD 240GB / Windows 10


    HuaweiMatebook 14: Ryzen 5 4600H / 16 GB DDR4 / 512 GB SSD / Windows 10

  • Nur indirekt, stehe momentan mit dem selben Problem da. Hatte eigentlich gedacht das ich es gelöst habe. :-/


    Es liegt an dem Bluetooth welches am USB hängt, dies verursacht den Walke. Eine Lösung sollte sein, den Port als „Integriert“ zu markieren. Allerdings hat es bei mir nur teilweise was gebracht.... Die Anleitungen zum Ports konfigurieren die ich so gefunden habe sind nur für neuere Chipsätze (Serie 7 oder neuer) unsere (Z68 bei mir H67 bei dir) sind da etwas anders gestrickt. :-/


    Aber da wird bestimmt jemand hier im Forum helfen können. Ich lade gleich mal meine DSDT und den EFI Ordner hoch.



    {Edit} Die DSDT wurde gerade mit Clover gedumped und befindet sich noch im Origin Ordner.

    Files

    • EFI+DSDT.zip

      (2.74 MB, downloaded 90 times, last: )
  • Also der FB-Patcher scheint mit 6er Chipsätzen wirklich nix anfangen zu können, auch nicht mit einem PortLimitPatch als KextToPatch Eintrag.

    Ich häng auch mal eine frisch mit F4 in Clover produzierte DSDT ran. Ans DSDT bearbeiten mit MaciASL trau ich mich noch nicht wirklich ran.

    Files

    • DSDT.aml

      (46.02 kB, downloaded 113 times, last: )

    iHackPro 1.1: Ryzen 5 3600 / Gigabyte A520M H / 16 GB DDR4 / MSI RX 580 ARMOR / 2x BX500 240 GB / 2x Seagate 1TB HDD / 10.15 Catalina / Windows 10


    MacBook Pro 8,1 : Intel Core i7 2620M / 16 GB Ram / 256 GB SSD / TB HDD / 10.13 High Sierra


    GamingPC: Ryzen 7 5800X / Gigabyte x570 Aorus Elite / 32 GB DDR4 / AMD Radeon 6900XT / Scandisk Ultra II 960 GB / Kingston Predator SSD 240GB / Windows 10


    HuaweiMatebook 14: Ryzen 5 4600H / 16 GB DDR4 / 512 GB SSD / Windows 10

  • Lese ich also richtig das es am Ethernet liegt? Wie fixe ich das?

    Versuchs mal mit dem HibernationFixup und dem entsprechenden bootflag.




    Gruss Coban

     MSI-Z590Pro Wifi | Intel® Core™ i9-10900k CometLake | 32GB DDR4 RAM | Radeon RX 570 Red Devil | Nvme WD Black SN750 1TB | BCM94360NG | OpenCore aktuell / macOS Catalina 10.15 / BigSur 11.0 / Monterey Beta / Win 10 Pro / Win 11 Pro Beta / Ubuntu 21.04

     MSI-B150M Mortar | Intel® Core™ i7-6700 Skylake | 64GB DDR4 RAM | Intel® HD Graphics 530 | Samsung NVMe 960 EVO / 1x2 TB HDD | BCM943602BAED DW1830 | OpenCore aktuell / macOS Catalina 10.15 / Windows 10 Pro / Ubuntu 21.04

     Lenovo S340-15IIL | Intel® Core™ i7-1065G7 IceLake | 12GB DDR4 RAM | Intel® Iris Plus Graphics G7 | Nvme Intel SSDPEKNW512G8L/SSD Samsung 256GB | BCM94360NG | OpenCore aktuell / macOS Catalina 10.15 / BigSur 11.0 / Win 10 Pro / Ubuntu 21.04


    " Chasch nöd s Föifi und s Weggli ha."

  • Ihr benötigt eine saubere SSDT-USB für Euer Board. Hierzu gibt es eine gute Anleitung im Board.


    Die USBInjectAll in Zusammenspiel mit dem Limit Patch ist super, der Connector an dem die BT Karte hängt wird jedoch als externer Anschluss erkannt. Dieser muss mittels der SSDT gepascht.


    Vorgehensweise ist ungefähr so:


    1.) IORegExplorer öffnen

    2.) Einen USB2.0 Stick in alle USB Ports stecken, dabei die angezeigten Ports aus dem ioregistryexplorer notieren.

    3.) Das ganze mit einen USB3.0 Stick in den USB3 Plätzen wiederholen.

    4.) Die Definitionen in der SSDT-USB eintragen und den Port an dem die BT Karte hängt den Connector Type 255 (intern) geben.


    Evtl. kann man das auch nur für den einen Port machen - das habe ich nicht versucht, da ich ein sauber gepaschtes System bevorzuge.


    Anleitung: USB 3.0 El Capitan / (High-) Sierra für jedermann (Zukunftssicher für Updates und komplett gepatcht)

  • Die Anleitung und das portmapping (255) funktioniert nicht mit den SandyBridge Chipsätzen. ;) Deshalb läuft der fbpatcher auch nicht.


    cobanramo Bei mir klappt’s damit nicht.

    Quote
    Die Anleitungen zum Ports konfigurieren die ich so gefunden habe sind nur für neuere Chipsätze (Serie 7 oder neuer

    Edited once, last by Neozee ().

  • Wie muss die bootflag genau aussehen? Mit -hbfx-patch-pci=EHC2 funktioniert bei mir schonmal nicht.

    Neozee hast du das SSDT-Patchen schon probiert? Ansonsten würde ich das in den nächsten Tagen mal probieren wenn ich ein wenig mehr Zeit aufwenden kann.

    Saubere DSDT und SSDTs wären schon was cooles...

    iHackPro 1.1: Ryzen 5 3600 / Gigabyte A520M H / 16 GB DDR4 / MSI RX 580 ARMOR / 2x BX500 240 GB / 2x Seagate 1TB HDD / 10.15 Catalina / Windows 10


    MacBook Pro 8,1 : Intel Core i7 2620M / 16 GB Ram / 256 GB SSD / TB HDD / 10.13 High Sierra


    GamingPC: Ryzen 7 5800X / Gigabyte x570 Aorus Elite / 32 GB DDR4 / AMD Radeon 6900XT / Scandisk Ultra II 960 GB / Kingston Predator SSD 240GB / Windows 10


    HuaweiMatebook 14: Ryzen 5 4600H / 16 GB DDR4 / 512 GB SSD / Windows 10

  • Hängt mal bitte einen IORegistryExplorer Dump an...


    Ich vermute, dass eure Boards nicht XHC nutzen (obwohl sich XHCI im ACPI finden lässt). Dementsprechend bringen auch etwaige PortLimitPatchs, FB-Patcher, normale UIAC_SSDTs, etc. nichts.


    Einfallen würde mir da spontan die Möglichkeit entweder per USBInjectAll die Ports als intern zu definieren (mit einer SSDT die sich an den entsprechenden EHCI Port richtet), oder in der DSDT per _UPC die Ports zu markieren und zu hoffen, dass macOS das ganze auch so übernimmt. Für letzteres wären primär erstmal folgende Renames in der config nötig:

    • change EHC1 to EH01
    • change EHC2 to EH02

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • MiChaRiot


    Laut dem Wake Reason Log würde bei dir der Bootarg dann so aussehen;

    -hbfx-patch-pci=GLAN, EHC2


    Wobei ich persönlich würde mich an kuckkuck halten, EHC2 ist schon mal nicht Apple like.


    Gruss Coban

     MSI-Z590Pro Wifi | Intel® Core™ i9-10900k CometLake | 32GB DDR4 RAM | Radeon RX 570 Red Devil | Nvme WD Black SN750 1TB | BCM94360NG | OpenCore aktuell / macOS Catalina 10.15 / BigSur 11.0 / Monterey Beta / Win 10 Pro / Win 11 Pro Beta / Ubuntu 21.04

     MSI-B150M Mortar | Intel® Core™ i7-6700 Skylake | 64GB DDR4 RAM | Intel® HD Graphics 530 | Samsung NVMe 960 EVO / 1x2 TB HDD | BCM943602BAED DW1830 | OpenCore aktuell / macOS Catalina 10.15 / Windows 10 Pro / Ubuntu 21.04

     Lenovo S340-15IIL | Intel® Core™ i7-1065G7 IceLake | 12GB DDR4 RAM | Intel® Iris Plus Graphics G7 | Nvme Intel SSDPEKNW512G8L/SSD Samsung 256GB | BCM94360NG | OpenCore aktuell / macOS Catalina 10.15 / BigSur 11.0 / Win 10 Pro / Ubuntu 21.04


    " Chasch nöd s Föifi und s Weggli ha."

  • Andersrum, auf EHC2 matchen Apples Port Injectoren, weshalb der ConnectorType des Ports immer nur dem Connector entsprechen wird, den das gewählte SMBios an diesem Port haben will. Um den ConnectorType der DSDT zu injecten, muss erstmal der Apple Port Injector durch einen Rename deaktiviert werden ;)

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • öhm, hab ich jetzt nicht verstanden, jetzt bitte bisschen klarer erklären :-D

    Erwartet Apple jetzt EHC1 oder EH01 bei diesen Geräten? :-)

    Gruss Coban

     MSI-Z590Pro Wifi | Intel® Core™ i9-10900k CometLake | 32GB DDR4 RAM | Radeon RX 570 Red Devil | Nvme WD Black SN750 1TB | BCM94360NG | OpenCore aktuell / macOS Catalina 10.15 / BigSur 11.0 / Monterey Beta / Win 10 Pro / Win 11 Pro Beta / Ubuntu 21.04

     MSI-B150M Mortar | Intel® Core™ i7-6700 Skylake | 64GB DDR4 RAM | Intel® HD Graphics 530 | Samsung NVMe 960 EVO / 1x2 TB HDD | BCM943602BAED DW1830 | OpenCore aktuell / macOS Catalina 10.15 / Windows 10 Pro / Ubuntu 21.04

     Lenovo S340-15IIL | Intel® Core™ i7-1065G7 IceLake | 12GB DDR4 RAM | Intel® Iris Plus Graphics G7 | Nvme Intel SSDPEKNW512G8L/SSD Samsung 256GB | BCM94360NG | OpenCore aktuell / macOS Catalina 10.15 / BigSur 11.0 / Win 10 Pro / Ubuntu 21.04


    " Chasch nöd s Föifi und s Weggli ha."

  • Grundsätzlich: Im ACPI (DSDT) werden über die _UPC Methode connector-types der einzelnen Ports definiert. Wenn es keine eigenen OS-Informationen gibt, versucht macOS die connector-types aus dem ACPI auszulesen und zu benutzen.


    Interne Informationen zu connector-types besitzt macOS für jedes SMBios in den Port-Injectoren. Dort steht nicht nur welche Ports injected werden, sondern auch welchen connector-type sie haben. Die Port-Injectoren matchen auf EHCX, laden also nur bei EHC1/EHC2. Da die Ports des bestimmten SMBios aber nicht den Ports unseres Hackys entsprechen, muss der Port-Injector für unsere Änderungen an den connector-types deaktiviert werden. Dafür benennt man (Apple like -) EHC2 in (non Apple -) EH02 um.

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Danke, wie immer erleuchtend deine Beiträge :-)

     MSI-Z590Pro Wifi | Intel® Core™ i9-10900k CometLake | 32GB DDR4 RAM | Radeon RX 570 Red Devil | Nvme WD Black SN750 1TB | BCM94360NG | OpenCore aktuell / macOS Catalina 10.15 / BigSur 11.0 / Monterey Beta / Win 10 Pro / Win 11 Pro Beta / Ubuntu 21.04

     MSI-B150M Mortar | Intel® Core™ i7-6700 Skylake | 64GB DDR4 RAM | Intel® HD Graphics 530 | Samsung NVMe 960 EVO / 1x2 TB HDD | BCM943602BAED DW1830 | OpenCore aktuell / macOS Catalina 10.15 / Windows 10 Pro / Ubuntu 21.04

     Lenovo S340-15IIL | Intel® Core™ i7-1065G7 IceLake | 12GB DDR4 RAM | Intel® Iris Plus Graphics G7 | Nvme Intel SSDPEKNW512G8L/SSD Samsung 256GB | BCM94360NG | OpenCore aktuell / macOS Catalina 10.15 / BigSur 11.0 / Win 10 Pro / Ubuntu 21.04


    " Chasch nöd s Föifi und s Weggli ha."

  • Habe heute leider keine Zeit fürs werkeln aber die nötigen Screenshots werden von mir am WE oder Ende nächste Woche mal gemacht!

    iHackPro 1.1: Ryzen 5 3600 / Gigabyte A520M H / 16 GB DDR4 / MSI RX 580 ARMOR / 2x BX500 240 GB / 2x Seagate 1TB HDD / 10.15 Catalina / Windows 10


    MacBook Pro 8,1 : Intel Core i7 2620M / 16 GB Ram / 256 GB SSD / TB HDD / 10.13 High Sierra


    GamingPC: Ryzen 7 5800X / Gigabyte x570 Aorus Elite / 32 GB DDR4 / AMD Radeon 6900XT / Scandisk Ultra II 960 GB / Kingston Predator SSD 240GB / Windows 10


    HuaweiMatebook 14: Ryzen 5 4600H / 16 GB DDR4 / 512 GB SSD / Windows 10

  • Wobei ich denk connector bei mir schon als intern Makiert habe, dass wird auch im Systembericht so angezeigt (Integriert: Ja)


    {Edit} @kuckkuck anbei mein ioregistryexplorer dump.

  • Ich werd mir das erst am Montag anschauen können, ich werd dann nochmal schreiben...

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.