i3-8300 auf Aorus Z370 Ultra Gaming V2 permanente Panic

  • Hallo und guten Abend


    Bei einem guten Freund versuche ich gerade einen Hackintosh zum Leben zu erwecken. Die Systemzusammenstellung erscheint mir reichlich abenteuerlich (Gamingboard mit Optane und die schwachbrüstige CPU), aber vielleicht hat einer eine Idee. Der i3 wird m.M. nach von Apple nicht unterstützt. Gibt es da trotzdem eine Lösung, oder soll er sich eine andere CPU besorgen?

    Bilder

    Viele Grüße

    macdesignerin


    ––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––

    Systeme:
    iHackPro | ASUS Prime Deluxe x299 | i9 7940x | Vega 64 | 64 G | 1TB NVMe | 10.13.6
    iHack 18.3 | ASUS Prime A z370 | i7 8086K | RX580 8G | 32 G | 500 G NVMe | 10.13.6
    Hack mini | ASOCK Fataly z370 ITX | i5 8600K | iGPU | 32 G | 500 GN VMe | 10.14.1

    Hack Book Pro | HP 14-ck0205ng | i7-8550U | iGPU | 8 G | 500 GN VMe | 10.14.1
    MacBookPro i7 2012, 5xMac Pro,QNAP TS932x 20TB | Color Classic

  • Das Optane-Viech ist raus? Das wird nämlich leider nicht mit macOS spielen wollen.

    Kabylake Laptop: Dell Vostro 5370, i5-8250U, UHD 620
    Dell T20: Intel Xeon E3-1225 v3, MSI GeForce GT 710 2GD3H LP

  • Versuche es doch erstmal mit einer minimalen Auswahl an Kexten, ehe Du es mit Sensor und Co probierst.

    In Arbeit x299 Asus


    iMac17,1 GA-Z170N WiFi F22f |i5-6600 HD530 |RX 560 |16GB RAM |250GB SSD |10.14.1 |Clover 4475

    iMac18,1Zotac Barebone ZBOX MI553 |i5-7300HQ |IntelHD 630 |10.14.1|Clover r4767

    MacBook 9,1 XiaoMi 12" |m3-6Y30 IntelHD515 |4GB RAM |SSD 128 & 250 GB |10.14.1 |10.14.2 DB |Clover r4767

    MacBookPro14,2 XiaoMi Pro 15,6" |i5-8250U IntelUHD620 |8GB RAM |250 & 250GB SSD |10.14,1 |Clover r4767

    MacBookPro14,2 Lenovo 510-15IKS |i5-6200U IntelHD520 |8GB RAM |128SSD 1TB HDD |Win10 - 10.14.1 |Clover r4767

  • Arbeitet ihr nur mit der internen Grafik?

    Gruß
    Al6042


    Asus Prime Z390-A 0602 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.1 | Clover 4741

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14.1 | Clover 4741

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.1


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Hat nur die IGPU. Kext sind nur FakeSMC, Lilu Netzwerk und ALC drin. Woher die Sensormeldungen kommen kann ich nicht sagen.


    Hier mal die EFI.

    Dateien

    • EFI.zip

      (3,38 MB, 7 Mal heruntergeladen, zuletzt: )

    Viele Grüße

    macdesignerin


    ––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––

    Systeme:
    iHackPro | ASUS Prime Deluxe x299 | i9 7940x | Vega 64 | 64 G | 1TB NVMe | 10.13.6
    iHack 18.3 | ASUS Prime A z370 | i7 8086K | RX580 8G | 32 G | 500 G NVMe | 10.13.6
    Hack mini | ASOCK Fataly z370 ITX | i5 8600K | iGPU | 32 G | 500 GN VMe | 10.14.1

    Hack Book Pro | HP 14-ck0205ng | i7-8550U | iGPU | 8 G | 500 GN VMe | 10.14.1
    MacBookPro i7 2012, 5xMac Pro,QNAP TS932x 20TB | Color Classic

  • ich habe auf Verdacht mal folgende EFI gebastelt...

    Dateien

    • EFI.zip

      (3,34 MB, 13 Mal heruntergeladen, zuletzt: )

    Gruß
    Al6042


    Asus Prime Z390-A 0602 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.1 | Clover 4741

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14.1 | Clover 4741

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.1


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • So ihr Lieben.


    Optane rausgeschmissen, al6042's EFI Ordner genommen und es funktioniert. Super.
    Intel UHD Grafik wird erkannt. Hardwarebeschleunigung ist auch da. Nur die Monitorauflösungen stimmen nicht. Bei 1080p ist Schluss, obwohl der Monitor 2540x1440 kann.
    Ohne die Hardwarebeschleunigung war die Auflösung richtig. Ich habe das Device IntelGFX in Clover auf 0x59168086 gesetzt, welches der i3 8300 entspricht. Sollte ich den Haken bei Injekt Intel bei Graphics wegnehmen?

    Viele Grüße

    macdesignerin


    ––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––

    Systeme:
    iHackPro | ASUS Prime Deluxe x299 | i9 7940x | Vega 64 | 64 G | 1TB NVMe | 10.13.6
    iHack 18.3 | ASUS Prime A z370 | i7 8086K | RX580 8G | 32 G | 500 G NVMe | 10.13.6
    Hack mini | ASOCK Fataly z370 ITX | i5 8600K | iGPU | 32 G | 500 GN VMe | 10.14.1

    Hack Book Pro | HP 14-ck0205ng | i7-8550U | iGPU | 8 G | 500 GN VMe | 10.14.1
    MacBookPro i7 2012, 5xMac Pro,QNAP TS932x 20TB | Color Classic

  • Ich würde die Einträge zur GraKa nicht setzen, dass sollte über die Kexte funktionieren.
    Wegen der Auflösung muss ggf. noch der HDMI20-Boot-Arg hinzugenommen werden, denn kenne ich bisher aber noch nicht persönlich.. :)

    Gruß
    Al6042


    Asus Prime Z390-A 0602 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.1 | Clover 4741

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14.1 | Clover 4741

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.1


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • ... enable-hdmi20 ...

    In Arbeit x299 Asus


    iMac17,1 GA-Z170N WiFi F22f |i5-6600 HD530 |RX 560 |16GB RAM |250GB SSD |10.14.1 |Clover 4475

    iMac18,1Zotac Barebone ZBOX MI553 |i5-7300HQ |IntelHD 630 |10.14.1|Clover r4767

    MacBook 9,1 XiaoMi 12" |m3-6Y30 IntelHD515 |4GB RAM |SSD 128 & 250 GB |10.14.1 |10.14.2 DB |Clover r4767

    MacBookPro14,2 XiaoMi Pro 15,6" |i5-8250U IntelUHD620 |8GB RAM |250 & 250GB SSD |10.14,1 |Clover r4767

    MacBookPro14,2 Lenovo 510-15IKS |i5-6200U IntelHD520 |8GB RAM |128SSD 1TB HDD |Win10 - 10.14.1 |Clover r4767

  • Wie fade... ich dachte das wäre umständlicher... ;)

    Gruß
    Al6042


    Asus Prime Z390-A 0602 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.1 | Clover 4741

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14.1 | Clover 4741

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.1


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • das bootarg habe ich gesetzt. Auflösung trotzdem nur 1080p.
    Irgendwie ist da noch ein kleiner Haken an der Sache.


    Viele Grüße Macdesignerin

    Viele Grüße

    macdesignerin


    ––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––

    Systeme:
    iHackPro | ASUS Prime Deluxe x299 | i9 7940x | Vega 64 | 64 G | 1TB NVMe | 10.13.6
    iHack 18.3 | ASUS Prime A z370 | i7 8086K | RX580 8G | 32 G | 500 G NVMe | 10.13.6
    Hack mini | ASOCK Fataly z370 ITX | i5 8600K | iGPU | 32 G | 500 GN VMe | 10.14.1

    Hack Book Pro | HP 14-ck0205ng | i7-8550U | iGPU | 8 G | 500 GN VMe | 10.14.1
    MacBookPro i7 2012, 5xMac Pro,QNAP TS932x 20TB | Color Classic

  • Zum setzen als Bootarg, dann eher -cdfon

    Zitat

    -cdfon (and enable-hdmi20 property) to enable HDMI 2.0 patches

    In Arbeit x299 Asus


    iMac17,1 GA-Z170N WiFi F22f |i5-6600 HD530 |RX 560 |16GB RAM |250GB SSD |10.14.1 |Clover 4475

    iMac18,1Zotac Barebone ZBOX MI553 |i5-7300HQ |IntelHD 630 |10.14.1|Clover r4767

    MacBook 9,1 XiaoMi 12" |m3-6Y30 IntelHD515 |4GB RAM |SSD 128 & 250 GB |10.14.1 |10.14.2 DB |Clover r4767

    MacBookPro14,2 XiaoMi Pro 15,6" |i5-8250U IntelUHD620 |8GB RAM |250 & 250GB SSD |10.14,1 |Clover r4767

    MacBookPro14,2 Lenovo 510-15IKS |i5-6200U IntelHD520 |8GB RAM |128SSD 1TB HDD |Win10 - 10.14.1 |Clover r4767

  • Hallo
    Hat es nicht gebracht. Habe aus „MacBook Pro (2018): Ergänzendes Update 2 auf macOS High Sierra 10.13.6“ mittels Pacifist die „AppleIntelCFLGraphicsFramebuffer.kext“ extrahiert. Damit hat es dann nativ funktioniert. Bei Bedarf muss die config.plist mit der richtigen Device-ID editiert werden. Ich bastle mal an einer kextpatcher.kext – so ähnlich wie es das schon für die AMD9500Graphics gibt.


    Hier sind mal die beiden originalen Dateien drin. Dann können wir das in Teamwork anpacken.

    Dateien

    • Archiv.zip

      (875,05 kB, 6 Mal heruntergeladen, zuletzt: )

    Viele Grüße

    macdesignerin


    ––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––

    Systeme:
    iHackPro | ASUS Prime Deluxe x299 | i9 7940x | Vega 64 | 64 G | 1TB NVMe | 10.13.6
    iHack 18.3 | ASUS Prime A z370 | i7 8086K | RX580 8G | 32 G | 500 G NVMe | 10.13.6
    Hack mini | ASOCK Fataly z370 ITX | i5 8600K | iGPU | 32 G | 500 GN VMe | 10.14.1

    Hack Book Pro | HP 14-ck0205ng | i7-8550U | iGPU | 8 G | 500 GN VMe | 10.14.1
    MacBookPro i7 2012, 5xMac Pro,QNAP TS932x 20TB | Color Classic

    Einmal editiert, zuletzt von macdesignerin ()

  • Nette Idee! :D

    Gruß
    Al6042


    Asus Prime Z390-A 0602 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.1 | Clover 4741

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14.1 | Clover 4741

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.1


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • @al6042
    du bist der bessere Programmierer, ich habe mal die originalen kexte angehangen.


    Bei meinem i3 war die Device ID 0x3E918086, in der info.plist steht für die native Unterstützung die 0x3E928086 drin.
    Ich habe dann zusätzlich in der AppleGraphicsDevicePolicy.kext meine Board-ID eingetragen.


    Mit einer patch.kext könnte man die Anpassungen in Clover verlagern und ist dann vor evtl. Updates sicher.

    Dateien

    • Archiv.zip

      (875,05 kB, 8 Mal heruntergeladen, zuletzt: )

    Viele Grüße

    macdesignerin


    ––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––

    Systeme:
    iHackPro | ASUS Prime Deluxe x299 | i9 7940x | Vega 64 | 64 G | 1TB NVMe | 10.13.6
    iHack 18.3 | ASUS Prime A z370 | i7 8086K | RX580 8G | 32 G | 500 G NVMe | 10.13.6
    Hack mini | ASOCK Fataly z370 ITX | i5 8600K | iGPU | 32 G | 500 GN VMe | 10.14.1

    Hack Book Pro | HP 14-ck0205ng | i7-8550U | iGPU | 8 G | 500 GN VMe | 10.14.1
    MacBookPro i7 2012, 5xMac Pro,QNAP TS932x 20TB | Color Classic

    Einmal editiert, zuletzt von macdesignerin ()

  • Ich bin überhaupt kein Programmierer.
    Tüftler würde ich durchgehen lassen... :D

    Gruß
    Al6042


    Asus Prime Z390-A 0602 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.1 | Clover 4741

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14.1 | Clover 4741

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.1


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Alle Achtung. Ich habe dein Video auf YouTube zum Thema DSDT gesehen – ich würde sagen zusätzlich zum Tüftler noch Programmierer ehrenhalber.
    Das ist wirklich außergewöhnlich :klatschen:

    Viele Grüße

    macdesignerin


    ––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––

    Systeme:
    iHackPro | ASUS Prime Deluxe x299 | i9 7940x | Vega 64 | 64 G | 1TB NVMe | 10.13.6
    iHack 18.3 | ASUS Prime A z370 | i7 8086K | RX580 8G | 32 G | 500 G NVMe | 10.13.6
    Hack mini | ASOCK Fataly z370 ITX | i5 8600K | iGPU | 32 G | 500 GN VMe | 10.14.1

    Hack Book Pro | HP 14-ck0205ng | i7-8550U | iGPU | 8 G | 500 GN VMe | 10.14.1
    MacBookPro i7 2012, 5xMac Pro,QNAP TS932x 20TB | Color Classic

  • Könnte man die DeviceID nicht einfach mit Clover überschreiben? Dann hätte man auch keine Probleme bei Updates

    Standrechner: (siehe links)


    Mobil: Thinkpad W520, i7 2860QM, QM67 Chipsatz, 16GB RAM, Nvidia Quadro 2000M (2GB VRAM), 1920x1080 Auflösung

  • Ich bastele gerade an einer Clover KextsToPatch-Lösung... :)
    @macdesignerin
    An welcher Stelle hast du den AGDP wie angepasst?

    Gruß
    Al6042


    Asus Prime Z390-A 0602 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.1 | Clover 4741

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14.1 | Clover 4741

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.1


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Geht das nicht andersherum? Also dass man Clover sagt "sag doch dem macOS dass die Grafikkarte die Device ID 0x3E928086 hat". Oder ist sowas nicht möglich?

    Standrechner: (siehe links)


    Mobil: Thinkpad W520, i7 2860QM, QM67 Chipsatz, 16GB RAM, Nvidia Quadro 2000M (2GB VRAM), 1920x1080 Auflösung