macOS Mojave Ozmosis BETA − OZ167X-XMAX

  • Ich habe es geschafft. SUPER. Vielen vielen Dank Kuckkuck.

    Ich habe wieder ein schönes Boot Menü bei F12.

  • Wird die aktuelle OZMOSIS Kern zeigte HD4000 4.600 unterstützen können?

    h77tn

    HD4000

    ozmosis10.13.6apfs

    clover10.14.2apfs


  • Ich habe meine NVME jetzt unter Sierra einbinden können.

    Hierzu habe ich einfach die "IONVMeFamily Pike R. Alpha Patche" unter "KextsToPatch" in der "KernextPatcher.plist" eingetragen. Die NVME wird jetzt auch normal unter Sierra angezeigt.

    Ich habe die "KernextPatcher.plist" hier mal drangehangen. Vielleicht hilft das den einen oder anderen.


    Aber nach der großen Euphorie kommt dann jetzt wieder die Ernüchterung.

    Ich kann leider Yosemite und EL Capitan mit dem XMAX ROM nicht mehr starten.

    Mit dem Sierra ROM keine Probleme (somit schließe ich also Default.plist & Kexte mal aus).

    - El Capitan startet erst garnicht (sofort einfach nur schwarzer Bildschirm, obwohl mit -v gestartet).

    - Yosemite startet und bleibt dann einfach hängen (siehe Bild).


    Ich habe hier nochmal die Unterschiede der ROMs angehangen (Bild). Was kann die Ursache hierfür sein?

    DarBoot habe ich bereits aus dem XMAX ROM Aufgrund des Legacy Problems entfernt.

  • Ich habe auf meinem Ozmosis-System auch dieses Problem. Bei mir liegt es am Kernextpatcher.

    Wenn du Yosemite und El Capitan nicht auf der NVME hast, kannst du mal testen, ob die ohne Kernextpatcher laufen. Dazu kannst du einfach die KernextPatcher.plist editieren und unter Preferences den key 'Off' auf 'true' ändern.

    Code
    1. <key>Off</key>
    2. <true/>

    iMac13,2: Gigabyte Ga-Z77X-UD3H, i5-3450, XFX Radeon HD 7850 2GB, 8GB RAM, Ozmosis, OSX 10.12.6, 10.13.6, 10.14


    iMac13,3: Asus H61M-K, i3-3225, intel HD4000, 4GB RAM, Clover 4630, OSX 10.10.5, 10.11.5, 10.12.6, 10.13.6, 10.14, Ubuntu 18.04, Windows 10


    MacBookPro11,1: Lenovo Y50-70, i5 4210H, intel HD4600 (nVidia GTX960), 16GB RAM, Clover 4359, OSX 10.12.6

  • Das habe ich soeben ausprobiert. Dann startet kein System mehr. Auch nicht Sierra und Mojave.

    Kann das irgend etwas mit ACPI zu tun haben. Weil bei El Capitan startet garnichts.

    Da sehe ich nur kurz die FP LED aufleuchten und dann sofort schwarzer Bildschirm obwohl mit -v gestartet.


    Vielleicht sollte ich als Ausgangslage mal das Sierra ROM (unten in dem Bild) nehmen und die notwendigen ffs für Mojave einbauen.

    Was ist denn zwingend notwendig für Mojave (aus dem oberen Bereich im Bild)?

  • Nur mal aus Neugier: Wieso müssen bei euch so viele verschiedene Systeme auf einem Rechner laufen?

    Yosemite, EL Capitan, Sierra, HighSierra und Mojave unterscheiden die sich so sehr das das notwendig ist (Weil es meinetwegen Apps gibt die nur auf dieser und jener Version laufen), oder ist das eher dieser "Ich will das es läuft auch wenn ich es nicht brauche Trieb"?

    Zum Verkauf geplant -> Board: GA-Z97X-UD5H-BK / CPU: i7-4790K / Grafikkarte: R280X / RAM: 16GB DDR3
    CNC Maschine (Apple Power Mac G5): Board: GA-Z77N-WiFi / CPU: i5-3570K / R280X / RAM: 16GB DDR3


    Rechtschreibung, Grammatik, Satzzeichen, Textformatierung und manchmal auch ein Komma führen zu einer besseren Verständlichkeit ;) :D

  • Sind bei mir reine Testumgebungen ....

    iMac13,2: Gigabyte Ga-Z77X-UD3H, i5-3450, XFX Radeon HD 7850 2GB, 8GB RAM, Ozmosis, OSX 10.12.6, 10.13.6, 10.14


    iMac13,3: Asus H61M-K, i3-3225, intel HD4000, 4GB RAM, Clover 4630, OSX 10.10.5, 10.11.5, 10.12.6, 10.13.6, 10.14, Ubuntu 18.04, Windows 10


    MacBookPro11,1: Lenovo Y50-70, i5 4210H, intel HD4600 (nVidia GTX960), 16GB RAM, Clover 4359, OSX 10.12.6

  • Also für von dir entwickelte/verwendete Apps um zu sehen ob die da laufen, oder wie darf man sich das vorstellen? Ich überlege die ganze Zeit zu was man heutzutage noch ein laufendes El Captain oder Yosemite gebrauchen kann. Aktuelle Systeme, ist mir vollkommen klar ...

    Zum Verkauf geplant -> Board: GA-Z97X-UD5H-BK / CPU: i7-4790K / Grafikkarte: R280X / RAM: 16GB DDR3
    CNC Maschine (Apple Power Mac G5): Board: GA-Z77N-WiFi / CPU: i5-3570K / R280X / RAM: 16GB DDR3


    Rechtschreibung, Grammatik, Satzzeichen, Textformatierung und manchmal auch ein Komma führen zu einer besseren Verständlichkeit ;) :D

  • Für Ozmosis und DBounce und Darboot Test sind Mavericks, Yosemite und El Capitan besstens geeignet, es geht auch Sierra aber HS und Mojave dann nur mit APFS.efi und dann beginnen die Probleme. ;)




    Irgendwie geht es (doch) immer, wobei mir die volle Hütte im rom schon (arg) unheimlich vorkommt. :)



    Die nächste Frage wäre dann wie lange hält das... :(

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.4 - OpenCore v0.1
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

    Edited once, last by derHackfan: Update eingefügt ().

    • Helpful

    Ich hab mal die KernextPatcher property List mit dem neuen Kernel Patch für die SIP ausgestattet. Vielleicht könnte mal jemand probieren, ob damit unter Mojave 10.14.4 die Kexte mittels KernextPatcher wieder vernünftig geladen werden können. Keine Garantie, dass es funktioniert. Erster Beta-Versuch.


    .plist bitte nach EFI/EFI legen, dann wird sie geladen

    Files

    Liebe Grüße
    Freddie :)




    Sind eure Probleme geheim? Falls nicht, nutzt bitte das Forum, statt meines Postfaches. Und falls doch, sind eure Geheimnisse bei mir eher weniger gut aufgehoben.


    Your problems are secrets? If not, please use the forum instead of my mailbox. But if they are, your secrets will not be safe anymore after having told me.


    Vos probèmes sont secret? Si non, vous pouvez utiliser le forum à place de mon boîte mail. Si oui, vos secrets ne seront plus assurés après que vous m'avez informés.

  • Voraussetzung ist natürlich ein XMAX Rom. Ist dies vorhanden, muss für ein Update auf die aktuelle 10.14.4 Beta einfach nur die obige Plist mit dem korrekten Namen KernextPatcher.plist nach EFI/Efi gelegt werden (neben den Oz Ordner). Daraufhin sollte in der Theorie die KextInjection mit 10.14.4 wieder funktionieren.

    Die Plist ist rückwärts kompatibel, alle andere Mojave Versionen (und alle weiteren OSs) funktionieren damit wie gewohnt.


    Für Tests am besten die Option SaveLogToFile in der Plist auf true setzen. Ein Log-File wird daraufhin neben der KernextPatcher.plist gespeichert und kann hier angehängt werden ;)

    Feedback ist sehr willkommen :)

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Hello kuckkuck


    Mojave 10.14.4 (18E174f) update still no native GVA support for AMD RX4XX/5XX, need dummy141 kext to enable AMD GVA support.


    Clover is working fine,but OZMOSIS not available..Can you help me with this problem:)


    dummy144.kext.zip

  • Could any mod update first page post with latest mojave kernextpatcher.ffs / plist?
    It may be useful to include also Mojave USB limit fix.


    Thanks.

    * GA-Z87MX-D3H F7 Ozmosis 167X * * i5-4570 HD 4600 | I217-V | ALC892 |
    I don't speak German, but G-Translator helps me. :D

  • Hier mal die plist :)

    Files

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.4 - OpenCore v0.1
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

    Edited once, last by derHackfan ().

  • Also ich habe weiterhin Probleme Yosemite und El Capitan zu starten. Siehe Post #243.

    Wobei ich laube, dass es am KeenextPatcher liegt.

    Wann wird der überhaupt gerstartet? Weill wenn ich Yosemite oder El Capitan starte wird überhaupt keine KernextPatcherLog.txt Datei erstellt. Bei Sierra und Mojave wird diese erstellt, da starten die Systeme ja auch.


    Weiterhin kann ich kein Update von Mojave 10.14.2 auf 10.14.3 intallieren. Er bricht beim Upate einfach ab (siehe Bilder).

    Ich habe bereits den KernextPatcher.ffs.zip aus Post #254 im Rom ersetzt und die KernextPatcher_XMAX.plist angepasst.

    Oder habe ich den Patcher falsch im Rom ersetzt?

  • Mojave 10.14.4 (18E174f) update still no native GVA support for AMD RX4XX/5XX, need dummy141 kext to enable AMD GVA support.


    Clover is working fine,but OZMOSIS not available..Can you help me with this problem:)

    You dont need dummy141 when using Clover with 10.14.4? Thats weird but I am pretty sure it's not Ozmosis related, I think it's a configuration issue... I would like to keep this thread related to issues regarding the ozmosis.efi driver itself ;)

    Could any mod update first page post with latest mojave kernextpatcher.ffs / plist?
    It may be useful to include also Mojave USB limit fix.

    Look at hackfans work :) I will update the first post of the thread once the update is reported to be working :thumbup:

    Probleme Yosemite und El Capitan zu starten. Siehe Post #243.

    Wobei ich glaube das es am KeenextPatcher liegt.

    Wann wird der überhaupt gerstartet? Weill wenn ich Yosemite oder El Capitan starte wird überhaupt keine KernextPatcherLog.txt Datei erstellt. Bei Sierra und Mojave wird diese erstellt, da starten die Systeme ja auch.

    Sehr interessante Beobachtung... Wenn du Sierra + bootest, wird ja ein Log erstellt und du kannst im Log sehen, dass 2 fixes "matchen" und angewendet werden. Wenn du Yosemite oder El Capitan bootest ist dies nicht so?

    Der KernextPatcher versucht ein Event namens ExitBootService zu "hooken". Evtl funktioniert die dahinterliegenden Technik aber nicht mit früheren OSs. Sollte das so sein, müsste El Cap etc aber funktionieren, wenn du FakeSMC naxh S/L/E legst, probier das mal. Sollte der KernelPatcher das Problem sein, könntest du deswegen mal cecekpawon kontaktieren, ich besitze den SourceCode von UEFTW nicht.


    Was dein Update angeht musst du unbedingt deine defaults.plist komplett updaten, vorallem die ROM Version und Firmware Feature Werte. Mehr dazu im Wiki und Forensuche ;)

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • @kuckkuck

    Wie gesagt so getan. Ich habe die FakeSMC nach S/L/E auf Yosemite kopiert, Rechte angepasst und Kext Cache upgedatet.

    Yosemite startet jetzt wie du gesagt hast. Jedoch kein Ton und kein Netzwerk. Ich denke da wird dann auch AppleALC.kext und IntelMausiEthernet.kext nicht von Efi geladen. Somit stimmt da irgend etwas mit dem KernelPatcher nicht.


    Unter El Capitan geht jedoch garnichts, nur ein schwarzer Bildschirm. Obwohl ich die FakeSMC nach S/L/E auf El Capitan kopiert habe, Rechte angepasst habe und Kext Cache upgedatet habe. Ich möchte dazu anmerken, es ist keine Fehler im System selber oder so ist. Sobald ich das Sierra Rom drauf mache läuft das System wie geschmiert.


    Die Routine sollte sich jemand grundsätlich ansehen. Denn ich glaube nicht das es bei anderen ohne Clover oder so funktioniert.

    Wenn ich Clover davor schiebe konnte ich auch bereits Yosemite starten.


    Ich stelle mich zum Testen auch jeder Zeit zur Verfügung. Ich bin auch bereit Roms selber zu erstellen. Jedoch sind meine Kenntnisse nicht so gut das ganze komplett zu durchschauen.

    Edited once, last by witjojo ().

  • Sobald ich das Sierra Rom drauf mache läuft das System wie geschmiert.

    Da bin ich ganz dicht bei dir...

    Wenn ich Clover davor schiebe konnte ich auch bereits Yosemite starten.

    Ist hier auch die bessere Wahl, das ganze Gefummel mit einer oder mehreren .plist macht es nicht besser.

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.4 - OpenCore v0.1
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

    Edited once, last by derHackfan ().

  • witjojo Sehr interessant, vielen Dank für deine Tests! Wie sieht es denn mit dem Log von Yosemite aus? Könntest du das mal anhängen?

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Jedoch sind meine Kenntnisse nicht so gut das ganze komplett zu durchschauen.

    Das "mit dem Ozmosis Rom erstellen" ist eigentlich gar nicht so schwer. ;)

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.4 - OpenCore v0.1
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

    Edited once, last by derHackfan: Rechtschreibung ().