Lenovo W530 - Installation grundsätzlich möglich?

  • Hallo und Guten Tag,


    zur Zeit versuche ich einen Lenovo W530 in einen Mac umzuwandeln. Bislang blieben die Versuche mit Clover und Unibeast jedoch ohne Erfolg. Der erste Bootvorgang brach in beiden Fällen nach einer Zeile mit Pluszeichen ab und es erfolgte ein Reboot.
    Das Gerät ist mit 24GB RAM und einer SSD Samsung EVO 840 bestückt. Prozessor ist ein i7-3740QM.


    Gibt es schon erfolgreiche Installationen auf diesem Lenovo Gerätetyp?


    Danke für Infos.


    Fontanus

  • Moin,


    soweit ich lesen konnte ist es grundsätzlich möglich das Lenovo W530 zu verwenden. Hat Irgendjemand eine Idee, wieso der Bootvorgang vom USB-Stick bei mir erfolglos abbricht?


    Gruß


    Fontanus

  • Dazu wäre erstmal interessant, an welcher Stelle er denn abbricht.
    Boote doch mal bitte im Verbose Mode und lade ein Foto hier hoch.


    Ebenso raten wir von den Beastern ab und empfehlen folgenden Weg : https://www.hackintosh-forum.d…llations-Stick-erstellen/


    Viel Glück :)

    Gruß CrusadeGT


    iMac 14.2

    GigaByte GA-B85M-D3H|Intel i7 4790K|16GB DDR3 1333Mhz|Sapphire RX580 Pulse 8GB|120 GB Sandisk SSD Plus

    MacBook Pro 7.1

    Lenovo Thinkpad T61 |T9500 2,6Ghz|2GB Ram|nVidia Quadro NVS140m|120 GB Sandisk SSD Plus



  • Sachma, @grt - hattest du nicht neulich so einen W530 auf dem OP-Tisch? ?(

    +++++++++++++++++++++++++++++++++


  • Moin blackcat,


    wenn Du mich meinst, dann habe ich vor Kurzem einen Test mit einem Lenovo T510 gefahren, der auch im Wesentlichen erfolgreich war. Danach habe ich mir voller Hoffnung den W530 zugelegt, da ich einen einigermaßen leistungsstarken Rechner für Grafik- und Videoberechnung benötige.
    Die Hoffnung habe ich noch nicht aufgegeben. Leider waren meine letzten Versuche mit Clover, Unibeast und auch mit Diskmaker X nicht erfolgreich. Wie und wo ich den von CrusadeGT vorgeschlagenen Verbose-Mode einstelle, weiss ich leider momentan auch noch nicht. Für jede Hilfe und Unterstützung bin ich dankbar.
    Zur Zeit startet der Rechner von USB-Stick. Das Clover-Menü erscheint und nach Auswahl des externen Laufwerks startet der weitere Vorgang und endet im Neustart per USB-Stick. Endlosschleife!
    VG
    Fontanus

  • Naja Clover, Unibeast und diskmaker sind 3 verschiedene paar Schuhe :P


    Zum verbose Mode auswählen im Clover Menü die Leertaste drücken.. n häckchen bei -v setzen und anschließend mit: boot macOS with selected options stArten.. dann ein Foto von der Stelle wo er stehen bleibt. :)!

    Gruß CrusadeGT


    iMac 14.2

    GigaByte GA-B85M-D3H|Intel i7 4790K|16GB DDR3 1333Mhz|Sapphire RX580 Pulse 8GB|120 GB Sandisk SSD Plus

    MacBook Pro 7.1

    Lenovo Thinkpad T61 |T9500 2,6Ghz|2GB Ram|nVidia Quadro NVS140m|120 GB Sandisk SSD Plus



  • @blackcat nee - das ist ein W520, was auch "nur" mit elCapitan läuft wg. diverser nicht mehr so ganz taufrischer soft, die ich aber gerne weiternutzen will.
    der klapptopp ist deutlich zickiger, als seine verwandschaft aus den T&X serien mit nur einer grafik, bis zum käptn hab ich ihn aber immer doch noch überreden können.


    hier mal ein paar stichworte:
    - für die installation die integrierte grafik an- und die nvidia im bios abschalten.
    - rohdsdt ziehen, wenn die igpu aktiv ist (das nicht zu machen hat mich mal einiges an nerven gekostet - warum hab ich nicht verfolgt, seit dem geh ich bei läppis mit 2 karten so vor)
    - smbios als MBP9.1 (ggf. beim W530 ein MBP10.?)
    - aptiofix2 nutzen
    - weniger ist mehr -> bei der installation nur die wirklich essentiell notwendigen kexte einsetzen (fakesmc, voodoops2 und nullcpupowermanagement (die einfach zur sicherheit))


    ob das beim W530 und HS greift, kann ich nicht garantieren. wär aber meine herangehensweise.

    thinkpad T440s: i5-4210U, intelHD4400, 8gbRam, 10.14/clover

    thinkpad W520: i7-2720qm, nVidiaQuadro1000m/intelHD3000, 16gbRam, 10.11.6/clover
    thinkpad X220: i5-2520m, intelHD3000, 16gbRam, 10.12.6/clover
    temporär: T520: i5-2520m, HD3000, 6gb, systemvorkoster


    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD
    nächster Termin: voraussichtlich MITTWOCH der 19.12.2018, 19.00 Uhr

  • Jupp, das kann ich unterstreichen.
    Ich denke das Teil wird nicht allzu weit vom T530 entfernt sein.
    Wäre mal spannend zu wissen, was tatsächlich alles verbaut ist.
    Womöglich kann mit meiner alten T530-EFI hier einiges vorweg genommen werden.

    Gruß
    Al6042


    Asus Prime Z390-A 0602 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.2 | Clover 4798

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14.2 | Clover 4798

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.2


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • @al6042 wenn ich mich recht erinnere, hatte dein T530 nur die intel HD4000? das nadelöhr bei den W... und auch den T... ist die zusätzliche nvidia. die ist schon beim käptn in der 20ger reihe alles andere als handzahm, ein kurzer sierratest beim W520 war einigermassen ernüchternd, so dass ich da dann erstmal wieder ruhe gegeben hab, ohne der sache genauer auf den grund zu gehen - auch wegen der alten programme, die unter sierra nicht mehr gelaufen wären.
    ich würde hier zuerst eine installation mit der intel durchziehen, das sollte eigentlich relativ einfach zu bewerkstelligen sein. die baustelle nvidia dann, wenn sonst alles funktioniert.

    thinkpad T440s: i5-4210U, intelHD4400, 8gbRam, 10.14/clover

    thinkpad W520: i7-2720qm, nVidiaQuadro1000m/intelHD3000, 16gbRam, 10.11.6/clover
    thinkpad X220: i5-2520m, intelHD3000, 16gbRam, 10.12.6/clover
    temporär: T520: i5-2520m, HD3000, 6gb, systemvorkoster


    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD
    nächster Termin: voraussichtlich MITTWOCH der 19.12.2018, 19.00 Uhr

  • Dann hätte ich hier mal eine EFI mit Clover 4411 und den groben T530 Settings ohne DSDT, sowie den spannendsten Kexten.
    In der config.plist ist auch zugleich der "nv_disable=1" aktiviert, damit sich die Nvidia nicht so arg bemerkbar macht.

    Dateien

    • EFI.zip

      (5,33 MB, 8 Mal heruntergeladen, zuletzt: )

    Gruß
    Al6042


    Asus Prime Z390-A 0602 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.2 | Clover 4798

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14.2 | Clover 4798

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.2


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • wenn die nvidia im bios abeschaltet wird, gibt die 100% ruhe. den ...disable brauchts eher nicht.

    thinkpad T440s: i5-4210U, intelHD4400, 8gbRam, 10.14/clover

    thinkpad W520: i7-2720qm, nVidiaQuadro1000m/intelHD3000, 16gbRam, 10.11.6/clover
    thinkpad X220: i5-2520m, intelHD3000, 16gbRam, 10.12.6/clover
    temporär: T520: i5-2520m, HD3000, 6gb, systemvorkoster


    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD
    nächster Termin: voraussichtlich MITTWOCH der 19.12.2018, 19.00 Uhr

  • Reine Vorsichtsmaßnahme... :)

    Gruß
    Al6042


    Asus Prime Z390-A 0602 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.2 | Clover 4798

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14.2 | Clover 4798

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.2


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Moin, moin,
    zunächst einmal Danke für alle Hinweise und Tipps, die hier aufgelistet sind. Ein Teil davon ist mir noch unverständlich, aber das ändert sich vielleicht noch.
    Einige Tipps habe ich nun schon angewendet, aber immer noch ohne Erfolg. Der Reihe nach (Fotos sind angehängt):
    - Ich verwende nun ausschließlich die aktuelle Clover-Version v2.4k r4411
    - Der USB-Stick wird erfolgreich erstellt.
    - Im BIOS habe ich UEFI only eingestellt und die NVIDIA-Grafikkarte deaktiviert.
    - Der Rechner bootet vom USB-Stick. Das Auswahlmenü wird angezeigt.
    - Der Verbose-Mode wird ausgewählt und dann vom USB-Stick weiter gebootet.
    - Das Ergebnis ist auf dem letzten Foto zu sehen. Weitestgehend schwarzer Bildschirm mit ++++Zeichen.


    Und jetzt suche ich nach einer Möglichkeit die Fotos anzuhängen. Übersehe ich da etwas?

  • welche(r) aptiofix-treiber ist/sind im einsatz? es darf nur einer sein, und meiner meinung nach sollte es der OsxAptioFix2Drv-64.efi sein in drivers64UEFI. wenn das immer noch nicht klappt, dann die anderen einzeln testen.

    thinkpad T440s: i5-4210U, intelHD4400, 8gbRam, 10.14/clover

    thinkpad W520: i7-2720qm, nVidiaQuadro1000m/intelHD3000, 16gbRam, 10.11.6/clover
    thinkpad X220: i5-2520m, intelHD3000, 16gbRam, 10.12.6/clover
    temporär: T520: i5-2520m, HD3000, 6gb, systemvorkoster


    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD
    nächster Termin: voraussichtlich MITTWOCH der 19.12.2018, 19.00 Uhr

  • Danke grt!
    Beim letzten Versuch hatte ich alle rausgeworfen. Der Versuch läuft schon.
    Erfolglos.
    Folgende Meldung wird angezeigt:


    OsxAtioFix2Drv: Starting Overrides for \.IABootFiles\boot.efi
    Using reloc block: no, hibernate wake: no
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++_


    VG
    Fontanus


    Nachtrag:


    ich habe nun die von al6042 bereitgestellte EFI.zip getestet. Fehler weiterhin vorhanden, jedoch mit abweichender Fehlermeldung:
    AptioMemoryFix(R12): Starting \.IABootfiles\boot.efi
    AMF: Only 127/256 slide values are usable! Booting may fail!
    Valid slides: 0-63, 128-190
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++_


    P.S. Kann man tatsächlich keine Fotos anhängen?

    Einmal editiert, zuletzt von Fontanus ()

  • versuch mal die config.plist im anhang.
    kommt von einem T430s
    und tausch vorsichtshalber die kexte (fakesmc und ps2dingsda) gegen die aus dem archiv.
    wenn er damit starten mag, wird nix weiter funktionieren, aber wir wären einen kleinen schritt weiter.


    deine sachen aber nicht einfach so überbügeln.. sicher die bitte. ;)

    Dateien

    thinkpad T440s: i5-4210U, intelHD4400, 8gbRam, 10.14/clover

    thinkpad W520: i7-2720qm, nVidiaQuadro1000m/intelHD3000, 16gbRam, 10.11.6/clover
    thinkpad X220: i5-2520m, intelHD3000, 16gbRam, 10.12.6/clover
    temporär: T520: i5-2520m, HD3000, 6gb, systemvorkoster


    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD
    nächster Termin: voraussichtlich MITTWOCH der 19.12.2018, 19.00 Uhr

  • Hallo grt,


    ich habe noch einmal die ganze EFI-Installation mit Clover durchgemacht. In drivers64UEFI habe ich nur OsxAptioFix2Drv-64.efi ausgewählt. Nach Abschluss der Installation habe ich manuell Deine config.plist und die beiden kext'e in die EFI Partition kopiert.
    Das Ergebnis ist wie vor:

    OsxAtioFix2Drv: Starting Overrides for \.IABootFiles\boot.efi
    Using reloc block: no, hibernate wake: no
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++_


    VG
    Fontanus

  • kannst du mal deine bioseinstellungen auflisten bitte?

    thinkpad T440s: i5-4210U, intelHD4400, 8gbRam, 10.14/clover

    thinkpad W520: i7-2720qm, nVidiaQuadro1000m/intelHD3000, 16gbRam, 10.11.6/clover
    thinkpad X220: i5-2520m, intelHD3000, 16gbRam, 10.12.6/clover
    temporär: T520: i5-2520m, HD3000, 6gb, systemvorkoster


    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD
    nächster Termin: voraussichtlich MITTWOCH der 19.12.2018, 19.00 Uhr

  • P.S. Kann man tatsächlich keine Fotos anhängen?


    Über "Erweiterte Antwort" --> "Dateianhänge" --> "Hochladen"

    MfG, docplag


    ..................................................................................................................................................................................................................................................................................
    GA-Z170M-D3H, i5-6600, 16 GB DDR4 RAM Corsair 2400, Gigabyte RX 560 Gaming OC 4GB | macOS 10.13.5 / 10.14 Beta, KDEneon, Ubuntu 18.04, Windows 10 Pro
    GA-X58A-UD3R, i7-960, 12 GB DDR3 RAM 1600, Asus GTX660 | OS X 10.11.6
    HP Envy 13-d071ng, i56200U mit HD520, 8GB DDR3L RAM | OS X 10.12.6, Windows 10 Home
    3.12.2017
    MacBook Pro Late 2011, optisches Laufwerk rausgeflogen, SSD eingebaut | OSX 10.9.5, macOS 10.13.2, Windows 7 Pro als VM
    E35M1-I Deluxe, AMD-CPU E350, EVGA-GTX210, 8 GB DDR3 RAM
    | Ubuntu-Server 16.04
    Dell XPS 15-9560, i7-7700HQ, 16GB DDR4 RAM, HD630, GTX1050M
    | macOS 10.13.5, Windows 10 Pro