AMD RX580 - High Sierra - TrippelScreen

  • ... deshalb sollten wir etwas ausprobieren und dafür benötige ich die BIOS P/N deiner Grafikkarte.


    Alles klar, wie lese ich diese unter OSX aus? Oder geht das nur unter Windows?

  • @ea.manic
    Es gibt 3 Möglichkeiten:


    1. IORegistryExplorer starten -> in der Suchleiste oben GFX0@0 angeben -> rechtes Fenster weit nach unten scrollen und nach ATI,Part# Ausschau halten



    Die ganze Nummer mit 113-... brauche ich, um einen KextToPatch für dich basteln zu können. Ob es nachher funzt, weißt keiner.


    2. DPCIManager starten -> links neben der Graka aufs Auge klicken -> bios.rom Datei speichern -> dem Leo hier hochladen


    3. Unter Windows mit ATIWinflash auslesen

     iPhone 4_iPhone 4s_iPhone 5_iPhone X_PowerMac7,2 G5 (Mid 2003)_iMac10,1 (27" Late 2009) out of order_MacPro5,1 (Mid 2012)




  • Here we go :)

  • ... das ging aber zügig :thumbup:
    Jetzt warte mal bitte ab, muss nach unten ein Glas Champagner holen ;)


    Und wenn es uns gelingt damit dein Prob zu lösen, dann das nächste Glas besorgst Du, okay?


    Edit:
    ich nehme mal an, daß deine Graka den AMD9500Controller.kext nutzt oder?


    Um meinerseits sicher zu sein, welchen Controller spricht deine Graka an, wäre es sehr hilfreich von dir IOReg Datei zu bekommen, kannst du das machen bitte?


    Und hier schon mal mein erster Versuch.
    Ich muss dir nicht erklären, wo du die Werte eintragen musst oder?
    Dann das System Neustarten und... wir werden es sehen ?(

    Dateien

     iPhone 4_iPhone 4s_iPhone 5_iPhone X_PowerMac7,2 G5 (Mid 2003)_iMac10,1 (27" Late 2009) out of order_MacPro5,1 (Mid 2012)


    Einmal editiert, zuletzt von Leo Duke ()



  • Wenn das klappt, geht die nächste Kiste auf mich :D


    Momentan nutze ich weder lilu noch weg noch AMD9500Controller.kext


    "Ich muss dir nicht erklären, wo du die Werte eintragen musst oder?"
    Ist meine erste AMD Karte seit, lass mich nicht lügen 15 Jahren :D Also eher schon :P

  • Wenn das klappt, geht die nächste Kiste auf mich


    Gerne, aber zu erst muss es klappen ;)


    Momentan nutze ich weder lilu noch weg noch AMD9500Controller.kext


    Doch Eric, du nutzt Lilu+WeG, die sind da und AMD9500Controller.kext ist im System unter anderen sowieso vorhanden und deine Graka läuft über den. Hier die Fotos:




    "Ich muss dir nicht erklären, wo du die Werte eintragen musst oder?"
    Ist meine erste AMD Karte seit, lass mich nicht lügen 15 Jahren Also eher schon


    Die Werte im Clover unter Kernel and Kext Patches einzutragen hat absolut nichts damit zu tun, ob jemand AMD oder Nvidia Graka benutzt.

     iPhone 4_iPhone 4s_iPhone 5_iPhone X_PowerMac7,2 G5 (Mid 2003)_iMac10,1 (27" Late 2009) out of order_MacPro5,1 (Mid 2012)


  • Hab gerade nochmal geschaut, du hast recht ich hatte lilu un weg wieder rein gemacht, macht aber keinen unterscheid.


    Ich werde es morgen mal ausprobieren die werte einzutragen, kannst du mir eventuell noch ne Kurzanleitung geben?

  • Die BIOS Part Nummer vom BIOS deiner Graka stimmt mit der Part Nummer aus der IOReg Datei nicht überein.
    Deshalb sind meine erste Werte obsolet und die brauchst du nicht zu benutzen.
    Die RX 580 wird vom macOS offiziell unterstützt und normalerweise braucht man WeG nicht mehr.
    In meinem Office-Hack läuft Sapphire RX 580 Nitro+ OHNE alles.


    Du solltest ausprobieren und feststellen, ob deine Asus RX 580 ohne WeG läuft, dann können wir weiter machen.
    Gute N8

     iPhone 4_iPhone 4s_iPhone 5_iPhone X_PowerMac7,2 G5 (Mid 2003)_iMac10,1 (27" Late 2009) out of order_MacPro5,1 (Mid 2012)


  • Die BIOS Part Nummer vom BIOS deiner Graka stimmt mit der Part Nummer aus der IOReg Datei nicht überein.
    Deshalb sind meine erste Werte obsolet und die brauchst du nicht zu benutzen.
    Die RX 580 wird vom macOS offiziell unterstützt und normalerweise braucht man WeG nicht mehr.
    In meinem Office-Hack läuft Sapphire RX 580 Nitro+ OHNE alles.


    Du solltest ausprobieren und feststellen, ob deine Asus RX 580 ohne WeG läuft, dann können wir weiter machen.
    Gute N8


    Ja wie gesagt sie läuft auch ohne WEG und LILU, ist dann quasi identisch vom verhalten her, also es gehen nur die 2 Displayports :)

  • @ea.manic
    Ok, dann sende mir bitte noch einmal IOReg Datei deines Systems zu, aber eben OHNE WeG und Lilu.

     iPhone 4_iPhone 4s_iPhone 5_iPhone X_PowerMac7,2 G5 (Mid 2003)_iMac10,1 (27" Late 2009) out of order_MacPro5,1 (Mid 2012)


  • Hi,
    hab' etwas 4 dich gebastelt und bin selber schon sehr gespannt.
    Mit Clover eröffnest du deine /EFI/CLOVER/config.plist, klickst du auf der linken Seite "Kernel and Kext Patches" und trägst du unter "KextsToPatch" die Werte aus mener .txt Datei ein, das ist alles.



    Deine config.plist speichern, Clover verlassen, Kext Utility seine tolle Arbeit machen lassen, das System Neustarten und... ?(
    Berichte bitte, ob es sich etwas mit den Ports geändert hat.

    Dateien

     iPhone 4_iPhone 4s_iPhone 5_iPhone X_PowerMac7,2 G5 (Mid 2003)_iMac10,1 (27" Late 2009) out of order_MacPro5,1 (Mid 2012)


  • Hi,
    hab' etwas 4 dich gebastelt und bin selber schon sehr gespannt.
    Mit Clover eröffnest du deine /EFI/CLOVER/config.plist, klickst du auf der linken Seite "Kernel and Kext Patches" und trägst du unter "KextsToPatch" die Werte aus mener .txt Datei ein, das ist alles.



    Deine config.plist speichern, Clover verlassen, Kext Utility seine tolle Arbeit machen lassen, das System Neustarten und... ?(
    Berichte bitte, ob es sich etwas mit den Ports geändert hat.



    Vielen Dank @Leo Duke Probiere ich gleich mal aus sobald ich zuhause bin :)

  • @ea.manic
    ... und ??? ?(

     iPhone 4_iPhone 4s_iPhone 5_iPhone X_PowerMac7,2 G5 (Mid 2003)_iMac10,1 (27" Late 2009) out of order_MacPro5,1 (Mid 2012)


  • Sooo bin gerade dran, melde mich gleich mit den Resultaten :)


    @Leo Duke
    Leider unverändert

    Einmal editiert, zuletzt von ea.manic ()

  • @ea.manic
    Du benutzt aber kein WeG Kext oder?

     iPhone 4_iPhone 4s_iPhone 5_iPhone X_PowerMac7,2 G5 (Mid 2003)_iMac10,1 (27" Late 2009) out of order_MacPro5,1 (Mid 2012)


  • ... gut, zuerst versuchst du bitte ohne alles. hier ein zweiter Versuch

    Dateien

     iPhone 4_iPhone 4s_iPhone 5_iPhone X_PowerMac7,2 G5 (Mid 2003)_iMac10,1 (27" Late 2009) out of order_MacPro5,1 (Mid 2012)


    2 Mal editiert, zuletzt von Leo Duke ()

  • ... gut, zuerst versuchst du bitte ohne alles. hier ein zweiter Versuch


    @Leo Duke
    Leider immer noch nicht, habe jetzt auch noch mal clover auf die aktuelle Version geupdated.

  • @ea.manic
    Erst in 1 Wo. kann ich weiter helfen. Ich werde auch dafür deine config.plist benötigen.

     iPhone 4_iPhone 4s_iPhone 5_iPhone X_PowerMac7,2 G5 (Mid 2003)_iMac10,1 (27" Late 2009) out of order_MacPro5,1 (Mid 2012)