[gelöst] Acer Spin 5: Finetuning !

  • Ok! Besten Dank schon mal! Ich schicke gleich den origin-Ordner mit den DSDT und SSDT Dateien.

    Dateien

    • origin.zip

      (66,04 kB, 5 Mal heruntergeladen, zuletzt: )

    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 8GB DDR3 1600 MHz, Broadcom BCM94352HBM Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.14


    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 256 GB SSD, MacOS 10.14

  • OK, nächster Versuch.
    Dieses mal die dsdt.aml mit diesen 2 Kexten probieren und dann wider die Ausgabe von IORegistryExplorer hier hochladen.


    VoodooI2C.kext
    VoodooI2CHID.kext

    Dateien

    • DSDT.aml

      (165,02 kB, 6 Mal heruntergeladen, zuletzt: )


    :hackintosh:

  • Damit startet er gar nicht, wie bei der von mir erstellten DSDT. Ich glaube, das liegt an der config.plist.


    Ich hänge darum meinen Clover-Odner mal an!

    Dateien

    • CLOVER.zip

      (3,12 MB, 5 Mal heruntergeladen, zuletzt: )

    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 8GB DDR3 1600 MHz, Broadcom BCM94352HBM Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.14


    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 256 GB SSD, MacOS 10.14

  • Versuche es nochmal mit diesen beiden Dateien und mit den neusten:
    VoodooI2C.kext
    VoodooI2CHID.kext

    Dateien

    • config.plist

      (18,23 kB, 3 Mal heruntergeladen, zuletzt: )
    • DSDT.aml

      (177,02 kB, 2 Mal heruntergeladen, zuletzt: )


    :hackintosh:

  • Hat leider nicht geklappt. Er hat kurz damit gestartet, dann Error und gleich Neustart.
    - Aber für heute muß ich Schluß machen -

    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 8GB DDR3 1600 MHz, Broadcom BCM94352HBM Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.14


    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 256 GB SSD, MacOS 10.14

  • Versuche die config.plist mit der dsdt as dem Thread davor.


    :hackintosh:

  • So, ein kleiner Erfolg: mit der config.plist (der ich allerdings noch ein paar Werte von der meinigen einfügen mußte) und der ersten DSDT startet er endlich durch … allerdings nur ohne die VoodooI2C-Kexte, mit diesen machte er einen sofortigen Neustart.


    Ich hänge die funktionierende config.plist an!

    Dateien

    • config.plist

      (17,78 kB, 5 Mal heruntergeladen, zuletzt: )

    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 8GB DDR3 1600 MHz, Broadcom BCM94352HBM Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.14


    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 256 GB SSD, MacOS 10.14

  • Nein das ist leider gar nicht gut für diesen Kext.
    Ich habe nur den Windows 10 Patch und den GPIO Controller Patch in diese DSDT eingefügt. Was bedeutet das der Kext den Neustart verursacht.
    Schade, aber vielleicht unterstützt die nächste Version des Kextes dein Trackpad.


    Mit der gepatchten DSDT aus Post 42 sollte dir zumindest der Name des Trackpads angezeigt werden so in etwa wie bei mir im Bild.



    Das wäre dann der erhoffte Erfolg und dann fehlt nur noch GPIO Pinning. :)
    https://voodooi2c.github.io/#GPIO Pinning/GPIO Pinning


    :hackintosh:

  • Ich weiß nicht mehr weiter, habe alles Mögliche schon probiert, aber leider ohne Erfolg! Also … ich bekomme keine vernünftige DSDT.aml an den Start. Es ist wie verhext. X(
    Ich habe schon DSDTs nur mit Grundpatches oder nur mit IGPU-Patch erstellt und damit probiert zu starten, aber immer das Gleiche: Bootstop und Error.


    Ohne DSDT startet mein Laptop brav, aber mit DSDT gibt es immer ACPI-Errors und da bleibt er dann hängen. Na ja, ohne DSDT, die man patchen kann, ist das Hacbook nur ein halbes Macbook :( .


    Richtig, mit der config aus Post 44 und der DSDT aus Post 42 hat es einmal geklappt, danach aber wieder nicht mehr. Zudem ist die Unterstützung der Helligkeit mit dieser config auch dahin.


    Ich hänge mal meine Cloverordner an. Darin befindet sich meine DSDT-13.aml, die ich mit angefügten Patches bestückt habe. Zudem ein Bild dessen, wo er beim Booten hängen bleibt. Und eine ungepatchte fehlerfreie DSDT.aml.


    Dateien

    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 8GB DDR3 1600 MHz, Broadcom BCM94352HBM Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.14


    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 256 GB SSD, MacOS 10.14

    Einmal editiert, zuletzt von iPhoneTruth ()

  • Die Fehlermeldung sieht aus als wenn du ein CPU-Problem hast.
    Was passier wenn du mit den gelb markierten Einstellungen spielst.
    Eventuell mal überall einen Haken setzen.



    :hackintosh:

  • Grad mal alle Haken gesetzt. Gleiches Ergebnis, allerdings steht in der letzten Zeile nicht "8 table load failures" sondern "9 table load failures".


    Edit: wenn ich alle Haken weglasse heißt es "7 table load failures".
    Edit 2: Habe gerade mal auch noch "NoOemTableld" weggeklickt, dafür "Drop OEM" angeklickt. Ergebnis "2 table load failures".

    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 8GB DDR3 1600 MHz, Broadcom BCM94352HBM Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.14


    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 256 GB SSD, MacOS 10.14

    Einmal editiert, zuletzt von iPhoneTruth ()

  • Kannst du Booten, wenn du die ungepatchte DSDT aus "origin" in "patched" ablegst?

    Skylake Laptop: Lenovo E460 20ETS04U00, i5-6200U, HD520
    Kabylake Laptop: Dell Vostro 5370, i5-8250U, UHD 620
    Dell T20: Intel Xeon E3-1225 v3, MSI GeForce GT 710 2GD3H LP

  • Nein! Damit legt er vom Bootvorgang gleich einen sofortigen Neustart hin! ;(

    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 8GB DDR3 1600 MHz, Broadcom BCM94352HBM Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.14


    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 256 GB SSD, MacOS 10.14

  • Die DSDT hast du auch mit der F4 Taste im Clover Menü extrahiert mit dem aktuell verwendeten BIOS?


    :hackintosh:

  • Ja! Per F4 in Clover! Mit dem aktuellen BIOS!

    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 8GB DDR3 1600 MHz, Broadcom BCM94352HBM Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.14


    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 256 GB SSD, MacOS 10.14

  • Dann extrahiere die DSDT mal versuchweise neu, lege diese danach in "patched" ab und starte erneut, ohne auch nur igendendeine Einstellung im BIOS zu verändern.

    Skylake Laptop: Lenovo E460 20ETS04U00, i5-6200U, HD520
    Kabylake Laptop: Dell Vostro 5370, i5-8250U, UHD 620
    Dell T20: Intel Xeon E3-1225 v3, MSI GeForce GT 710 2GD3H LP

  • Habs getan. Und er startet damit. :thumbup:
    (Obwohl ich im BIOS nichts geändert hatte muß die alte DSDT wohl irgendwelche Fehler gehabt haben, oder ich habe der was eingefügt, was dann die Fehler verursacht hat.)


    Gehe nun schrittweise vor:
    • Habe zuerst die DSDT von Fehlern befreit! Neustart! Er bootet damit!
    • Dann toledo AMI-Clean Compile! Er bootet damit!


    -> Endlich ein Weg aus der Sackgasse!
    Ich berichte dann, wenn ich weiter bin und die restlichen Patches eingefügt habe!


    Euch schon mal besten Dank!

    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 8GB DDR3 1600 MHz, Broadcom BCM94352HBM Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.14


    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 256 GB SSD, MacOS 10.14

  • Vielleicht würde dann jetzt mit den richtigen Patches der VoodooI2C.kext und der VoodooI2CHID.kext laufen.


    https://voodooi2c.github.io/#Installation/Installation

    Und du findest noch gefallen am ACPI Tasten Patch in der DSDT. :D


    :hackintosh:

  • So! Es läuft … :klatschen:


    Folgende Patches sind alle drin!


    Würdet Ihr noch andere Patches empfehlen?


    @anonymous writer
    Guten Morgen! In vielfacher Hinsicht! :)
    Habe nämlich die Patches für VoodooI2C in die DSDT eingepflegt und die entsprechenden Kexte in die EFI reingelegt, gestartet und … er hat sie gefressen. :):)
    Der Eintrag erscheint nun in der IOReg-Datei, die ich hier anhänge. Da kann man auch sehen, daß das Touchpad ein ELAN 0501 ist.
    Allerdings funktioniert der Touchscreen dadurch noch nicht! :(
    Da fehlt wohl noch das GPIO Pinning. Dazu brauche ich wohl noch Deine Hilfe, @anonymous writer :thumbup:

    Dateien

    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 8GB DDR3 1600 MHz, Broadcom BCM94352HBM Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.14


    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 256 GB SSD, MacOS 10.14

    10 Mal editiert, zuletzt von iPhoneTruth ()

  • In der Zwischenzeit habe ich eine BRC94352Z DW1560 eingebaut. Sie läuft auch schon. :)


    Allerdings funktioniert Bluetooth nicht. :(
    Es wird auch in den Systemeinstellungen kein Bluetooth angezeigt. Auch im Systembericht steht, daß keine Informationen gefunden wurde.
    Das war übrigens schon bei der alten WLAN-Karte so, nachdem ich das System neu aufgespielt hatte. Davor ging Bluetooth mit der alten WLAN-Karte.


    Wie bekomme ich da Bluetooth zum Laufen?

    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 8GB DDR3 1600 MHz, Broadcom BCM94352HBM Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.14


    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 256 GB SSD, MacOS 10.14