Sierra, High Sierra black screen nach wake - wahrscheinliche Lösung

  • Das Problem tritt nach wake Versuch auf, abhängig von der Konfiguration der config.plist mal nach kurzer Zeit, meistens jedoch nach längerer Zeit.
    Der Rechner scheint zu arbeiten, jedoch das Bild bleibt schwarz. Das einzige was man machen kann ist Neustart. OS Sierra, High Sierra, alle Versionen waren bei mir betroffen. Grafikkarte GTX 960.


    Was ich ausprobiert habe: hunderte Konfigurationen, alle Darkwake Varianten, Sleep Image löschen, HibernationFixup-e, standard-DSDT Patches, usw. Nix hat geholfen, hatte immer wieder random black screen nach wake. Oft war ich schon fast sicher, dass ich es erledigt hatte, nach dem nächsten wake - black screen. El Capitan hat mit sleep/wake überhaupt kein Problem bei mir.


    Die (höchstwahrscheinliche) Lösung, die für mich bis Dato, nach 3 Tagen Tests (2 x ganze Nacht) unterschiedlicher sleeps erfolgreich ist:


    HaltEnabler, SuspendOverride, SlpSmiAtWake in clover angehakt, hibernatemode 0, womp 0, networkoversleep 0.
    Ein leeres Sleep Image wurde früher erstellt.

  • @Altemirabelle Moin
    Wie oder wo hast du diese Werte gesetzt? "hibernatemode 0, womp 0, networkoversleep 0"

     iMacPro1,1  Im PowerMac G5 Wakü ● GA Z77-UD3H ● i7 3770K @4,4Ghz ● G.SKILL 16 GB DDR3 2400
    Sapphire Radeon RX Vega 56 ● WIFI+BT BCM94360CD PCI-E Card ● Samsung 500GB SSD Evo 850
    Style/Umbau - zum Showroom hier lang
     MacBookPro10.1  Lenovo G500 i5 3230m ● 2x4 GiByte DDR3 ● SSD 120 ● WIFI BCM94312MCG
     MacBookAir5,2  Lenovo G500 i5-3320m ● 4 GiByte DDR3 ● SSD 240 ● WIFI+BT BCM94352HMB

  • @Altemirabelle würdest du mir die TerminalBefehle bitte geben, ich habe es da so garnicht mit ;-)

     iMacPro1,1  Im PowerMac G5 Wakü ● GA Z77-UD3H ● i7 3770K @4,4Ghz ● G.SKILL 16 GB DDR3 2400
    Sapphire Radeon RX Vega 56 ● WIFI+BT BCM94360CD PCI-E Card ● Samsung 500GB SSD Evo 850
    Style/Umbau - zum Showroom hier lang
     MacBookPro10.1  Lenovo G500 i5 3230m ● 2x4 GiByte DDR3 ● SSD 120 ● WIFI BCM94312MCG
     MacBookAir5,2  Lenovo G500 i5-3320m ● 4 GiByte DDR3 ● SSD 240 ● WIFI+BT BCM94352HMB

  • Das wäre dann:

    Code
    1. sudo pmset -a hibernatemode 0
    2. sudo pmset -a womp 0
    3. sudo pmset -a networkoversleep 0

    Gruß
    Al6042


    Asus Prime Z390-A 1005 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.4 | Clover 4920

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.14.4 | Clover 4920

    NUC7i5BNK 0076 | i5 7260U | 16GB | HD640 | NVMe 500 GB | macOS 10.14.4 | Clover 4920

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.4


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!


    al6042.png

  • @al6042 Dankeschön,


    Hat leider keinen Effekt bei mir. Warte nun auf Version 10.13.4 und die entsprechend neunen NvidiaWebDriver.

     iMacPro1,1  Im PowerMac G5 Wakü ● GA Z77-UD3H ● i7 3770K @4,4Ghz ● G.SKILL 16 GB DDR3 2400
    Sapphire Radeon RX Vega 56 ● WIFI+BT BCM94360CD PCI-E Card ● Samsung 500GB SSD Evo 850
    Style/Umbau - zum Showroom hier lang
     MacBookPro10.1  Lenovo G500 i5 3230m ● 2x4 GiByte DDR3 ● SSD 120 ● WIFI BCM94312MCG
     MacBookAir5,2  Lenovo G500 i5-3320m ● 4 GiByte DDR3 ● SSD 240 ● WIFI+BT BCM94352HMB

    Edited once, last by Schorse ().

  • @Altemirabelle: Nutzt Du für die Nvidia GTX die Webdriver in Kombination mit der NvidiagraphicsFixup-Kext und Lilu?
    In dem Fall bitte mal in Clover bei den boot-args folgende 3 Argumente durchprobieren und jeweils testen:


    ngfxpatch=cfgmap
    ngfxpatch=vit9696
    ngfxpatch=pikera


    Hintergrund:
    Siehe auch hier (https://github.com/lvs1974/NvidiaGraphicsFixup)


    Der NvividaGraphicsFixup-Kext benutzt standardmäßig die Methode ngfxpatch=vit9696 zum Patchen wenn man nicht explizit ein anderes boot-arg angibt.
    Ich stand damals mit dem Entwickler dazu in Kontakt, weil ich genau das gleiche Problem hatte: BlackScreen nach Wakeup bei Nutzung von NvidiaGraphicsFixup. Ohne NvidiagraphicsFixup und der Nutzung von PikerAs Kext to Patch hatte ich die Probleme nicht mehr.
    Das führte dazu das der Entwickler über die Bootargs 3 Methoden in die Kext implementiert hat um hier flexibel eine auswählen zu können.


    Hier auch mal der Kext to Patch für Clover:
    Name: AppleGraphicsDevicePolicy
    Find: 626F6172 642D6964
    Replace: 626F6172 642D6978
    Comment: (c)Pike R. Alpha


    Bei mir hat die Variante von pikera das Problem mit den Blackscreens nach Wakeup gelöst. Eventuell klappt das bei Dir ja auch? Probieren macht klug :-)


    cheers


    PS: Bei mir nutze ich darkwake=10. Alle anderen von Dir aufgeführten Einstellungen für hibernatemode etc. habe ich nicht getätigt.

    _______________________________________________________________________________

  • @elmacci WOW, das ist es! Wakeup ohne Verzögerung... DANKE

     iMacPro1,1  Im PowerMac G5 Wakü ● GA Z77-UD3H ● i7 3770K @4,4Ghz ● G.SKILL 16 GB DDR3 2400
    Sapphire Radeon RX Vega 56 ● WIFI+BT BCM94360CD PCI-E Card ● Samsung 500GB SSD Evo 850
    Style/Umbau - zum Showroom hier lang
     MacBookPro10.1  Lenovo G500 i5 3230m ● 2x4 GiByte DDR3 ● SSD 120 ● WIFI BCM94312MCG
     MacBookAir5,2  Lenovo G500 i5-3320m ● 4 GiByte DDR3 ● SSD 240 ● WIFI+BT BCM94352HMB

  • Super, freut mich das es bei Dir geholfen hat! :-)


    cheers

    _______________________________________________________________________________

  • @elmacci


    OK wunderbar, selbstverständlich werde ich auch diese Lösung testen. Wenn das schon dem Schorse geholfen hat! :D


    Um es kurz zu bestätigen, du hast den NvividaGraphicsFixup-Kext entfernt und den Kext to Patch für Clover von Pike R. Alpha gemacht
    (was bewirkt: replaces board-id with board-ix) – also Find: 626F6172 642D6964...?
    Weil problematisch war die Mehode von vit9696 in dem NvividaGraphicsFixup?


    EDIT.
    Kext to Patch gemacht, NvividaGraphicsFixup-Kext entfernt, jetzt mal testen. Wird lange dauern. Der Rechner muss verschieden lange sleeps durchstehen.


    EDIT2.
    Test1 - 31 Min - positiv.

  • Ob KextToPatch oder NvdiaiGraphicsFixup mit entsprechendem bootarg ist erstmal egal - beide Wege führen nach Rom :)
    Allerdings ist die Variante mit dem Boot-Arg charmanter, da:
    1) Auch noch die cfgmap-Methode probiert/ausgewählt werden kann falls pikera nicht klappt
    2) Diverse weitere Fixes der NvidiaGraphicsKext weiter zur Anwendung kommen - unter anderem die LibraryValidation die dafür sorgt das z.B. der Transparenz-Bug in iBooks behoben wird


    KextToPatch oder bootarg mit pikera haben bei mir den gleichen positiven Effekt.
    Beispiel bzw. Hintergrundanmerkung :-) : Ich konnte mit meinem Setup glücklicherweise recht schnell testen welche Methode funktioniert und musste nicht erst mehrere SleepCycles abwarten und testen.
    Warum? Ich betreibe meinen Hackintosh mit 3 Monitoren, jeweils am Displayport. Der Monitor in der Mitte zeigt den Bootscreen an. Sobald die Webdriver initialisiert wurden konnte ich folgendes Verhalten beobachten je Patchmethode:


    Verhalten 1) Bei Anwendung des KextToPatches von Piker oder des entsprechenden bootargs blieb der mittlere Monitor immer der Hauptmonitor, den ganzen Bootvorgang über
    : BIOS -> CloverScreen -> Apfel-Logo -> Initialisierung Webdriver -> Apfel Logo -> Login Screen


    Verhalten 2) Bei Anwendung ohne KextToPatch/ohne Bootarg (sprich, Standardmethode vit9696) oder mit Bootarg cfgmap wechselte der Hauptmonitor kurzzeitig vom mittleren Monitor zum rechten Monitor:
    BIOS -> CloverScreen -> Apfel-Logo -> Initialisierung Webdriver -> rechter Monitor wurde grau, Apfel-Logo erscheint auf rechtem Monitor -> Login-Screen erscheint dann wieder auf dem mittleren Monitor


    Sprich, bei der Initialisierung der Webdriver "verschaltet" sich in Verhalten 2) irgendwas in der Bildübertragung bzw. Bildzuweisung an die Monitore. Was dann beim Erscheinen des Login-Screens zwar wieder korrigiert ist, aber irgendwas scheint da auf jeden Fall nicht ganz optimal zu sein. Und bei der PikerA-Methode gibt es diese "Verschaltung" nicht.


    Meine These war also: Wenn es diesen kurzzeitigen Sprung auf den rechten Monitor gibt --> potenzielles Wake-Problem. Wenn nicht --> Alles paletti. Und das hat sich dann bewahrheitet :-)


    @Altemirabelle Ich bin gespannt ob es funktioniert. Der erste Test sieht ja schon recht positiv aus. :klatschen:


    cheers

    _______________________________________________________________________________

  • Also echt, das bringt die Sache definitiv nach vorne! Danke schön!


    Test2 - 45 Min. Sleep - positiv.
    Test3 - 58 Min. Sleep - positiv.


    Es hat noch einen zusätzlichen Effekt:
    Diese Artefakte die Während der Schaltung auftauchen, also weisse Linien auf schwarzem Bildschirm sind plötzlich nicht mehr zu sehen. :)

  • Na das sieht doch bislang ganz gut aus - ich drücke weiterhin die Daumen :-)


    Den zweiten Teil habe ich aber ehrlich gesagt nicht so wirklich verstanden - welche Artefakte traten denn bei Dir auf, in welcher Situation, zu welchem Zeitpunkt?


    Wenn Sie jetzt weg sind um so besser, aber rein aus Neugierde würde es mich dennoch mal interessieren ;)


    cheers

    _______________________________________________________________________________

  • Echt schwer zu erklären, ist eine art Störung. Sieht aus wie Kratzer, weisse horizontale Linien auf dem schwarzen Bildschirm. Dauert echt kurz, Bruchteil von Sekunden. Erscheint wenn die Karte die Schaltung macht, bei der Initialisierung des Webdrivers. Ist jetzt nach 3 Starts nicht mehr zu sehen. Hat mich zwar gestört, jedoch dachte ich, das ist ein Problem der Grafikkarte.

  • Ah, ok. Danke für die Beschreibung - hatte das noch nie bzw. auch noch nicht davon gehört.
    Wenn es jetzt weg ist, um so besser :-)

    _______________________________________________________________________________

  • @elmacci Ich habe den NvividaGraphicsFixup-Kext in EFI gelassen, da mir die wechselnde Bildschirmauflösung, boot in 3840x2160, Anmeldung in HD und Benutzeroberfläche in 3008x1692 nicht gefällt.

     iMacPro1,1  Im PowerMac G5 Wakü ● GA Z77-UD3H ● i7 3770K @4,4Ghz ● G.SKILL 16 GB DDR3 2400
    Sapphire Radeon RX Vega 56 ● WIFI+BT BCM94360CD PCI-E Card ● Samsung 500GB SSD Evo 850
    Style/Umbau - zum Showroom hier lang
     MacBookPro10.1  Lenovo G500 i5 3230m ● 2x4 GiByte DDR3 ● SSD 120 ● WIFI BCM94312MCG
     MacBookAir5,2  Lenovo G500 i5-3320m ● 4 GiByte DDR3 ● SSD 240 ● WIFI+BT BCM94352HMB

  • tip-top, @Altemirabelle, endlich keinen sporadischen schwarzen Schirm mehr. Vielen Dank für's "Rausfummeln" und teilen!!!