Road zum Goldenen Hackintosh

  • Hey,
    Mein Hacki (Siehe Signatur) läuft jetzt auf High Sierra ^^
    Leider habe ich einige Probleme um den Hackintosh "Golden" bzw. völlig funktionstüchtig zu machen :D
    Also folgende Probleme:
    1. HS startet vom USB Stick ohne Probleme und auch echt schnell allerdings startet er von der normalen Boot Disk nicht.
    EFI ist bei beiden gleich...
    Die normale Boot Disk hängt sich immer bei Busy timeout [] (60s) AppleACPICPU auf...


    2. Sleep funktioniert, naja teilweise... Die Lüfter sind weiterhin an. Also ist das einzige was funktioniert, dass der Bildschirm kein Signal mehr hat und wenn ich wieder an
    die Tastatur gehe muss ich mich halt wieder einloggen. Daraus ziehe ich dass die Sleep-Funktion "funktioniert" ... :huh:


    3. iMessage und Facetime funktionieren immernoch nicht und das obwol ich eigentlich alles beachtet habe.


    4. Es funktionieren leider nur 3 USB Steckplätze (alle USB 3.0) Ich bin höchstwahrscheinlich bei der HCKCN 2018 dabei. Vlt. Kann mir da dann jmd mit dem eigenen Kext helfen ;-)


    5. Er startet bei der Benutzung von AE und/oder Premiere nach ner Zeit neu. Auch wenn das nur bei starker Last passiert ist das halt ärgelich. Es gibt keinen Log beim Restart. (Ist kein Hardware Problem, denn unter der Windows Partition läuft AE und Premiere)


    Danke fürs Lesen
    Felix

  • Hast du nur eine ssd/festplatte oder mehrere weil windows/mac installiert sind...

    Gruß
    Jan

  • Ich habe eine SSD auf der Früher Windows und Mac installiert war. Jetzt habe ich nur noch MacOS installiert allerdings habe ich schon eine neue Partition für Windows angelegt ^^ Warum die Frage? :D

  • Ich hatte 2 platten und 2 EFI partitionen. Da gab es ärger... nachden es nur noch eine EFI gab funktionierte Clover!

    Gruß
    Jan

  • Clover funktioniert ja es bleibt nur hängen... Aber die ganzen Kexte sind da Naja.... :|

  • ein Foto und der clover ordner selbst wären cool :)

  • Oooops habe gerade gesehen dass auf meiner OSXEfi ein nvram.plist lag... Nachdem ich die gelöscht habe (natürlich auch ein Backup gemacht) bootet er wieder von der SSD ;)
    Problem 1 gelöst :danke:

  • Bei den x-er Boards halte ich mich zurück, da kann ich nichts zu beitragen... :)

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Danke trotzdem ^^ Bei Sierra hat's funktioniert ich weiß echt nicht warum jetzt nicht mehr...
    Meine EFI ist im Anhang btw. ^^

  • Ja das hab ich Probiert funktioniert nur leider nicht... Ist schon komisch dass nur 3 USB Ports funktionieren und all die USB 3 sind und nicht USB 2 ... :|

  • Kext as Kext can oder USB 3.0 ohne USBInjectAll


    Meiner Meinung nach die beste Lösung zwecks USB, die uns hier der @Brumbaer präsentiert und entwickelt hat.

    Computerbau - Bei Interesse PN!

    Delidding Service - Skylake/Kaby Lake/Coffee Lake/Skylake X - Bei Interesse PN!


  • Danke nur das Problem sind eher die USB 2.0 Ports nicht wirklich die USB 3.0er

  • Du verstehst nicht ganz wie das ganze funktioniert... Deine Ports müssen konfiguriert werden und dann laufen sie auch.
    Nimm mal einen USB 2.0 Stick und Stöpsel in einen USB 2.0 Port und du wirst feststellen das diese funktionieren aber eben nur mit nem USB 2.0 Gerät.

    Computerbau - Bei Interesse PN!

    Delidding Service - Skylake/Kaby Lake/Coffee Lake/Skylake X - Bei Interesse PN!


  • USB_Injector x99.kext ist nicht weiter entwickelt, wie es scheint. Das Ding ist schon 2 Jahre alt.
    Ich würde mir eine kext bauen, obwohl es nicht eine schnelle Nummer ist. Aber die beste.


    Und haben die schon mal funktioniert?

  • Danke... Unter Sierra hat es noch funktioniert... Naja :|
    Ich hab nur ein Problem... Ich habe keine Ahnung wie ich einen Kext schreiben soll... :whistling:

  • Das ganze ist mehr als ausführlich erklärt in dem von mir verlinkten Guide! Es kann keiner von uns den Kext für dich schreiben, da du selbst gewisse Schritte machen musst, damit man überhaupt die Kext schreiben kann! Lies dir das ganze in Ruhe durch und Probier es mit dem Guide, bei Problemen kannst du immer noch fragen!


    Edit: Oder benutz usbinjectall

    Computerbau - Bei Interesse PN!

    Delidding Service - Skylake/Kaby Lake/Coffee Lake/Skylake X - Bei Interesse PN!


    2 Mal editiert, zuletzt von DSM2 ()

  • Ich habs nochmal mit dem USBInjectAll ausprobiert und jetzt funktionieren alle Ports außer einer (HS14) Aber den kann ich selbst mit dem boot arg. nicht zum laufen bringen. Irgendwelche vorschlage? ^^