Sierra auf Asus F751lk-t4009h

  • Hallo und guten Morgen, ich brauche mal eure Hilfe, ich habe die unten angehängte EFI bekommen, anschließend einen USB-Stick erstellt und auch erfolgreich Sierra installieren können. Es funktioniert auch alle bis auf WIFI, aber das wird ja wieder an der Karte liegen wie immer. Jetzt wollte ich mir mal die config.plist im Clover-Configurator ansehen und da kam das sie nicht gelesen werden kann oder so ähnlich. Es zeigte diese nur in Textform an. Könnt ihr mir bitte erklären was es damit auf sich hat, oder könnt ihr die mir so abändern das es zu öffnen geht? Vielleicht sind ja auch ein paar Sachen enthalten die rausgelöscht werden können eventuell. Über Hilfe von euch würde ich mich sehr freuen, vielen Dank!


    LG Micha

    Dateien

    • EFI.zip

      (19,97 MB, 2 Mal heruntergeladen, zuletzt: )

    LG justl82


    System: Lenovo ThinkPad T420S, Intel Core i5-2520M, 2,50-3,2Ghz, 3MB Cache, 8 GB DDR3, IntelHD 3000, MAC OSX High Sierra



  • Das liegt daran, dass die Clover-Variante aus dem Juni 2016 stammt und somit seit 1,5 Jahren nicht mehr aktuell.
    Sowohl Clover als auch der Clover Configurator haben in der Zwischenzeit diverse Neuerungen erfahren.


    Um den Juni 2016 wurden die ersten Clover-Versuche mit den SIerra-Betas verteilt und noch jede Menge verfeinert...
    Erst ab Oktober 2016 gab es dann stabilere Versionen, die trotzdem noch weitere Anpassungen erfahren haben.
    Ich glaube nicht, das du damit viel Spaß haben wirst...


    Sinnvoller wäre es, die möglichst genauen Hardware-Details dieses Asus F75lk... in deine Signatur aufzunehmen und dann mit Unterstützung einen sauberen Stick mit aktueller Clover-Version zu erstellen.

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • @al6042 Ok aber du/ihr müsst mir dann aber bitte helfen da ich das nicht alleine hinbekomme. Dies war die erste Efi die funktioniert hat. Ich werde mal alles in meine Signatur aufnehmen.


    So jetzt müsste alles eingetragen sein.

    LG justl82


    System: Lenovo ThinkPad T420S, Intel Core i5-2520M, 2,50-3,2Ghz, 3MB Cache, 8 GB DDR3, IntelHD 3000, MAC OSX High Sierra



    Einmal editiert, zuletzt von justl82 ()

  • Wir werden unser Bestes tun... das geht aber nur wenn wir wissen, mit welchen Komponenten du dich herumschlagen musst.

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Keine Ahnung habe die Signatur eingegeben wird aber noch nicht angezeigt. So hier die wichtigsten Komponenten:


    F751lk-t4009h Notebook, Intel® Core™ i5 (4. Generation) 4210U Prozessor 2x 1,70 GHz, 8 GB DDR3, NVIDIA GeForce GTX 850M,
    Samsung 850 EVO 250GB, IntelHD 4400

    LG justl82


    System: Lenovo ThinkPad T420S, Intel Core i5-2520M, 2,50-3,2Ghz, 3MB Cache, 8 GB DDR3, IntelHD 3000, MAC OSX High Sierra



  • Kannst du die GTX850M im BIOS deaktivieren?

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Nein das geht leider nicht, ich habe da nur ganz wenige Einstellungen die man machen kann. Irgendwie muß der Typ ja auch umgangen haben von dem die EFI war. Deswegen kann ich auch die normalen Anleitungen hier nicht durchführen, wie gesagt das war die erste EFI die funktioniert hat. Vielleicht könnt ihr die irgendwie auseinandernehmen und rausfinden was der gemacht hat. Kann das auch mit der "dsdt" zusammenhängen, das der die angepasst hat?


    Die Einstellungen konnte ich machen im BIOS:


    Advanced:
    Intel Virtualization Technology - disable
    VT-d - disable
    SATA Configuration: SATA Mode Selection: AHCI
    Graphics Configuration: DVMT Pre-Allocation: 64M (128M didn't work for this guide)
    Network Stack Configuration: Network Stack - disabled
    USB Configuration: Legacy USB Support - enabled
    XHCI Pre-Boot Mode - enabled
    USB Mass Storage Driver - enabled
    Boot: Boot Configuration: Launch CSM - enabled
    Boot Option Priorities: select the USB stick, see next line Add New Boot Option: you might want to add your USB stick here Security: Secure Boot Mode: disable

    LG justl82


    System: Lenovo ThinkPad T420S, Intel Core i5-2520M, 2,50-3,2Ghz, 3MB Cache, 8 GB DDR3, IntelHD 3000, MAC OSX High Sierra



  • Ich habe da mal versucht aus den wenigen Infos über das Gerät und dessen weiteren Einzelheiten, ein Paket für dich zusammen zu stellen.

    Dateien

    • EFI.zip

      (12,11 MB, 1 Mal heruntergeladen, zuletzt: )

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Ich werde es heute Nachmittag ausprobieren, und melde mich dann bei dir, vielen Dank. Was brauchst du denn noch für Infos über das Gerät?

    LG justl82


    System: Lenovo ThinkPad T420S, Intel Core i5-2520M, 2,50-3,2Ghz, 3MB Cache, 8 GB DDR3, IntelHD 3000, MAC OSX High Sierra



  • Ich bräuchte die komplette Liste der PCI-Geräte und Details zu Audio und USB-Geschichten, welche du mit folgender Anleitung zusammentragen kannst:
    https://www.hackintosh-forum.d…inem-Ger%C3%A4te-verbaut/

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Ok mache ich dir, ganz lieben Dank für deine Hilfe bis hierhin. :thumbup:


    #Edit: Die Dateien habe ich unten Angehängt.

    Dateien

    • codec00_dump.txt

      (2,18 kB, 1 Mal heruntergeladen, zuletzt: )
    • PCI.txt

      (1,05 kB, 2 Mal heruntergeladen, zuletzt: )
    • USB.txt

      (290 Byte, 1 Mal heruntergeladen, zuletzt: )

    LG justl82


    System: Lenovo ThinkPad T420S, Intel Core i5-2520M, 2,50-3,2Ghz, 3MB Cache, 8 GB DDR3, IntelHD 3000, MAC OSX High Sierra



    Einmal editiert, zuletzt von justl82 ()

  • Wie ich sehe, hast du die "Bearbeiten"-Funktion gefunden und erfolgreich eingesetzt... :thumbsup:


    Diese Variante gilt hier grundsätzlich zur Aktualisierung, falls du den letzten Post in einem Thread geschrieben hast, da User nicht auf ihre eigenen Beiträge antworten dürfen (SPAM-Schutz) -> https://www.hackintosh-forum.d…tr%C3%A4ge-aktualisieren/


    Ich schaue mir dir Daten gleich mal an, kann aber für heute erstmal nichts weiter tun, da ich gleich auf Achse bin... ;)

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Sehr gut danke für den Hinweis ich habe mich schon gewundert. Also bis jetzt Installiert er noch fröhlich mit deinem Ordner mal sehen wie weit ich komme du kannst ja den Ordner noch ein wenig Verfeinern und ich Kopiere ihn dann darüber.

    LG justl82


    System: Lenovo ThinkPad T420S, Intel Core i5-2520M, 2,50-3,2Ghz, 3MB Cache, 8 GB DDR3, IntelHD 3000, MAC OSX High Sierra



  • @al6042 Hi, also deine EFI die du auf die Schnelle erstellt hat läuft erstmal soweit super, es funktioniert sogar iMessage und Facetime, wahnsinn! Sound klappt auch soweit, Webcam, WIFI habe ich selbst hinbekommen. Mir fällt auch erstmal nur ein das Hell/Dunkel nicht geht mit der Tastatur und das komplette TouchPad, hast du da noch Ideen was ich machen könnte?

    LG justl82


    System: Lenovo ThinkPad T420S, Intel Core i5-2520M, 2,50-3,2Ghz, 3MB Cache, 8 GB DDR3, IntelHD 3000, MAC OSX High Sierra



  • Für den Hell/Dunkel Regler per Tastatur wäre erst mal spannend zu wissen, ob unter Systemeinstellungen -> Monitor ein Helligkeitsregler angeboten wird und dieser bei Nutzung auch hoch und runter regeln kann.
    Wenn das nicht der Fall ist, gibt es zwei Möglichkeiten.
    1.
    In deiner Config.plist, unter Acpi -> DSDT -> Fixes, setzt du den Haken bei "2"->"AddPNLF", startest neu und schaust mal was daraus wurde.
    Sollte der Regler in den Systemeinstellungen aufgetaucht sein, besteht aber immer noch die Chance, dass die Tastenbelegung für diese Funktion nicht dem vorgedruckten Standard entspricht.
    2.
    Der Brightness-Patch wird, zusammen mit ein paar anderen Patches, in eine DSDT.aml gepackt, mit der du dass dann testen kannst.


    "das komplette Touchpad" bedeutet nun, dass dies überhaupt nicht zu nutzen ist?
    Wenn ja, wird es daran liegen, dass der VoodooPS2Controller.kext die verbaute Hardware nicht unterstützt.
    An der Stelle ist es ratsam das Ganze auch über einen anderen Kext zu testen -> ElanTouchpad / SmartTouchpad

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Hi, Danke für deine Ideen werde ich mal alles Testen. Zu dem Touchpad, ja es geht garnicht, weder die links/rechts Taste und auch das Touchfeld an sich. Den VoodooPS2Controller.kext habe ich ja drin also werde ich das mal mir der zweiten Variante versuchen. Danke!

    LG justl82


    System: Lenovo ThinkPad T420S, Intel Core i5-2520M, 2,50-3,2Ghz, 3MB Cache, 8 GB DDR3, IntelHD 3000, MAC OSX High Sierra



    3 Mal editiert, zuletzt von justl82 ()

  • Ne Frage noch, kann es sein das der Akku mehr Beansprucht wird als bei Windows? Kann man da irgendwas machen, oder ist das eben so?


    #Edit Das Touchpad funktioniert jetzt auch. Danke!

    LG justl82


    System: Lenovo ThinkPad T420S, Intel Core i5-2520M, 2,50-3,2Ghz, 3MB Cache, 8 GB DDR3, IntelHD 3000, MAC OSX High Sierra



  • @al6042 So ich mal wieder, nach ein paar Tagen glücklichem Arbeiten mit meinem Hackintosh habe ich noch ein paar Sachen zu Fragen.


    1. Helligkeitsregler funktioniert leider nicht, siehe Post 15. Der Regler ist aber da in den Einstellungen nur Regelt er nicht auf Hell/Dunkel.


    2. Mein HDMI-Anschluss geht leider nicht, oder besser Teilweise. Wenn ich den Stecker reinstecke wird das Bild schwarz am Laptop, kommt aber kein Bild am TV. Ziehe ich den Stecker wieder raus, geht das Bild am Laptop nicht mehr wieder an.


    Wenn andere User ausser @al6042 eine Idee haben immer her damit. Vielen Dank leute!


    LG

    LG justl82


    System: Lenovo ThinkPad T420S, Intel Core i5-2520M, 2,50-3,2Ghz, 3MB Cache, 8 GB DDR3, IntelHD 3000, MAC OSX High Sierra



  • Das heisst dann einfach nur, dass für diesen Laptop die bereits angesprochene, gepatchte DSDT fällig ist.
    Das ist aber nichts was nur ich kann, zudem wird der heutige Tag so umfangreich, dass ich erst morgen oder am Sonntag dran kommen würde.
    Also lass dir ruhig auch von anderen Usern helfen und warte nicht unbedingt auf mich.. ;)

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Deswegen habe ich auch geschrieben das mir auch gern andere User helfen können. Ich hänge einfach mal heute Nachmittag die Aktuelle EFI an und dann werden wir sehen. Entweder du schaust nochmal, oder jemand anderes nimmt sich der DSDT bitte mal an.


    LG

    LG justl82


    System: Lenovo ThinkPad T420S, Intel Core i5-2520M, 2,50-3,2Ghz, 3MB Cache, 8 GB DDR3, IntelHD 3000, MAC OSX High Sierra