"Wake reason: RTC (Alarm)" – mdnsresponder-/ Bonjour-/ Wake-Fix?

  • Moin zusammen!


    Ich denke viele kennen das Problem, dass der Hacky nach einiger Zeit im Sleep (meist nach 1-2 std) plötzlich die Fans hochfährt, ca. 3 Minuten so verweilt und dann wieder in den Sleep geht. In den meisten Fällen wird dabei das Display noch nicht mal aktiviert, dieser kleine Wake ist dann nur durch eventuelles Fan-Geräusch ausmachbar.
    Im Log erscheint dabei die Wake Reason: RTC (Alarm).
    Das Problem haben auch nicht nur Hackys, sondern ebenfalls echte Macs. Zutun hat es soweit ich mich erinnern kann mit dem Bonjour-Feature von OS X und mit dem mdnsresponder.
    Früher gab es dafür verschiedene Fixes, bei denen meist der mdnsresponder ein wenig angepasst wurde. Für aktuelle macOS Versionen sind mir jedoch solche fixes nicht bekannt.


    Gibt es derzeit einen zuverlässigen Fix für die RTC-Problematik? Vielleicht hat da ja jemand eine Idee :thumbup:

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

    Edited 2 times, last by kuckkuck ().

  • ich würde das eher mal an die tollen "neuen" Funktionen von macOS binden:


    Mit diesen Einstellungen wird der Rechner natürlich per RTC in aller Regelmäßigkeit kurz geweckt, um dort aufgeführten Funktionen auszuführen...
    Warum da nun noch Bonjour mit reinspielt, sollte noch genauer beobachtet werden.

    Gruß
    Al6042


    Asus Prime Z390-A 1005 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.6 | Clover

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.14.6 | Clover

    NUC7i5BNK 0076 | i5 7260U | 16GB | HD640 | NVMe 500 GB | Windows

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.6


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Ich hatte das Problem auch, allerdings alles, auch das "Enable Power Nap" ausgeschalten.


    Nach einigen Recherchen im Internet habe ich bei "Datum & Uhrzeit" das "Datum und Uhrzeit automatisch einstellen" deaktiviert, und dafür in "Energie sparen", "Netzteil" die Funktion "Ruhezustand bei WLAN-Netzwerkzugriffen beenden" aktiviert.


    Das letzte scheint widersprüchlich zu sein, hat aber genau zu dem gewünschten Ergebnis geführt:

    Heut nacht hat mein Hackbook brav geschlafen ohne alle zwei oder drei Stunden aufzuwachen und den Bildschirm anzumachen. Voila!

    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 16GB DDR3 1600 MHz, 480 GB SSD (Toshiba Q300), macOS Mojave 10.14.5


    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 512 GB SSD, macOS Mojave 10.14.6


    Hackmini: HP Compaq 8300 Elite, Intel Core i5-3470, 4 x 3,20 GHz, 8 GB RAM, Ivy Bridge, Nvidia Geforce GT 710 (Intel HD Graphics 2500), macOS Mojave 10.14.5

  • Hallo kuckkuck


    Was ist die RTC-Problematik?


    Hatte zum Testen mal diesen Kext versucht welche jedoch ab und zu Kernelpanik nach Sleep verursachte.

    https://github.com/acidanthera/RTCMemoryFixup

    Grüße und Good Hack Michael


    :hackintosh:

  • In diesem Fall meinte ich damit einfach nur das Problem, dass der Hacky alle paar Stunden aufwacht und RTC als WakeReason ausgibt ;)

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Muss ich mal beobachten. Ist mir noch gar nicht so aufgefallen.

    Grüße und Good Hack Michael


    :hackintosh:

    • Helpful

    Mein Z97 ist seit Mojave auch immer mal zwischendrin aufgewacht (ebenfalls RTC .....). Ich habe jetzt herausgefunden das es bei pmset einen neuen Parameter gibt: proximitywake. Seitdem das deaktiviert ist scheint Ruhe zu sein.

    Airportkompatible Karte trotz BIOS Whitelist? >> Klick <<

    -------------------------------------------------------------------------------------
    Habe mir gestern beim Harken den Haken in die Hacken gehauen

    -------------------------------------------------------------------------------------
    Bitte keine Supportanfragen auf meiner Pinnwand bzw. per PM. Dafür ist das Forum da!

  • Das ist dann wohl die Lösung. :thumbup:


    Auch wenn mir das nicht aufgefallen ist teste ich auch mal diese Lösung. Danke!

    Grüße und Good Hack Michael


    :hackintosh:

  • Sascha_77 Da ich da nicht so der Fachmann bin: Das heißt dann, daß ich im Terminal den folgenden Befehl eingebe?


    "sudo pmset -a proximitywake 0"

    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 16GB DDR3 1600 MHz, 480 GB SSD (Toshiba Q300), macOS Mojave 10.14.5


    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 512 GB SSD, macOS Mojave 10.14.6


    Hackmini: HP Compaq 8300 Elite, Intel Core i5-3470, 4 x 3,20 GHz, 8 GB RAM, Ivy Bridge, Nvidia Geforce GT 710 (Intel HD Graphics 2500), macOS Mojave 10.14.5

  • So sieht es aus.

    Airportkompatible Karte trotz BIOS Whitelist? >> Klick <<

    -------------------------------------------------------------------------------------
    Habe mir gestern beim Harken den Haken in die Hacken gehauen

    -------------------------------------------------------------------------------------
    Bitte keine Supportanfragen auf meiner Pinnwand bzw. per PM. Dafür ist das Forum da!

  • Das mußte ich heute früh auch feststellen: ich hatte über die Nacht verteilt sogar fast jede Stunde ein "Wake reason: RTC (Alarm)".

    Somit habe ich also das mit "sudo pmset -a proximitywake 1" rückgängig gemacht und wieder bei "Datum & Uhrzeit" das "Datum und Uhrzeit automatisch einstellen" deaktiviert, und dafür in "Energie sparen", "Netzteil" die Funktion "Ruhezustand bei WLAN-Netzwerkzugriffen beenden" eingestellt.

    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 16GB DDR3 1600 MHz, 480 GB SSD (Toshiba Q300), macOS Mojave 10.14.5


    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 512 GB SSD, macOS Mojave 10.14.6


    Hackmini: HP Compaq 8300 Elite, Intel Core i5-3470, 4 x 3,20 GHz, 8 GB RAM, Ivy Bridge, Nvidia Geforce GT 710 (Intel HD Graphics 2500), macOS Mojave 10.14.5

    Edited once, last by iPhoneTruth ().

  • Hat der Kext


    RTCMemoryFixup

    überhaupt etwas mit dem RTCwake zu tun ?


    Werde da nicht schlau draus mit excluden und so weiter ....


    Fahre jetzt auch mal längeren Test mit der Methode von iPhoneTruth


    Gruß

    Gigabyte Aorus B450 M Ryzen 2600 16 GB DDR4:love:

  • Bei mir führte der Kext nur zu gelegentlichen Kernelpaniken nach Sleep.

    Grüße und Good Hack Michael


    :hackintosh:

  • Hat er das RTCwake Problem gelöst ?

    Gigabyte Aorus B450 M Ryzen 2600 16 GB DDR4:love:

  • Nein, denke nicht. Meine Vermutung ist das der Laptop damit genau in diesen Wake Phasen abgestürzt ist. Nachdem ich den Laptop aus dem Schlaf holte nach längerer Zeit machte er sofort einen Neustart und brachte die Kernelpanik.

    Grüße und Good Hack Michael


    :hackintosh:

  • Interessanterweise zickt mein T530 und T440 überhaupt nicht rum. Habe dort alles so gelassen wie unter HS. Auch taucht dort proximitywake gar nicht erst auf. Das ist nur beim Z97.


    Sleep kann eine echt mysteriöse Sache sein. :/

    Airportkompatible Karte trotz BIOS Whitelist? >> Klick <<

    -------------------------------------------------------------------------------------
    Habe mir gestern beim Harken den Haken in die Hacken gehauen

    -------------------------------------------------------------------------------------
    Bitte keine Supportanfragen auf meiner Pinnwand bzw. per PM. Dafür ist das Forum da!

  • Bei RtcMemoryFixUp geht es eher um CMOS resets und restarts... Ich habe dazu hier etwas verfasst: RTCMemoryFixup.kext

    Bei der Kext gilt, dass einfaches Benutzen meistens keinen Sinn hat (bisschen wie USBInjectAll), sondern die Kext konfiguriert werden muss. Der Restart/Resets bei Benutzung der Kext ist "gewollt" könnte man sagen...


    Hier in diesem Thread geht es eher um das PowerNap feature, das für Wake Reason: RTC (Alarm) sorgt. Hier spielen eher noch Faktoren wie Systemeinstellungen, Darkwake und CPU-Powermanagement mit rein ;)

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Hatte auch das Problem, jede 2 Stunden hat sich mein Hack aufgeweckt trotz der deaktivierten PowerNAP. Leider weiß ich jetzt nicht mehr was da "wake reason" war.

    Dann habe ich in der Energie Einstellung die Standard wiederhergestellt, und wie gewünscht konfiguriert, danach war ruhe. Hat auf meinen Laptop funktioniert, sowie auf den Dell T20.

  • habe jetzt als bootflag darkwake=no gesetzt.

    Heute nacht keine RTC wakes bzw. wakes.


    Wenn das so bleibt, bin ich glücklich .....


    edit:

    proximitywake ist 1

    Gigabyte Aorus B450 M Ryzen 2600 16 GB DDR4:love:

    Edited once, last by shark ().