HowTo: RYZEN – El Capitan - Catalina

  • Den passenden Kernel gibt es hier ... AMD Kernel Bronya (Ryzen)


    Ganz vereinfacht gesagt machst du von deinem laufenden El Capitan eine Kopie mit CCC, SuperDuper oder Clonezilla, setzt den AMD Kernel ein und erneuerst den PrelinkenKernel, als Bootloader verwendest du entweder Enoch oder Clover.


    Ozmosis Support für macOS Mojave/Catalina ausschließlich über das Postfach, im Rahmen der Hilfe vor Ort und oder auf dem Stammtisch.

  • Ich hab eine RX460 im Ryzen laufen, also keine Nvidia. Es ist so, dass wohl alle Karten minimal langsamer laufen (wovon ich nichts merke), Nvidia-Karten mit Webtreiber (!) bis zu 50% langsamer. Gerade wenn auch Linux drauf soll würde ich keine Nvidia nehmen, da handelt man sich mit den Closed-Source Treibern nur Abhängigkeiten zu alten Kernels ein. Eine RX560 wäre für dich wahrscheinlich die beste Wahl, die schnelleren RX570/580 sind wegen Mining im Moment wieder kaum zu haben.

    iHack: Ryzen 5 1600, GA-AB350M-D3H, Sapphire RX570 4GB, 16GB DDR4-3000, 250GB NVMe SSD + 512GB SSD + 1TB HDD, Clover, macOS 10.15.1, Kubuntu 19.10, Win 8.1


    alter iHack: i3-4330, GA-H81M-HD3, Sapphire RX460 4GB -> RX560 BIOS, 8GB DDR3-1600, 128GB SSD, 250GB HDD, Clover, macOS 10.15.1, Kubuntu 19.10, Win 8.1


    ThinkPad T410: i5-520M, Nvidia NVS3100M, 4GB DDR3-1066, 120GB SSD, 250GB HDD, Clover, macOS 10.14.6


    Bastlerware: Acer Aspire 7741G: i5-430M, ATI HD 5650 1GB; 4GB DDR3-1066; 250GB HDD, Clover, macOS 10.13.6, 1.5 von 2 SATA-Ports defekt...


    Originals: MacBook Pro 15 Late 2013 (macOS 10.15.1), iPhone X 64GB (iOS 13.2)

  • Der Clover Stick wird nicht erkannt


    In Windows EasyUEFI Version 2.7 installieren.


    Manage EFI Boot Option


    Die EFI vom Stick wird nicht erkannt


    Create a new Entry


    Linux or other OS auswählen


    Den Stick wählen, und Browse


    Die Boot64.efi auswählen


    Oben rechts einen Namen beispielsweise macos eintragen


    Ok und schließen. Jetzt sollte im Bios der Eintrag macos auftauchen.

    AMD X4 605e - Scythe Ninja Plus - N68-S3 UCC - 8400 GS - Enermax Digifanless 550W Platinum

    AMD 3 1200 - Nofan CR-80EH - A320M-DGS - GT710 Passiv - Enermax Digifanless 550W Platinum

    AMD 7 3700X - Nofan CR-95C - GA-A320M-S2H - RX460Passiv - Silentmaxx Fanless II 500 Platinum

    Intel i3 4330 - Nofan CR-95C - H81M-C - 16GB - Intel HD 4600 - Seasonic X-Series Fanless X-400FL

    Intel i5-6500T - Coollink Corator - B250ME - 1050ti.Passiv - SuperFlower GoldenSilent Fanless Platinum

    Edited 5 times, last by ralf. ().

  • In dem Forum kam ich nicht zurecht es gibt der App aber auch hier https://github.com/chris1111/macOS-High-Sierra-HD/releases

    iMac 18,3 : Acer 27'' WQHD: Asrock Fatality Z270 Gaming K4 - Intel i5-7600K - 16GB DDR4 Intenso - Palit GT710 2GB *OBB - macOS 10.14.x - Clover

  • Okay, danke für den Tipp. Baue ich mit ein.

    AMD X4 605e - Scythe Ninja Plus - N68-S3 UCC - 8400 GS - Enermax Digifanless 550W Platinum

    AMD 3 1200 - Nofan CR-80EH - A320M-DGS - GT710 Passiv - Enermax Digifanless 550W Platinum

    AMD 7 3700X - Nofan CR-95C - GA-A320M-S2H - RX460Passiv - Silentmaxx Fanless II 500 Platinum

    Intel i3 4330 - Nofan CR-95C - H81M-C - 16GB - Intel HD 4600 - Seasonic X-Series Fanless X-400FL

    Intel i5-6500T - Coollink Corator - B250ME - 1050ti.Passiv - SuperFlower GoldenSilent Fanless Platinum

  • Welches ist das beste SMBios für Ryzen 5 1400 und RX560 ???

    iMac 18,3 : Acer 27'' WQHD: Asrock Fatality Z270 Gaming K4 - Intel i5-7600K - 16GB DDR4 Intenso - Palit GT710 2GB *OBB - macOS 10.14.x - Clover

  • Aufgrund der AMD Karte iMac15,1 iMac16,2 iMac17,1und iMac18,2 (Radeon Pro 550/560) und dann durch Benchmark testen welches am besten läuft, die CPU ist wegen AMD weniger bis garnicht entscheident.


    Ozmosis Support für macOS Mojave/Catalina ausschließlich über das Postfach, im Rahmen der Hilfe vor Ort und oder auf dem Stammtisch.

    Edited 2 times, last by derHackfan ().

  • OK läuft ganz gut nur ich brauche die Plastik Halter die auf dem Mainboard geschraubt sind für den Kühler für AM4 finde ich niergendswo keine lust mir ne Neue Wasserkühlung zu kaufen.

    iMac 18,3 : Acer 27'' WQHD: Asrock Fatality Z270 Gaming K4 - Intel i5-7600K - 16GB DDR4 Intenso - Palit GT710 2GB *OBB - macOS 10.14.x - Clover

  • Bei Atelco und K&M gab es im Store die Retention Module für 5€ aus der Schublade vom Monteur, vielleicht hast du einen Laden in der Nähe?


    Ozmosis Support für macOS Mojave/Catalina ausschließlich über das Postfach, im Rahmen der Hilfe vor Ort und oder auf dem Stammtisch.

  • Hab jetzt aus China bestellt


    EDIT: Habe es dann jetzt mal ohne Wakü schonmal eingebaut nun musste ich feststellen dann mit meiner RX560 der HDMI und der Display Port zusammen nicht gehen einzeln gebootet laufen beide aber nicht zusammen ? Ich nutze Whatevergreen ? Weiß jemand einen rat ?


    Und auch hier läuft der Ryzen hacklig


    Wenn ich versuche meine Windows 10 VM zu starten bleibt der Rechner immer hängen komisch

    iMac 18,3 : Acer 27'' WQHD: Asrock Fatality Z270 Gaming K4 - Intel i5-7600K - 16GB DDR4 Intenso - Palit GT710 2GB *OBB - macOS 10.14.x - Clover

    Edited 4 times, last by SirusX ().

  • @ralf.


    laufen bei dir auf dem Board alle USB auch 3.1 usw und laufen auch Wlan Sticks BT Sticks oder ne PCIE WLAN/BT Karte ?

    iMac 18,3 : Acer 27'' WQHD: Asrock Fatality Z270 Gaming K4 - Intel i5-7600K - 16GB DDR4 Intenso - Palit GT710 2GB *OBB - macOS 10.14.x - Clover

  • An jedem Anschluss kann ich USB2-Sticks betreiben. USB3-Sticks gehen nur hinten (am USB3.1-Anschluß).
    Habe ich hier genauer erklärt.
    BT Sticks oder ne PCIE WLAN/BT Karte hab ich noch nicht getestet.

    AMD X4 605e - Scythe Ninja Plus - N68-S3 UCC - 8400 GS - Enermax Digifanless 550W Platinum

    AMD 3 1200 - Nofan CR-80EH - A320M-DGS - GT710 Passiv - Enermax Digifanless 550W Platinum

    AMD 7 3700X - Nofan CR-95C - GA-A320M-S2H - RX460Passiv - Silentmaxx Fanless II 500 Platinum

    Intel i3 4330 - Nofan CR-95C - H81M-C - 16GB - Intel HD 4600 - Seasonic X-Series Fanless X-400FL

    Intel i5-6500T - Coollink Corator - B250ME - 1050ti.Passiv - SuperFlower GoldenSilent Fanless Platinum

    Edited once, last by ralf. ().

  • Misst das wäre mir total wichtig würde mir sonst heute ein anderes Board bestellen bei dem jetztigen läuft meine neue BCM94360CS das BT nicht richtig und kann auch nicht per Apple Watch entsperren.

    iMac 18,3 : Acer 27'' WQHD: Asrock Fatality Z270 Gaming K4 - Intel i5-7600K - 16GB DDR4 Intenso - Palit GT710 2GB *OBB - macOS 10.14.x - Clover

  • Ich schaffe es vielleicht diese Woche noch, Bluetooth-Sticks zu testen. Allerdings hab ich keine Apple-Watch,

    AMD X4 605e - Scythe Ninja Plus - N68-S3 UCC - 8400 GS - Enermax Digifanless 550W Platinum

    AMD 3 1200 - Nofan CR-80EH - A320M-DGS - GT710 Passiv - Enermax Digifanless 550W Platinum

    AMD 7 3700X - Nofan CR-95C - GA-A320M-S2H - RX460Passiv - Silentmaxx Fanless II 500 Platinum

    Intel i3 4330 - Nofan CR-95C - H81M-C - 16GB - Intel HD 4600 - Seasonic X-Series Fanless X-400FL

    Intel i5-6500T - Coollink Corator - B250ME - 1050ti.Passiv - SuperFlower GoldenSilent Fanless Platinum

  • Also bei mir laufen alle USB-Ports, ich kann einen USB3-Stick sowohl Vorne als auch Hinten betreiben. Ich habe gerade ein paar Tests gemacht:
    USB3.0-Stick (Kingston wasweißich, nicht schnell, aber schneller als USB2)

    • USB3.0-Port Vorne (Chipsatz): 116MB/s lesen -> mehr als USB2
    • USB3.0-Port Hinten (Ryzen CPU): 96MB/s lesen (Kann am Stick liegen) -> mehr als USB2
    • USB3.1-Port Hinten: Stick wird nicht erkannt, ein USB2-Stick hingegen schon

    Auch einen CSL-Bluetooth-Stick habe ich gerade getestet: Er geht am Ryzen tatsächlich nicht. Dann habe ich ihn an meinem alten Hacke getestet, der hat nämlich vorne zwei Intel-USB3.0, hinten zwei Intel-USB2.0, und, da der Chipsatz nur 2 mal USB3.0 bietet (H81), hat er hinten noch 4 VIA-USB3.0. Ergebnis: An allen Intel-USB-Anschlüssen geht der Bluetooth-Stick, an den VIAs geht er nicht (er erscheint auch nicht im System Profiler). Ich nutze, sowohl auf dem Ryzen, als auch auf dem Intel die GenericUSBXHCI.kext
    Eine Watch habe ich auch nicht, das ist jedoch ein Feature bei dem ich mit gut vorstellen kann dass es nicht gehen wird (muss aber nicht sein!). Im Open Source Kernel, auf dem der AMD-Kernel basiert, fehlt ein Teil des Codes, der u.a. für die Authentifizierung genutzt wird, weswegen iMessage und FaceTime nicht gehen. Gut möglich dass hier auch was für die Watch fehlt.

    iHack: Ryzen 5 1600, GA-AB350M-D3H, Sapphire RX570 4GB, 16GB DDR4-3000, 250GB NVMe SSD + 512GB SSD + 1TB HDD, Clover, macOS 10.15.1, Kubuntu 19.10, Win 8.1


    alter iHack: i3-4330, GA-H81M-HD3, Sapphire RX460 4GB -> RX560 BIOS, 8GB DDR3-1600, 128GB SSD, 250GB HDD, Clover, macOS 10.15.1, Kubuntu 19.10, Win 8.1


    ThinkPad T410: i5-520M, Nvidia NVS3100M, 4GB DDR3-1066, 120GB SSD, 250GB HDD, Clover, macOS 10.14.6


    Bastlerware: Acer Aspire 7741G: i5-430M, ATI HD 5650 1GB; 4GB DDR3-1066; 250GB HDD, Clover, macOS 10.13.6, 1.5 von 2 SATA-Ports defekt...


    Originals: MacBook Pro 15 Late 2013 (macOS 10.15.1), iPhone X 64GB (iOS 13.2)

  • Gibt ryzen patches für Bluetooth dann gehen die auch aber meine USB Ports verhalten sich komisch und BT geht auch nur wenn ich alle usb kexte raus nehme ... kann im bios auch zu USB nix einstellen ...


    Würde da eine PCIE USB 3.0 Karte helfen ?

    iMac 18,3 : Acer 27'' WQHD: Asrock Fatality Z270 Gaming K4 - Intel i5-7600K - 16GB DDR4 Intenso - Palit GT710 2GB *OBB - macOS 10.14.x - Clover

  • Ich denke mal, dass eine PCIe-Karte die selben Probleme mitbringen dürfte. Evtl. wird es etwas einfacher, wenn der USB-Chip von Intel wäre, aber gibts von denen überhaupt Standalone-USB-Chips?
    Ich denke dass das Problem bei deinen USB3-Ports an der bekannten Port-Limit-Problematik liegt - wie oben von @ralf. verlinkt.
    Hast du zufällig einen Link zu den Bluetooth-Patches? Habe auf die Schnelle nichts gefunden, würde mich aber mal interessieren.

    iHack: Ryzen 5 1600, GA-AB350M-D3H, Sapphire RX570 4GB, 16GB DDR4-3000, 250GB NVMe SSD + 512GB SSD + 1TB HDD, Clover, macOS 10.15.1, Kubuntu 19.10, Win 8.1


    alter iHack: i3-4330, GA-H81M-HD3, Sapphire RX460 4GB -> RX560 BIOS, 8GB DDR3-1600, 128GB SSD, 250GB HDD, Clover, macOS 10.15.1, Kubuntu 19.10, Win 8.1


    ThinkPad T410: i5-520M, Nvidia NVS3100M, 4GB DDR3-1066, 120GB SSD, 250GB HDD, Clover, macOS 10.14.6


    Bastlerware: Acer Aspire 7741G: i5-430M, ATI HD 5650 1GB; 4GB DDR3-1066; 250GB HDD, Clover, macOS 10.13.6, 1.5 von 2 SATA-Ports defekt...


    Originals: MacBook Pro 15 Late 2013 (macOS 10.15.1), iPhone X 64GB (iOS 13.2)

  • Also ich glaube das liegt mit an meinen usb Problemen mein usb3.0 hub läuft auch nicht immer


    http://forum.amd-osx.com/viewtopic.php?f=24&t=3587


    Weil erkann wird sie ja wenn ich den Generic raus nehme sporadisch


    Naja habe das mainboard wieder storniert werde morgen noch mal nach den USB sehen sonst kommt der Ryzen wieder in den Schrank und hol mir bald was gebrauchtes Kabylake oder so.

    iMac 18,3 : Acer 27'' WQHD: Asrock Fatality Z270 Gaming K4 - Intel i5-7600K - 16GB DDR4 Intenso - Palit GT710 2GB *OBB - macOS 10.14.x - Clover

    Edited once, last by SirusX ().

  • Bluetooth-Stick werden nicht erkannt. Ich hab 2 verschiedene Typen. Am Skylake werden sie erkannt.
    Der Wlan-Stick funzt. meine PCIe-Wlan-Karte läuft oob.
    eine Bluetooth/Wlan-Karte hab ich nicht, ...das Unterteil hab ich schon,..

    AMD X4 605e - Scythe Ninja Plus - N68-S3 UCC - 8400 GS - Enermax Digifanless 550W Platinum

    AMD 3 1200 - Nofan CR-80EH - A320M-DGS - GT710 Passiv - Enermax Digifanless 550W Platinum

    AMD 7 3700X - Nofan CR-95C - GA-A320M-S2H - RX460Passiv - Silentmaxx Fanless II 500 Platinum

    Intel i3 4330 - Nofan CR-95C - H81M-C - 16GB - Intel HD 4600 - Seasonic X-Series Fanless X-400FL

    Intel i5-6500T - Coollink Corator - B250ME - 1050ti.Passiv - SuperFlower GoldenSilent Fanless Platinum

  • Welche USB-Kext(e) / Patches benutzt du denn? Mit dem GenericUSBXHCI gehts bei mir ja auch am Intel (an Nicht-Intel-USB-Ports) nicht.

    iHack: Ryzen 5 1600, GA-AB350M-D3H, Sapphire RX570 4GB, 16GB DDR4-3000, 250GB NVMe SSD + 512GB SSD + 1TB HDD, Clover, macOS 10.15.1, Kubuntu 19.10, Win 8.1


    alter iHack: i3-4330, GA-H81M-HD3, Sapphire RX460 4GB -> RX560 BIOS, 8GB DDR3-1600, 128GB SSD, 250GB HDD, Clover, macOS 10.15.1, Kubuntu 19.10, Win 8.1


    ThinkPad T410: i5-520M, Nvidia NVS3100M, 4GB DDR3-1066, 120GB SSD, 250GB HDD, Clover, macOS 10.14.6


    Bastlerware: Acer Aspire 7741G: i5-430M, ATI HD 5650 1GB; 4GB DDR3-1066; 250GB HDD, Clover, macOS 10.13.6, 1.5 von 2 SATA-Ports defekt...


    Originals: MacBook Pro 15 Late 2013 (macOS 10.15.1), iPhone X 64GB (iOS 13.2)