HDMI Audio (Nvidia) funktioniert nicht - generelle Optimierungen

  • Ich guck mal und meld mich wieder... moment :) und Danke


    Update: Vielen Dank ... geht wieder - aus irgendeinem Grund hat sich beim Update die int. GraKa deaktiviert .. warum? Keine Ahnung.
    P.S Jetzt nach dem Reboot ist übrigens der Sound via HDMI wieder weg. Werde mal testen, ob das in Korrelation zueinander steht.


    Aktuelle Konfiguration im BIOS = siehe Bild.
    Ich kann also wieder iGFX deaktivieren - Test 1
    oder das primary Display auf iGFX setzen - Test 2


    Wobei letzteres ja (aus meiner Sicht) ein Kabeltausch notwendig macht, weil aktuell am iGFX HDMI Port nichts angeschlossen ist.

  • @al6042


    Habe mittlerweile eine lauffähige Config (HDMI Audio, Headphone Audio) unter 10.13.1 auf dem Zotac EN1070k. 1 HDMI (von 2) und beide DP Ports liefern HDMI/DP Audio an den Monitor. System scheint hinreichend stabil zu sein, alle USB Port funktionieren und Video Encode/Deocde lief über Nacht einwandfrei.


    Anbei ist der Zip zum Clover-Folder (wesentliche Inhalte). WLAN/BT geht noch nicht, da muß ich noch die WLAN Karte austauschen.



    Was gewinne ich, wenn ich die DSDT noch zusätzlich bereinige / optimiere?


    Vielen Dank

    Dateien

    • CLOVER short.zip

      (4,19 MB, 18 Mal heruntergeladen, zuletzt: )

    Einmal editiert, zuletzt von muc_mac ()

  • Bitte nutze keine externen Filehoster für die Bereitstellung der Daten.
    über „Erweiterte Antwort“, bzw. „Erweiterte Bearbeitung“, kannst du im Reiter „Dateianhänge“ das Ganze als ZIP direkt hinzufügen.


    drauf schauen kann ich vermutlich erst im Laufe der Woche.

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Hallo Al6042,


    hattest Du die Gelegenheit mal in die Files zu schauen? Herzlichen Dank

  • Da du die Daten direkt Post rein gepackt hast, konnte niemand sehen, dass es Neuigkeiten im Thread gab.
    Somit habe ich das auch nicht mitbekommen...
    Zudem: wenn es funktioniert, warum sollte ich dann nochmal drauf schauen? ;)


    Wenn du die DSDT bereinigst und dabei auch einige Details zur Hardware direkt dort rein patchst, sparst du dir ggf. ein paar der config.plist Einstellungen und eventuell auch den ein oder anderen Injector-Kext.


    Da Clover und die Kexte durch eher einer stärkeren Fluktuation unterliegen, habe ich solche Settings gerne zentral.

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Klasse, danke für das Feedback - ich kann die Logik nachvollziehen. Andere brauchen die Hilfe eher.


    Macht es Sinn dass ich die Config irgendwo zentral ablege, so daß andere profitieren? Wenn ja, wo?


    Weiterhin viel Erfolg, habe durch das Mitlesen viel gelernt

  • Du kannst die Kiste im Detail gerne unter Skylake Sammelthread (lauffähige Konfigurationen) Desktop verewigen.

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Also ich hab immer noch die HDMI Audio Probleme... gibt es mittlerweile eine Lösung?


    Mit Freundlichen Grüßen

    HackMac:
    Intel Core i7 3770K@4,2Ghz/Gigabyte Z77X-UP5TH/GSKILL 16GB DDR3-1866MHz
    Asus GeForce GTX680 DirectCU II 2GB /Crucial M550 480GB @ OSX 10.13/Crucial M4 240GB @ Win10 Prof.


    MacBook Pro 15 Early 2011
    Core i7/8GB Ram/Crucial M500 120GB SSD


    Apple Devices:
    iPad Air 1 & 2, Iphone 5, 7Plus, Watch Series 2, Apple TV 2, Apple iPod Nano

  • Die gab und gibt es schon immer das Zauberwort heißt DSDT Patch natürlich vorausgesetzt die Grafikkarte beherrscht auch HDMI Audio was nicht immer der Fall ist.

    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, macOS Mojave 10.14
    System 2 (MacBook Pro 10.2): ThinkPad T430, i5-3360M @ 2.8 GHz, 8GB DDR3, IntelHD 4000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Dual Boot MacOS Mojave 10.14, Windows10 Pro 64Bit

  • Die gab und gibt es schon immer das Zauberwort heißt DSDT Patch natürlich vorausgesetzt die Grafikkarte beherrscht auch HDMI Audio was nicht immer der Fall ist.


    wie stell ich das an???


    Mit freundlichen Grüßen

    HackMac:
    Intel Core i7 3770K@4,2Ghz/Gigabyte Z77X-UP5TH/GSKILL 16GB DDR3-1866MHz
    Asus GeForce GTX680 DirectCU II 2GB /Crucial M550 480GB @ OSX 10.13/Crucial M4 240GB @ Win10 Prof.


    MacBook Pro 15 Early 2011
    Core i7/8GB Ram/Crucial M500 120GB SSD


    Apple Devices:
    iPad Air 1 & 2, Iphone 5, 7Plus, Watch Series 2, Apple TV 2, Apple iPod Nano

  • Einen guten Einstieg findest Du hier: DSDT in den Repositories zu MacIASL gibt es auch welche zu HDMI Audio.

    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, macOS Mojave 10.14
    System 2 (MacBook Pro 10.2): ThinkPad T430, i5-3360M @ 2.8 GHz, 8GB DDR3, IntelHD 4000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Dual Boot MacOS Mojave 10.14, Windows10 Pro 64Bit

  • ich hab eine dsdt der al hat mir die erstellt...


    aber klappt noch nicht mit dem audio...

    Dateien

    • DSDT.aml.zip

      (16,98 kB, 1 Mal heruntergeladen, zuletzt: )

    HackMac:
    Intel Core i7 3770K@4,2Ghz/Gigabyte Z77X-UP5TH/GSKILL 16GB DDR3-1866MHz
    Asus GeForce GTX680 DirectCU II 2GB /Crucial M550 480GB @ OSX 10.13/Crucial M4 240GB @ Win10 Prof.


    MacBook Pro 15 Early 2011
    Core i7/8GB Ram/Crucial M500 120GB SSD


    Apple Devices:
    iPad Air 1 & 2, Iphone 5, 7Plus, Watch Series 2, Apple TV 2, Apple iPod Nano

  • Du meinst, mit dem Audio per HDMI?
    Poste doch bitte mal das Ergebnis des folgenden Terminal Befehls:

    Code
    1. ioreg -p IODeviceTree -n HDEF -r

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • hier


    HackMac:
    Intel Core i7 3770K@4,2Ghz/Gigabyte Z77X-UP5TH/GSKILL 16GB DDR3-1866MHz
    Asus GeForce GTX680 DirectCU II 2GB /Crucial M550 480GB @ OSX 10.13/Crucial M4 240GB @ Win10 Prof.


    MacBook Pro 15 Early 2011
    Core i7/8GB Ram/Crucial M500 120GB SSD


    Apple Devices:
    iPad Air 1 & 2, Iphone 5, 7Plus, Watch Series 2, Apple TV 2, Apple iPod Nano

    Einmal editiert, zuletzt von al6042 ()

  • Das ist sehr verwunderlich, da in deiner DSDT die Unterstützung für HDMI-Audio der externen Grafik tatsächlich eingebunden ist:


    Handelt es sich bei deiner DSDT.aml um die Datei vom 14.10.2017?

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • ja das ist korrekt

    HackMac:
    Intel Core i7 3770K@4,2Ghz/Gigabyte Z77X-UP5TH/GSKILL 16GB DDR3-1866MHz
    Asus GeForce GTX680 DirectCU II 2GB /Crucial M550 480GB @ OSX 10.13/Crucial M4 240GB @ Win10 Prof.


    MacBook Pro 15 Early 2011
    Core i7/8GB Ram/Crucial M500 120GB SSD


    Apple Devices:
    iPad Air 1 & 2, Iphone 5, 7Plus, Watch Series 2, Apple TV 2, Apple iPod Nano

  • Wenn ich die DSDT aus deinem obigen Anhang entpacke, ist die vom 15.10.2017... aber egal...
    An welchem Port an der Grafikkarte ist denn der Monitor angeschlossen?

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • hdmi port...


    welche Nummer der hat weis ich nicht...


    mfg


    DVI Output : Yes x 1 (DVI-I), Yes x 1 (DVI-D)HDMI Output : Yes x 1 Display Port : Yes x 1 (Regular DP)

    HackMac:
    Intel Core i7 3770K@4,2Ghz/Gigabyte Z77X-UP5TH/GSKILL 16GB DDR3-1866MHz
    Asus GeForce GTX680 DirectCU II 2GB /Crucial M550 480GB @ OSX 10.13/Crucial M4 240GB @ Win10 Prof.


    MacBook Pro 15 Early 2011
    Core i7/8GB Ram/Crucial M500 120GB SSD


    Apple Devices:
    iPad Air 1 & 2, Iphone 5, 7Plus, Watch Series 2, Apple TV 2, Apple iPod Nano

  • Poste doch bitte mal noch eine Screenshot vom ersten Fenster des DPCIManagers.

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • hier mal screenshot


    EDIT: Was recht seltsam ist... schau mal die andere Bilder an...