DSDT muss nach jedem BIOS Reset neu gepatcht werden

  • Hallo,


    ich habe bei meinem Kabylake System das komische Verhalten was mir erst seit diesem aufgefallen ist, dass z. B. nach jedem BIOS Reset wenn die BIOS Batterie abgeklemmt wurde, immer neu gepatcht werden muss. Bei einem BIOS Update verstehe ich das ja noch, das sich dort etwas ändern kann bzw. ändert was dann nicht mehr passt. Das komische daran ist dann auch noch, wenn ich z.B. die Grafikkarte, die Soundkarte usw. in die DSDT integriere, ich auch die SSDT's komplett patchen muss damit dann überhaupt gebotet wird ansonsten kommen ACPI Fehler. In den SSDT's werden eigentlich nur renames gemacht von GFX= auf IGPU und SAT0 to SATA was ich eigentlich schon über Clover umbenennen lasse. Bei meinem Dell XPS habe ich dieses Verhalten nicht.


    Ist dies ein normales Verhalten von Kabylake System oder ist es vielleicht auch das Mainboar das einfach so reagiert?


    Danke.


    Gruss
    hitman20

    System 1: Laptop Modell: Dell XPS 15 9550, Mainboard: Intel HM170, Grafikkarte: Intel HD 530, Soundkarte: Realtek ALC298, OS X Version: High Sierra 10.13.5


    System 2: CPU: Intel i5 7400, Mainboard: Gigabyte GA-Z370N-WIFI, Grafikkarte: Intel HD 630, AMD Sapphire Radeon RX560 4GB, Soundkarte: Realtek ALC1120, OS X Version: High Sierra 10.13.5


    System 3: Modell: Dell Inspiron 17 N7110, CPU: Intel Core i3 2310, Mainboard, Intel HM67, Grafikkarte: Intel HD 3000, Nvidia GeForce GT 525M, Soundkarte: Realtek ACL269, OS X Version Sierra 10.12.5

  • eine einmal gepachte DSDT ist gepacht die entpacht sich nicht selbst
    die SSDT´s liegen bei mir in clover Ordner unter acpi gepacht mit der DSDT zusammen drin ansonsten startet mein System auch nicht.


    und wenn deine Batterie mal leer ist was ich auch nicht verstehe weil die cosmos Batterie hält ja nicht nur 1 Monat oder so sondern jahre, stellt man einfach die Einstellungen wieder ein wie zuvor und gut ist.


    wieso klemmt man die Batterie ab nur im äußersten Notfall ansonsten stellt man nur das bios oder uefi nur um

    System: Mac mini 5.1


    System: MacBookPro 13.1 T460s

    Ein Like ist ein Zeichen des Respekts gegenüber dem Helfenden

  • Wenn ich mein BIOS zurücksetzte, nutze ich ja die selbe DSDT und SSDT's weiter. Nur startet dann das System nicht mehr und bringt ACPI Fehler. Wenn ich dann die DSDT und SSDT's über Clover neu extrahiere und neu patche geht es wieder.


    Im BIOS selber habe ich keine Option gefunden, dies wieder auf Werkszustand zurückzusetzen, deswegen der Weg mit der BIOS Batterie abklemmen, damit es sich wieder die Werkseinstellungen lädt. Das System ist erst zwei Wochen alt und ich teste mit diesem noch. Die DSDT muss ich trotzdem neu patchen auch wenn ich die selben Einstellungen im BIOS wieder setze.

    System 1: Laptop Modell: Dell XPS 15 9550, Mainboard: Intel HM170, Grafikkarte: Intel HD 530, Soundkarte: Realtek ALC298, OS X Version: High Sierra 10.13.5


    System 2: CPU: Intel i5 7400, Mainboard: Gigabyte GA-Z370N-WIFI, Grafikkarte: Intel HD 630, AMD Sapphire Radeon RX560 4GB, Soundkarte: Realtek ALC1120, OS X Version: High Sierra 10.13.5


    System 3: Modell: Dell Inspiron 17 N7110, CPU: Intel Core i3 2310, Mainboard, Intel HM67, Grafikkarte: Intel HD 3000, Nvidia GeForce GT 525M, Soundkarte: Realtek ACL269, OS X Version Sierra 10.12.5

  • Vielleicht hilft der Floating Regions Fix.
    In Clover Configurator "FixRegions_10000000" unter ACPI aktivieren.


    Erläuterung im Clover Wiki oder im RehabMan-Guide "[Guide] Patching LAPTOP DSDT/SSDTs" am Ende der Seite unter der Überschrift "Floating regions".

    Liebe Grüße aus Berlin


    Lenovo X230 (Clover), i5-3320m/QM77, HD4000, 1366x768, 10.14 Beta
    Lenovo X220 (Clover), i7-2620m/QM67, HD3000, 1366x768, 10.14 Beta

    Edited once, last by andreas_55 ().

  • Unser @vviolano hatte ein ähnliches Thema mit seinem neuen Board gehabt.
    Eventuell kann er was dazu sagen.

    Gruß
    Al6042


    Asus Prime Z390-A 1005 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.5 | Clover 4934

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.14.5 | Clover 4934

    NUC7i5BNK 0076 | i5 7260U | 16GB | HD640 | NVMe 500 GB | macOS 10.14.5 | OC 0.3

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.5


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Den Fix Regions Fix habe ich mal aktiviert im Clover hat aber leider nichts gebracht. Sonst muss ich die DSDT halt nochmal neu patchen, damit es wieder funktioniert.

    System 1: Laptop Modell: Dell XPS 15 9550, Mainboard: Intel HM170, Grafikkarte: Intel HD 530, Soundkarte: Realtek ALC298, OS X Version: High Sierra 10.13.5


    System 2: CPU: Intel i5 7400, Mainboard: Gigabyte GA-Z370N-WIFI, Grafikkarte: Intel HD 630, AMD Sapphire Radeon RX560 4GB, Soundkarte: Realtek ALC1120, OS X Version: High Sierra 10.13.5


    System 3: Modell: Dell Inspiron 17 N7110, CPU: Intel Core i3 2310, Mainboard, Intel HM67, Grafikkarte: Intel HD 3000, Nvidia GeForce GT 525M, Soundkarte: Realtek ACL269, OS X Version Sierra 10.12.5

  • Hast du mal das Handbuch von deinem Board gelesen ?


    auf Seite 45 wird die F9 taste erwähnt mit der du optimale werkseinstellungen für alles zurücksetzen kannst.


    Auf seite 43 wird erklärt wie du nur UEFI zurücksetzen tust

    System: Mac mini 5.1


    System: MacBookPro 13.1 T460s

    Ein Like ist ein Zeichen des Respekts gegenüber dem Helfenden

  • Ich hatte nur den Teil gelesen auf Seite 21 mit dem Clear CMOS Jumper und hatte dann nicht mehr weitergelesen weil ich im BIOS keinen Menüpunkt gefunden mit auf Werkseinstellungen zurücksetzen, deswegen habe ich es dann über die BIOS Batterie gemacht aber danke für die Info mit F9. Hatte nämlich einmal ausversehen abgestellt das Legacy USB Geräte nicht mehr gehen und dann ging auch keine Tastatur mehr und Maus und deswegen musste ich es dann da über die BIOS Batterie machen.

    System 1: Laptop Modell: Dell XPS 15 9550, Mainboard: Intel HM170, Grafikkarte: Intel HD 530, Soundkarte: Realtek ALC298, OS X Version: High Sierra 10.13.5


    System 2: CPU: Intel i5 7400, Mainboard: Gigabyte GA-Z370N-WIFI, Grafikkarte: Intel HD 630, AMD Sapphire Radeon RX560 4GB, Soundkarte: Realtek ALC1120, OS X Version: High Sierra 10.13.5


    System 3: Modell: Dell Inspiron 17 N7110, CPU: Intel Core i3 2310, Mainboard, Intel HM67, Grafikkarte: Intel HD 3000, Nvidia GeForce GT 525M, Soundkarte: Realtek ACL269, OS X Version Sierra 10.12.5

  • Das wird irgendein Fehler in deiner Clover Konfiguration sein. Eine DSDT Datei kann sich nicht selber verändern. Die liegt nur auf der Festplatte rum.

  • Die DSDT bleibt ja die selbe nur passt die halt nachdem CMOS Reset nicht mehr mit den BIOS Einstellungen zusammen und bringt dann ACPI Fehler und das System startet dann nicht mehr.

    System 1: Laptop Modell: Dell XPS 15 9550, Mainboard: Intel HM170, Grafikkarte: Intel HD 530, Soundkarte: Realtek ALC298, OS X Version: High Sierra 10.13.5


    System 2: CPU: Intel i5 7400, Mainboard: Gigabyte GA-Z370N-WIFI, Grafikkarte: Intel HD 630, AMD Sapphire Radeon RX560 4GB, Soundkarte: Realtek ALC1120, OS X Version: High Sierra 10.13.5


    System 3: Modell: Dell Inspiron 17 N7110, CPU: Intel Core i3 2310, Mainboard, Intel HM67, Grafikkarte: Intel HD 3000, Nvidia GeForce GT 525M, Soundkarte: Realtek ACL269, OS X Version Sierra 10.12.5

  • Du musst schon die originale DSDT von deinem board verwenden und patchen, dann gehts. Nicht etwas was dir Clover da anzeigt und vorlegt.

  • @Senseye Sei mir nicht böse aber das ist mir schon klar das ich die von meinem eigenen Board nehmen muss wenn ich diese mit allen nötigen DSDT Patches patche funktioniert die auch korrekt nur bei einem BIOS Reset wenn die BIOS Batterie dabei abgeklemmt ist und wieder angeklemmt wurde funktioniert die DSDT nicht mehr und muss neu extrahiert und gepatcht werden damit die wieder geht.

    System 1: Laptop Modell: Dell XPS 15 9550, Mainboard: Intel HM170, Grafikkarte: Intel HD 530, Soundkarte: Realtek ALC298, OS X Version: High Sierra 10.13.5


    System 2: CPU: Intel i5 7400, Mainboard: Gigabyte GA-Z370N-WIFI, Grafikkarte: Intel HD 630, AMD Sapphire Radeon RX560 4GB, Soundkarte: Realtek ALC1120, OS X Version: High Sierra 10.13.5


    System 3: Modell: Dell Inspiron 17 N7110, CPU: Intel Core i3 2310, Mainboard, Intel HM67, Grafikkarte: Intel HD 3000, Nvidia GeForce GT 525M, Soundkarte: Realtek ACL269, OS X Version Sierra 10.12.5

  • Hast du die DSDT denn aus AmiboardInfo aus deinem Bios extrahiert? Oder kommt die von Clover? Denn Clover kann es nur aus dem RAM extrahieren und dann ist die schon verfälscht.

  • Wie meinst Du mit AmiboardInfo extrahiert? Als Programm habe ich das nicht gefunden. Meine DSDT habe ich mit Clover extrahiert.

    System 1: Laptop Modell: Dell XPS 15 9550, Mainboard: Intel HM170, Grafikkarte: Intel HD 530, Soundkarte: Realtek ALC298, OS X Version: High Sierra 10.13.5


    System 2: CPU: Intel i5 7400, Mainboard: Gigabyte GA-Z370N-WIFI, Grafikkarte: Intel HD 630, AMD Sapphire Radeon RX560 4GB, Soundkarte: Realtek ALC1120, OS X Version: High Sierra 10.13.5


    System 3: Modell: Dell Inspiron 17 N7110, CPU: Intel Core i3 2310, Mainboard, Intel HM67, Grafikkarte: Intel HD 3000, Nvidia GeForce GT 525M, Soundkarte: Realtek ACL269, OS X Version Sierra 10.12.5

  • Bei mir funktioniert das irgendwie nicht. Ich habe mir das BIOS heruntergeladen für mein Board und wollte das mit UEFITool 0.18.7 öffnen und dann stürzt mir das Tool ab. Mache ich da etwas falsch?


    Edit: Mit der Windows Version UEFI Tool geht es aber allerdings finde ich dort nichts von AmiboardInfo.

    System 1: Laptop Modell: Dell XPS 15 9550, Mainboard: Intel HM170, Grafikkarte: Intel HD 530, Soundkarte: Realtek ALC298, OS X Version: High Sierra 10.13.5


    System 2: CPU: Intel i5 7400, Mainboard: Gigabyte GA-Z370N-WIFI, Grafikkarte: Intel HD 630, AMD Sapphire Radeon RX560 4GB, Soundkarte: Realtek ALC1120, OS X Version: High Sierra 10.13.5


    System 3: Modell: Dell Inspiron 17 N7110, CPU: Intel Core i3 2310, Mainboard, Intel HM67, Grafikkarte: Intel HD 3000, Nvidia GeForce GT 525M, Soundkarte: Realtek ACL269, OS X Version Sierra 10.12.5

    Edited once, last by hitman20 ().