Kaby Lake Sammelthread (lauffähige Konfigurationen) Desktop

  • Welche Kaby-Lake laufen bei dir mit macOS X?
    Ab 10.12.6 sollte es ja keine Probleme mehr damit geben.
    Hier ein entsprechender Thread dafür. Das Prinzip kennst du ja schon vom Skylake Sammelthread (lauffähige Konfigurationen) Desktop


    Ein Foto vom Mainboard & Über diesen Mac ist erwünscht, allerdings kein muss.
    Der EFI Ordner als ZIP für diene Konfiguration ebenfalls.


    Ich bin sehr gespannt auf eure Zusammenstellungen.
    Selber habe ich noch kein Kaby Lake System... also kann ich nicht Anfangen.


    Bitte dankschöön :D

  • Ich bin ja jetzt auch endlich Fertig mit dem Kaby Lake System.

    • Mainboard Asus Prime B250M-Plus
    • ProzessorIntel i3-7100
    • GrafikkarteIntel HD 630
    • Arbeitsspeicher 8GB DDR4
    • Festplatte WD Black PCIe 256 GB interne NVMe-SSD
    • Audio ALC 887 mit Apple ALC und AudioID 1
    • Betriebssystem Sierra 10.12.6
    • System Definition iMac 18,2
    • BootloaderClover 4114

    Bis jetzt ein sehr zuverlässiges System und keinerlei abstürze oder sonst was gehabt.


    Dateien

  • *UPDATE 10.13.2*
    Seit dem Update muss die AMD-Grafik anders eingebunden werden, ich verweise hierzu auf meinen Thread auf insanelymac


    Beim ASUS Prime B250M-C läuft alles, Netzwerk, Audio, Sleep.
    Hier der Mini-Guide.


    Angehängt auch meine EFI. Achtung: config.plist mit NVMe-Patches für 10.12.5, läuft möglicherweise mit anderen Sierra-Versionen nicht! Update: Läuft auch mit 10.12.6 problemlos.Zusätzlich noch SMBIOS zu iMac18,2 ändern und FakeCPU-ID löschen: Perfekter Kaby Lake Hack! Update2: Achtung, neue config, USB kext und DSDT für USB sleep, die alte bitte nicht benutzen (läuft ab 10.12.6)

    Dateien

    • EFI.zip

      (24,33 MB, 42 Mal heruntergeladen, zuletzt: )
    • NEW_config_usb_dsdt.zip

      (64,09 kB, 30 Mal heruntergeladen, zuletzt: )

    5 Mal editiert, zuletzt von macinsane ()

  • Intel Core i5-7600K
    ASUS ROG Strix Z270I Gaming
    Corsair Vengeance LPX 16GB DDR4-3000
    MSI GeForce GT 1030 2G LP OC, 2GB GDDR5
    Samsung SSD 960 EVO 250GB, M.2 (macOS 10.12.6)
    Corsair Force Series MP500 120GB, M.2 (Win10)
    Crucial MX300 1TB, SATA (Datengrab)
    Noctua NH-L9i
    Lian Li PC-Q20A silber
    Corsair SF450 450W SFX12V
    Dell DW1830 BCM943602BAED Wifi + BT
    SMBios iMac18,3


    Super kompakter Hackintosh, der zudem optisch noch etwas "Apple-like" aussieht.
    Danke 10.12.6 nativer Support von Kaby Lake und der HD630, nutze allerdings nur die GT 1030.
    Habe mit der 630 keine 2560 x 1440 HiDPi (Retina) Auflösung auf meinem LG 27UD88-W zum Laufen bekommen, mit der 1030 gehts perfekt.
    Ist jetzt nahezu ein baugleicher iMac 5k Retina 27" :)
    Wifi läuft mit der Karte OOB, Bluetooth benötigt Kexts von Rehabman (siehe hier).


    Alles in Allem läuft absolut stabil und zuverlässig bisher.
    EFI Ordner hänge ich noch an.

    Bilder

    iMac Pro (iMacPro1,1):
    Intel Core i7-8700K | Gigabyte Z370N WIFI | Corsair Vengeance LPX 16GB DDR4-3000 | Sapphire Pulse ITX Radeon RX 570
    Samsung SSD 960 EVO 250GB, M.2 | Corsair Force Series MP500 120GB, M.2 | Crucial MX300 1TB, SATA
    Dr. Zaber Sentry Black | Corsair SF450 450W SFX12V | Dell DW1830 BCM943602BAED Wifi + BT | LG 2788B-W
    macOS 10.14.3 | Windows 10 Professional

  • Dann gesellen wir uns doch auch mal in die Reihe... :)


    Hier mal meine Komponenten für den KabyLake Eimer:

    Mainboard Gigabyte Z270-HD3P (Bios Version F7)
    CPU i7 7700K (mit be quiet! Dark Rock Advanced C1 Tower Kühler)
    RAM Corsair Vengeance LPX 32GB DDR4-2400
    Grafik 8GB Palit GeForce GTX 1080 Super Jetstream Aktiv PCIe 3.0 x16
    SSD Samsung 960 EVO 250 GB (m.2 NVMe)
    HDDs 3x WD 3TB WD30EFRX Red (SATA3)
    WLAN/BT Broadcom BCM943602CSAX 1300Mbps Dual Band BT4.1 Wlan Card
    Netzteil Corsair RM650 650W ATX24
    Gehäuse Corsair Carbide 500R wh ATX


    Welche Hardware funktioniert:

    Grafik Mit dem Nvidia WebDriver volle Beschleunigung auf 2x 4K Samsungs
    Audio ALC888 mit LayoutID 1 und Audio über Displayport
    LAN Intel I219V2
    USB Ports Alle, IORegistryExplorer zeigt unter XHC@14000000 die Ports HS01-HS14, SS01-SS10 und USR1 & USR2 = 26 Ports
    WLAN
    BT
    Für WLAN OOT plus 2 KextsToPatch Einträge (Country & Airport Extreme)
    Für BT OOT plus 2 KextsToPatch Einträge (30 seconds & BT4LE-Handoff
    m.2 NVMe SSD mit Pike´s KextToPatch einträgen (ohne dem "InfoPlistPatch" da die NVMe dem originalen Eintrag entspricht
    ACHTUNG: Zum ersten Installieren muss der "IONVMeFamily.kext" unter ForceKextsToLoad eingetragen werden)


    Welche Hardware funktioniert nicht:
    > keine... :)
    Die HD630 habe ich aktuell deaktiviert


    Installation:
    > keine, da mit den Komponenten mein altes Haswell-Setup abgelöst wurde. Trotzdem mussten ein paar Sachen erledigt werden:
    > Erstellen eines Clover-Bootsticks mit den Angaben für ein iMac18,3 und den EInträgen für die NVMe-SSD
    > damit die alte SATA-SSD gebootet und per CCC die SATA-SSD auf die NVMe-SSD geklont (aktuelle CCC-Version bot auch die automatische Erstellung der Recovery HD an... das fand ich nett.. ;)
    > Clover auf die NVMe-SSD Installiert
    > SATA-SSD ausgebaut und von der NVMe-SSD gebootet, dabei im Clover Bootmenü direkt die aktuellen .aml-Dateien extrahiert
    > DSDT.aml nach bestem Wissen und Gewissen gepatcht... ;)
    > folgende Kexte in /EFI/CLOVER/kexts/Other platziert: AppleALC, FakeSMC (ohne GPU-Sensoren), IntelGraphicsFixup (just in case), IntelMausiEthernet, Lilu, NvidiaGraphicsFixup, Shiki, USBInjectAll und XHCI-200-series-injector
    > beiliegenden Clover Ordner hineinkopiert
    > und läuft


    Post Installation:
    > Durch die SMBIOS und Seriennummern-Änderung wurde mein AppleID-PW bei der Anmeldung an iMessage mal wieder "zerlegt", sodass ich ein neues PW vergeben musste
    > DSDT noch ein wenig verfeinert
    > Reboot
    > Fertig



    Sleep Einstellungen:


    Achtung: Zur besseren Lesbarkeit wurden die Angaben alphabetisch sortiert. Im Terminal wird das nicht der Fall sein... ;)


    Offene Punkte:
    Sleep noch nicht getestet... :)
    Wenn die HD630 aktiviert wurde, gibt es den Apple-Logo-Fehler in iTunes und Screenshots in Preview (Vorschau) zeigen kein Bild, sondern "Schnee" wie bei einem analogen TV-Kanal ohne Empfang.

    Dateien

    • CLOVER.zip

      (16,93 MB, 115 Mal heruntergeladen, zuletzt: )

    Gruß
    Al6042


    Asus Prime Z390-A 0602 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.2 | Clover 4842

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14.2 | Clover 4842

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.2


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

    3 Mal editiert, zuletzt von al6042 ()

  • Ich packe hier mal noch die Bilder der BIOS-Settings dazu:


    Gruß
    Al6042


    Asus Prime Z390-A 0602 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.2 | Clover 4842

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14.2 | Clover 4842

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.2


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Was funktioniert? Alles. Sleep/Wake, NVMe, Airport, AMD-Grafik

    Config:
    ASUS Prime B250M-C μATX
    Intel Core i5 7500 (Kaby Lake)
    Gigabyte Radeon RX560 4GB
    Airport-kompatible PCIe-Karte für Wifi (BCM943602CS) und Bluetooth USB (Broadcom 20702A3)
    2 NVMe Laufwerke: Samsung P961 mit 1 TB und 256 GB

    Installiertes Mac OS: 10.13 GM
    Clover: 4220


    * Update * Ich habe eine NEUE config.plist und DSDT hinzugefügt. Für ein funktionierendes Grafik-Power-Management muss CPU Graphics im BIOS aktiviert sein, aber PCIE die primäre Anzeige. Außerdem muss man mit Clover die ig-platform-id 0x59120003 injizieren und den Clover-Patch GFX0 zu IGPU verwenden. Dies ist die einzige Möglichkeit, Abstürze von iMovie, FinalCut oder Slowdowns nach Videowiedergaben zu verhindern.

    Der rundeste Hackintosh meines Lebens. Es ist einfacher als die Sierra-Installation wegen der nativen Unterstützung der verwendeten Hardware in High Sierra. Nicht viel zu tun mit einer aktuellen Clover-Version wie 4184. Auf jeden Fall muss apfs.efi in /Clover/drivers64UEFI/ auf der EFI-Partition sein, wenn man APFS nutzen möchte (ich rate allerdings davon ab und habe ein Backup auf eine HFS-Partition erstellt, die APFS wieder auf HFS formatiert und zurückgespielt) und EmuVariableUEFi.efi gelöscht werden (ohne die EmuVariable geht iMessage natürlich nicht mehr).

    Benötigte Kexts (in der EFI in /Clover/kexts/Other oder /10.13): FakeSMC, IntelMausiEthernet für die Netzwerkkarte, USBInjectAll (habe ich für meine Konfiguration gepatched, muss nach eigenen Wünschen angepasst werden) und XHCI-200-Serie-Injektor für USB, Lilu und AppleALC für Audio, Whatevergreen für die AMD-Grafik und IntelGraphicsFixup.

    Dateien

    • DSDT.aml

      (172,52 kB, 19 Mal heruntergeladen, zuletzt: )
    • config.plist

      (3,27 kB, 25 Mal heruntergeladen, zuletzt: )

    15 Mal editiert, zuletzt von macinsane ()

  • Und weil ich es für meine Skylake-Büchse gemacht habe, lege ich für das Kabylake-Board gleich mal nach...
    Hier handelt es sich um die EFI für High Sierra des Z270-HD3P, mit BIOS-Version F7 und Clover 4243.


    Achtung: für eine Neuinstallation von HS sollten die DSDT.aml und der EmuVariableUefi-64 umbenannt oder entfernt werden.


    Ansonsten gilt: Neue Seriennummer bauen lassen...

    Dateien

    Gruß
    Al6042


    Asus Prime Z390-A 0602 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.2 | Clover 4842

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14.2 | Clover 4842

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.2


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • So, der nächste Rechner läuft auch, ebenso mit @antagon Hilfe.


    Mainboard: ASUS Strix z270H
    Prozessor: Intel 7700K
    RAM: 32GB Kingston (4 x 8GB)
    Grafik: Gigabyte GeForce GTX 1070 (8GB) G1 Gaming
    27" Cinema Display & 16" Samsung Monitor
    OS X: Sierra 10.12.6
    Bootloader: Clover
    SSD: Samsung 850 EVO 500GB


    Insgesamt bestückt mit 4 Festplatten : SSD Mac OS; SSD Win10; 2 int 3,5"FP 4TB


    Dateien lade ich am Montag noch hoch

    Einmal editiert, zuletzt von bigben24 ()

  • @bigben24
    Da es sich bei deinen Komponenten um ein KabyLake-System handelt, habe ich die mal in den passenden Thread verschoben.

    Gruß
    Al6042


    Asus Prime Z390-A 0602 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.2 | Clover 4842

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14.2 | Clover 4842

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.2


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!