Sierra auf einem Lenovo E460

  • Schönen guten Abend,


    ich habe eine Lenovo E460 im Zulauf und möchte darauf Sierra installieren. Dieser Thread soll mir und möglichen Interessenten bei der Installation helfen.


    Erstmal die wichtigsten technischen Spezifikationen:


    Prozessor: Intel Core i5-6200U
    Grafik: Intel HD520 und AMD Radeon R7 M360
    RAM: 4GB
    500GB HDD
    Full HD IPS Display


    Die HDD wird gegen eine SSD getauscht (bereits vorhanden), vorerst möchte ich es bei 4GB RAM belassen.


    WLAN und Bluetooth werden mit der verbaute Karte von Intel nicht funktionieren, deshalb muss ein anderes Modell her.


    Finden konnte ich bisher nur diese recht ungenaue Information:



    Die Karte von Broadcom scheint mir geeignet zu sein, nur welche ist das genau?

    Edited once, last by Harper Lewis ().

  • Die AMD Radeon R7 M360 wird unter OS Sierra nicht funktionieren.


    Außer Du hast die Möglichkeit im BIOS in den Advanced Bios Settings die
    AMD R7 M360 als primäre Graphikkarte und die integrierte Intel HD520 als
    sekundäre Graphikkarte einzustellen.


    Ich rate daher dringend vorerst auf dem Lenovo kein BIOS-Update durchzuführen,
    weil Lenovo die Advanceds BIOS Settings für den normalen User geblockt hat.


    WLAN und Bluetooth wird wenn überhaupt nur mit der Broadcom Wireless-AC laufen.
    Lenovo verbaut in den in Europa ausgelieferten Notebooks fast ausschließlich Intel-Karten,
    die unter OS Sierra bzw. OS X definitiv nicht laufen. Dazu müsste man aber das genaue Modell
    kennen. Sieh bitte im technical appendix des Repair and Maintenance Manual nach.
    Da steht die exakte FRU-Nummer und die Typenbezeichnung der vom BIOS akezptierten
    Karten. Dann wissen wir mehr.


    OS Sierra mit 4 GB betreiben zu wollen, wenn die AMD Graka im Worst Case nicht angesprochen
    werden kann, grenzt schon an ein Geduldsspiel, denn die Intel HD520 zwickt sich vom RAM
    exakt 1,5 GB ab. Dann bleiben nur mehr 2,5 GB RAM fürs System. Einen weiteren 4 GB- oder
    8 GB Riegel würde ich dem Notebook in jedem Fall gönnen.

    iMac 14.2:
    GA Z97-D3H:
    Intel I7-4790, 16 GB-RAM, MSI Radeon RX 6600XT, Monterey 12.1


    iMac 14.2:
    GA Z97-D3HM:
    Intel I7-4590, 16 GB-RAM, Sapphire Radeon RX 580, Monterey 12.1


    Apple Originale

    MacBook Pro 15,2, 16 GB, 500 GB SSD

    iPad Air 10.5 Zoll 3. Generation

    iPhone SE 2022




  • Besten Dank schonmal!


    Bei den 4GB RAM soll es nicht bleiben, sollte ich Sierra erfolgreich installieren können.


    Ich hab die Version ohne OS und schaue gleich mal nach, was die BIOS-Einstellungen so hergeben.


    Wegen der WLAN- und Bluetooth-Karte bin ich hier fündig geworden. Unter den komaptiblen Adaptern ist dieser: FRU: 00JT485


    Gefunden habe ich z.B. diesen hier. Würde der passen?

  • Wenn die Infos von http://www.aliexpress.com stimmen, dann gehen, die nicht für Dein Lenovo-E460 sondern
    nur für die Vorgängermodelle. Zuerst würde ich versuchen mal OS X oder OS Sierra zu installieren und
    ein kabelgebundenes Internet zum Laufen zu bringen.


    Erst im 2. Schritt würde ich mir überlegen, ob ich entweder auf einen USB-Dongle für WLAN setze oder
    ich die vorhandene Mini-PCIe Combocard für WLAN und BT gegen eine mit OS X oder OS Sierra kompatible
    tausche.

    iMac 14.2:
    GA Z97-D3H:
    Intel I7-4790, 16 GB-RAM, MSI Radeon RX 6600XT, Monterey 12.1


    iMac 14.2:
    GA Z97-D3HM:
    Intel I7-4590, 16 GB-RAM, Sapphire Radeon RX 580, Monterey 12.1


    Apple Originale

    MacBook Pro 15,2, 16 GB, 500 GB SSD

    iPad Air 10.5 Zoll 3. Generation

    iPhone SE 2022




  • Stimmt, hatte ich gar nicht gesehen. Es gibt ja noch mehr Alternativen, aber ich versuche es erstmal ohne und schaue jetzt mal mit Ubuntu live auf die Kiste.


    Edit: Meine Version scheint nur die iGPU als Grafikeinheit zu haben. Hat jemand auf die Schnelle mal eine Idee für die SMBIOS-Einstellungen?


    Edit: Anbei mal die Hardware Infos (lshw).


    Edit: Weit gekommen bin ich nicht. Ich habe mit S-Installationstick-Creating-Tool 3.01 einen Bootstick mit Sierra 10.12.3 erstellt, danach Clover Clover_v2.4k_r4035 installiert und FakeSMC.kext so wie USBInjectAll.kext in kexts/other kopiert. Als SMBIOS habe ich MacBook Pro 13.1 und als ig-platform-id 0x19160002 ausgewählt. Nachdem ich nach dem Booten von Clover vom Stick "Boot from OS X Base System" ausgewählt habe, passiert trotz der Bootflags -v und -x genau nix, der Bildschirm bleibt schwarz.


    BIOS-Einstellungen:


    Display > Total Graphics Memory: 256MB (512MB wären ebenfalls möglich)
    Intel Virtualization: alles disabled
    Secure Boot: Disabled (Platform Mode: User Mode, Secure Boot Mode: Standard Mode, kann auch nicht geändert werden)
    UEFI/Legacy Mode: UEFI Only
    CSM Support: No


    Anbei auch mal der komprimierte EFI-Ordner inklusive DSDT usw. in ACPI/Origin

    Files

    • lshw.txt

      (16.49 kB, downloaded 251 times, last: )
    • EFI.zip

      (4.19 MB, downloaded 190 times, last: )

    Edited 2 times, last by Harper Lewis ().

  • Ich habe hier ein Lenovo E560 mit Sierra am Laufen. Da die Grafikkarte die gleiche ist wie bei mir, schicke ich Dir mal meinen EFI-Ordner. Du kannst damit auf jeden Fall die config.plist übernehmen. SMBIOS habe ich Dir auch mal wie bei mir eingestellt und eine neue Serial Number generiert. Auch die anderen Kexts könnten bei Dir u.U. gut funktionieren.


    Was WLAN & BT anbelangt kann ich Dir meine Erfahrungen mitteilen, wenn Du soweit bist.


    Viel Erfolg!

    Files

    • EFI.zip

      (8.12 MB, downloaded 187 times, last: )

    HP Elite X2 G2, 12'', Intel Core i5-7200U, 8 GB RAM, Intel HD Graphics 620, 1 TB SSD, macOS Monterey 12.6.1

    ---

    HP Compaq 8300 Elite, Intel Core i5-3470, 4 x 3,20 GHz, 8 GB RAM, Ivy Bridge, Nvidia Geforce GT 710 (Intel HD Graphics 2500), macOS Catalina 10.15.7

  • Schaut mal hier...
    gleiche Hardware
    Hilfe: Lenovo Ideapad 500-15ISK und Sierra 10.12.4

  • @iPhoneTruth Besten Dank! Ich habe mal dein EFI-Verzeichnis benutzt und komme schonmal deutlich weiter. Allerdings gibt's jetzt eine kernel panic wegen der iGPU:



    Edit: Ich habe mal den Kext für deinen Wifi-Adpater, die Patches dafür und deine RAM-Einstellung aus der config.plist entfernt, was aber logischerweise trotzdem nix an der panic geändert hat. DSDT und ssdt habe ich ebenfalls entfernt.


    Edit2: Ich habe mal 0x12345678 als ig-platform-id eingetragen und komme jetzt in den Installer. Mal schauen, wie es weitergeht...

    Edited once, last by Harper Lewis ().

  • Du musst im BIOS auf die IGPU umstellen. OS Sierra kann bei Hacks nur eine Graphikkarte ansprechen.
    Lenovo verwendet eine Switch-Technologie, wo zwischen der Intel HD und der dedizierten AMD-Graphikkarte
    je nach Erfordernissen für die Graphikleistung umgeschaltet wird. OS Sierra und auch alle anderen OS X Versionen
    können damit nichts anfangen.


    Die Kernel-Panik sollte verschwinden, wenn die AMD-Graka abgeschaltet ist.

    iMac 14.2:
    GA Z97-D3H:
    Intel I7-4790, 16 GB-RAM, MSI Radeon RX 6600XT, Monterey 12.1


    iMac 14.2:
    GA Z97-D3HM:
    Intel I7-4590, 16 GB-RAM, Sapphire Radeon RX 580, Monterey 12.1


    Apple Originale

    MacBook Pro 15,2, 16 GB, 500 GB SSD

    iPad Air 10.5 Zoll 3. Generation

    iPhone SE 2022




  • Mein E460 hat anscheinend nur die HD520. Ich konnte mit 0x12345678 Sierra installieren, die HD520 hat so natürlich keine Grafikbeschleunigung. Mit ig-platform-id für die HD520 gibt's wieder eine kernel panic. Mit 0x12345678 kann ich auch wieder Sierra booten, die HD520 hat so natürlich nur 7MB VRAM.


    Edit: LAN und Trackpad funktionieren, Audio noch nicht. Statt Neustart gibt es einen Reboot, aber mit der EFI für das E560 bin ich ja schonmal weiter gekommen. Wichtig wäre jetzt erstmal die Grafikbeschleunigung, aber für heute ist erstmal Schluss...

    Edited 2 times, last by Harper Lewis ().

  • Das hört sich ganz nach dem hier an:


    Sierra trotz Problemen mit der Intel HD Grafik (u.a. ?) installieren!


    EDIT:
    U
    nd für Audio: den VoodooHDA.kext hast Du ja von meinem EFI-Ordner. Ich füge diesen mit der zugehörigen Systemeinstellung genannt VoodooHDA.prefPane noch einmal an. Letzteren einfach doppelklicken und installieren. Dann die Systemeinstellung "Ton" wie im Bild gezeigt einstellen.

  • Mahlzeit! Mit diesem Patch und der ig-platform-id 0x19160000 gibt es jetzt auch Grafikbeschleunigung, allerdings mit Glitches und Geflickere ohne Ende. Das Trackpad funktioniert ganz ok. Wenn ich aber z.B. in der Menüleiste ein Menü öffnen möchte, gibt es nur wildes Geflickere. Eine per USB angeschlossene Maus funktioniert auch nur halb. An Sound möchte ich momentan noch gar nicht denken... Erstmal sollte die Grafik laufen :) Anbei auch nochmal das EFI-Verzeichnis.


    Files

    • EFI.zip

      (5.56 MB, downloaded 177 times, last: )
  • Ich bin mir ziemlich sicher, dass Du mit meinem Script die Glitches wegbekommst. Bei mir hat der Patch in der config.plist alleine nicht genügt.



    Gesendet von iPhone mit Tapatalk Pro

    HP Elite X2 G2, 12'', Intel Core i5-7200U, 8 GB RAM, Intel HD Graphics 620, 1 TB SSD, macOS Monterey 12.6.1

    ---

    HP Compaq 8300 Elite, Intel Core i5-3470, 4 x 3,20 GHz, 8 GB RAM, Ivy Bridge, Nvidia Geforce GT 710 (Intel HD Graphics 2500), macOS Catalina 10.15.7

  • Leider hat der Patch zu keiner Verbesserung geführt. Scheint aber auch nicht korrekt durchgelaufen zu sein:



    Edit: Die Glitches habe ich jetzt nur noch in der linken oberen Ecke in der Menüleiste.


    Die Glitches sind weg, ich habe folgenden Patch benutzt:



    Das ist schonmal gut. Die nächsten beiden größeren Probleme:


    - Die Batterieanzeige zeigt mir 0% Ladung an. funktioniert mit der DSDT von iPhoneTruth
    - Das Touchpad spinnt etwas rum. Wenn ich in der oberen Menüleiste ein Menü öffnen will, öffnet und schliesst sich dieses abwechslend und rasend schnell. Das Konto ich mit einer anderen Version von VoodooPS2Controller.kext beheben (1.8.25)


    Audio funktioniert auch mit AppleALC ohne jegliche LayoutID (?)


    Update: Ich habe mich gestern weiter mit dem E460 beschäftigt und es funktioniert schon recht viel, auch z.B. Bild & Ton über HDMI.


    Leider dauert der Bootvorgag weiterhin recht lang, Herunterfahren führt zum Neustart und Sleep/Wake funktioniert nicht (wacht nicht mehr auf). Die SSDT habe ich mir für meine CPU generiert und ausgetauscht.


    Ich benutze noch die DSDT für das E560 von @iPhoneTruth, mit der Audio und die Batterieanzeige funktionieren. Da es aber nur ein ähnliches Modell ist, dürfte mit einer gepatchten DSDT für mein E460 mehr drin sein. Ob mir wohl dabei jemand behilflich sein kann? Ich habe mal die DSDT aus origin und die von @iPhoneTruth angegehangen, ebenso die config.plist.

    Files

    Edited 7 times, last by Harper Lewis ().

  • Dann rufen wir mal den großen "Meister der DSDT" @al6042


    :bitte:


    Da braucht jemand Deine Hilfe !

    HP Elite X2 G2, 12'', Intel Core i5-7200U, 8 GB RAM, Intel HD Graphics 620, 1 TB SSD, macOS Monterey 12.6.1

    ---

    HP Compaq 8300 Elite, Intel Core i5-3470, 4 x 3,20 GHz, 8 GB RAM, Ivy Bridge, Nvidia Geforce GT 710 (Intel HD Graphics 2500), macOS Catalina 10.15.7

  • Morsche...
    natürlich werde ich euch unter die Arme greifen, aber ich kann erst heute Abend gegen 21 Uhr drauf schauen.

    Gruß
    Al6042

    Keine Unterstützung per PN oder Pinnwand... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Hallo,


    vielen Dank schonmal, es hat keine Eile.


    Anbei auch mal die ssdt, die ich mit dem Script ssdtPRGen.sh von Pike R. Alpha erstellt habe.


    Nachtrag: Ich habe jetzt mal komplett ohne DSDT und nur mit der ssdt im Anhang gebootet: Sleep/Wake hat funktioniert und zwar sowohl durch aktives in den Schlaf schicken, als auch durch Warten, bis das E460 von allein einschläft. Das ist ja schonmal ein ganz gutes Zeichen, denke ich. Audio, Batterieanzeige und Shutdown funktionieren so natürlich nicht mehr.


    Nachtrag: Ich habe jetzt mal selbst versucht, die DSDT zu dekompilieren (iasl im Terminal), aber erhalte die selben vier syntax errors in MaciASL die ich auch erhalte, wenn ich die DSDT.aml direkt in MaciASL öffne und versuche, diese zu kompilieren. Dooferweise verstehe ich die Fehlermeldungen nicht, das ist dann doch noch zu sehr Neuland für mich. :(

    Files

    • ssdt.aml

      (1.79 kB, downloaded 169 times, last: )

    Edited 2 times, last by Harper Lewis ().

  • Das was du da drangehängt hast, ist die ssdt für die CPU. Die hilft hier nicht viel...(: Wir brauchen die DSDT.
    Da hast du dich wohl Verklickt

  • Die steht etwas weiter oben... :)

    Gruß
    Al6042

    Keine Unterstützung per PN oder Pinnwand... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Jau, die DSDT aus Clover (F4) ist die DSDT-E460.aml aus dem Beitrag weiter oben. Ist manchmal etwas verwirrend, wenn man den letzten Beitrag mehr als einmal editiert hat (insbesondere für mich :) ).