Kein Sleep & Power Nap

  • Mit dem Script von PikerAlpha kann man eine SSDT erstellen. Als output bekommt man das was in dem screenshot abgebildet ist.
    Man bekommt 2 ssdt-s.
    Ich hab probeweise die 2 ausprobiert. Da verschwindet der Schieber "Ruhezustand für Computer",
    Dann hab ich den ganzen Inhalt von ACPI kopiert mit SSDT.aml (1). Scheint alles zu laufen und "Ruhezustand für Computer" ist vorhanden.
    Dann hab ich noch die ssdt.dsl dazugegeben, wieder läuft alles ohne Probleme.
    Kann jemand erklären was man eigentlich verwenden soll?

  • Was genau ist das für ein Ordner? Benutzt du die Anleitung aus der Wiki?

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Bin auch gerade am Powernap „herumdoktern“ muss denn jetzt dafür noch immer die SSDT generiert werden oder sollte auch „Plugintype“ in der clover config.plist reichen?


    Momentan geht der Rechner problemlos schlafen, wacht dann aber komplett wieder auf zum zb. Time Machine backup und geht danach wieder schlafen. Darkwake steht auf 1

    Gigabyte Z490 Vision G
    Intel Core i7-10700k
    Ram 32GB DDR4
    AMD RX 570

  • Das eine sind die Einstellungsmöglichkeiten im "Energie Sparen"-Setting denn diese geben nur in bestimmten Fällen die Power Nap Funktion.
    Notwendig hierfür sind meistens 2 Dinge:
    1. Das X86PlatformPlugin wird für die CPU geladen: Dies wird ganz einfach durch den Plugin Type erzielt. Ob jetzt ssdtprgen genutzt wird oder die Clover Option ist für das bloße Laden relativ egal
    2. Ein kompatibles SMBios wird benutzt: Griven hat hier schonmal ein kleine Liste gemacht (Post 6)


    Das andere ist ein funktionierendes Power Nap zu haben, und das ist eine ganz andere Geschichte. Power Nap verspricht die Aktualisierung von Netzwerkdiensten und Sicherung des Systems, selbst wenn sich dieses im Sleep befindet. Hierfür sendet es meist RTC-Wake Calls. Damit ein Hacky an diesem Punkt nicht abschmiert ist verschiedenes notwendig, ist dies aber nicht das Problem, wacht trotzdem praktisch jeder Desktop-Hacky an diesem Punkt aus dem Sleep in der Art auf, dass sich die Fans anfangen zu drehen und das System seine Power Nap Aufgaben durchführt, die Bildausgabe jedoch deaktiviert bleibt. Nach einiger Zeit schläft der Hacky dann wieder ein...

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Ahhhh ok, ok jetzt hab ich das wohl gerafft. Irgendwie (warum auch immer) war ich der Meinung, der wacht immer Powernap nicht auf. Irrglaube .. gerade noch mal im Fritz DECT gecheckt, passt dann wohl so. gegen 12 Uhr hatte ich Powernap aktiviert, das Time Machine Backup lief wohl um 13:30 Uhr danach stündlich mal wach mit ca. 70 Watt verbrauch und danach wieder in den Sleep. Er wacht auch problemlos auf ohne Absturz. Monitor geht an, Audio auch keine Probleme.

  • Das sieht doch so aus als sollte das so :D

  • @Higgins12
    Du hast in deine Signatur noch das selbe Board, wie ich. Hast/Hattest Du dort Sleep/Wake mit PowerNap voll laufend?


    Würdest Du mir in diesem Falle deine EFI zur Verfügung stellen? Bei mir läuft das immer an einzelnen Stellen nicht.

  • Nein, die Signatur, sollte ich mal überarbeiten :) Das was in der linken Spalte unter Profil steht ist richtig. Also das Gigabyte Aorus Z370

    Gigabyte Z490 Vision G
    Intel Core i7-10700k
    Ram 32GB DDR4
    AMD RX 570

  • griven

    Added the Label Erledigt