Dualboot Mac OS X und Windows auf einer Festplatte

  • Lösung:
    Siehe Auf einer Festplatte: Windows und macOS im Dualboot

    unter Achtung (falls keine Beanstandung durch die Mods)



    Liebe Community,


    ich habe, nachdem ich vor einem halben Jahr meinen Hackintosh erfolgreich aufgesetzt habe, nun das Problem, dass ich mein Windows von meiner super langsamen Festplatte auf meine SSD verschieben wollte. Anlass dafür war, dass sich Windows selbst zerstört hatte und sich auch nicht mehr richtig reparieren ließ. Deshalb habe ich jetzt gerade kein Windows zur Verfügung.


    Hier das Problem:


    Wenn ich versuche Windows zu Installieren, sagt er mir entweder: "Es konnte keine neue Partition erstellt oder eine vorhandene Partition gefunden werden. Weitere Informationen entnehmen sie dem Protokolldateien zum Setup" oder er meint, dass ich Windows nicht installieren kann, aufgrund des MBR-Festplattenformatierung. Wenn ich jedoch unter Mac OS X nachschaue, dann ist das Format GUID (GPT was Windows benötigt).
    Zu den Infos die ich schon habe: Ich habe gelesen, dass es irgendwelche Hybrid MBR/GPT Formate gibt, die von Windows als MBR und von allen anderen als GPT gelesen werden.


    Wenn ich den Prozess umkehre, also erst Windows, dann Mac OS X, dann meint er, dass er die Partition nicht löschen kann. ("MediaKit: Für den Vorgang ist nicht genügend Speicher verfügbar" oder so, Es sind aber noch 118GB frei) Ich vermute, dass es mit dem Windows Formatierungsschema zusammen hängt.


    Zu meinen Installationen:


    Ich versuche macOS sierra 10.12.0.x und
    Windows 14393.693 (ist nur ne Vermutung, jedenfalls die aktuellste)


    Ich habe auch schon mit Misserfolg die FAQ abgearbeitet.


    wenn ihr mir also helfen könntet, wäre das echt klasse :)

    Edited 2 times, last by DelphiXE ().

  • Hast du die SSD mit deiner Sierra-Installation vor der versuchten Installation von Windows 10 abgeklemmt? Wie hast du das Installationsmedium für Windows 10 vorbereitet? Solltest du ein UEFI-Board haben, würde ich unter Windows mit Rufus einen USB-Bootstick ("GPT Partitionsschema für UEFI Computer") erstellen und Windows 10 auf einer zusätzlichen SSD oder HD installieren. Danach die SSD mit Sierra wieder anklemmen und entweder über die Bootauswahl des Mainboards oder Clover das OS booten.

    Kabylake Laptop: Dell Vostro 5370, i5-8250U, UHD 620
    Dell T20: Intel Xeon E3-1225 v3, MSI GeForce GT 710 2GD3H LP

  • Installiere zuerst macOS. Schiebe im FPDP die Mac-Partition um ca. die Hälfte zusammen und lasse den entstandenen unpartionierten Platz unangetastet.
    Neustart mit Windows-Installstick und jetzt sollte die Installation funzen.

    MfG, docplag


    ..................................................................................................................................................................................................................................................................................
    ASRock Z390 Phantom Gaming ITX, i5-9600K, 32GB Corsair 3000, Sapphire RX570 Nitro 8GB | macOS 10.13.6

    GA-Z170M-D3H, i5-6600, 16 GB DDR4 RAM Corsair 2400, Gigabyte RX 560 Gaming OC 4GB | macOS 10.13.6 / 10.14.2 KDEneon, Ubuntu 18.04, Windows 10 Pro
    GA-X58A-UD3R, i7-960, 12 GB DDR3 RAM 1600, Asus GTX660 | OS X 10.11.6
    MacBook Pro Late 2011, optisches Laufwerk rausgeflogen, SSD eingebaut | OSX 10.9.5, macOS 10.13.2, Windows 7 Pro als VM
    E35M1-I Deluxe, AMD-CPU E350, EVGA-GTX210, 8 GB DDR3 RAM
    | XPEnology DSM 6.1.7
    Dell XPS 15-9560, i7-7700HQ, 16GB DDR4 RAM, HD630, GTX1050M
    | macOS 10.13.6, ElementaryOS 5 , Windows 10 ToGo

  • Sorry - ich hatte überlesen, dass Windows und Sierra auf die selbe SSD installiert werden sollen.

    Kabylake Laptop: Dell Vostro 5370, i5-8250U, UHD 620
    Dell T20: Intel Xeon E3-1225 v3, MSI GeForce GT 710 2GD3H LP

  • Installiere zuerst macOS. Schiebe im FPDP die Mac-Partition um ca. die Hälfte zusammen und lasse den entstandenen unpartionierten Platz unangetastet.
    Neustart mit Windows-Installstick und jetzt sollte die Installation funzen.


    Nein, das habe ich alles schon versucht, er sagt mir dass er nicht installieren kann.


    Edit: Kann es eventuell an der Windows 10 versuon liegen? Mir sagte nämlich jemand, das die mit Linux große Probleme habe und mac OS ist ja ein Unix System.

    Edited once, last by DelphiXE ().

  • Genau so wie beschrieben habe ich die Installation von MacOSX und Windows 10 auf einer SSD in meinem HPEnvy-Notebook erfolgreich zu Ende gebracht.
    "Er sagt mir dass er nicht installiern kann" ist jetzt nicht gerade eine präzise Beschreibung. Ein Foto der Fehlermeldung wäre hilfreicher.

    MfG, docplag


    ..................................................................................................................................................................................................................................................................................
    ASRock Z390 Phantom Gaming ITX, i5-9600K, 32GB Corsair 3000, Sapphire RX570 Nitro 8GB | macOS 10.13.6

    GA-Z170M-D3H, i5-6600, 16 GB DDR4 RAM Corsair 2400, Gigabyte RX 560 Gaming OC 4GB | macOS 10.13.6 / 10.14.2 KDEneon, Ubuntu 18.04, Windows 10 Pro
    GA-X58A-UD3R, i7-960, 12 GB DDR3 RAM 1600, Asus GTX660 | OS X 10.11.6
    MacBook Pro Late 2011, optisches Laufwerk rausgeflogen, SSD eingebaut | OSX 10.9.5, macOS 10.13.2, Windows 7 Pro als VM
    E35M1-I Deluxe, AMD-CPU E350, EVGA-GTX210, 8 GB DDR3 RAM
    | XPEnology DSM 6.1.7
    Dell XPS 15-9560, i7-7700HQ, 16GB DDR4 RAM, HD630, GTX1050M
    | macOS 10.13.6, ElementaryOS 5 , Windows 10 ToGo

  • Siehe Fehlermeldung bei Windows Installation Foto kann ich noch liefern.


    Edit: Mein Tippfehler

    Edited once, last by DelphiXE ().

  • Diese Fehlermeldungen hatte ich auch, die oben genannte Methode (Installation in unpartitionierten Bereich) funktionierte dann.
    Wie hast du den Install-Stick für Windows 10 erstellt?
    Oder versuchst du es von einer DVD?
    Wählst du das Installationsmedium im UEFI-Modus?

    MfG, docplag


    ..................................................................................................................................................................................................................................................................................
    ASRock Z390 Phantom Gaming ITX, i5-9600K, 32GB Corsair 3000, Sapphire RX570 Nitro 8GB | macOS 10.13.6

    GA-Z170M-D3H, i5-6600, 16 GB DDR4 RAM Corsair 2400, Gigabyte RX 560 Gaming OC 4GB | macOS 10.13.6 / 10.14.2 KDEneon, Ubuntu 18.04, Windows 10 Pro
    GA-X58A-UD3R, i7-960, 12 GB DDR3 RAM 1600, Asus GTX660 | OS X 10.11.6
    MacBook Pro Late 2011, optisches Laufwerk rausgeflogen, SSD eingebaut | OSX 10.9.5, macOS 10.13.2, Windows 7 Pro als VM
    E35M1-I Deluxe, AMD-CPU E350, EVGA-GTX210, 8 GB DDR3 RAM
    | XPEnology DSM 6.1.7
    Dell XPS 15-9560, i7-7700HQ, 16GB DDR4 RAM, HD630, GTX1050M
    | macOS 10.13.6, ElementaryOS 5 , Windows 10 ToGo

  • Bin gerade dabei, das ganze nochmal zu versuchen.


    Der Stick ist mit Rufus mit GPT für UEFI Systeme erstellt wurden.
    Die Installation wird automatisch gestartet, im UEFI Modus, da mein UEFI auf UEFI Boot steht und USB an erster stelle. Mehr kann ich auch im UEFI nicht einstellen

  • Hast du nach der ISO Auswahl in Rufus auch nochmal auf GPT umgestellt?
    Sobald man in Rufus ein ISO auswählt, wird nämlich normalerweise wieder zurückgestellt.

    System 1: Skylake System, GIGABYTE Z170X-Designare, Intel i7 6700K, EVGA GTX 980 Ti SC+ 6GB GDDR5, 2x 16GB Vengeance Corsair, BCM943602CS, G5 ATX Mod - TheLaserHive, Clover
    System 2: Terra Workstation, Fujitsu D3402-B1 Mainboard, i5 6500 CPU, ZOTAC GTX 1060 3GB, 2x 8GB RAM, BCM943602CS, Clover
    System 3:
    Dell Optiplex 780, Intel® Core™2 Quad CPU Q9550, 4x 2GB RAM 800MHz, NVIDIA GeForce GT 710 2047 MB, BCM943602CS, Clover

  • Ja. Habe ich

  • Ups, das ist ja hinterhältig. Ich erstelle Bootmedien für Windows immer händisch. Mit diskpart wird der Stick vorbereitet und mit xcopy werden die Daten des Iso's rüberkopiert. Klappt immer.

    MfG, docplag


    ..................................................................................................................................................................................................................................................................................
    ASRock Z390 Phantom Gaming ITX, i5-9600K, 32GB Corsair 3000, Sapphire RX570 Nitro 8GB | macOS 10.13.6

    GA-Z170M-D3H, i5-6600, 16 GB DDR4 RAM Corsair 2400, Gigabyte RX 560 Gaming OC 4GB | macOS 10.13.6 / 10.14.2 KDEneon, Ubuntu 18.04, Windows 10 Pro
    GA-X58A-UD3R, i7-960, 12 GB DDR3 RAM 1600, Asus GTX660 | OS X 10.11.6
    MacBook Pro Late 2011, optisches Laufwerk rausgeflogen, SSD eingebaut | OSX 10.9.5, macOS 10.13.2, Windows 7 Pro als VM
    E35M1-I Deluxe, AMD-CPU E350, EVGA-GTX210, 8 GB DDR3 RAM
    | XPEnology DSM 6.1.7
    Dell XPS 15-9560, i7-7700HQ, 16GB DDR4 RAM, HD630, GTX1050M
    | macOS 10.13.6, ElementaryOS 5 , Windows 10 ToGo

  • Installiere zuerst macOS. Schiebe im FPDP die Mac-Partition um ca. die Hälfte zusammen und .....


    Warum erst auf der gesamten HDD-Größe installieren und dann wieder zusammenschieben?
    Vor der Installation von OS X die dafür gedachte Partitionsgröße im FPDP festlegen und darauf installieren erspart das Zusammenschieben.


    Richtig (& wichtig) ist, den verbliebenen Platz für die nachfolgende Win OS-Installation unangetastet zu lassen. So habe ich es bei meinem Vaio gemacht und dahinter noch zwei Win OS installiert.
    Das schaute dann so aus:



    Gruß
    LOM

    System 2 (Macbook Pro9.1) Vaio VPC-F23A9E, Intel Core i7-2670QM @2.2GHz, Intel HD3000/Nvidia GT540M 1GB, Samsung 6GB DDR3, HTS5475A9E384 640GB & WD5000LPVX 500GB, 4xBoot EC 10.11.6 & Yos 10.10.5 & Win10- & Win7-Home x64
    System 3 (iMac14.2/FlatMac) Gigabyte GA-H81TN, Intel i3-4370 @3.9GHz, 4GB, HD4600, 2x WD5000LPVX, Sony Optiarc AD7585H, EC 10.11.6 & Win8.1x64
    System 4 (iMac 10.1/ PM G5) Gigabyte GA-G41M-Combo, Intel C2D E8500 @3.16GHz, 4GB HyperX, Gigabyte HD5770, WD1600S, OS X Yos & Win10x64
    System 5
    (iMac10.1/Hyundai) Gigabyte GA-G31M-ES2L, Intel X5450 @3.00GHz, 4GB, HD4870 1GB, WD5000AAKX, EC 10.11.6 & Win10x64
    (System 6 (iMac /Atari 1040 ST-F) ASRock Q1900TM-ITX, intel Q1900 @2.0GHz, 8GB, HD2500/HD6450, WD5000LPVX 5000GB, SL 10.6.5 & Win 8.1-x64
    Original Mac
    MacPro2.1 2x Intel X5355 QuadCore 2.66GHz, SL/Lion/ML/Mav/Yos/EC/Win7x64/8.1x64/10x64, HD5770 * Power Mac G5: 1.8GHz SP/1.8GHzDP/2.0GHzDP/2.5GHzDP/2.7GHzDP @ Tiger & Leopard

  • den verbliebenen Platz für die nachfolgende Win OS-Installation unangetastet zu lassen


    Das habe ich doch auch schon geschrieben.


    Wenn ich auf einer leeren Platte MacOSX installiere, ist das nun wirklich kein Aufwand den Platz im FPDP einfach zu verkleinern, denn wie soll ich ein Windows-Tool vorher benutzen, wenn ich gar kein Windows installiert habe.

    MfG, docplag


    ..................................................................................................................................................................................................................................................................................
    ASRock Z390 Phantom Gaming ITX, i5-9600K, 32GB Corsair 3000, Sapphire RX570 Nitro 8GB | macOS 10.13.6

    GA-Z170M-D3H, i5-6600, 16 GB DDR4 RAM Corsair 2400, Gigabyte RX 560 Gaming OC 4GB | macOS 10.13.6 / 10.14.2 KDEneon, Ubuntu 18.04, Windows 10 Pro
    GA-X58A-UD3R, i7-960, 12 GB DDR3 RAM 1600, Asus GTX660 | OS X 10.11.6
    MacBook Pro Late 2011, optisches Laufwerk rausgeflogen, SSD eingebaut | OSX 10.9.5, macOS 10.13.2, Windows 7 Pro als VM
    E35M1-I Deluxe, AMD-CPU E350, EVGA-GTX210, 8 GB DDR3 RAM
    | XPEnology DSM 6.1.7
    Dell XPS 15-9560, i7-7700HQ, 16GB DDR4 RAM, HD630, GTX1050M
    | macOS 10.13.6, ElementaryOS 5 , Windows 10 ToGo

  • Doctor Plagiat :


    Lies bitte richtig, denn ich habe ja Deine Aussage bzgl. unangetastet damit nochmal unterstützend bestätigt.


    Warum man eine Installation erst über die gesamte Platte machen soll, um dann die Größe zu mindern, erschließt sich mir nicht. Beim Erstellen der Partition an sich (ein Vorgang, den man eh machen muss) direkt die richtige Größe angeben erspart den zusätzlichen Vorgang des Verkleinerns.


    Von welchem notwendigen Windows-Tool sprichst Du? Habe ich was überlesen?


    Gruß
    LOM

    System 2 (Macbook Pro9.1) Vaio VPC-F23A9E, Intel Core i7-2670QM @2.2GHz, Intel HD3000/Nvidia GT540M 1GB, Samsung 6GB DDR3, HTS5475A9E384 640GB & WD5000LPVX 500GB, 4xBoot EC 10.11.6 & Yos 10.10.5 & Win10- & Win7-Home x64
    System 3 (iMac14.2/FlatMac) Gigabyte GA-H81TN, Intel i3-4370 @3.9GHz, 4GB, HD4600, 2x WD5000LPVX, Sony Optiarc AD7585H, EC 10.11.6 & Win8.1x64
    System 4 (iMac 10.1/ PM G5) Gigabyte GA-G41M-Combo, Intel C2D E8500 @3.16GHz, 4GB HyperX, Gigabyte HD5770, WD1600S, OS X Yos & Win10x64
    System 5
    (iMac10.1/Hyundai) Gigabyte GA-G31M-ES2L, Intel X5450 @3.00GHz, 4GB, HD4870 1GB, WD5000AAKX, EC 10.11.6 & Win10x64
    (System 6 (iMac /Atari 1040 ST-F) ASRock Q1900TM-ITX, intel Q1900 @2.0GHz, 8GB, HD2500/HD6450, WD5000LPVX 5000GB, SL 10.6.5 & Win 8.1-x64
    Original Mac
    MacPro2.1 2x Intel X5355 QuadCore 2.66GHz, SL/Lion/ML/Mav/Yos/EC/Win7x64/8.1x64/10x64, HD5770 * Power Mac G5: 1.8GHz SP/1.8GHzDP/2.0GHzDP/2.5GHzDP/2.7GHzDP @ Tiger & Leopard

  • Das Problem ist, das ich nichts "Unangetastet" lassen kann. Hast du dir schon mal das FPDP von Sierra oder El Capitan angesehen?


    Oh, Entschuldigung, dachte, das war an mich gerichtet

  • Die Fehlermeldung ist mr vorher noch nie unter die Augen gekommen. Schön das man immer wieder mal was Neues sieht, hilft an der Stelle aber überhaupt nicht.
    Kann es sein, dass die Recovery da auch noch weg muss? Wobei ich gerade bei meinem Notebook nachgesehen habe, dort gibt es die Recovery auch.
    Leider fällt mir momentan nichts weiter dazu ein. :(

    MfG, docplag


    ..................................................................................................................................................................................................................................................................................
    ASRock Z390 Phantom Gaming ITX, i5-9600K, 32GB Corsair 3000, Sapphire RX570 Nitro 8GB | macOS 10.13.6

    GA-Z170M-D3H, i5-6600, 16 GB DDR4 RAM Corsair 2400, Gigabyte RX 560 Gaming OC 4GB | macOS 10.13.6 / 10.14.2 KDEneon, Ubuntu 18.04, Windows 10 Pro
    GA-X58A-UD3R, i7-960, 12 GB DDR3 RAM 1600, Asus GTX660 | OS X 10.11.6
    MacBook Pro Late 2011, optisches Laufwerk rausgeflogen, SSD eingebaut | OSX 10.9.5, macOS 10.13.2, Windows 7 Pro als VM
    E35M1-I Deluxe, AMD-CPU E350, EVGA-GTX210, 8 GB DDR3 RAM
    | XPEnology DSM 6.1.7
    Dell XPS 15-9560, i7-7700HQ, 16GB DDR4 RAM, HD630, GTX1050M
    | macOS 10.13.6, ElementaryOS 5 , Windows 10 ToGo

  • DelphiXE :


    Mein Fehler - ich hatte gedacht, ich pack es unmittelbar drunter und habe deshalb mit der Anrede Doctor Plagiat geschlampt. Ich bin beim Tippen einfach zu langsam.


    Erkläre mir mal bitte, wann diese Meldung rechts kam (lt. Foto war das vor dem Foto der Partitionstabelle)?


    Wieso gibt es ein Laufwerk 1?

    System 2 (Macbook Pro9.1) Vaio VPC-F23A9E, Intel Core i7-2670QM @2.2GHz, Intel HD3000/Nvidia GT540M 1GB, Samsung 6GB DDR3, HTS5475A9E384 640GB & WD5000LPVX 500GB, 4xBoot EC 10.11.6 & Yos 10.10.5 & Win10- & Win7-Home x64
    System 3 (iMac14.2/FlatMac) Gigabyte GA-H81TN, Intel i3-4370 @3.9GHz, 4GB, HD4600, 2x WD5000LPVX, Sony Optiarc AD7585H, EC 10.11.6 & Win8.1x64
    System 4 (iMac 10.1/ PM G5) Gigabyte GA-G41M-Combo, Intel C2D E8500 @3.16GHz, 4GB HyperX, Gigabyte HD5770, WD1600S, OS X Yos & Win10x64
    System 5
    (iMac10.1/Hyundai) Gigabyte GA-G31M-ES2L, Intel X5450 @3.00GHz, 4GB, HD4870 1GB, WD5000AAKX, EC 10.11.6 & Win10x64
    (System 6 (iMac /Atari 1040 ST-F) ASRock Q1900TM-ITX, intel Q1900 @2.0GHz, 8GB, HD2500/HD6450, WD5000LPVX 5000GB, SL 10.6.5 & Win 8.1-x64
    Original Mac
    MacPro2.1 2x Intel X5355 QuadCore 2.66GHz, SL/Lion/ML/Mav/Yos/EC/Win7x64/8.1x64/10x64, HD5770 * Power Mac G5: 1.8GHz SP/1.8GHzDP/2.0GHzDP/2.5GHzDP/2.7GHzDP @ Tiger & Leopard