Quicksync, Virtual-Screen Abstürze und iGPU+ded. GPU mit Grafikbeschleunigung

  • Bei @herrfelix wäre es folgendes:


    in beiliegender DSDT...

    Files

    • DSDT.aml

      (144.45 kB, downloaded 10 times, last: )

    Gruß
    Al6042


    Asus Prime Z390-A 1302 | i9 9900k | 32GB | 5700XT 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.15.1 | OC

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.15.1 | OC

    NUC7i5BNK 0076 | i5 7260U | 16GB | HD640 | NVMe 500 GB | Windows

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.15.1


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Und bei mir lediglich:

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Der unterschied liegt in den Skylake Properties, welche für den Bild-Fehler am linken oberen Rand zuständig waren.
    Zwischendurch habe ich @herrfelix auch eine Version mit der gleichen Menge an Angaben wie bei dir übergeben.
    Aber auch damit hatte er Boot-Probleme.

    Gruß
    Al6042


    Asus Prime Z390-A 1302 | i9 9900k | 32GB | 5700XT 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.15.1 | OC

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.15.1 | OC

    NUC7i5BNK 0076 | i5 7260U | 16GB | HD640 | NVMe 500 GB | Windows

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.15.1


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Hat das überhaupt mal jemand mit einer HD4000 umgesetzt?

    System 1 (iMac 15,1) InterTech W-III: ASROCK Z97 Pro4, OpenCore, Intel I7-4970K @ 4.0 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, macOS Mojave 10.14, macOS Catalina 10.15
    System 2 (MacBook Pro 10.2): ThinkPad T430, i5-3360M @ 2.8 GHz, 8GB DDR3, IntelHD 4000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Dual Boot MacOS Mojave 10.14, Windows10 Pro 64Bit

    griven.png

  • Nein, mit einer HD 530 vor diesem Thread auch nicht, aber inzwischen wissen wir was es dazu braucht ;) Welche spezifischen Änderungen in der DSDT für die HD 4000 notwendig sind weiß ich nicht aber irgendwie ist es kompliziert. Die generelle Vorgehensweise ist aber die gleiche wie bei der HD 4600 und 530...
    @griven SysDefi ist bei dir 13.2 oder?

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • 15.1 ist es bei mir passend zu AMD...
    Ich kann aber als SMBIOS nutzen was ich will sobald ich die HD4000 mit einer Connectorless ID ausstatte bekomme ich Kernelpaniken...

    System 1 (iMac 15,1) InterTech W-III: ASROCK Z97 Pro4, OpenCore, Intel I7-4970K @ 4.0 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, macOS Mojave 10.14, macOS Catalina 10.15
    System 2 (MacBook Pro 10.2): ThinkPad T430, i5-3360M @ 2.8 GHz, 8GB DDR3, IntelHD 4000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Dual Boot MacOS Mojave 10.14, Windows10 Pro 64Bit

    griven.png

  • Hast du es mal mit iMac 13.2 ausprobiert?
    Und entsprechen die folgenden Änderungen deiner DSDT?
    Comment: change GFX0 to IGPU
    Find: 47465830
    Replace: 49475055


    Comment: change HECI to IMEI
    Find: 48454349
    Replace: 494D4549


    Comment: change MEI to IMEI
    Find: 4D45495F
    Replace: 494D4549

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Das Device MEI oder IMEI fehlte bisher in meiner DSDT ich habe es mal hinzugefügt (PJALM Graphics Patch) und es wird mit den folgenden Werten belegt:

    nur sehe ich hier erstmal keinen Grund warum das dazu beitragen sollte die ConnectorLess ID zu laden (habe das mit iMac 15.1, 14,1 und 13.1 und 13.2 als Sysdef durch)...


    Edit Nachtrag das einfügen des IMEI Device bewirkt lediglich das mit HDMI Audio flöten geht...

    System 1 (iMac 15,1) InterTech W-III: ASROCK Z97 Pro4, OpenCore, Intel I7-4970K @ 4.0 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, macOS Mojave 10.14, macOS Catalina 10.15
    System 2 (MacBook Pro 10.2): ThinkPad T430, i5-3360M @ 2.8 GHz, 8GB DDR3, IntelHD 4000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Dual Boot MacOS Mojave 10.14, Windows10 Pro 64Bit

    griven.png

  • Habe die letzte DSDT auch getestet, habe aber nur wieder einen Panic.

    Mainboard: ASUS PRIME Z270-A • CPU: Intel Core i7-6700K • Grafikkarte: Saphirre RX 570 Nitro+ 4GBClover & macOS Mojave (steht's aktuell) • Gehäuse: NZXT S340 Midi-Tower Weiß

  • Hab das Thema QuickSync nun auch bemerkt :D
    Da ich einiges mit FCPX mache wäre es ja nicht verkehrt es aktiviert zu bekommen. Allerdings tu ich mich mit dem Verständnis diesbezüglich schwer :huh:


    Prozessor ist ein i5 6600K, Grafikkarte eine Gigabyte GTX980 Ti...sollte damit machbar sein oder?
    Prozessorinterne Grafikeinheit ist seit Geburt des Hackis im Feb. 2016 deaktiviert gewesen.

    iPhone X - 256GB
    iPad Mini 2 - 128GB

    MacBook Pro Late 2012 - i5, 8GB RAM, 128GB SSD

    Mac Mini Late 2018 - i7, 32GB RAM 512GB SSD

  • Der 6600k greift ja auch die HD 530 zurück. Du solltest dich also am HD 530 Eintrag (verlinkt im ersten Post) entlanghangeln und dementsprechend als ersten Schritt die iGPU aktivieren ;)

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Ich wollte nur nur nochmals anmerken, ich habe keine Ahnung ihr da gezaubert habt und wie das nun funktioniert aber es funktioniert :groesten:


    möchte auch noch davon kund tun das motion und Compressor auch voll funktionsfähig sind ..
    nächster Test Compressor Stapelverarbeitung und die Übergabe aus fcpx an Compressor..


    nächste Geschichte wird Resolve werden und die Tests mit affinity..


    was nicht funktionierte ist der luxmark ocl Test.. resp er funktioniert aber die igpu taucht nicht auf..

  • Soll auch so sein, also bei dir ist alles 1A. Du bist das Vorzeigekind :D

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Grmph das muss doch mit der HD4000 auch gehen....

    System 1 (iMac 15,1) InterTech W-III: ASROCK Z97 Pro4, OpenCore, Intel I7-4970K @ 4.0 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, macOS Mojave 10.14, macOS Catalina 10.15
    System 2 (MacBook Pro 10.2): ThinkPad T430, i5-3360M @ 2.8 GHz, 8GB DDR3, IntelHD 4000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Dual Boot MacOS Mojave 10.14, Windows10 Pro 64Bit

    griven.png

  • Stapelverarbeitung aus Compressor funktioniert auch... bei 4kzu4k avc läuft nur die Qsync Engine
    beim Eindampfen von 4K zu FullHD sieht man genau wie die GTX 970 sich um das Resizen kümmert und parallel die IGPU via QSync in h264 wandelt.


    Resolve NO nur die GTX wird erkannt ebenso Fusion.. ok da steht die 14 in den Startlöchern.


    Affinty funktioniert auch ... resp. es macht keine Troubles..


    so ich hau mich aufs Ohr muss o5:00 raus aus dem Haus :facepalm:


    :danke2::hackintosh:
    absolut der Hammer

  • danke kuckuck und allen anderen.
    fcp x 10.3,sierra und rx 480 scheint stabil zu laufen.
    jetzt geh ich mal an die sonne und werde später meine neue Konfiguration nachtragen.
    morix


    sorry für das delay. im Anhang meine plist und ein terminal befehl zum 36 units zu aktivieren. mein hackt läuft wie geschmiert, ruhen und aufwachen und sogar über bluetooth den code eingeben bei neustart! als Nachtisch : keine booteinträge beim starten.
    clover 4047 und bios 20 plus tips von antagon und forum. sierra 10.12.4.
    special thanks to kuckkuck.
    ps.beim booten ist der monitor 45 sec black bis enter password.hab jetzt ein benq monitor über hdmi.
    @ motion group
    mit tob (thunderbold) habe ich noch keine Erfahrung,auch kein display,sorry.
    morix

    Files

    Motherboard GA-Z170X-UD5-TH/Prozessor Intel Core i7 6700K /RAM Crutial BALLISTIX SPORT LT DDR4-2400 kit 2 x 8 GB/GPU AMD RX 480/Samsung ssd 850 EVO/BenQ EW2775ZH/Audio extern Zoom u-24.iMac 17,1/Sierra 10.12.4/Clover 4.60.0.0


    Mac block 13" i5 mid 2012 high sierra

    Edited 2 times, last by morix ().

  • Super! Vielleicht kannst du noch deine config mal anhängen, dann habe ich ein weiteres Vergleichsobjekt ;)

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Hallo Morix was mich besonders interessieren würde, wäre ob bei deinem Mobo der THb Port mit dem alten THb Display funktionieren würde..


    ich suche solch eine Konfiguration um meine alten guten THb Displays weiter betreiben zu können..

  • Jungens, ich dreh durch: HEUREKA!
    Quicksync läuft bei mir!
    ich hab mich heute nochmal drangesetzt und ein bissl rumgespielt - insbesondere da es mich nicht in Ruhe gelassen hat das es wohl offensichtlich nicht an meiner NVIDIA liegen kann.


    Ich teste gerade noch ein wenig, in Kürze mehr ;)

    _______________________________________________________________________________

  • Auf jeden Fall, eine NVIDIA ist kein Grund, warum es nicht gehen soll. Vielleicht nicht bei allen, aber bei meiner GTX 970 klappt es hervorragend. Bin von kuckkucks Arbeit auch schwer begeistert.

    Mainboard: ASUS PRIME Z270-A • CPU: Intel Core i7-6700K • Grafikkarte: Saphirre RX 570 Nitro+ 4GBClover & macOS Mojave (steht's aktuell) • Gehäuse: NZXT S340 Midi-Tower Weiß