iMovie crasht mit Radeon RX 460

  • Hallo,


    habe nun erfolgreich meine Gigabyte Radeon RX 460 ans Laufen bekommen, allerdings stürzt jetzt iMovie (und die Trial von FCP) beim Öffnen oder Anlegen eines Projektes ab:



    Nehme ich das AMDRadeonX4100.kext raus, tritt der Fehler nicht mehr auf, natürlich wird dann aber auch die Karte nicht mehr zum Rendern verwendet. :(


    Kann das vielleicht jemand von euch mal :bitte: gegentesten, damit ich weiß, ob das ein bedauerliches Einzelschicksal ist?


    Vielen Dank, Elladaan

  • Jo Elladaan,
    ich bekomme den gleichen Fehler wie du, und auch bei mir geht alles wenn ich nur die prozessorinterne GraKa benutze!!


    Vielleicht (oder sehr wahrscheinlich) wird apple diese Grafikkarte bald auch in iMacs verbauen,
    deswegen glaube ich dass sich das ganze mit der Zeit klären wird... :verneigen:
    Vielleicht verirrt sich aber auch noch eine andere Lösung in diesen thread


    Ich werde auf jeden fall dran bleiben!


    LG, Cube




    Spoilerd by derHackfan

    Hacki v2:


    Hacki v1:

    Edited once, last by derHackfan ().

  • Der Fehler tritt auf, wenn man gleichzeitig eine Intel und eine AMD Grafikkarte verwendet. Eine solche Kombination gibt es in echten Macs nicht, da hier Apples Grafikumschaltung genutzt wird. Da die Intel Grafik bei den RX-Karten nur für den Boot gebraucht wird hilft es die entsprechenden Intel-Kexte für die jeweilige Karte erst zu sichern, dann aus /System/Library/Extensions zu löschen. Dann hat die Intel-Karte zwar keine Beschleunigung mehr, aber sie ist ja sowieso nur Starthilfe.

    iHack: Ryzen 5 1600, GA-AB350M-D3H, Sapphire RX570 4GB, 16GB DDR4-3000, 250GB NVMe SSD + 512GB SSD + 1TB HDD, OC, macOS 10.15.3, Kubuntu 19.10, Win 8.1


    alter iHack: i3-4330, GA-H81M-HD3, Sapphire RX460 4GB -> RX560 BIOS, 8GB DDR3-1600, 128GB SSD, 250GB HDD, OC, macOS 10.15.3, Kubuntu 19.10, Win 8.1


    ThinkPad T410: i5-520M, Nvidia NVS3100M, 4GB DDR3-1066, 120GB SSD, 250GB HDD, Clover, macOS 10.14.6


    Bastlerware: Acer Aspire 7741G: i5-430M, ATI HD 5650 1GB; 4GB DDR3-1066; 250GB HDD, Clover, macOS 10.13.6, 1.5 von 2 SATA-Ports defekt...


    Originals: MacBook Pro 15 Late 2013 (macOS 10.15.3), iPhone X 64GB (iOS 13.3.1)

  • Hi DerJKM,
    geht imovie bei dir denn?


    Werde es wahrscheinlich heute nicht mehr schaffen die kexte zu löschen/zu sichern, ausserdem habe ich noch einen Eintrag bei clover (siehe Anhang), muss ich den auch löschen oder ist der diesbezüglich egal?


    Ansonsten probiere ich es einfach, mit backup kann man ja alles machen :)
    LG, Cube

    Hacki v2:


    Hacki v1:

  • Der Eintrag dient zur Korrektur eines Darstellungsfehlers der HD530 Onboard Grafik und sollte dort stehen bleiben.

    Gruß
    Al6042


    Asus Prime Z390-A 1401 | i9 9900k | 32GB | 5700XT 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.15.3 | OC

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.15.3 | OC

    NUC7i5BNK 0081 | i5 7260U | 16GB | HD640 | NVMe 500 GB | macOS 10.15.3 | OC

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.15.3


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Ja, das ist mir bewusst, was ich wissen wollte und was du ja auch beantwortet hast ist ob der gelöscht werden sollte oder nicht :thumbup:


    danke für für deine schnelle antwort!!!


    LG, Cube

    Hacki v2:


    Hacki v1:

  • Dann hat die Intel-Karte zwar keine Beschleunigung mehr, aber sie ist ja sowieso nur Starthilfe.


    Weißt du zufällig ob die iGPUs bei echten Macs mit int. und ded. GPU, auf beiden Karten Beschleunigung haben? Ich denke mal schon... ?( Angeblich sollen sie aber eine Connector leere ig-platform-id haben, wenn ich mir 0x0A260005 (original HD4600 MBP ID) anschaue ist diese überhaupt nicht connector leer.


    Eine weitere Frage wäre ob QuickSync die Chance hat ohne Grafikbeschleunigung zu funktionieren, da es sich hierbei ja um einen Hardwarebeschleuniger handelt. Müsste man mal austesten. Das ganze ist aber sehr interessant, auch für alle FCPX User!

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

    Edited 2 times, last by kuckkuck ().

  • Soweit ich das verstehe (reine Spekulation, hab das nur mal auf einem 2015er MBP gesehen) ist der Hauptunterschied dass sich im Mac die Grafikkarten alle Displayanschlüsse teilen, da das interne Display ohne Umstecken durch beide Grafikkarten betrieben werden kann. Es wird ein "virtual Screen" erstellt, von dem um FCPX Absturzbericht die Rede ist. Wie genau das umgesetzt ist, ob mit einem Hardwareumschalter oder wie bei Optimus (alle Displays an der IGPU, Signale der NVIDIA werden durchgeschleift), keine Ahnung.
    Beim Hackintosh hat jede Grafikkarte ja Ihre eigenen Anschlüsse, wodurch diese Umschaltung ("virtual Screen Change") nich möglich ist und fehlschlägt.
    Wenn die Karte durch sichern und löschen der Kexte abgeschaltet wurde, wird vermutlich auch QuickSync nicht mehr gehen. Zumindest bei mir ist FCPX subjektiv mit der RX460 ohne QuickSync von der IGPU schneller als nur mit der IGPU.
    Aber wie gesagt, Belege dafür hab ich keine, das ist nur wie ich vermute dass es funktioniert.

    iHack: Ryzen 5 1600, GA-AB350M-D3H, Sapphire RX570 4GB, 16GB DDR4-3000, 250GB NVMe SSD + 512GB SSD + 1TB HDD, OC, macOS 10.15.3, Kubuntu 19.10, Win 8.1


    alter iHack: i3-4330, GA-H81M-HD3, Sapphire RX460 4GB -> RX560 BIOS, 8GB DDR3-1600, 128GB SSD, 250GB HDD, OC, macOS 10.15.3, Kubuntu 19.10, Win 8.1


    ThinkPad T410: i5-520M, Nvidia NVS3100M, 4GB DDR3-1066, 120GB SSD, 250GB HDD, Clover, macOS 10.14.6


    Bastlerware: Acer Aspire 7741G: i5-430M, ATI HD 5650 1GB; 4GB DDR3-1066; 250GB HDD, Clover, macOS 10.13.6, 1.5 von 2 SATA-Ports defekt...


    Originals: MacBook Pro 15 Late 2013 (macOS 10.15.3), iPhone X 64GB (iOS 13.3.1)

  • Hi,
    bei meinem setup (intel hd530, radeon rx460) bin ich jetzt darauf gekommen, dass die kexts und bundles die mit "AppleIntelSKLGraphics" beginnen das entscheidende Element waren.
    hab diese jetzt entfernt, imovie geht, aber der Ruhezustand funktioniert nicht mehr :negativ:
    (Bildschirm wird schwarz, sonst passiert nix)


    kann mir da vllt jemand helfen?


    LG, Cube

    Hacki v2:


    Hacki v1:

  • Hi,
    "AppleIntelSKLGraphics" [...] entscheidende Element waren.


    Sorry, das ich gerade mal so eingrätsche - hoffe das ist in Ordnung.


    Für welchen Typ von Intel IGPU gelten diese KEXT Dateien? Nur für moderne oder auch für ältere - in meinem Fall RX460 + INTEL HD 4600

    Mit (un)freundlichen Grüßen,
    Murashi


    iMac15,1: MSI B85M-E45 - Intel Core i5 3,2GHz - 16GB DDR3 - RX460 4GB - 275GB Crucial M300 - 240GB Kingston A400
     MacBookPro9,2:
    HP EliteBook 8470p - Intel Core I5 3,2GHz - 8GB DDR3 - Intel HD400 - 120GB Sandisk SSD-Plus

     MacBook7,1: Apple MacBook - Intel Core 2 Duo 2,4 - 9GB DDR3 - nVidia GeForce 320M - 120GB Sandisk SSD-Plus

    MacBookPro3,1: Apple MacBook Pro 17" - Intel Core 2 Duo 2,4 - 4 GB DDR2 - nVidia GeForce 8600GT - 240GB Kingston-A400


    uV2SMdZ.png

  • Hi,
    Das Kürzel SKL in den Kexten steht für Skylake... ;)
    Das Kürzel BDW in den Kexten steht für Broadwell.
    Für Haswell gab es diese Konvention noch nicht, deswegen wurde dort noch der Framebuffer-Name Azul genutzt.
    Für IvyBridges war es der Framebuffer-Name Capri...

    Gruß
    Al6042


    Asus Prime Z390-A 1401 | i9 9900k | 32GB | 5700XT 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.15.3 | OC

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.15.3 | OC

    NUC7i5BNK 0081 | i5 7260U | 16GB | HD640 | NVMe 500 GB | macOS 10.15.3 | OC

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.15.3


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Hat jemand von Euch auch das Problem mit dem Ruhezustand??

    Hacki v2:


    Hacki v1:

  • Hat jemand von Euch auch das Problem mit dem Ruhezustand??


    Jemand von euch? Eine ganze Menge habe Probleme mit dem Ruhezustand von macOS Sierra. Ich leider auch - trotz der Kompetenten Hilfe von al6042 gabs keinen Erfolg.
    Ein leidiges Thema :(

    Mit (un)freundlichen Grüßen,
    Murashi


    iMac15,1: MSI B85M-E45 - Intel Core i5 3,2GHz - 16GB DDR3 - RX460 4GB - 275GB Crucial M300 - 240GB Kingston A400
     MacBookPro9,2:
    HP EliteBook 8470p - Intel Core I5 3,2GHz - 8GB DDR3 - Intel HD400 - 120GB Sandisk SSD-Plus

     MacBook7,1: Apple MacBook - Intel Core 2 Duo 2,4 - 9GB DDR3 - nVidia GeForce 320M - 120GB Sandisk SSD-Plus

    MacBookPro3,1: Apple MacBook Pro 17" - Intel Core 2 Duo 2,4 - 4 GB DDR2 - nVidia GeForce 8600GT - 240GB Kingston-A400


    uV2SMdZ.png

  • Ja, dass viele das haben Weiß ich aber ich hatte mit den Kernel extensions für die interne Grafikkarte nie Probleme damit... Ohne diese funktioniert er aber nicht mehr, und ich wollte Wissen ob speziell dieses Problem jemand von Euch hatte/und vielleicht ne Lösung hat


    LG, Cube

    Hacki v2:


    Hacki v1:

  • Wenn der Bildschirm nach dem Aufwecken schwarz bleibt, kann das daran liegen:
    Skylake-Desktop bootet in schwarzen Bildschirm

    Gruß
    Al6042


    Asus Prime Z390-A 1401 | i9 9900k | 32GB | 5700XT 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.15.3 | OC

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.15.3 | OC

    NUC7i5BNK 0081 | i5 7260U | 16GB | HD640 | NVMe 500 GB | macOS 10.15.3 | OC

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.15.3


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Ich habe gestern bis tief in die Nacht rumgeforscht bezüglich iGPU+ded. GPU, Anschlüssen, Quicksync, Grafikbeschleunigung, Grafikkexten und unterschieden zwischen den Systemversionen und bin auf eine Teillösung gekommen. Ich erstellen heute im Lauf des Tages dazu einen neuen Thread mit meinen Erkenntnissen und verlinkte ihn dann hier.

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Wenn der Bildschirm nach dem Aufwecken schwarz bleibt, kann das daran liegen:
    Skylake-Desktop bootet in schwarzen Bildschirm


    hm, passt leider nicht ganz zu meinen Symptomen, die wären die hier:


    imovie geht, aber der Ruhezustand funktioniert nicht mehr :negativ:
    (Bildschirm wird schwarz, sonst passiert nix)


    trotzdem danke für deine Hilfe, al6042 !!!!


    Ich habe gestern bis tief in die Nacht rumgeforscht bezüglich iGPU+ded. GPU, Anschlüssen, Quicksync, Grafikbeschleunigung, Grafikkexten und unterschieden zwischen den Systemversionen und bin auf eine Teillösung gekommen. Ich erstellen heute im Lauf des Tages dazu einen neuen Thread mit meinen Erkenntnissen und verlinkte ihn dann hier.


    Vielen Dank, Ihr seid echt eine Super community!!!


    Lg, Cube

    Hacki v2:


    Hacki v1:

  • Wie sehen denn deine pmset-Einträge aus?
    Poste doch bitte mal das Ergebnis des folgenden Terminal-Befehls:

    Code
    1. pmset -g


    Zudem wäre spannend zu wissen, welche "Darkwake"-Einstellungen du in Clover vorgenommen hast.
    Die findest du per Clover Configurator unter "Boot" -> "Arguments"

    Gruß
    Al6042


    Asus Prime Z390-A 1401 | i9 9900k | 32GB | 5700XT 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.15.3 | OC

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.15.3 | OC

    NUC7i5BNK 0081 | i5 7260U | 16GB | HD640 | NVMe 500 GB | macOS 10.15.3 | OC

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.15.3


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Hi al6042,


    meine pmsets sehen so aus: (Ich habe den command öfter ausgeführt, da manchmal verschiedene Prozesse den Ruhezustand verhindert haben)



    die darkwake einstellungen habe ich so gelassen Wie sie beim Standard waren, also ohne Zusatz (da steht nur darkwake ;) )


    Ausserdem wollte ich nur noch mal erwähnen dass der Ruhezustand bei mir funktioniert, wenn ich die kexts für die interne Grafikkarte geladen habe (nur dass imovie dann halt net geht :wallbash: )


    LG, Cube

    Hacki v2:


    Hacki v1:

    Edited 2 times, last by CubeMonster ().

  • Dann würde ich dir folgende Herangehensweise nahelegen wollen:


    Ändern auf Hibernatemode 0

    Code
    1. sudo pmset -a hibernatemode 0


    Das Sleep Image löschen

    Code
    1. sudo rm /var/vm/sleepimage


    Ein leeres Sleep Image erstellen

    Code
    1. sudo touch /var/vm/sleepimage


    Die Datei unveränderlich machen

    Code
    1. sudo chflags uchg /var/vm/sleepimage


    Danach einmal neu starten und erneut testen.
    Sollte das nicht zum erwünschten Ergebnis führen, den Darkwake auf "Darkwake=0" ändern und erneut testen.
    Dann schauen wir mal weiter... :)

    Gruß
    Al6042


    Asus Prime Z390-A 1401 | i9 9900k | 32GB | 5700XT 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.15.3 | OC

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.15.3 | OC

    NUC7i5BNK 0081 | i5 7260U | 16GB | HD640 | NVMe 500 GB | macOS 10.15.3 | OC

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.15.3


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!