Lenovo Thinkpad T540p?

  • Hallo zusammen,


    gibt es vielleicht jemanden der schon mal versucht hat aus einem T540p ein Hackbook zu machen?


    Wenn ja, hat es geklappt? Ich beschäftige mich gerade erst mit dem Thema und kann leider zu diesen NB nicht finden und wäre für jeden Input dankbar.


    Gruß
    Kai

  • Guten Morgen und herzlich Willkommen im Forum... :)


    Für das T540p wäre spannend zu wissen, ob dort zusätzlich ein Nvidia GrafikChip drinnen ist und ob du diesen per BIOS Setting deaktivieren kannst.
    Von "Discrete" auf "Internal" oder so...
    Ansonsten wäre eine kurze Aufstellung der verbauten Geräte spannend.
    Diese bekommst du per Linux (LiveCD oder Full-Install) mit dem Befehl

    Code
    1. lspci -nn > ~/Desktop/PCI-Infos.txt


    Darin stehen nicht nur die Namen der Geräte, sondern auch deren Vendor- und Device-IDs für weitere Recherchen.

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Hallo @al6042,


    nein es ist kein Nvidia verbaut.
    Es handelt sich um ein Gerät mit I5-4300M, 16GB Ram, Intel HD4600, 850 EVO 500GB und den weiteren Standard Elementen. Wenn du mehr Infos brauchst, such ich mal eben meine Live CD.

  • Das klingt doch schon mal ziemlich gut.
    Sobald die PCI-Daten vorliegen, kann man mehr dazu sagen.

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • @al6042
    bitte sehr, was mir wichtig ist, ich habe 2 Windows systeme, eins auf der Evo850 und eins auf einer weiteren SSD, kann man da einen Bootloader installieren das ich wenn eines von den 3 Systemen starten kann, sofern OS X überhaupt möglich ist auf dem T540p?


    Die gewünschte Datei:

    Dateien

    • PCI-Infos.txt

      (4,73 kB, 17 Mal heruntergeladen, zuletzt: )
  • Also,
    das OSX sollte auf dem Gerät gut zu installieren sein.
    Das einzige was nicht funktionieren wird, ist die WLAN Karte.
    Für Onboard Audio müssten wir noch wissen, welcher AudioCodec verbaut ist, da die PCI-Infos hier nicht aussagekräftig sind.
    Dies bekommst du per Linux mit folgenden Befehl als Text-Datei auf den Desktop gelegt:

    Code
    1. cat /proc/asound/card0/codec#0 > ~/Desktop/codec00_dump.txt
    2. 
cat /proc/asound/card0/codec#1 > ~/Desktop/codec01_dump.txt

    3. 
cat /proc/asound/card1/codec#0 > ~/Desktop/codec10_dump.txt
    4. cat /proc/asound/card1/codec#1 > ~/Desktop/codec11_dump.txt


    Wenn deine vorherigen WIndows-Installs im UEFI-Modus laufen, kannst du per Clover auf der OSX-Platte wunderbar mindestens den Dualboot einrichten.
    Triple sollte auch gehen.

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Hallo @al6042,


    NB läuft ohne UEFI kann ich auch nicht ändern. Das Wlan wäre für mich das Wichtigste überhaupt, auf Ton kann ich locker verzichten. Wobei ich dir den Output heute abend noch hoch lade.

  • Wegen WLAN solltest du mal in den Support-Docs für das Gerät schauen, welche anderen Karten eingesetzt werden können.
    Die Lenovos haben gerne eine sogenannte Whitelist im BIOS, sodass nicht jede WLAN-Karte eingebaut werden kann.
    Sollte bei der Prüfung etwas von Broadcom oder Atheros heraus kommen, wäre die genaue Bezeichnung wichtig, um zu prüfen, ob diese OSX-tauglich sind.


    In deinem BIOS lässt sich nicht zwischen Legacy und UEFI hin und herschalten?
    Unter "Startup" -> "UEFI/Legacy Boot" auf "UEFI only" setzen und darunter "CSM Support" auf "No" stellen?

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Wenn ich nicht ganz falsch liege, dann ist auch beim T540p die Wlan-Karte per m.2 / NGFF angebunden. Und zufällig gibt es bei ebay ab und zu mal eine BCM94352Z von Lenovo, dh. diese sollte ohne Nachbearbeitung die BIOS-Sperre und sie läuft auch unter OSX...


    "Aber macOS ist manchmal eine Elb gewordene Vulkanette..."
    - Griven


    Du hast dringende Fragen zur Installation deines Systems? Dann poste in einem themenverwandten Thread und [size=12]nutze die geballte Power des Forums anstelle meines Postfaches. Ich bin vielleicht Moderator, aber nicht allwissend oder unfehlbar - sondern moderiere Diskussionen

  • Unter diesem Link ist die FRU-Liste für das T540 zu finden, leider ist - so weit ich das sehe - keine OSX-lauffähige WLAN-Karte dabei ;(


    https://download.lenovo.com/pa…t540_fru_bom_20140108.pdf

    iMac13,2: Gigabyte Ga-Z77X-UD3H, i5-3450, XFX Radeon HD 7850 2GB, 8GB RAM, Ozmosis, OSX 10.12.6, 10.13.6, 10.14


    iMac13,3: Asus H61M-K, i3-3225, intel HD4000, 4GB RAM, Clover 4630, OSX 10.10.5, 10.11.5, 10.12.6, 10.13.6, 10.14, Ubuntu 18.04, Windows 10


    MacBookPro11,1: Lenovo Y50-70, i5 4210H, intel HD4600 (nVidia GTX960), 16GB RAM, Clover 4359, OSX 10.12.6

  • Da die Liste für das T540p leider genauso aussieht, sehe ich da leider keine andere Möglichkeit als
    - entweder die Nutzung eines USB-WLAN-Adapters
    - suche nach einem Mod-BIOS mit entfernter Whitelist.


    Letzteres kann aber nur mit Zusatz-Hardware direkt auf den BIOS-Chip geflasht werden, da die Lenovo Flash-Routine ein solches ROM nicht akzeptieren wird.

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • ich danke euch für die infos, dann bleibt mir also weiterhin nur VMWare nutzen


    @al6042 wlan karte wechseln wäre genauso wenig wie bios umstellen, ist ein firmennotebook und hat seine gründe warum es nicht auf UEFI steht, aber hat sich durch die fehlende wlan karte dann eh erledigt


    danke an allen die hier input geliefert haben

  • Schade...
    Dann werde ich dem Vorgang aber trotzdem einen grünen Haken für "erledigt" spendieren.

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Hallo al6042,


    gern würde ich das Thema hier aufgreifen und mit zum Erfolg des Threads beitragen. Neben mir habe ich ein ThinkPad T540p stehen habe (Type 20BF) und würde dort gern die aktuelle MacOS Version installieren.


    Was BIOS Einstellungen etc. angeht unterliege ich keinen Einschränkungen. Bei der Festplatte werde ich die aktuelle (mit Windows 10 laufende) SDD ausbauen und eine leere, andere Festplatte (HDD) einbauen. Somit ist das Thema Datensicherung, Dual-/Multiboot ebenfalls nicht zu berücksichtigen. Die Funktionalität der Wireless LAN (WLAN) Schnittstelle hat nicht die höchste Priorität, da ich im Zweifel gern einen kompatiblen USB WLAN Stick nutze (dazu muss ich mich noch informieren welche "Mini"-WLAN-USB-Sticks kompatibel und noch zu erhalten sind). An erster stelle erscheint mir das Thema Grafikbeschleunigung und Audio wichtig, um "Garageband" sinnvoll nutzen zu können. Ein aktueller durchgeführter Test innerhalb von VMware ist aufgrund mangelnder Grafikbeschleunigung und Audio-Verzögerung weniger zufriedenstellend. An zweiter Stelle folgt dann die Funktionalität des LAN Interfaces (ohne Internet ist doch recht wenig möglich) und eine optimale Touchpad-Funktionalität.


    An sich wäre es das erste Mal, dass ich MacOS auf ein Nicht-Apple-Gerät installiere. Von daher benötige ich ein wenig Guidance von Euch und werde natürlich von der Suchfunktion gebrauch machen.


    al6042, weiter oben hast Du einige Linux-Befehle erwähnt - die auszuführen sind - um weitere, detailliertere Hardware-Informationen zu erhalten. Gern möchte ich auf Dein Wissen zurückgreifen, um die bestmögliche Hardwareunterstützung zu erzielen. Daher meine Frage, soll ich die Befehle auf meiner Hardware (mit welcher Linux-Distribution -> z.B. Ubuntu?) ausführen und hier einmal posten um den nächsten Schritt (welcher das auch sein wird) anzugehen?


    Gruß MacPad

  • Hallo und herzlich Willkommen im Forum... :)


    Die Linux-Befehle kannst du mit Ubuntu erstellen.
    Zudem wäre es spannend die unbehandelte DSDT.aml per F4-Taste im Clover-Bootmenü zu nutzen, um diese in den Ordner /EFI/CLOVER/ACPI/origin auf der versteckten EFI-Partition zu extrahieren.
    Welche Kexte hast du denn bereits im Einsatz, bzw. hast du hoffentlich unter /EFI/CLOVER/kexts/Other liegen?


    Zudem wäre die config.plist spannend.

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Vielen Dank für die Willkommensgrüße.


    Anbei kurz skizziert die ersten Schritte die ich vorgenommen habe, inkl. Output-Files:

    • Ubuntu 17.04 via LiLi USB Creator auf USB Stick extrahiert (Live Modus)
    • Ubuntu 17.04 von USB Stick gestartet
    • Ubuntu Terminal gestartet und folgende Befehle ausgeführt:
    • lspci -nn > ~/Desktop/PCI-Infos.txt
    • cat /proc/asound/card0/codec#0 > ~/Desktop/codec00_dump.txt
    • cat /proc/asound/card0/codec#1 > ~/Desktop/codec01_dump.txt
-> Ergebnis -> No such file or Directory
    • cat /proc/asound/card1/codec#0 > ~/Desktop/codec10_dump.txt
    • cat /proc/asound/card1/codec#1 > ~/Desktop/codec11_dump.txt -> Ergebnis -> No such file or directory
    • Output-Files in File-Share kopiert
    • Ubuntu heruntergefahren

    Bzgl. Deinen anderen Hinweisen muss ich mich erst in die Materie einlesen. Die Begriffe sind mir nicht geläufig. Ich werde dazu die Forensuche und weitere Online-Quellen bemühen, um die Abläufe weiter kennenzulernen. Unterstützung für die nächsten Schritte sind natürlich auch gern willkommen.


    Im Anhang einmal die Output-Files, vielleicht geben die ja Aufschluss für das weitere Vorgehen.


    Gruß
    MacPad

    Dateien

    • PCI-Infos.txt

      (1,93 kB, 14 Mal heruntergeladen, zuletzt: )
    • codec00_dump.txt

      (3,83 kB, 13 Mal heruntergeladen, zuletzt: )
    • codec10_dump.txt

      (11,11 kB, 12 Mal heruntergeladen, zuletzt: )

    Einmal editiert, zuletzt von al6042 ()

  • Laut codec10_dump.txt ist die ALC3232 verbaut...
    Die wird auch als ALC292 bezeichnet und kann vom AppleALC.kext unterstützt


    Der Rest aus der PCI-Infos.txt sieht, bis auf die Intel WLAN-Karte, sehr gut aus.

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Folgendes habe ich bisher durchgeführt, leider mit dem Ergebnis, dass der USB Stick bis zum Apple Logo bootet und dann nichts mehr passiert (kein Ladebalken, kein Zugriff auf USB Stick mehr). Ideen sind herzlich willkommen.


    macOS Installations-USB-Stick erstellen
    - Ein MacOS (hier Ver. 10.12.4) auf anderes System starten
    - USB (>8GB) Stick anschließen
    - Disk Utility App starten (z.B. über Spotlight Suche suchen)
    -- USB Stick auswählen
    -- Löschen Button wählen
    --- Name: Untitled
    --- Format: Mac OS Extended (Journaled)
    --- Schema: GUID-Partitionstabelle
    -- "Löschen" klicken -> abwarten -> fertig


    - Appstore starten, um macOS Sierra Installationsprogramm herunterzuladen
    -- Nach macOS Sierra suchen
    -- Anschließend Ergebnis "macOS Sierra / Dienstprogramme" Laden (angebotene Version 10.12.5)
    -- Nachdem das Laden abgeschlossen ist den Installer/Installationsprogramm ignorieren / minimieren


    - Terminal starten
    -- Um bootfähigen USB -Installations-Datenträger zu erstellen folgenden Befehl eingeben:
    --- sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ macOS\ Sierra.app --nointeraction &&say Done
    --- Passwort eingeben
    --- Um Fortzufahren "Y" eingeben und Enter drücken
    --- Nach Abschluss Terminal beenden


    - Clover EFI v2 auf gestarteten Mac installieren
    -- Clover ZIP File herunterladen und entpacken
    -- Clover_v2.4k_r4061.pkg starten
    --- Fortfahren
    --- Fortfahren
    --- "Ort für die Installation ändern" wählen
    ---- USB Stick / Volume "Install macOS Sierra" auswählen -> Fortfahren
    --- Button "Anpassen" wählen
    ---- Paketname aktivieren
    ----- "Installation für UEFI-Motherboards"
    ----- "Drivers64UEFI\OsxAptioFixDrv-64"
    ----- "Drivers64UEFI\PartitionDxe-64"
    --- Button "Installieren" wählen, Passwort eingeben, "Software installieren" klicken -> Schließen


    - Clover Configurator herunterladen (Version 4.42.1, (Vibrant Edition) [>=10.10])


    - Volume "EFI" auf Desktop öffnen
    -- Nach EFI/CLOVER/ wechseln
    -- Sicherungskopie der Datei "config.plist" auf Desktop ablegen und umbenennen in "config org.plist"
    -- Datei "config.plist" mit Clover Configurator öffnen und folgende Einstellungen vornehmen (alles andere so belassen)
    --- Devices -> Audio -> "ResetHDA" deaktivieren
    --- Gui -> Language -> "de" gewählt
    --- Gui -> Language -> "Screen Resolution" -> "1920x1080" gewählt
    --- Graphics -> "Inject Intel" aktiviert
    --- SMBIOS -> Zauberstab klicken -> MacBook Pro Retina (11,1) -Core i5/i7 (Haswell) wählen
    ---- Week of Manufacturer -> share einige male klicken
    ---- Unit Number -> share einige male klicken
    ---- OK
    --- System Parameters -> "Inject Kexts" -> "Yes" auswählen
    --- Programm beenden und Änderungen speichern
    -- Weitere Sicherungskopie der Datei "config.plist" auf Desktop ablegen und umbenennen in "config mod.plist"
    -- kext Files auf Volume "EFI" kopieren
    -- folgende Dateien nach EFI/CLOVER/kexts/Other kopieren
    --- AppleALC.kext V1.1.1
    --- VoodooPS2Controller.kext
    --- IntelBacklight.kext
    --- ACPIBatteryManager.kext
    --- IntelMausiEthernet.kext


    -- Heruntergeladene Programme (Clover + Configurator + kext Files) in neuen Ordner "Post Install" auf Desktop kopieren und anschließend auf Volume "Install macOS Sierra" kopieren
    -- USB Stick / Volumes auswerfen


    -- Thinkpad BIOS Settings vornehmen
    --- Config -> Power -> Intel Rapid Start -> Disabled
    --- Security -> Virtualization -> Intel VT + VTd Disabled
    --- Security -> Secure Boot -> Disabled


    -- USB Stick in hinteren USB (2.0) Port Seite Rechts einstecken und davon booten
    --- Boot OS X Install wählen


    ... ab hier geht es nicht weiter. Das Apple-Logo wird angezeigt, aber es wird weder auf den USB-Stick zugegriffen, noch ein Ladebalken/Fortschritt angezeigt.


    Gruß
    MacPad

  • Hallo @MacPad ,
    auch von mir Herzlich Willkommen! :welcome:
    Du brauchst auch zwingend in dem Kextordner die FakeSMC.kext:


    https://bitbucket.org/RehabMan…fakesmc-kozlek/downloads/

    iMac13,2: Gigabyte Ga-Z77X-UD3H, i5-3450, XFX Radeon HD 7850 2GB, 8GB RAM, Ozmosis, OSX 10.12.6, 10.13.6, 10.14


    iMac13,3: Asus H61M-K, i3-3225, intel HD4000, 4GB RAM, Clover 4630, OSX 10.10.5, 10.11.5, 10.12.6, 10.13.6, 10.14, Ubuntu 18.04, Windows 10


    MacBookPro11,1: Lenovo Y50-70, i5 4210H, intel HD4600 (nVidia GTX960), 16GB RAM, Clover 4359, OSX 10.12.6

  • Mit einem in Internet befindlichen Guide der den Titel "Booting the OS X installer on LAPTOPS with Clover" trägt konnte ich macOS Sierra auf dem T540p installieren.


    Ich bin dabei Schritt für Schritt vorgegangen. Beim den ersten Versuchen habe ich allerdings beim Booten des Setups über den USB Stick mit Clover immer einen schwarzen Bildschirm erhalten. Nach einigen Tests mit angepassten „Devices“ und „Graphics“ Werten in der config.plist konnte ich mit folgenden Werten ein Bild auf den Monitor zaubern, um schlussendlich die macOS Sierra Installation durchführen zu können.


    Graphics -> Ig platform id
    0x0a260006 geändert in 0x0d220003


    Devices -> IntelGFX
    0x04128086 geändert in <leer> (alle Zeichen in dem Feld gelöscht)


    Folgende .kext Dateien habe ich für die Installation verwendet:
    - FakeSMC.kext
    - IntelMausiEthernet.kext
    - VoodooPS2Controller.kext


    Die Installation war soweit ein Erfolg. Im nächsten Schritt folgen die im oben genannten Guide erwähnten „Post Installation Steps“. Nach der ersten Anmeldung an macOS fällt auf, dass der Sound nicht funktioniert, was aber sicherlich auch hinzubekommen sein wird.