Anleitung: USB 3.0 El Capitan / (High-) Sierra für jedermann (Zukunftssicher für Updates und komplett gepatcht)

  • Ach Quatsch... ;)


    Es gibt manche Dinge, die bleiben einfach hängen... ob man will oder nicht... ;)
    @WeWin
    Coole Sache... dann sollt das Gerät doch soweit erledigt sein, oder?

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Ja mein großer Mac läuft jetzt :)
    Ich mach gerade noch genau das selbe einmal bei dem mac von einem bekannten, dann sollte das Sleep Problem auch gelöst sein :)
    Danke! :danke:



    EDIT:
    @kuckkuck Was ist denn wenn bei dem 6ten Schritt mit dem USB3.0 Stick nur HSXX aufleuchten? Soll ich dann trotzdem SSP1-6 exluden? Bei meinem anderen Hacki haben mit dem USB3 Stick auch nur SSPX grün geleuchtet.
    **Wenn ich die SSP1-6 exclude kommt nix mehr =O

    iMac15,1 Z97MX-Gaming5 | i5 4690K 3,9GHz | 24GB DDR3 | HD4600 1,5GB | Clover/OZ | 10.13.4 APFS | GTX 1050 Ti OC 4GB | Power Mac G5
    iMac14,2 Z97MX-Gaming5 | i5 4460 3,40GHz | 16GB DDR3 | HD4600 1,5GB | Ozmosis | 10.12.6 HFS+
    iMac14,2 Z97M-D3H | i7 4790K 3,6GHz | 16GB DDR3 | HD4600 1,5GB | Ozmosis | 10.12.6 HFS+
    MacBookPro9,2 T430 | i5 3320M 3,3GHz | 12GB DDR3 | HD4000 1,5GB | Clover | 10.13.4 APFS
    Dell E7450 (10.13) | Toshiba L750 1xp (10.13) | Asus EEEpc 1005ha (10.6)

    2 Mal editiert, zuletzt von WeWin ()

  • Wenn nur HSXX aufleuchtet dann Schaust du welche ports noch unbenutzt sind und excludest diese bis USB 3.0 funktioniert ;)

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Hm okay, das habe ich gemacht. Habe dann nachdem mit dem USB3 Stick nur wieder HSXX geleuchten haben mal alle SSPX excludet, aber danach kamen keine neuen Ports.. :(
    Ich hatte dann quasi nur noch die paar HSXX vom USB2.0 und sonst keine mehr.

    iMac15,1 Z97MX-Gaming5 | i5 4690K 3,9GHz | 24GB DDR3 | HD4600 1,5GB | Clover/OZ | 10.13.4 APFS | GTX 1050 Ti OC 4GB | Power Mac G5
    iMac14,2 Z97MX-Gaming5 | i5 4460 3,40GHz | 16GB DDR3 | HD4600 1,5GB | Ozmosis | 10.12.6 HFS+
    iMac14,2 Z97M-D3H | i7 4790K 3,6GHz | 16GB DDR3 | HD4600 1,5GB | Ozmosis | 10.12.6 HFS+
    MacBookPro9,2 T430 | i5 3320M 3,3GHz | 12GB DDR3 | HD4000 1,5GB | Clover | 10.13.4 APFS
    Dell E7450 (10.13) | Toshiba L750 1xp (10.13) | Asus EEEpc 1005ha (10.6)

  • Pack mal USR aus der excludest list... Wie sind denn deine BIOS settings?

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Okay werde ich machen. Auto, Enabled, Enabled, wie in deiner Anleitung geschrieben :)

    iMac15,1 Z97MX-Gaming5 | i5 4690K 3,9GHz | 24GB DDR3 | HD4600 1,5GB | Clover/OZ | 10.13.4 APFS | GTX 1050 Ti OC 4GB | Power Mac G5
    iMac14,2 Z97MX-Gaming5 | i5 4460 3,40GHz | 16GB DDR3 | HD4600 1,5GB | Ozmosis | 10.12.6 HFS+
    iMac14,2 Z97M-D3H | i7 4790K 3,6GHz | 16GB DDR3 | HD4600 1,5GB | Ozmosis | 10.12.6 HFS+
    MacBookPro9,2 T430 | i5 3320M 3,3GHz | 12GB DDR3 | HD4000 1,5GB | Clover | 10.13.4 APFS
    Dell E7450 (10.13) | Toshiba L750 1xp (10.13) | Asus EEEpc 1005ha (10.6)

  • Wie ich in der Anleitung geschrieben habe, kann es passieren das IOReg rumspinnt. Pack nochmal alle SSP Ports aus der excludest und teste dann nochmal die USB 3.0 Ports. Immerwenn du einen stick reinsteckst und es leuchtet nichts auf, restartest du das Programm und schaust nochmal. Außerdem steck den Stick dann nochmal raus und wieder rein ;)

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Okay ich werds nochmal testen, er bootet gerade neu.
    Aber es hat ja an jedem USB3 Port mit einem USB3 Stick was aufgeleuchtet, aber nur HSXX Einträge.


    HS10 ist zum Beispiel ein USB3 Port direkt am Mainboard, wird aber nicht als PSS erkannt.


    Mittlerweile geht es, keine Ahnung wieso.
    Vll war ich gestern einfach zu müde :wallbash:
    Danke :)

    iMac15,1 Z97MX-Gaming5 | i5 4690K 3,9GHz | 24GB DDR3 | HD4600 1,5GB | Clover/OZ | 10.13.4 APFS | GTX 1050 Ti OC 4GB | Power Mac G5
    iMac14,2 Z97MX-Gaming5 | i5 4460 3,40GHz | 16GB DDR3 | HD4600 1,5GB | Ozmosis | 10.12.6 HFS+
    iMac14,2 Z97M-D3H | i7 4790K 3,6GHz | 16GB DDR3 | HD4600 1,5GB | Ozmosis | 10.12.6 HFS+
    MacBookPro9,2 T430 | i5 3320M 3,3GHz | 12GB DDR3 | HD4000 1,5GB | Clover | 10.13.4 APFS
    Dell E7450 (10.13) | Toshiba L750 1xp (10.13) | Asus EEEpc 1005ha (10.6)

  • Super! Freut mich das ich auch dir helfen konnte :thumbsup:

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Vielen Dank für deine Anleitung? Gibt es auch eine Möglichkeit extra-current darüber zu steuern? Ich würde gerne mein iPad laden können... ;)

  • Persönlich würde ich den 10watt ipad ladeadapter benutzen! Der usb port schafft das nicht...

    Gruß
    Jan

  • Doch, es geht unter Windows problemlos. Mein Hack stellt unter Sierra über USB leider nur 500mA bereit, sollte aber eigentlich 2000 extra draufpacken, wenn ein Apple-Gerät dranhängt. Viele haben das Problem und ich wollte nur wissen, ob es sich über USBInject patchen lässt oder ob ein komplizierter DSDT-Hack dafür nötig ist.

  • Dafür muss die DSDT gepatched werden, damit diese Angaben der USB-Port-Definition an OSX übergeben werden.

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Jap, USBInjectAll hat darauf keine Auswirkungen ;)

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Hätte da jemand noch einen Tipp? Bisher haben meine Dsdt's leider nie eine Veränderung gebracht. Könnte man auch über Clover patchen? Vielen Dank!
    Habe auch an anderer Stelle gelesen, dass es mit den 10.11.6 USB-Kexten funktionieren soll, deutet das nicht auch auf ein anderes Problem hin?

    Einmal editiert, zuletzt von macinsane ()

  • Ohne deine DSDTs wenigstens mal in Augenschein genommen zu haben, werde ich mich hier zu keiner Aussage hinreissen lassen.
    Kexte alleine tun es nicht, die helfen dir vielleicht in der erfolgreichen Nutzung von USB3.0 und USB2.0 Anschlüssen, aber den Eintrag für die Stromzufuhr bekommst du aus der DSDT.
    Hier zum Beispiel mal ein Patch aus dem Maciasl:

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Vielen Dank, hatte ich schon eingebaut, leider ohne Erfolg. Allerdings für 100er Boards(habe ja ein Z170) der Patch unterscheidet sich leicht. Vielleicht probiere ich es nochmals mit dem 9-Series Patch und schaue, was passiert. Es wäre so großartig, wenn ich so einen Patch über Clover injecten könnte, ohne dutzende Errors und Warnings aus ner Dsdt bügeln zu müssen :)
    Aber wie gesagt, drüben bei insanelymac behaupten Leute, sie hätten schlicht die alte Kext aus El Capitan genommen.

  • Dann mach das mal und sage uns ob es funktioniert hat...

    Gruß
    Al6042


    GA Z270-HD3P F9d | i7 7700k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14 | Clover 4700

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14 | Clover 4700

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Ja ist es denn...?


    Auf meinem Dienstrechner hatte ich den Tipp mit dem USB-Port-Limit noch gelesen, aber jetzt finde ich ihn nicht mehr. Könnte mir jemand sagen, wo ich den Finde oder machen muss, damit ich das Limit erhöhen kann?


    Das habe ich doch richtig verstanden, dass ein USB3-Port automatisch zwei Ports belegt, ja? Einmal für USB2 und einmal für USB3, oder?


    Danke.

  • Ja die zweite Aussage stimmt so ;) Hier ist der umstrittene Port Limit Patch: Neue Clover "KextsToPatch"-Einträge für Sierra bzw für Ozmosis:
    Perl-Befehle zum Patchen von Kexten unter Ozmosis

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.