AppleALC ins BIOS

  • Lass mal nachdem Du die AppleALC in den Rom eingebaut hast die Caches neu bauen oft liegt hier der Hund begraben...

    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, macOS Mojave 10.14
    System 2 (MacBook Pro 10.2): ThinkPad T430, i5-3360M @ 2.8 GHz, 8GB DDR3, IntelHD 4000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Dual Boot MacOS Mojave 10.14, Windows10 Pro 64Bit

  • Mich intressiert erstmal ob das bei jemand anderen überhaupt klappt das die AppALC_OZM.ffs letzte v.1.0.1.6 aus dem Rom gelesen wird.

  • Ich habe es eben auch mal probiert und es klappt nicht...
    Ich schiebe das aber Kext2FFS zu denn der umgewandelte Kext bekommt exakt die selbe GUID wie die SMCEmulator.ffs und das kann ja per se schon nicht klappen obwohl es sich trotzdem einfügen lässt zumindest mit dem UEFITool...

    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, macOS Mojave 10.14
    System 2 (MacBook Pro 10.2): ThinkPad T430, i5-3360M @ 2.8 GHz, 8GB DDR3, IntelHD 4000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Dual Boot MacOS Mojave 10.14, Windows10 Pro 64Bit

  • Ich habe es eben auch mal probiert und es klappt nicht...
    Ich schiebe das aber Kext2FFS zu denn der umgewandelte Kext bekommt exakt die selbe GUID wie die SMCEmulator.ffs und das kann ja per se schon nicht klappen obwohl es sich trotzdem einfügen lässt zumindest mit dem UEFITool...


    Dann änder' sie doch mal ^^

  • Wenn Du mir sagst wie mache ich das glatt :D

    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, macOS Mojave 10.14
    System 2 (MacBook Pro 10.2): ThinkPad T430, i5-3360M @ 2.8 GHz, 8GB DDR3, IntelHD 4000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Dual Boot MacOS Mojave 10.14, Windows10 Pro 64Bit

  • Ich schiebe das aber Kext2FFS zu denn der umgewandelte Kext bekommt exakt die selbe GUID wie


    Guck mal bitte mein Screenshot an! Das liegt nicht daran!

  • Naja aber die GUID sind bei Dir bei den letzten Einträgen auch überall gleich...

    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, macOS Mojave 10.14
    System 2 (MacBook Pro 10.2): ThinkPad T430, i5-3360M @ 2.8 GHz, 8GB DDR3, IntelHD 4000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Dual Boot MacOS Mojave 10.14, Windows10 Pro 64Bit

  • Das ist egal solange eine Zahl oder Buchstable anders ist.




    @given Mal ein Tipp nimm MMTool. Wenn du die Meldung bekommst: .ffs has the same guid..Lösch die File in deinem Fall ist es die SMCEmulator.ffs und füge dann die Files neu ein ins Bios. Erst die File die nicht ging und dann SMCEmulator.ffs als letztes. Danach wird die GUID Automatisch angepasst um eine Zahl oder Buchstaben. Insert AS is so lassen, da ich jetzt mal davon ausgehe das du Sie verkleinert hast.

    Einmal editiert, zuletzt von Nanimos ()

  • Stimmt wenn man mal genau hinsieht fällt es einem auch auf...
    Wie auch immer habe es nun auch noch mal mit anderer GUID getestet also komplett anders und geht trotzdem nicht sprich offenbar nur über die EFI möglich -.-

    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, macOS Mojave 10.14
    System 2 (MacBook Pro 10.2): ThinkPad T430, i5-3360M @ 2.8 GHz, 8GB DDR3, IntelHD 4000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Dual Boot MacOS Mojave 10.14, Windows10 Pro 64Bit

  • Das ergibt irgendwie keinen Sinn, Kexts aus'm NVRAM werden genauso geladen wie kexts von der ESP... also, ihr habt' diese Kext OHNE PlugIn-Ordner, ja? Kann sein, dass kext2ffs das Plugin einfach weglässt, falls es denn da ist.

  • Ist ohne Plugin Ordner...
    Ich habe mal zum angucken angehangen.

    Dateien

    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, macOS Mojave 10.14
    System 2 (MacBook Pro 10.2): ThinkPad T430, i5-3360M @ 2.8 GHz, 8GB DDR3, IntelHD 4000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Dual Boot MacOS Mojave 10.14, Windows10 Pro 64Bit

  • Kannst du mal die Version von given Konvertieren Manuell? Ich würde gerne mal deine Version dann Testen! Danke oder Poste mal wie es Manuell geht. Danke!

  • Hi @griven,


    das Problem mit der GUID, das du ansprichst ist mir auch nicht neu, jedoch kann man das Problem ganz einfach umgehen, indem wie in dem Bsp.:

    einfach irgendein Kext genommen wird und 0, 1 etc genannt wird, sodass sich der GUID-Name ändert, wie bei der angefügten OZM-1.0.15, sry 16 kann ich grad nicht umwandeln, da ich gerade Windows fahre.


    Update:


    mir fällt gerade mal ein, es kann glaube ich auch das modifizierte Skript von kext2ffs hier ausm Forum genommen werden, da muss gar nichts mehr gemacht werden. Das Skript fängt gleich mit A an, anstatt 6 oder welcher Zahl auch immer.

    Dateien


    Hackmac:

    • Mainboard: GA-Z97X-Gaming 5
    • Cpu: Intel Core XEON 1231 v3
    • RAM: 12GB HyperX Savage
    • HDD: 1TB Seagate Drive, 3x 1TB WesternDigital NAS Drives, 128GB m.2 SATA-SSD
    • Grafikkarte: AMD Radeon RX 580 von Sapphire
    • OS: Windows 10, Arch Linux, macOS Mojave (Ozmosis/auf der SSD)


    :hackintosh:


    Dell Latitude 5580:

    • Cpu: Intel Core i5 7440HQ
    • RAM: 8GB
    • HDD: 256GB SanDisk SSD
    • OS: Windows 10, Fedora 29, macOS Mojave
  • So hab das Script mal getestet! Also das Script selbst Konvertiert ja nicht von Kext zu ffs sondern macht lediglich die GUID sichtbar. Das löst ja leider nicht das Problem.


    Link zum Script, falls du das hier meinst?


    Neues Script um bei .ffs files die GUID auszulesen und in den dateinamen zu schreiben

    2 Mal editiert, zuletzt von Nanimos ()

  • Uno momento !


    Update:


    New version of kext2ffs


    Hackmac:

    • Mainboard: GA-Z97X-Gaming 5
    • Cpu: Intel Core XEON 1231 v3
    • RAM: 12GB HyperX Savage
    • HDD: 1TB Seagate Drive, 3x 1TB WesternDigital NAS Drives, 128GB m.2 SATA-SSD
    • Grafikkarte: AMD Radeon RX 580 von Sapphire
    • OS: Windows 10, Arch Linux, macOS Mojave (Ozmosis/auf der SSD)


    :hackintosh:


    Dell Latitude 5580:

    • Cpu: Intel Core i5 7440HQ
    • RAM: 8GB
    • HDD: 256GB SanDisk SSD
    • OS: Windows 10, Fedora 29, macOS Mojave

    Einmal editiert, zuletzt von modzilla ()

  • Sooo das ( neue Script ) geht ebenfalls nicht so wie erwünscht. Sprich keine Reaktion der AppleALC_OZM.ffs .


    Dieser Mod gibt nur die Namenreinfolge ABCD usw der GUID jetzt richtig an. Vorher war es durcheinander. Also keine Veränderung!

  • Wäre Top Download-Fritz! Ich hab jetzt alles durchgetestet! Das geht einfach nicht. Aus EFi läd er aber nicht aus dem Bios. Ich versteh es einfach nicht!

  • Bin mit meinem Latein auch am Ende sprich egal was ich tue aus dem ROM wird es nicht geladen aus der EFI schon. Ich weiß zu wenig über die interne Funktionsweise von OZ und hier besonders darüber wie die KextInjection im Detail funktioniert und ob es einen Unterschied macht ob der Kext aus dem ROM injected wird oder von der EFI.

    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, macOS Mojave 10.14
    System 2 (MacBook Pro 10.2): ThinkPad T430, i5-3360M @ 2.8 GHz, 8GB DDR3, IntelHD 4000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Dual Boot MacOS Mojave 10.14, Windows10 Pro 64Bit